BEASY_CP_HomePage

BEASY version 21 - CP

Filename: installdir\docs\cp\beasy_cp_homepage.htm

BEASY CP

BEASY CP is designed to simulate the behaviour of galvanic corrosion problems and cathodic protection designs. BEASY CP can be used to analyse corrosion and monitor any protection system employed.

Getting Started

Installation and Set Up , Help and Support and Release Notes

Working environment

Introduction

CP Desktop and software components

Graphical Interfaces

Introduction

BEASY GiD Interface

CP Solver and Modelling aspects

Introduction

Theoretical Background

Input data and outputs

Input data and outputs

Input data

Geometry and mesh

General data

Polarisation Data

Modelling guidance

Approach to modelling, model definition, solution of problems, causes of errors

Meshing guidelines for BEASY CP

Steps to create a BEASY CP model

Results

BEASY CP Results

List of available results

Checks to perform after a run

Result visualisation

Processing numeric results

Special Topics

Forward time stepping

Modelling multi-layered zones

Sigmoidal Curve method

Offshore jacket structures

Tutorials

Index to CP Tutorials

Index to Tutorials for BEASY-GiD

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


BEASY CP

Your browser does not support frames. We recommend that you update your browser to a version that supports frames.

To view the Help system without frames click on thishyperlink.


About WebHelp

BEASY SOFTWARE & SERVICES

Helping Engineers

Control Corrosion & Cracks

Copyright © 2020, BEASY

Contact Support at: support@beasy.com

Website: www.beasy.com


Select a Topic

Select a topic, then click Display


Approach To Modelling

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\approachtomodelling\approachtomodelling.htm

Approach to Modelling Corrosion and Cathodic Protection with BEASY CP

Preparation

Data Requirement

Building the Model

Results

Resolving Problems

Optimisation and Modification

The following steps outline the general approach to modelling CP problems.

Preparation

Before a model is constructed the objectives of the analysis should be considered.

  • Do you need the potential and current density on the structure or in the electrolyte as well?

If you need the results in the electrolyte you will need to define internal points (points, display surfaces or lines).

  • Do you need to model the whole structure or can you just focus on a detailed area?

If you can focus on one particular area, have you sufficient information to define the boundary condition on the local model? If not, you will have to model the whole structure.

E.g. If you wish to model the CP system in a tank you can simply model the inside of the tank. However, if you wish to model in detail the propulsion system of a ship you need to be able to define a box of sea water surrounding the propulsion system and either the potential or current density on the surface of that box must be prescribed.

Data Requirement

In order to make a prediction you need the following information.

  1. Mesh

    The geometry of the model has to be defined in sufficient detail to achieve the desired results. Therefore, if the detailed potentials and current densities are required, for example, near a weld then the geometry has to be refined enough to represent the geometry of the weld and the potential field. If, however, a more global result is required then these features can be excluded from the model.

  2. Resistivity/Conductivity of the electrolyte

    The conductivity of the electrolyte has to be specified in the model. The conductivity can vary in different regions of the model. Therefore, the conductivity value for each region has to be known.

  3. Polarisation

    For each material involved in the model the polarisation properties must be known. This can range between a simple Tafel slope representation to a complete non linear time dependent curve.

    The polarisation data is specified as a table of voltage and current density values.

    If a time dependent analysis is to be performed then the voltage and current density values are specified for a range of values of the formation parameters. The formation parameter describes the build of, for example, calcareous scale and is computed within the software as the cumulative current history for that particular part of the model.

    An atlas of polarisation data for typical Naval material is included with the software.

    Each polarisation curve needs to be included in the material file (*.mat_cp)

  4. Anodes

    The type and location of the anodes must be known (note these can be adjusted once the model is built to look at alternative designs).

  5. Size of the model

    The computational time is dependent upon the number and type of elements used in the model. Define a target or maximum size of the model before it is built to avoid creating a model which is too costly to run on the computer available.

  6. Time stepping analysis

During the time stepping procedure, it is possible to model the anode decay and/or the degradation of the coating on some parts of the structure along the design life.

Building the Model

The model geometry can be created (or imported from another CAD system) in a 3D graphical interface equipped with a BEASY plugin. Instructions for creating the model are described in detail in the tutorials. The following additional points should be considered.

  1. Mesh element type

    The element type coming from the geometry needs to be quadratic. Check that you are exporting the correct element type from 3D graphical interface. For the calculation, it is suggested to use "constant elements" to obtain quick but accurate solutions. You can adjust the default element order for the calculation using the "Solve" tab in the "CP Model Editor". In the Model Settings window select the "Solution Control" tab and adjust the "Default element order".

    For guidelines in mesh definition visit "Guidelines on Meshing"

  2. Symmetry

    Can the model be simplified with symmetry? Can a symmetry plane at the interface between air and electrolyte be defined? If you are using a multi-zone approach you could define a symmetry plane at z=0, for example. (note symmetry planes are not defined in a multi-layered zone). In addition, can the structures assumed to be symmetric? If so, you can define a symmetry plane and create a mesh that considers only half the structure.

  3. Immerse or buried surfaces

    Only the wetted (or buried) surfaces of the structure should be defined with elements. Therefore in the case of an offshore structure the area above the water line should not be modelled and in the case of a buried structure, the area above ground should not be modelled.

  4. Free surface of the electrolyte

    Make the model coordinate system origin on the free surface of the electrolyte. The free surface of the electrolyte can therefore be defined as a symmetry plane thus avoiding the task of meshing the free surface.

  5. Anodes

    Decide how the anodes are to be defined.

    For sacrificial stand-off anodes, it is not necessary to physically connect the anodes to the structure. They can appear to float in the electrolyte.

    Assign a boundary condition: material polarisation, fixed potential or fixed current density.

  6. Metallic Surfaces

    Model the metallic surfaces with mesh elements. Assign a boundary condition: material polarisation, fixed potential or fixed current density.

  7. Normal Vectors to Surfaces

    The orientation of the normal vectors to surfaces is critical in BEASY CP. The rule is that the normal direction to a surface (in a 3D model) should point out of the electrolyte (or zone) being modelled.

  8. Boundary Conditions at Infinity

    At infinity, the current density should be zero. Therefore the user has to apply an insulating boundary condition to enforce the correct physical behaviour.

  9. Polarisation Data

    The polarisation data should be divided into a piecewise linear curve. The data point pairs are entered into the material file.

    Avoid sharp changes in the slope of the curve as this will introduce convergence problems. See tutorials and user guide for examples of polarisation data. If for practical purposes it is known that the potential will be in the range of say -700mv to -1100mv restrict the polarisation data to that range. This avoids unnecessary iterations and improves convergence.

    (Note BEASY CP will not force the solution to fit within that range).

    You can check if the range is exceeded in the results and modify the polarisation data accordingly.

  10. Material file

    The polarisation data is defined in the material file. The material file is a fixed format file so it is recommended not to edit this file but use the Polarisation Database Tool to create, enter new data and manipulate these files.

  11. Internal points, display lines, planes and surfaces

    If results are required within the electrolyte, define internal points either using the CP Model Editor or using the 3D graphical interface to define result elements.

    You can use internal points also to compute results on reference electrodes or survey points.

  12. Non Conducting Shields

    To model non-conducting shields apply insulating boundary conditions to the mesh elements on the corresponding surfaces.

  13. Stray Current or independent CP System

Independent structures (i.e. not electrically connected except through the electrolyte) can be included by defining independent electrical components.

Solving procedure

Geometry and Mesh:

  • First create/import the geometry using the 3D graphical interface equipped with the corresponding BEASY plugin.

  • Export the mesh of your model or several meshes of the different parts of your model

Model Data:

Using the CP Model Editor:

  • "Import mesh" or meshes for all the parts of your model

  • Import a polarisation file (*.mat_cp file) using the "Imported polarisation" tool.

  • On the "Groups Definitions" tab, for each group of mesh elements: Define zone id, boundary conditions, element type, and other pertinent data

  • On the "Zones" tab define zone conductivities and relevant parameters

  • If you want to simulate anode decay and calculate consumption of sacrificial anodes, on the "Sacrificial Anodes" tab define sacrificial anode data.

  • If you need to calculate the solution within the electrolyte or at reference electrode locations, or want to evaluate the solution at survey points, define internal points on the "Internal Points" tab. (Alternatively, you can create result elements at the pre-processing stage using the 3D graphical interface)

  • If connection resistances between components are significant or if a Transformer Rectifier Unit (TRU) is defined, define a non-default return path circuit using the "Return Path Circuit" tab. In these cases, voltage losses will be calculated.

  • When all data is created, save the hmd file using "File > Save" or "Files > Save As"

  • Then go to the "Solve" tab where you can edit settings for the solver, create the model.

  • Check the "Model Creation Report" for possible errors

  • Launch the Solver pressing "Solve Model"

  • After the solver finishes, check the Solver log file for possible errors during the simulation

  • Go to the "Results" tab to create a results summary report.

  • You can now visualise 3D results using the GiD graphical interface or/and analyse numerical results using

Note that you can open an existing ".hmd" file with model data defined and edit it to simulate other conditions using the same mesh for example.

Results

Having completed the above steps you can check the results. Before looking at their physical significance there are a few ways BEASY CP can help.

Checks "warning" messages in the log file

Check for "Warning" messages in the log file to discard inaccuracies due to distorted elements for example.

Equilibrium

You should check the "Summary Report" created by the "CP Model Editor". The section "Model Current balance" reports the summation of the current in the system. This should be in equilibrium. A small error of a few percent is acceptable.

If there are significant errors in the equilibrium it is highly unlikely that the results are correct.

Polarisation

A good check is to confirm that the results (i.e. Normal Current Density and Potential) conform to the polarisation curve specified. You can use the tool "CPResPolCurve" to help you generate the data needed for this check.

Having completed the checks the results can be assessed from a physical point of view.

Resolving Problems

If the results appear to be unrealistic or the equilibrium of the model is not satisfied etc. then the problem may be caused by one of the following.

  • Units: Make sure the units of the model are consistent. For example, check the conductivity units, also the values of the current and voltage in the material file. Inconsistencies in the units will cause convergence and accuracy problems.

  • Polarisation: Check that the polarisation data is correct. Also avoid large changes in slope. If unsure that this is the problem, simplify the polarisation curve to see if this is the source of the error.

  • Anodic/Cathodic: Check if the structure is behaving as expected, i.e. parts of the structure which should be cathodic but show anodic current density. If this is possible make sure that both the anodic and cathodic part of the curve is in the material file.

  • Internal Points: If the values are unrealistic, check to make sure that the model has a boundary box. Check internal points were defined using the correct zone id number.

Fatal errors

If the run stops abruptly very shortly after the start of reading the data, look for errors in the "*.log" file.

Material File

If the run stops abruptly very shortly after the start of reading the data, make sure the Material file is present and it is formatted correctly.

Normal vectors to surfaces

If the run stops abruptly and the log file says there is a fatal error due to inconsistent normal directions in the model, check the direction of vectors normal to surfaces in the model.

Note that the vectors should point outwards from the electrolyte.

Optimisation and Modification

Once a good model has been solved, optimisation of the model can be performed by varying the parameters and assessing their impact on the result.

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Define Tube Properties

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_assigntubeel\gd_assigntubeel.htm

Define tube elements properties

Introduction

How to model tube elements

Manually editing the hmd file

Introduction

Tube elements are used to represent cylindrical structures in which the diameter of the cylinder is considerably smaller than the length. The solution in this representation is uniform around the circumference of the cylinder.

This is of particular use in modelling of jacket structures, pipelines, etc. In this way, the number of degrees of freedom involved is substantially diminished.

How to model tube elements

First, create the geometry for the tubes (lines) in the graphical interface and export the mesh. (how to create the geometry for tube elements)

Then define tube properties such as diameter and/or resistance per unit length using the "Group Definitions" tab in the "CP Model Editor". You need to activate "Intermediate Visualisation".

Manually editing the hmd file

We strongly recommend you to use the "CP Model Editor" to define tube elements.

However, you can alternatively edit the ".hmd" file section "BEGIN NON_OVERLAPPING_GROUPS_DATA". The "IS_PIPE" property column can be "0" or "1" . "0" indicates that the group does not contain tube elements, "1" indicates that the group contains tube elements. If "1" is introduced, a value for the diameter needs to be entered in the property column "DIAMETER".

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Boundary Conditions

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_bc\gd_bc.htm

Boundary Conditions

Boundary Conditions on BEASY CP

Polarisation Curves

Insulated surfaces

Boundary condition at infinity

Boundary condition on interfaces between zones

How to define boundary conditions

Every boundary element in a BEASY CP model should have a boundary condition specified, except elements on interfaces which automatically ensure continuity on normal current density and potential.

This means that for all elements (except interfaces) either the value of one of the primary variables (u or jn) should be prescribed, or the relationship between the two primary variables should be prescribed.

Boundary Conditions on BEASY CP

For a BEASY CP analysis the following boundary conditions can be applied to surfaces (i.e. groups of elements):

  • Fixed potential

  • Fixed normal current density

  • Linear or non-linear relationship between potential and normal current density given by a polarisation curve

Polarisation Curves

BEASY CP allows the user to define a non-linear relationship between potential and current density. This relationship is modelled along a curve known as a polarisation curve and defined at discrete points in the "*.mat_cp" file. For each element in the model there are two variables to consider, the potential (u) and normal current density or current density (j). The linear relationship between these quantities is defined by,

in G, (7)

where k is the transfer coefficient and uo is the potential on the metal.

For a non-linear analysis the polarisation curve specifies the relationship between potential and current density.

Insulated surfaces

An insulated surface has normal current density zero.

For the CP Solver, groups of surfaces that do not belong to an interface, the default boundary conditions are insulating conditions i.e. normal current density zero.

Boundary condition at infinity

The condition required at infinity is zero normal current density. This enforces the condition that the summation of current on the anodic and cathodic surfaces is zero.

A way of applying a condition of zero current density at infinity is by defining a large box that completely surrounds the structures at a large distance away from the area of interest. The size of the box should be at least twenty structure-lengths away from the area of interest.

Insulating conditions should be applied to the group of elements representing the surface of the box. You can consider that the box represents a tank of seawater in which your model is located.

Another way of achieving insulating conditions at infinity is by means of the Multi-layer approach, which applies the required condition by default for a zone that extends to infinite on the sides.

Boundary condition on interfaces between zones

Boundary conditions are not prescribed on interfaces. Mesh elements on interfaces are assigned continuity on normal current density and potential.

How to define boundary conditions

Boundary conditions are defined using the CP Model Editor.

First, create the geometry of the model in your 3D graphical interface and export the mesh file. Second, import the mesh in the CP Model Editor .

Then, define the boundary conditions using the "Group Definitions" tab.

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Return Path Circuit

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_circuits\gd_circuits.htm

Non default return path circuit

Introduction

Resistance per unit length

Electrical components

TRUs

JBOX

Electrical connections in a circuit

How to define a non-default return path circuit

Introduction

By default, all the groups in the model are electrically connected. This is the case in many real situations where the connecting resistances between metals are negligible. Therefore, in default return path circuit all groups are electrically connected.

You will need to define a non-default circuit if either:

  • The internal resistances on flowlines, pipelines or any other structure that can be represented using tube elements have significant influence on the results.

  • There are connection resistances between different objects in the model with significant influence on the results.

  • A TRU unit needs to be implemented

  • A group (or set of groups) needs to be disconnected

Return-path metal voltage losses will be calculated in those cases.

Resistance per unit length

For any structure where the internal resistance produces a non-negligible voltage drop along their length (for example flowlines, pipelines, etc. ) and which can be represented by tube elements, the internal resistance can be modelled and the voltage drop calculated by the solver.

The internal resistance per unit length is defined as the material resistivity per unit of cross sectional area:

R = s / A where s is the resistivity of the material

The cross sectional area A can be expressed as a function of the pipe diameter D and its thickness t as A = 0.25 π [ D2 – ( D – 2 t) ] 2

Electrical components

A component is a set of groups and a method to connect them electrically. Figure 1 shows a schematic representation of a component.

To fully define a component you need to assign:

  • A name to the electrical component

  • Associate all the groups that will be inter-connected with the component name

  • A value for the inter-connecting resistance

In the example, the component name is COPM_1. It is made up of 3 groups with interconnecting resistance 0 Ohms.

Figure 1. The "component" is connected internally with resistance R

TRUs

A transformer rectifier unit (TRU) is an electrical power supply with two terminals named "supply" and "return" which represent positive and negative terminals, respectively. In a typical CP system the anodes are connected to the supply terminal while the structure to protect is connected to the "return" terminal.

Two types of TRUs are supported by the solver, namely V-TRU and I-TRU. The former is a voltage-controlled TRU which maintains a fixed (target) potential difference across its terminals, while the latter is a current-controlled TRU, which maintains a fixed (target) current.

Note that in a V-TRU, the current flowing through it will change depending on the loading conditions, whereas in an I-TRU it is the voltage across its legs which varies depending on the loading conditions.

JBOX

A junction box (JBOX) is a connection point as shown in Figure 2

Figure 2. Junction box in red. (JBOX)

Electrical connections in a circuit

In a circuit, an electrical connection is set up between two objects (object 1 and object 2). The objects can be groups, the so called "components" (a collection of interconnected groups), transformer rectifier units (TRU) or junction boxes (JBOX).

To fully define an electrical connection you need to define:

  • The name of two connected objects

  • The interconnection method

  • The value for the inter-connecting resistance

  • The connection point in object 1

  • The connection point in object 2

Figure 3 shows an example of a circuit.f

Figure 3. Schematic representation of a circuit

How to define a non-default return path circuit

You can follow a tutorial illustrating how to define a circuit.

First, create the geometry of the model in your 3D graphical interface and export the mesh file.

Second, import the mesh in the CP Model Editor and define the circuit using the "Group Definitions" and "Return Path Circuits" tabs. Note that you need to activate the no-default return path circuit in Settings using the "Solve" tab.

Detail information on how to define a non-default circuit can be found at CP Model Editor – Return Path Circuit.

Manually editing the hmd file

We strongly recommend you to use the "CP Model Editor" to define a non-default circuit.

However, you can alternatively edit the following sections in the "hmd" file ::

SOLUTION_CONTROL_SETTINGS

The option RUN_METAL_VOLTAGE could be "yes", "TRUE", "1" or "no", "FALSE" or "0". Enter "yes", "TRUE" or "1" to activate the non-return path circuit in the simulation.

The sections containing circuit data are only considered if RUN_METAL_VOLTAGE is true.

"NON_OVERLAPPING_GROUPS_DATA"

The "NON_OVERLAPPING_GROUPS_DATA" section contains the property column "RESISTANCE_LENGTH" to enter the value of the resistance per unit length. A non-zero value can be input only if the group contains tube elements.

The property column "COMPONENT_NAME" contains the name assign to a component. All groups that are electrically connected with zero resistance can have the same component name.

GROUP_NAME | COMPONENT_NAME | AREA_FACTOR | DIAMETER | RESISTANCE_LENGTH
GroupA | PIPELINE1 | 1 | 0.25 | 1.5E0-5

Table 1: Non-overlapping groups (Columns 2, 13, 14, 15 and 16)

COMPONENTS_DEFINITIONS

A component is a set of groups and a method to connect them electrically. The field COMPONENT_NAME must match the value assigned in the NON_OVERLAPPING_GROUPS_DATA section.

There are different ways offered to connect groups in the same component. This is controlled by the INTERCONNECTION_METHOD field. Choose one method following the description available in the template.

The INTERCONNECTION_RESISTANCE is the resistance used to interconnect all groups that belong to the same component.

The TOLERANCE field sets a tolerance for the proximity search.

#COMPONENT_NAME | INTERCONNECTION_METHOD | INTERCONNECTION_RESITANCE | TOLERANCE
PIPELINE1 | 6 | 0 | 0.1

Table 2: COMPONENTS_DEFINITION section

USER_CONNECTIONS

This region is used to define electrical connections between two components, two groups, or a component and a group.

The example below shows:

  • a connection between component PIPELINE1 and component PIPELINE2.

  • The connecting method is "P" proximity for both components (selects a mesh-point in the component which is nearest to the opposite component across the connection).

  • The connecting resistance between components is 0.2 Ohm

BEGIN USER_CONNECTIONS

#Type1 | Name1 | Method1 | Type2 | Name2 | Method2 | Resistance_Value
COMPONENT | PIPELINE1 | P | COMPONENT | PIPELINE2 | P | 0.2

END USER_CONNECTIONS

Table 3: USER_CONNECTIONS section

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Control Element Order in Solution

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_controlelorder\gd_controlelorder.htm

Change element order used in the simulation

Introduction

Control element order

Introduction

By default, the solver uses constant elements for CP simulations.

Control element order

To change the order of the elements in the Solve tab in the CP Model Editor select the "Settings" button. In the "Model Settings" window use the drop down menu shown in Figure 1 to change to Linear or Quadratic.

Figure 1 Settings tab

NOTE that if your model has a multi-layered zone, linear or quadratic elements are not supported.

Alternatevely, you can manually edit the hmd file to change the default order use for the elements in the simulation by editing the variable "DEFAULT_ELEMENT_ORDER " in the "hmd" file section "SOLUTION_CONTROL_SETTINGS",

Adjust the value "DEFAULT_ELEMENT_ORDER" to the desired order:

DEFAULT_ELEMENT_ORDER 1

where

  • Integer value: 1 (constant, default)

  • 2 (linear)

  • 3 (quadratic)

  • 38 (Q38)

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Dual Elements

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_fordualel\gd_fordualel.htm

Define dual elements

Introduction

How to model dual elements

Manually editing the hmd file

Boundary Condition on both sides of the dual element

Offset parameter for post-processing

Restrictions

Introduction

Dual elements can be used for modelling thin surfaces (e.g. thin plates) submerged in the electrolyte.

In this way, the number of degrees of freedom involved is substantially diminished.

How to model dual elements

First, create the geometry for dual elements in the graphical interface and export the mesh. (How to create the geometry for dual elements)

Second, import the mesh in the CP Model Editor and define dual elements using the "Group Definitions" tab. Note that you need to activate the "Intermediate Visualisation" to access the settings for dual elements.

Manually editing the hmd file

We strongly recommend you to use the "CP Model Editor" to define model parameters.

However, you can alternatively edit the "hmd" file section "BEGIN NON_OVERLAPPING_GROUPS_DATA".

The "IS_DUAL" property column can be "0" or "1" . "0" indicates that the group does not contain dual elements, "1" indicates that the group contains dual elements. If "1" is introduced,

Boundary Condition on both sides of the dual element

It is possible to assign different conditions to each side of the dual element by assigning a different polarisation label to the column: BOUNDARY_VALUE_SIDE2" while editing the ".hmd" file section "BEGIN NON_OVERLAPPING_GROUPS_DATA". Change "SAME_AS_SIDE1" by the corresponding label:

Offset parameter for post-processing

The parameter "offset distance used for dual elements" is the separation used in the post-processing to represent solutions at both faces.

This parameter can be modified while editing the ".hmd" file section "BEGIN SOLUTION_CONTROL_SETTINGS", "GID_OFFSET_DISTANCE".

The default value is 0.025.

Follow the link to see display of results for dual elements

Restrictions

  • Multi-layer zones do not support dual elements

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_index\gd_index.htm

General input data

The model data including parameters to adjust solver performance and physical properties is regarded as general data.

General data is defined using the "CP Model Editor".

Included in general data are the following topics:

  • Zone definition : Single zone, Homogeneous zone, Multi-layered zone, Multi-zones

  • Boundary Conditions : Types of boundary conditions, insulated condition, Bounding condition at infinity

  • How to assign tube elements properties : Tube elements are used to represent cylindrical thin geometries. The geometry consists of a line. The additional data assigned using the CP Model Editor is the diameter and a value for the resistance per unit length if it is not negligible.

  • How to assign dual elements properties : Dual elements can be used to model thin surfaces (e.g. thin plates) submerged in the electrolyte. To declare a group contains dual elements use the CP Model Editor.

  • How to define sacrificial anode properties : Sacrificial anode data is defined if you need to calculate anode mass loss and/or consumption rates of sacrificial anodes at initial life or you are planning to perform step forward simulations, you have to introduce some additional data such as anode mass, initial consumption, anode capacity, etc. The geometry for sacrificial anodes is defined as cuboid or lines. The anode data is introduced using the CP Model Editor.

  • How to define a non-default return path circuit : By default, all the groups in the model are electrically connected. You will need to define a non-default circuit if either:

- The internal resistances on flowlines, pipelines or any other structure that can be represented using tube elements have significant influence on the results.

- There are connection resistances between different objects in the model with significant influence on the results.

- A TRU unit needs to be implemented

- A group (or set of groups) needs to be disconnected

  • The hmd file

  • How to change the elements order used by the solver in the simulation.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Sacrificial Anode Data

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_sacanode\gd_sacanode.htm

Sacrificial Anode Data

Introduction

Anode Types

BRICK

CYLINDER

BRACELET or SHAPELESS

STAND OFF

BRICK FLUSH MOUNTED

How to model sacrificial anodes

Introduction

If you need to calculate anode mass loss and/or consumption rates of sacrificial anodes at initial life or you are planning to perform step forward simulations, you have to introduce some additional data such as anode mass, initial consumption, utilisation factor, anode capacity, etc.

Anode Types

The supported anode types are:

  • BRICK

  • CYLINDER

  • BRACELET (or SHAPELESS)

  • STAND_OFF

  • BRICK_FLUSH_MOUNTED

BRICK

These anodes are represented by cuboids.

  • The geometry is a cuboid

  • The bottom face (1 surface facing the material) needs to be in one group

  • The top faces (5 other surfaces) need to be in a different group.

  • The bottom face must be made of quadrilateral elements

  • Top surfaces of different individual anodes of the same properties can belong to one group. The same applies for the bottom surfaces.

  • When assigning sacrificial anode data with the CP Model Editor fill the property column "SAC geometry" in the "Group Definitions" tab selecting:

-"TOP" for the group containing the top and side faces.

-"BOTTOM" for the group containing the bottom faces

  • In the simulation, the bottom face (back) remains fixed, and the anode is consumed from the front surface according to CF parameter.

CYLINDER

These anodes are represented by tube elements.

  • The geometry is a line.

  • The group needs to be assigned tube element properties

  • Lines of different anodes with the same properties can be all assigned to one group.

  • When assigning sacrificial anode data with the CP Model Editor fill the property column "SAC geometry" in the "Group Definitions" tab selecting "TOP".

  • The anode shrinks in the radial direction according to CF parameter. And it retains the same length dimension.

BRACELET or SHAPELESS

These anodes can have any shape.

  • There is no restriction on the anode shape

  • All the anode faces should belong to one group.

  • Surfaces of different individual anodes of the same properties can be put into one group. The same applies for the bottom surfaces.

  • When assigning sacrificial anode data with the CP Model Editor fill the column property "SAC geometry" in the "Group Definitions" tab selecting "TOP"

  • In the simulation, the anodes don't change shape with CF

STAND OFF

These anodes are represented by cuboids.

  • The geometry is a cuboid

  • They allow the definition of a mounting bar (default value for the mounting bar diameter is zero)

  • If mounting bar diameter is given and greater than zero, the DENSITY parameter must be provided

  • The length dimension must be distinctively larger than the other two dimensions

  • All the anode faces should belong to one group.

  • Surfaces of different individual anodes of the same properties can belong to the same group.

  • When assigning sacrificial anode data with the CP Model Editor fill the column property "SAC geometry" in the "Group Definitions" tab select "TOP"

It consumes such that:

  • Length at UF = 0.9 x length at CF = 0

  • The cross sectional area of the anodic material is zero when the UF is reached.

BRICK FLUSH MOUNTED

These anodes are represented by cuboids.

  • The geometry is a cuboid

  • They allow the definition of a mounting bar (default value for the mounting bar diameter is zero)

  • If mounting bar diameter is given and greater than zero, the DENSITY parameter must be provided

  • The bottom face (1 surface facing the material) needs to be in one group

  • The top faces (5 other surfaces) need to be in a different group.

  • The bottom face must be made of quadrilateral elements

  • Top surfaces of different individual anodes of the same properties can belong to one group. The same applies for the bottom surfaces.

  • When assigning sacrificial anode data with the CP Model Editor fill the column property "SAC geometry" in the "Group Definitions" tab selecting:

- "TOP" for the group containing the top and side faces.

- "BOTTOM" for the group containing the bottom faces

It consumes such that:

  • Length at UF = 0.9 x length at CF = 0

  • The cross sectional area of the anodic material is zero when the UF is reached.

  • The bottom face does not recede as the anode consumes

How to model sacrificial anodes

First, create the geometry of the anodes in your 3D graphical interface and export the mesh. If you are using GiD you have the additional tools available to create the geometry and groups for sacrificial anodes.

Then, open the CP Model Editor and proceed as follows:

  • Add the mesh containing the anode geometry using the "Imported Meshes" tool.

  • While defining the group properties in the "Group Definitions" tab, define entries for the group properties "SAC geometry" and "SAC Name". The default value for "SAC geometry" is "NO_SAC". Use the drop down menu to access the possible values: "TOP", "BOTTOM" or "NO_SAC". Select:

- NO_SAC: If you don't intend to model sacrificial anode data

- TOP: Use TOP for any anode type except for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

- BOTTOM: Use for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

If "TOP" or "BOTTOM" are selected you need to define "SAC Name". Define the anode type name in this group. You will use this name in the "Sacrificial Anodes" tab to assign properties such as anode mass, anode capacity, etc.

  • Finally, in the " Sacrificial anodes " tab select the corresponding anode name and introduce the anode data (utilisation factor, consumption factor, anode capacity, mass).

Manually editing the hmd file

We strongly recommend you to use the "CP Model Editor" to introduce sacrificial anode data.

However, you can alternatively edit the ".hmd" file section "BEGIN NON_OVERLAPPING_GROUPS_DATA". The "SACRIFICIAL_ANODE_GEOMETRY" property column can be "NO_SAC", "TOP", or "BOTTOM". If "TOP" (or "BOTTOM") is introduced, a name for the property column "SACRIFICIAL ANODE_TYPE" needs to be entered as shown in Table 1.

In addition, in the "SACRIFICIAL_ANODES_DATA" section (Table 2) , the property column "PROPERTY_NAME" identifies the name defined in "SACRIFICIAL ANODE_TYPE".

Other column properties identify utilisation factor (UF), consumption factor (CF), Mass , Rate (kg/mA year), mounting bar diameter and anode material density.

Table 1. NON_OVERLAPPING_GROUPS_DATA section

Table 2. SACRIFICIAL_ANODE_DATA section

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Zones

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\gd_zones\gd_zones.htm

Zone definition

Single zone model

Symmetry planes

Multi-layer approach

Multi-zone

How to define zones

A zone is a region of the integration domain (a volume of electrolyte in 3D). It can have homogeneous conductivity or layered conductivity values.

In this way a homogeneous zone is characterised by:

  • Its conductivity value

  • The groups of surfaces enclosing the zone

  • Boundary conditions on the enclosing surfaces

A layered zone (where the electrolyte is stratified) is characterised by the set of parameters:

  • Thickness and conductivity of each layer

  • Layering direction

  • Boundary conditions on the top and bottom surfaces of the model.

Layered zones where the electrolyte is stratified are modelled using the so-called "Multi-Layer" approach.

In principle, zones must be totally surrounded by surfaces discretised with boundary elements.

In BEASY CP it is important that:

  • The normal direction of all surfaces is correctly defined

  • The zone boundary is complete

The orientation of the normals to the surfaces (or lines in 2D) tells the CP Solver in which side of the surface (or line in 2D) the electrolyte lies on. It is of paramount importance to define the normals correctly in your model.

  • By convention, in a BEASY CP model, the normal direction of surfaces should point outwards from the electrolyte.

Single zone model

An example of one zone model is shown schematically in Figure 1 where the electrolyte is characterised by conductivity value σ1.

Figure 1 Side view showing a metallic structure and a cylindrical anode immersed in an electrolyte.

Figure 2 shows with dashed lines the surfaces delimiting zone 1, i.e. the "wetted" external surfaces of the metallic structure and anode, the bottom and sides of the electrolyte. Note that these surfaces (a big box enclosing the structures, approximately 20 times the size of the structure) are included to prescribe boundary conditions at infinity.

Figure 2 Showing surfaces enclosing zone 1 with dashed lines

A mesh needs to be created in all dashed surfaces. Note all normal vectors (indicated with cyan arrows) point outwards in a single zone model.

Symmetry planes

There are special cases in which the zone can be left opened (i.e. without being fully confined by surfaces).

In the case of homogeneous zones with symmetry, a surface lying on the plane X = 0, y = 0 or Z = 0, can be replaced by a symmetry plane.

For the example described above, when a symmetry plane is declared at z=0, the surface of the electrolyte in contact with air does not need to be meshed. (Figure 3).

Figure 3 Showing surfaces needed to define the zone with dashed lines (when symmetry plane is declared)

The declaration of symmetry planes may simplify the geometry building but more importantly, it reduces the number of mesh elements in the model.

Multi-layer approach

Zones are also left open in the multi-layer approach. The example above could as well be modelled defining one multi-layer zone with 1 layer. The only surfaces needed to describe the problem are the external surfaces of the anode and tank as shown with dashed lines in Figure 4.

Note that multi-layered zones cannot be assigned symmetry planes. (multi-layer approach).

Figure 4 Showing surfaces needed to define the multi-layer zone with dashed lines

Multi-zone

In a multi-zone approach the electrolyte is divided into two or more zones.

Multi-zone strategies are aimed at problems with non-homogeneous electrolytes; however, the technique can be employed for homogeneous electrolytes (sometimes for achieving more efficiency in the solving process)

Use a multi-zone approach:

  • If there are two or more regions with different conductivity/resistivity

  • If the geometry of the electrolyte is long and thin it is recommended to divide the region into different zones

  • To improve the performance of the CP solver, it could be useful to divide the region in different zones with smaller number of elements. When possible, try to keep similar number of elements on the different zones.

Interfaces between zones

A surface representing an "interface" must be added between two adjacent zones where continuity of current density and electrolyte potential through the electrolyte is enforced.

Boundary conditions on interfaces

Mesh elements on interfaces are automatically assigned continuity on normal current density and potential. Hence, boundary conditions are not applied on interfaces.

An example of a multi-zone model

An example of a metallic structure and anode in regions with different conductivity is shown schematically in Figure 5. The problem can be solved using a two zone model and a symmetry plane at z=0.

Figure 5 Metallic structure and anode in two regions with different conductivity

Figure 6 shows the surfaces needed to define zone 1 with dashed lines and with a solid violet line for the interface between zones.

Figure 6 Showing surfaces enclosing zone 1 and zone 2 with dashed lines and with a violet line for the interface between zone 1 and zone 2

Zone 1 is defined by:

  • the wetted external surfaces of the metallic structure and anode

  • the outer sides of the electrolyte

  • and the interface between zone 1 and zone 2

Zone 2 is defined by:

  • the outer sides of the electrolyte

  • the interface between zone 1 and zone 2

From the point of view of the interface one of the zones becomes the "master" zone, and the other the "slave" zone. The normal direction of the interface points from the master zone to the slave zone.

In this way,

  • the external surfaces of the metallic structure and anode, the outer sides of the electrolyte

  • The outer sides of the electrolyte are master to zone 2

  • the interface between zone 1 and zone 2 is "master" to zone 1 and "slave" to zone 2.

Note: The CP solver produces one set of influence matrices H and G for each zone. The data is stored in files with extension *.h001, *.g001 for zone 1; *.h002, *.g002 for zone 2; etc.

How to define zones

Zones are defined using the CP Model Editor .

First, create the geometry of the model in your 3D graphical interface.

Create all surfaces enclosing zones and surfaces representing interfaces and export the mesh file. Second, import the mesh in the CP Model Editor .

Then, define the zones using the "Zones" tab.

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


hmd File

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\hmdfile\hmdfile.htm

The *.hmd file

The "*.hmd" file stores all the model properties and model data defined through the CP Model Editor. It is used, together with the mesh file to create a model file for the BEASY CP Solver.

The user of BEASY CP will not normally edit this file, since these operations are done by the CP Model Editor.

Data sections

hmd file template

Editing the hmd file

Data sections

The "hmd" file is structured into data sections as follows:

This data is stored in the "hmd" file.

hmd file template

A template of the hmd file can be created opening a command shell window and introducing "CPBuilder.exe". This generates a template file "MyModel.hmd" in the current directory.

The template is self documented.

Editing the hmd file

Open the template for the .hmd template with a text editor (e.g. notepad).

Edit the file to add model data.

Note: Anything written after a "#" is a comment.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP Data file

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\input_data_file\input_data_file.htm

BEASY CP data file

The data file (dat file) is a text file (in ASCII format, with extension ".dat") containing all modelling parameters that control the simulation process for a model.

It also contains geometric information of the mesh and groups of elements defined in the model.

Modelling parameters including:

  • physical properties for the electrolyte,

  • physical properties assigned to the different surfaces,

  • solver parameters

  • post-processing options

are defined in the CP data file.

The CP data file is written when pressing "Create model" in the "Solve" tab in the CP Model Editor ( the data file is created by the "CP Builder")

Reference

==========Endof document=================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP Data file

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\generaldata\ref_datafile\ref_datafile.htm

The BEASY data file

Document Overview

This document describes the data keywords required by the main BEASY analysis program and all the files used by BEASY analysis. The first section describes the file structure and which files are required for the different types of analysis performed by BEASY. The main section of the document describes all of the data keys used in the BEASY DAT file and their meaning.

Some of the keywords described here are not applicable to the current BEASY version (either from older BEASY version or internal development).

Document Overview

Introduction

Overview of BEASY files

Model files

Work files

Structure of the BEASY Data File

Private Data Sections

Keyword details

Header Information

Solution Control Section

General Data Section - Header, Mesh Points and Property Sets

General Data - Zone Definition Data

Private data sections

Group Tool Data

Introduction

Overview of BEASY files

This section describes the files used by the BEASY solver for a typical problem. A BEASY data file must always have a root name with a ".dat" extension. Associated files may be referenced using the root name and a standard extension, for example a material file for corrosion analysis has a ".mat" extension or using a filename reference directly in the data file, for example a load spectrum (lsp) file used in fracture.

There are a number of different analysis scenarios that can be used and in each of these different tools are used to create, modify or update model files. In all cases the tools ultimately create a BEASY data file that can be solved using the main BEASY solver (beasyand.exe). Other documents in the documentation system describe how the files are modified and updated.

Result files are usually generated using the root filename and a series of standard extensions. The figure below gives an overview of the programs and files used for a problem name file.

Figure 1 BEASY Analysis file structure

Model files

This section gives information about all files relating to a BEASY model. These include all data files and results files. The problem name file will be used to remain consistent with names in Figure 1.

The files used by the BEASY solver are:

file.dat: The main BEASY data file which defines the problem to be analysed. This ASCII file is made up of 'keywords' which are recognised by the solver.

file.log: A formatted file containing timing information and a listing of any errors, warnings or notes flagged by the BEASY analysis.

file.lo2: A small formatted file used to store internal information about file opening and closing. In the case of a restart analysis, this file should not be deleted or modified in any way between the two runs.

file.sf1: A small formatted file containing information about the size of the model, including the number of elements, number of zones, etc.

file.sf2: An unformatted, direct access file containing the geometry and results as output by the BEASY analysis program. Keep this file if you need to perform a run for internal points, for example, using the obtained solution.

Work files

This section gives information about all working files used by the BEASY analysis program during a run. These files are typically deleted once they are no longer needed, but users do have the option of keeping their work files for later use in a restart analysis. The problem name file will be used to remain consistent with Figure 1. The work files use the same file name convention as the BEASY data and results files, i.e. a model name followed by an extension describing the file type. The file names are different for potential analysis and stress analysis, and in the listing below each work file is followed by a letter 'P' or 'S' in parentheses indicating whether the file relates to a potential or stress run of BEASY. The work files used by BEASY are:

file.h01 (P), file.g01 (P), file.f01 (S), file.e01 (S): 'Influence' matrices for zone 1 of the problem. These relate the behavior of every 'node' point in the zone to that at every other. Similarly, files 'file.h02', 'file.e03', etc. refer to zones 2 and 3 respectively, containing the zone influence matrices in each case.

file.a01 (P), file.b01 (P), file.c01 (S), file.d01 (S): 'System' matrices for zone 1 of the problem. These files contain the same information as the 'influence' matrices, but rearranged to suit the boundary conditions applied. The filename extension again refers to the zone number, so a system matrix for zone 13 may be named file.c13. The files are unformatted, direct access, and the file size is approximately the same as the influence matrices.

file.m01 (P), file.n01 (S): A small, unformatted file containing matrix map information.

file.agp (P), file.ags (S): The global (i.e. for all zones) 'left hand side' system matrix. This file is caused by the summation of contributions from the individual zone system matrices. This file is overwritten by the lower triangular reduced matrix during the solution process. The file is unformatted and direct access

file.mgp (P), file.mgs (S): A small, unformatted file. This is the global map file.

file.vgp (P), file.vgs (S): A vector representing the 'right hand side' system matrix multiplied out by the vector of known boundary conditions. This small, unformatted file contains N real numbers, where N is the number of degrees of freedom in the problem.

file.wgp (P), file.wgs (S): A vector representing the right hand side once the body forces have been added.

file.xgp (P), file.xgs (S): A vector representing the right hand side after reduction identical to the left hand side reduction.

Structure of the BEASY Data File

This chapter describes the composition of the data file which is read by BEASY solver and which defines the problem to be solved. This data file may be created automatically by an interface. This chapter is not intended as a teaching text, as it is not expected that users will create their data files using an editor, but it may be used as a reference text by users wishing to make small edits to existing data files, or by users wishing to write interface programs between their own pre-processors and the BEASY analysis program.

A system of keywords allows complete generality in the data structure, i.e. a single data file format will be used to describe 2D, 3D or axisymmetric geometries and to solve either potential or elasticity problems. The keyword system follows a tree structure. At the top of the tree are four main keywords, which MUST occur in the order defined below:

Keyword BEASY

Keyword SOLUTION CONTROL

Keyword GENERAL DATA

Keyword END

The keyword END clearly marks the end of the standard data file, however this may now be followed by some additional data used for specific functions within the analysis, for example group definitions. These will however always be surrounded by private data section keywords (see below for details). Within each of the other three main keyword sections there are several legal branch keywords which may be placed in any order. Some of these branch keywords themselves have branch keywords, and so the tree structure is built up. It should be noted that all keywords and branch keywords must start in the first column and, where a keyword consists of two or more words, it must contain one blank space between the words.

Many keywords require numerical data and parameters to be input. All of the parameters following keywords may be input in free format, allowing the user complete flexibility in data preparation. The parameters may be separated by either spaces or commas, though it should be noted that adjacent commas will be treated as a single separator. The parameters may continue over several records of the data file.

Many of the keywords described in this chapter are optional. However, others are compulsory, and this is indicated in the listing under each command. The order in which the keywords appear in the data file is generally flexible within any one branch. However, the tree structure must be observed at all times. For example, if in the 'GENERAL DATA' section it is desired to define planes of symmetry using the 'PLANES123' keyword, the user must first enter the 'DEFINE ZONE' branch by issuing that keyword, and then follow the tree by issuing the 'ZONE SYMMETRY' keyword. The program is then ready to recognise the keyword 'PLANES123' and apply the required planes of symmetry.

Note that in this document, the general section is further split into general data, zone data and loading data.

In addition to the main sections, further private data sections are included in the data file. These contain keywords that are used in various BEASY tools. These include sections for data to be passed to the crack adder and data to be used in the life code. Some of these keywords are detailed in this document in later sections on the private data groups. Also after the end of the main data file, group data is also included. This is either written by the pre-processor or is added additional processing wizard or tools.

Private Data Sections

Within the standard data file a series of private data sections can be defined. These sections contain specific tools that are used either by the solver or by one of the additional "add on" tools. These data sections are described at the end of this document.

Keyword details

The next sections in this document describe the keywords that can be used in the various sections of the BEASY data file. Most of the keywords are described, however this is not an exhaustive list.

For each keyword, the following information is listed:

  • The form of the keyword, giving the keyword itself with a list of any data parameters needed.

  • The function of the keyword, giving details of the effects of including the keyword in the data file, and its implications on the model being analyzed.

  • The use of the keyword, giving information on whether the command is optional or compulsory, and any special uses or restrictions on use of the keyword.

  • The last command, giving the position of the command in the tree structure of keywords.

  • The parameters expected, giving details of each data item which should follow the keyword.

  • The default condition which would exist if the keyword did not appear in the data file

  • Any remarks, giving further descriptions of effects of the keyword, restrictions in its use, cross references with other keywords, etc.

Header Information

The first section of the BEASY data file contains information about the model to be analysed, the type of analysis to be performed and data about some of the output files required. The initial section is ended by the keyword SOLUTION CONTROL.

BEASY

Form:

BEASY date time

Function:
The first record of the data file. Commences the BEASY data block.

Use:
Compulsory

Last command:
None - main keyword.

Parameters:
date : Date on which the data file was created. Should be in format A9 dd-mmm- yy where dd, mmm and yy represent the day, month and year respectively, e.g. 04- FEB-10.

time : Time at which the data file was created. Should be in format A8 hh:mm:ss , where hh, mm and ss represent the hours, minutes and seconds respectively, e.g. 18:35:20.

Default:
None

Remarks:
Correct order of the four main keywords must be observed.

SOLUTION TYPE

Form:
SOLUTION TYPE type

Function:
Indicates whether the solution to a potential problem, stress problem or thermal stress problem is required.

Use:
Compulsory

Last command:
BEASY

Parameters:

type :

'PP' for Potential Analysis

'TE' for Stress Analysis

'PP+TE' for Thermal Stress Analysis

'MG' for Magnetic Analysis

'AV' for Acoustic Analysis

'CP' for CP Analysis

Default:
None

Remarks:
BEASY will expect to read the keyword TWO DIMENSIONAL, THREE DIMENSIONAL or AXISYMMETRIC in the definition of each zone . Furthermore, for axisymmetric problems, BEASY uses an (r,z,q) system.

If type is given as 'PP+TE' then BEASY looks for results from a thermal analysis. If no such results are found the program assumes that it is to do the potential analysis to obtain the thermal solution. If the thermal solution is found then the program takes that as an input to a stress analysis. Thus no alteration of the data file is required between the two runs of BEASY.

PLANE STRESS

Form:
PLANE STRESS

Function:
Indicates that the plane stress assumption is to be selected. This keyword is meaningful only in the 2D stress analysis option.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE

Parameters:
None

Default:
If neither plane stress nor plane strain is specified for a 2D stress analysis (either here or in the zone definition), plane stress is assumed.

Remarks:
If this keyword is present, then the whole problem will be plane stress. If this keyword does not appear, then plane stress or plane strain may be specified in the definition of each zone.

PLANE STRAIN

Form:
PLANE STRAIN

Function:
Indicates that the plane strain assumption is to be selected. This keyword is meaningful only for the 2D stress analysis option.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE

Parameters:
None

Default:
If neither plane stress nor plane strain is specified for a 2D stress analysis (either here or in the zone definition), plane stress is assumed.

Remarks:
If this keyword is present, then the whole problem will be plane strain. If this keyword does not appear, then plane stress or plane strain may be specified in the definition of each zone.

INCONSISTENT UNIT SET

Form:
INCONSISTENT UNIT SET setid

Function:
Indicates that an inconsistent set of units is used to define the problem.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE

Parameters:
setid : the identification number of the inconsistent unit set.

Default:
A consistent set of units is used.

Remarks:
In the current version of BEASY only one inconsistent set of units is available. Thus setid must be set to 1. The following units represent this inconsistent set:

TABLE 3 Inconsistent units set
Quantity | Units
Linear dimension | inches
Area | square inches
Volume | cubic inches
Temperature | Degrees Fahrenheit
Flux | Btu per hour
Flux density | Btu per hr. per sq. ft.
Heat transfer coefficient | Btu/hr./sq foot/degree F
Conductivity | Btu/hr./foot/degree F
Displacement | inches
Traction | lbf per sq.in.
Youngs modulus | lbf per sq.in.
Mass density | lb per cubic foot
Coeff. of linear expansion | per degree Fahrenheit
Rotational speed | r.p.m

Further inconsistent unit sets may be incorporated according to user requirements.

FILE ACCESS AND STORAGE

Form:
FILE ACCESS AND STORAGE

Function:
Commences sub-block of data which determines file access type and controls deletion of work files on completion of the analysis.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE

Parameters:
None

Default:
Working files containing matrices, etc. will be of the direct access type. These working files will be deleted when they are no longer required.

Remarks:
Working files should not be deleted if the problem is to be re-analysed.

DIRECT

Form:
DIRECT

Function:
Indicates that the working files containing matrices, etc. will be of direct access type.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE - FILE ACCESS AND STORAGE

Parameters:
None

Default:
Direct access

Remarks:
None

DELETE

Form:
DELETE

Function:
Indicates that working files containing matrices, etc. are to be deleted once they are no longer required.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE - FILE ACCESS AND STORAGE

Parameters:
None

Default:
Working files are deleted once they are no longer required.

Remarks:
Working files should not be deleted if the problem is to be re-analysed. The data, results, printout and log files are never deleted by BEASY.

SAVE SYS

Form:
SAVE SYS

Function:
Indicates that the working files necessary for a restart at solution step 5 are to be kept. All other working files will be deleted.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
All working files are deleted once they are no longer required.

Remarks:
Solution step 5 is the earliest stage at which a restart analysis can be attempted if this keyword is used. Use of this keyword instead of the 'KEEP' keyword will lead to a reduced requirement for disk space in which to store working files.

KEEP

Form:
KEEP

Function:
Working files which may be used in a re-analysis of the problem will not be deleted after completion.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE - FILE ACCESS AND STORAGE

Parameters:
None

Default:
Working files will be deleted once they are no longer required.

Remarks:
The data, results, printout and log files are never deleted by BEASY.

SEQUENTIAL ACCESS SOLUTION FILE 2

Form:
SEQUENTIAL_ACCESS_SOLUTION_FILE_2

Function:
Indicates that a sequential access formatted version of solution file 2 will be produced as well as the default direct access unformatted file.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE - FILE ACCESS AND STORAGE

Parameters:
None

Default:
Only the direct access unformatted version of solution file 2 is created.

Remarks:
Generally only used to create a solution file which can be easily transported between different computer systems. This file (SF3) is considerably larger than the direct access (SF2) file, and so should be deleted if not required.

DIRECT ACCESS SOLUTION FILE 2

Form:
DIRECT_ACCESS_SOLUTION_FILE_2

Function:
Indicates that a direct access version of the solution file 2 will be produced.

Use:
Optional

Last command:
BEASY - SOLUTION TYPE - FILE ACCESS AND STORAGE

Parameters:
None

Default:
Only the direct access unformatted version of solution file 2 is created.

Remarks:
None

Solution Control Section

The solution control section allows further data to be specified about the model that is being analysed such as switches for the specific analysis type and futher model parameters. This section is begins with the keyword SOLUTION CONTROL and ends with the keyword GENERAL DATA after which the general model data section begins.

SOLUTION CONTROL

Form:
SOLUTION CONTROL

Function:
Commences data block for SOLUTION CONTROL keyword tree.

Use:
Compulsory

Last command:
None - main keyword.

Parameters:
None

Default:
None.

Remarks:
Correct order of the four main keywords must be observed.

CHECK

Form:
CHECK

Function:
Switches on full data checking for ALL zones. No other analysis steps are performed. The full data check consists of:

a check on the area/volume of the region modelled, giving a guide to whether the elements have been defined in the correct direction and without gaps or overlaps in the mesh

a check on the mesh grading and aspect ratios used

a check on the positions of any internal points

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
All analysis steps are performed. The full analysis includes a basic data check.

Remarks:
If the data check option is selected, then the only other keyword which it is necessary to include in the 'SOLUTION CONTROL' tree is 'LOAD AND B COND SET', since BEASY will check for any material properties which have been omitted. The area (2D) or volume (3D) enclosed by the boundary elements is calculated from a number of different 'observation points'. If these values are identical then it is very likely that the geometry has been defined correctly, i.e. there are no gaps or overlaps and each element has been defined in the correct direction. A 'volume check error' indicates that these volumes or areas differ, and that it is likely that a modeling error has been made. See details of the data check run of BEASY.

POTENTIAL ANALYSIS ONLY

Form:
POTENTIAL ANALYSIS ONLY

Function:
Forces program to carry out the thermal analysis only for a thermal stress problem

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Both thermal and stress analysis runs are carried out.

Remarks:

SEQUENTIAL SOLVER

Form:
SEQUENTIAL SOLVER

Function:
Turns on the sequential solver

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
The parallel solver is used by default.

Remarks:

ITERATIVE SOLVER

Form:
ITERATIVE SOLVER

Function:
Turns on the iterative solver.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
The direct solver is used by default.

Remarks:

ITERATIVE SOLVER INITIAL SOLUTION FROM FILE

Form:
ITERATIVE SOLVER INITIAL SOLUTION FROM FILE

Function:
Makes the iterative solver look for the initial solution in a given file.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Name of file containing the initial solution

Default:
The initial solution is used by default.

Remarks:

None

MEMORY LIMIT MEGABYTES

Form:
MEMORY LIMIT MEGABYTES value

Function:.

Specify the maximum memory for the code to use

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Memory limit in megabytes

Default:
Unlimited

Remarks:

For optimal performance, use this command to prevent the analysis from accessing virtual memory

USER DEFINED BLOCK SIZE

Form:
USER DEFINED BLOCK SIZE: DEFAULT

or

USER DEFINED BLOCK SIZE: value

Function:

Define a block size for use in the analysis. This over-rides any other block size keyword defined in data files. The default value selects values based on the analysis machine and model type. For example a stress analysis on a 64bit machine uses a value of 241 but the same model on a 32 bit machine uses a value of 81.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Define either the block size or enter the DEFAULT keyword option

Default:
Uses the defined block size using the block size keyword.

Remarks:

WRITE ASCII SIMLAB FILES

Form:
WRITE ASCII SIMLAB FILES

Function:.

Turns on the creation of output files for use in SIMLAB

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Output is disabled

Remarks:

WRITE ASCII GID FILES

Form:
WRITE ASCII GID FILES

Function:.

Turns on the creation of output files for use in GID

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Output is disabled

Remarks:

GID STEP NUMBER

Form:
GID STEP NUMBER n

Function:.

Select the "step" number for the GID output. This is usually the load case, iteration number or crack growth step and gives a starting point for the result case output. This is used to animate the results in the GID post-processing tool

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Step number

Default:
If there is no keyword the output starts with step number 1

Remarks:

None

GID OFFSET DISTANCE

Form:
GID OFFSET DISTANCE value

Function:

This defines an offset for the elements in the normal direction and can be used to identify coincident surfaces, such as crack faces or dual element surface.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Offset distance – this creates the offset in the normal direction.

Default:
No offset is applied

Remarks:

None

PARALLEL SOLVER NUMBER THREADS

Form:
PARALLEL SOLVER NUMBER THREADS

Function:
Sets the number of of worker threads.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Number of worker threads required.

Default:
The default number of threads is 1.

Remarks:

PARALLEL SOLVER NUMBER PROCESSES

Form:
PARALLEL SOLVER NUMBER PROCESSES

Function:
Sets the number of parallel solver processes to be used.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Number of solver processes

Default:
The default number of solver processes is 1.

Remarks:

PARALLEL SOLVER SLAVE MEMORY WORDS

Form:
PARALLEL SOLVER SLAVE MEMORY WORDS.

Function:
Sets the memory used by the parallel solver and by slave processes.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Memory (in words) required for the parallel solver.

Default:
The default used is 8000000 words (8000000*4 bytes)

Remarks:

ITERATIVE SOLVER KRYLOV DIMENSION

Form:
ITERATIVE SOLVER KRYLOV DIMENSION

Function:
Sets the Krylov dimension.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Krylov dimension.

Default:
30

Remarks:

ITERATIVE SOLVER PRECISION

Form:
ITERATIVE SOLVER PRECISION

Function:
Sets the iterative solver precision.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
3

Remarks:

ITERATIVE SOLVER MAXIMUM ITERATIONS

Form:
ITERATIVE SOLVER MAXIMUM ITERATIONS

Function:
Sets the maximum number of iterations in a solution.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
Maximum number of iterations allowed.

Default:
100

Remarks:

FRICTION CONTACT

Form:
FRICTION CONTACT

Function:
Switches on the friction contact analysis.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Frictionless Contact

Remarks:

MAXIMUM CRACK PROPAGATION LENGTH

Form:
MAXIMUM CRACK PROPAGATION LENGTH

Function:
Defines the maximum propagation length after which the crack propagation analysis is terminated.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
None

Default:
The length of the initial crack. ie The crack will double in length.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

INCREMENTAL CRACK EXTENSION DISTANCE FACTOR

Form:
INCREMENTAL CRACK EXTENSION DISTANCE FACTOR

Function:
Defines the ratio of the length of the new crack tip element to the length of the initial crack element at the first growth increment for all crack groups in the problem.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Crack Growth Distance Factor

Default:
The extension factor of 1.0 is used, i.e. the length of the new crack tip element at the first step is chosen to be the same as the length of the initial crack tip element.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

INCREMENTAL CRACK EXTENSION DISTANCE

Form:
INCREMENTAL CRACK EXTENSION DISTANCE

Function:
Explicitly defines the crack growth distance that is required. This overrides any other calculation of the crack growth distance and the INCREMENTAL CRACK EXTENSION DISTANCE keyword.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Crack Growth Distance

Default:
The default crack growth distance is based on the size of the elements on the crack and the crack growth distance factor that has been specified.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

MAXIMUM NO OF CRACK PROPAGATION STEPS

Form:
MAXIMUM NO OF CRACK PROPAGATION STEPS

Function:
Defines the maximum number of crack propagation steps to be performed in an automatic crack growth analysis.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Maximum number of propagation steps required.

Default:
The default number of crack steps is 0.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

MAXIMUM NUMBER OF LOAD CYCLES

Form:
MAXIMUM NUMBER OF LOAD CYCLES

Function:
This defines the maximum number of load cycles during a crack growth analysis. If the number of load cycles is exceeded then the crack growth will stop.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Maximum number of load cycles.

Default:
A default value of 1E25 cycles is used in the analysis.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

INITIAL NUMBER OF LOAD CYCLES

Form:
INITIAL NUMBER OF LOAD CYCLES

Function:
This defines the number of load cycles at the start of a crack growth analysis. This is used to count the total number of load cycles if the crack growth is continuing from a previous analysis and also can be used to start the analysis at the correct position within a load spectrum file.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Initial load cycle number.

Default:
The default for a model is that the analysis will start at the first load cycle.

Remarks:
This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

MAXIMUM CIRCUMFERENTIONAL STRESS GROWTH DIRECTION CRITERION

Form:
MAXIMUM CIRCUMFERENTIONAL STESS GROWTH DIRECTION CRITERION

Function:
The maximum circumferential stress criterion is used to predict the direction of the crack growth

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
None

Default:
Maximum principal stress criterion is used for 2D analysis and Strain Energy Density direction criterion is used for 3D analysis.

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

STRAIN ENERGY DENSITY GROWTH DIRECTION CRITERION

Form:
STRAIN ENERGY DENSITY GROWTH DIRECTION CRITERION

Function:
The strain energy density criterion is used to predict the direction of the crack growth.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
None

Default:
Maximum principal stress criterion is the default condition for 2D analysis.

Minimum strain energy density is the default condition for 3D analysis

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

MAXIMUM PRINCIPAL STRESS GROWTH DIRECTION CRITERION

Form:
MAXIMUM PRINCIPAL STRESS GROWTH DIRECTION CRITERION

Function:
The maximum principal stress criterion is used to predict the direction of the growth of the crack.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
None

Default:
Maximum principal stress criterion is the default condition for 2D analysis.

Minimum strain energy density is the default condition for 3D analysis

Remarks:

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

NUMBER OF J INTEGRAL PATH POINT

Form:
NUMBER OF J INTEGRAL PATH POINT

Function:
Defines the number of internal points which will be automatically generated in order to define the J integral path for each crack group.

Use:
Optional

Last command:
SOLUTION CONTROL - CRACK PROPAGATION

Parameters:
Number of points used in the J Integral Calculation

Default:
The total number of 33 points are used.

Remarks:
It is not recommended to use more than 33 J integral points as it produces internal points too close to the crack surface and hence an inaccurate stress intensity factor may be obtained.

This control is for 2D only further 3D controls can be found from the crack wizard.

This keyword only applies to manually built cracks – when using the crack wizard the selection in the wizard overrides this option.

DO NOT ALLOW SINGLENODE CONTACT INCREASE

Form:
DO NOT ALLOW SINGLENODE CONTACT INCREASE

Function:
This is used to explicitly disable the use of single node contact load changes.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
This is the default setting if no single node contact keyword is present

Remarks:

None

ALLOW SINGLENODE CONTACT INCREASE

Form:
ALLOW SINGLENODE CONTACT INCREASE

Function:
This turns on the single node contact increase option. Using this option, the displacement is increased (during load changes) only until a single node (or sometimes a pair of nodes) comes into contact. This can be used to give greater control over contact iterations. Note however this will also usually increase the number of iterations required.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

DO NOT ALLOW SINGLENODE CONTACT DECREASE

Form:
DO NOT ALLOW SINGLENODE CONTACT DECREASE

Function:
This is used to explicitly disable the use of single node contact load changes.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
This is the default setting if no single node contact keyword is present

Remarks:

None

ALLOW SINGLENODE CONTACT DECREASE

Form:
ALLOW SINGLENODE CONTACT DECREASE

Function:
 This turns on the single node contact decrease option. Using this option, the displacement is increased (during load changes) only until a single node (or sometimes a pair of nodes) come out of contact. This can be used to give greater control over contact iterations. Note however this will also usually increase the number of iterations required.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

DO NOT ALLOW SINGLENODE SLIP CHANGE

Form:
DO NOT ALLOW SINGLENODE SLIP CHANGE

Function:
This is used to explicitly disable the use of single node slip changes.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
This is the default setting if no single node contact keyword is present

Remarks:

None

ALLOW SINGLENODE SLIP CHANGE

Form:
ALLOW SINGLENODE SLIP CHANGE

Function:
 This turns on the single node slip change option. Using this option, the displacement is increased (during load changes) only until a single node (or sometimes a pair of nodes) slips in or out of contact. This can be used to give greater control over contact iterations. Note however this will also usually increase the number of iterations required.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

UNIFORM LOAD INCREMENT

Form:
UNIFORM LOAD INCREMENT

Function:
This turns on the use of a uniform load increments during the contact analysis. Normally the load will increase faster if the previous load steps converge in few iterations. This can be used to provide additional control over the load and convergence behaviour.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

FIXED LOAD INCREMENT

Form:
FIXED LOAD INCREMENT

Function:
This turns on the use of a fixed load increment during the contact analysis. Normally the load will increase faster if the previous load steps converge in few iterations. This can be used to provide additional control over the load and convergence behaviour.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

ARCHIVE SOLUTION FILES

Form:
ARCHIVE SOLUTION FILES

Function:
This turns on the creation of solution files after each stage in the loading change has converged.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

DETAILED LOG FILE

Form:
DETAILED LOG FILE

Function:
This turns on the creation of additional contact details into the log file.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
By default this option is disabled

Remarks:

None

ACOUSTIC DIAGNOSTIC ANALYSIS

Form:
ACOUSTIC DIAGNOSTIC ANALYSIS

Function:
Switches on the facility which evaluates the pure velocity contribution of elements to the pressure at internal points.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Analysis is carried out with the above facility switched off.

Remarks:

None

CREATE PRI FILE

Form:
CREATE PRI FILE

Function:
Indicates that this run is to be used to create the printout file only, from existing solution files SF1 and SF2. No analysis or data checks will be performed. Any solution control keywords which would normally cause analysis steps to be performed will be ignored. This type of run is useful since it allows the user to completely suppress the printout file, which can become large for large 3D problems, but still to be able to recover the file at a later date if that type of information is required.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
All analysis steps are performed. (By default a printout file is created).

Remarks:
For normal analysis runs, it is not necessary to include this keyword to create a printout file.

CREATE SOLUTION FILES

Form:
CREATE SOLUTION FILES

Function:
Indicates that this run is to be used to create the solution files only. No analysis steps will be performed, so the solution files will contain only information about the model and boundary conditions. Any solution control keywords which would normally cause analysis steps to be performed will be ignored. This type of run is useful since it allows the user to view the model in a postprocessing environment (either BEASY User Interface or another postprocessor by using BEASY-GIS) before running the analysis.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
All analysis steps are performed. (By default solution files are created).

Remarks:
None

CHECK MEMORY

Form:
CHECK MEMORY

Function:
Indicates that this run is to be used only to calculate the amount of memory needed by the full analysis run. No analysis steps will be performed, and any solution control keywords which would normally cause analysis steps to be performed will be ignored. If insufficient memory is available, a full BEASY analysis will stop. This type of run allows the user to check beforehand for large analysis cases.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
All analysis steps are performed.

Remarks:
If there is insufficient memory for the job, there are a number of ways of proceeding.

  • reduce the size of the problem, by using linear elements instead of quadratic where possible, or by reducing the number of elements where possible.

  • increase the maximum problem size (i.e. the maximum amount of memory available to BEASY) to a figure in excess of the memory required.

  • if options 1 and 2 above do not produce enough memory for your job, the analysis may still be run by adjusting the block size used to store the boundary element equations.

ALL

Form:
ALL zonelist

Function:
Indicates that all analysis steps are to carried out by BEASY, for the zones mentioned in the parameter list.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : list of the zones for which this keyword applies. See 'Remarks' for the forms this list may take.

Default:
No analysis steps are carried out.

Remarks:
When a list of numbers is required, as one is here, it may take any of the following forms:

(a) characters ALL. This implies that all eligible numbers are to be included in the list. Thus the statement ALL ALL specifies that all analysis steps are to be carried out for all zones in the problem.

(b) the individual numbers in free format.

(c) a list such as 1 THRU 12 , indicating that all numbers between 1 and 12 inclusive are to be considered.

Types (b) and (c) above may be mixed enabling any combination of values to be defined. However, lists such as 3 THRU 6 THRU 9 are NOT permitted.

CREATE INF

Form:
CREATE INF zonelist

Function:
Indicates that the influence matrices are to be computed for the zones mentioned in the parameter list.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which this keyword applies.

Default:
No solution steps are carried out.

Remarks:

None

CREATE SYS

Form:

CREATE SYS zonelist

Function:
Indicates that the system matrices are to be computed for the zones mentioned in the parameter list.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which this keyword applies

Default:
No analysis steps are carried out.

Remarks:
None

REDUCE SYS

Form:
REDUC SYS zonelist

Function:
Indicates that, for the zones mentioned in the parameter list, the left hand side matrix is to be reduced.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which this keyword applies

Default:
No analysis steps are carried out.

Remarks:
None

SOLVE ZONE

Form:
SOLVE ZONE zonelist

Function:
Indicates that, for the zones mentioned in the parameter list, the boundary/coupling conditions and body forces are to be applied and the boundary solution calculated.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which this keyword applies

Default:
No analysis steps are carried out.

Remarks:
None

SOLVE INT PNTS

Form:
SOLVE INT PTS zonelist

Function:
Indicates that the solution is to be found at all internal points occurring in the zones mentioned in the parameter list.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which this keyword applies

Default:
No analysis steps are carried out.

Remarks:
None

PRODUCE PRINTOUT

Form:
PRODUCE PRINTOUT zonelist

Function:
Indicates that a file suitable for line-printer output is to be produced. The printout contains general data and results according to the branch keywords in the sub-block from this keyword.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
zonelist : the list of zones for which the zone-based information is to be written to the printout file.

Default:
No printout file is created.

Remarks:
None

VERIFY DATA TYPES

Form:
VERIFY DATA TYPES

Function:
Commences a sub-block of branch keywords controlling which types of data are written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT

Parameters:
None

Default:
Printout file contains only results if this keyword is omitted.

Remarks:
None

ALL

Form:
ALL

Function:
Indicates that all types of data are to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
This keyword should not appear if any of the keywords detailed in the remainder of this section is used.

CONTROL

Form:
CONTROL

Function:
Indicates that the control information is to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
None

MESH POINT

Form:
MESH POINT

Function:
Indicates that the mesh point coordinates are to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
None

CONNECTIVITY

Form:
CONNECTIVITY

Function:
Indicates that the element connectivity information is to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
None

INTERNAL POINTS

Form:
INTERNAL POINTS

Function:
Indicates that the internal point coordinates are to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
None

BOUNDARY CONDITIONS

Form:
BOUNDARY CONDITIONS

Function:
Indicates that details of the applied boundary conditions are to be written to the printout file.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT - VERIFY DATA TYPES

Parameters:
None

Default:
If the 'VERIFY DATA TYPES' data block is empty, no types of data are verified by being written to the printout file.

Remarks:
Element boundary conditions, nodal boundary conditions and interface conditions will be printed. For large problems, the boundary condition listing in the printout file may become large, as it lists not only the user-applied conditions, but also the default conditions of free and insulated surfaces. For large problems, users may wish to suppress this output.

ELEMENT RESULT POSITION CODE

Form:
ELEMENT RESULT POSITION CODE code

Function:
Switches on printing of element results according to the value of code.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT

Parameters:
code = 1 : Print results at nodes code = 2 : Print results at mesh points code = 3 : Print results at nodes and mesh points

Default:
code = 3 : Results at the nodes and mesh points are written to the printout file if this keyword is omitted.

Remarks:
None

AVERAGE MESH POINT RESULTS

Form:
AVERAGE MESH POINT RESULTS

Function:
Switches on printing of results averaged at mesh points.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT

Parameters:
None

Default:
Mesh point average results are not printed

Remarks:
The BEASY analysis program calculates the boundary solution at the nodes. If the nodes and mesh points do not coincide the results are then extrapolated to the mesh points in order to simplify the interpretation of the results. Since BEASY uses discontinuous elements as well as continuous elements, the positions of mesh points may not be the same as the node points. In this case, the results at a mesh point will vary according to which element is used to perform the extrapolation. The mesh point average results give the mean of the values obtained from the extrapolation of results from all elements to which the particular mesh point is connected.

INTERNAL POINT RESULTS

Form:
INTERNAL POINT RESULTS

Function:
Switches on printing of the results at the internal points.

Use:
Optional

Last command:
SOLUTION CONTROL - PRODUCE PRINTOUT

Parameters:
None

Default:
Internal point results are not written to the printout file.

Remarks:
None

LOAD AND B COND SET

Form:
LOAD AND B COND SET bcids

Function:
Indicates that the boundary condition sets with identification numbers contained in the list bcids are to be used in the analysis.

Use:
Compulsory

Last command:
SOLUTION CONTROL

Parameters:
bcids : The list of identification numbers of the boundary condition sets which are to be used in the current analysis.

Default:
None. This keyword may not be omitted.

Remarks:
The user should ensure that in the event of more than one boundary condition set being included in the list, that the load sets are "similar". See the BEM fundamentals section from the main menu.

Multiple instances of this keyword can be used if it is required to analyse loads that do not have similar boundary condition types. In this case each keyword used can contain multiple boundary conditions but they should themselves be similar but loads on different keywords can be non-similar.

BALANCE CHECK

Form:
BALANCE CHECK

Function:
Indicates that a force equilibrium check (for a stress analysis) or a total flux balance check (for a potential analysis) is to be performed. Commences a sub-block of branch keywords specifying data relevant to balance checks.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
Balance checks are performed on a zonal basis

Remarks:
Results will be printed for all zones appearing in the parameter list following keyword PRODUCE PRINTOUT. This facility of BEASY enables the user to calculate the torsion constant of a section

BY ZONE

Form:
BY ZONE

Function:
Indicates that balance checks are to be performed on a zone-by-zone basis.

Use:
Optional

Last command:
SOLUTION CONTROL - BALANCE CHECK

Parameters:
None

Default:
Balance checks will be carried out for each zone.

Remarks:
Results of the balance checks will be printed for those zones appearing in the parameter list following keyword PRODUCE PRINTOUT.

ON ELEMENTS

Form:
ON ELEMENTS elmtlist

Function:
Indicates that a balance check is to be performed on a list of elements.

Use:
Optional

Last command:
SOLUTION CONTROL - BALANCE CHECK

Parameters:
elmtlist : the list of elements over which the balance check is to be performed.

Default:
None

Remarks:
This keyword may be repeated indicating that balance checks are required over two or more groups of elements. If the list contains contains elements from several zones and if results are not available for elements in some of the zones, then the balance checks will not be performed. See section on command ALL for details of input of numbers in parameter lists.

KINK ANGLE

Form:
KINK ANGLE angle

Function:
This is the value (in degrees) of the maximum angle between adjacent element normals which will allow continuous elements to be used.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
angle : angle (in degrees)

Default:
angle=10\circ

Remarks:
See BEASY fundamentals section in the main menu for further details on the use of continuous and discontinuous elements.

SELF ADAPTIVE CONTACT LOAD INCREMENT

Form:
SELF ADAPTIVE CONTACT LOAD INCREMENT

Function:
Indicates that for problems involving non-linear contact between surfaces, the load is to be incremented automatically by BEASY in variable sized increments. The size of each increment is determined by the degree of change in contact area, etc. brought about by the addition of the previous increment in load.

Use:
Optional

Last command:
SOLUTION CONTROL

Parameters:
None

Default:
If this keyword does not appear, the load will be incremented in equal steps.

Remarks:
See also the keyword MAXIMUM NUMBER OF CONTACT LOAD STEPS

General Data Section - Header, Mesh Points and Property Sets

The general data section begins with the GENERAL DATA keyword and contains the general data for the model. There are a number of sections within the GENERAL DATA group of commands -

Header commands - model title and subsection headers

Mesh Point Coordinates - mesh point positions for all mesh points in the model

Property Sets

Zone ID Information

Loading Information

GENERAL DATA

Form:
GENERAL DATA

Function:
Commences data block for GENERAL DATA keyword tree.

Use:
Compulsory

Last command:
None - main keyword.

Parameters:
None

Default:
None. This keyword may not be omitted.

Remarks:
Correct order of the four main keywords must be observed.

TITLE

Form:
TITLE

Function:
Indicates that the next record in the data file contains the problem title in A80 format.

Use:
Compulsory

Last command:
GENERAL DATA

Parameters:
None in the keyword record. The following record contains the title of the problem which appears at the top of each page in the printout file. The title may be left blank.

Default:
None

Remarks:
For some installations the length of the title may be limited to 72 characters. If in doubt, consult your system manager.

MESH POINT COORDINATES

Form:
MESH POINT COORDINATES

Function:
Indicates the start of the data block in which all mesh points are defined. The records of the data file which follow this keyword define the coordinates of the mesh points. Each point must occupy a separate record which takes the form: id-number x1 coord x2 coord x3 coord in which 'id-number' represents the (unique) identifying number of that mesh point, and the other three terms specify the coordinates of the point in the current axis system.

Use:
Compulsory. Mesh points must be defined.

Last command:
GENERAL DATA

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
As soon as the MESH POINT COORDINATES keyword has been issued, the default coordinate system is adopted. For 2D applications this is the z=0 plane of the global Cartesian reference system. Therefore the value of the x3 coordinate should be specified as zero. For 3D problems the default coordinate system is the full global Cartesian (x,y,z) reference system. For axisymmetric applications the default coordinate system is the q=0 plane of a cylindrical (r,z,q) system. Thus the parameter x3 should appear as zero for all mesh points. See also the remarks for the SOLUTION TYPE keyword.

Remarks:
No 'end-of-data' record is required to mark the end of the mesh point definition records. The program automatically recognises the next keyword when it encounters it.

PROPERTY SET FOR GAP ELEMENTS

Form:
PROPERTY SET FOR GAP ELEMENTS psid

Function:
Commences a sub-block of branch keywords which may be used to define the friction properties of gap elements. The keyword may be issued a number of times to define several different sets of gap element properties. The property set identification number psid will be referred to by the GAP ID keyword, when the values of the initial gap are specified.

Use:
Compulsory if gap elements are to be defined.

Last command:
GENERAL DATA

Parameters:
psid : The identification number of the gap element property set to be defined.

Default:
None. Friction coefficients must be set up for gap elements even if they are zero.

Remarks:
See the GAP ID keyword.

STATIC FRICTION COEFFICIENT

Form:
STATIC FRICTION COEFFICIENT fric

Function:
Defines the static friction coefficient (i.e. the friction coefficient applied before slippage occurs) to be applied to the gap element property set currently being defined.

Use:
Compulsory if gap elements are to be defined.

Last command:
GENERAL DATA - PROPERTY SET FOR GAP ELEMENTS

Parameters:
fric : Value of the static friction coefficient

Default:
None. This keyword must be used to define a friction coefficient, even if it is zero.

Remarks:
See the contact analysis documentation section for further details on this keyword

DYNAMIC FRICTION COEFFICIENT

Form:
DYNAMIC FRICTION COEFFICIENT fric

Function:
Defines the dynamic friction coefficient (i.e. the friction coefficient applied after slippage occurs) to be applied to the gap element property set currently being defined.

Use:
Compulsory if gap elements are to be defined.

Last command:
GENERAL DATA - PROPERTY SET FOR GAP ELEMENTS

Parameters:
fric : Value of the dynamic friction coefficient

Default:
None. This keyword must be used to define a friction coefficient, even if it is zero.

Remarks:
See the contact analysis documentation section for further details on this keyword

PROPERTY SET FOR TUBE ELEMENTS

Form:
PROPERTY SET FOR TUBE ELEMENTS psid

Function:
Commences a sub-block of branch keywords which may be used to define the properties of tube elements. The keyword may be issued a number of times to define several different sets of tube element properties. The property set identification number psid will be referred to by the U1, U2 and U3 keywords, when the tube elements are defined .

Use:
Compulsory if tube elements are to be defined.

Last command:
GENERAL DATA

Parameters:
psid : The identification number of the tube element property set to be defined in the following data block.

Default:
None

Remarks:
Tube elements are currently available for 3D potential analysis only.

DIAMETER

Form:
DIAMETER d1 d2 d3

Function:
Defines the diameter properties of the tube elements assigned property set psid.

Use:
Compulsory if tube elements are to be defined.

Last command:
GENERAL DATA - PROPERTY SET FOR TUBE ELEMENTS

Parameters:
d1 : Diameter at the start mesh point d2 : Diameter at the end mesh point d3 : Diameter at the middle mesh point

Default:
None

Remarks:
Minimum length/diameter ratios should be observed as below: Element type U1 Minimum L/D ratio 5 Element type U2 Minimum L/D ratio 7 Element type U3 Minimum L/D ratio 10 NOTE THAT IN THE CURRENT VERSION TUBE ELEMENTS ARE RESTRICTED TO STRAIGHT ELEMENTS OF CONSTANT DIAMETER.

HOLE

Form:
HOLE

Function:
Indicates that tube elements to be defined with this property set are to represent holes or voids in the master zone.

Use:
Optional

Last command:
GENERAL DATA - PROPERTY SET FOR TUBE ELEMENTS

Parameters:
None

Default:
None.

Remarks:
HOLE must be specified for each tube element property set.

General Data - Zone Definition Data

The zone data section contains the data that defines each zone of the model this includes

DEFINE ZONE

Form:
DEFINE ZONE zoneid

Function:
Indicates the start of a sub-block of branch keywords which are used to define all geometric properties of the zone having identification number zoneid.

Use:
Compulsory for all zones.

Last command:
GENERAL DATA

Parameters:
zoneid : The (unique) identification number of the zone to be defined in the following data block.

Default:
None

Remarks:
This data block must be used to define each zone which forms part of the problem.

TWO DIMENSIONAL

Form:
TWO DIMENSIONAL

Function:
Indicates that the zone currently being defined has 2D geometry.

Use:
Compulsory for 2D problems, though see the remarks for SOLUTION TYPE .

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
None. The geometry of a zone must be specified either in the SOLUTION TYPE keyword or in the zone definition using TWO DIMENSIONAL, THREE DIMENSIONAL or AXISYMMETRIC.

Remarks:
See the SOLUTION TYPE keyword remarks .

THREE DIMENSIONAL

Form:
THREE DIMENSIONAL

Function:
Indicates that the zone currently being defined has 3D geometry.

Use:
Compulsory for 3D problems, though see the remarks for SOLUTION TYPE .

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
None. The geometry of a zone must be specified either in the SOLUTION TYPE keyword or in the zone definition using TWO DIMENSIONAL, THREE DIMENSIONAL or AXISYMMETRIC.

Remarks:
See the SOLUTION TYPE keyword remarks .

AXISYMMETRIC

Form:
AXISYMMETRIC

Function:
Indicates that the zone currently being defined has axisymmetric geometry.

Use:
Compulsory for axisymmetric problems, though see the remarks for SOLUTION TYPE.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
None. The geometry of a zone must be specified either in the SOLUTION TYPE keyword or in the zone definition using TWO DIMENSIONAL, THREE DIMENSIONAL or AXISYMMETRIC.

Remarks:
See the SOLUTION TYPE keyword remarks .

ZONE SYMMETRY

Form:
ZONE SYMMETRY

Function:
Indicates that symmetry or antisymmetry is to be applied to the problem. Symmetry conditions are defined by the branch keywords associated with this keyword.

Use:
Optional

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no symmetry

Remarks:
For discussion of symmetry and antisymmetry see BEM fundamentals section from the main menu.

PLANES123

Form:
PLANES123 p1 p2 p3

Function:
Defines the state of symmetry or anti-symmetry which applies to the problem.

Use:
Optional

Last command:
GENERAL DATA - DEFINE ZONE - ZONE SYMMETRY

Parameters:
p1,p2,p3 : Specify reflection conditions about planes x1=0, x2=0 and x3=0 respectively. Here x1, x2 and x3 are the coordinate axes of the Cartesian reflection planes system. The value of p1,p2 and p3 must be specified according to the type of symmetry required:

TABLE 4 Symmetry conditions
Value | Reflection Condition |
 | Geometry | Variables
+1 | Symmetric | Symmetric
0 | No reflection | No reflection
-1 | Symmetric | Antisymmetric

Default:
There is no symmetry.

Remarks:
No elements should be placed on planes of symmetry. For 2D applications p3 is not used, but it should be included with value zero since the program expects to read three parameters. Antisymmetry is currently available only for 3D stress analysis. For axisymmetric situations the only plane about which symmetry is permissible is z=0. This will appear as the p2 parameter, though for versions 3.0 to 3.3 it was the p3 parameter. See the remarks for the SOLUTION TYPE keyword .

ZONE ELEMENTS

Form:
ZONE ELEMENTS

Function:
Indicates the start of a sub-block of branch keywords which define the elements comprising the current zone.

Use:
Compulsory for each zone

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
None

Remarks:
For each element, the zone in which it is first defined is referred to as its master zone. If the element is an interface element (i.e. forming part of the boundary between two zones) then it will be used to define a second zone. This second zone is referred to as its slave zone. The ZONE ELEMENTS data block is split into two branches - MASTER and SLAVE, in which elements are listed according to whether the zone being defined is the master or slave zone for each. The master zone is the zone for which the element is defined in the correct direction. If the direction is incorrect for a zone it will be a slave zone for that element. Only elements on interfaces may be slave elements for zones. Note that for a single zone problem no element will have a slave zone.

MASTER

Form:
MASTER

Function:
Indicates the start of the list of elements for which the current zone is the master zone. This is a list of all elements which have been defined in the correct direction for the zone being defined.

Use:
It is compulsory to define all elements. It is unlikely that a zone will exist which is the slave zone for all elements defining it. Thus it is unlikely that this keyword may be omitted.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS

Parameters:
None

Default:
None

Remarks:
A zone is the master zone to ALL elements forming an external boundary to the zone.

L1

Form:
L1 elnum (contflag) mp1mp2 mp3 parentid groupid

Function:
Defines an L1 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See the BEM fundamentals section for description of element types and notation. The characters DD may be included between L1 and elnum to indicate that the elements are to be made fully discontinuous.

L2

Form:
L2 elnum (contflag) mp1mp2 mp3 parentid groupid

Function:
Defines an L2 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See the BEM fundamentals section for description of element types and notation. The characters DD may be included between L2 and elnum to indicate that the element should be fully discontinuous.

L3

Form:
L3 elnum (contflag) mp1mp2 mp3 parentid groupid

Function:
Defines an L3 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
The mesh point at the 'middle' of the element is not required to be exactly at the mid-point of the element. However it is beneficial in terms of accuracy if it is placed as close as possible to the mid-point. See the BEM fundamentals section for description of element types and notation. The characters DD may be included between L3 and elnum to indicate that the element is to be fully discontinuous.

U1

Form:
U1 elnum (contflag) mp1 mp2 mp3 psid parentid groupid

Function:
Defines a U1 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

psid : Tube element property set number

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
The tube element property set identification number has already been defined in the PROPERTY SET FOR TUBE ELEMENTS data block . Tube elements are currently available for 3D potential analysis only. See BEM fundamentals section for description of element types and notation.

U2

Form:
U2 elnum (contflag) mp1 mp2 mp3 psid parentid groupid

Function:
Defines a U2 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

psid : Tube element property set number

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
The tube element property set identification number has already been defined in the PROPERTY SET FOR TUBE ELEMENTS data block . Tube elements are currently available for 3D potential analysis only. See BEM fundamentals section for description of element types and notation.

U3

Form:
U3 elnum (contflag) mp1 mp2 mp3 psid parentid groupid

Function:
Defines a U3 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mp1 : Mesh point number at the start of the element

mp2 : Mesh point number at the end of the element

mp3 : Mesh point number at the middle of the element

psid : Tube element property set number

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
The mesh point at the 'middle' of the element is not required to be at exactly the mid-point of the element. However it is beneficial in terms of accuracy if it is placed as close as possible to the mid-point. The tube element property set identification number has already been defined in the PROPERTY SET FOR TUBE ELEMENTS data block . Tube elements are currently available for 3D potential analysis only. See BEM fundamentals section for description of element types and notation.

Q1

Form:
Q1 elnum (contflag) mp1 mp2 mp3 mp4 mp5 mp6 mp7 mp8 mp9 parentid groupid

Function:
Defines a Q1 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDDD may be included between Q1 and elnum to indicate that the element is to be fully discontinuous.

Q2

Form:
Q2 elnum (contflag) mp1 mp2 mp3 mp4 mp5 mp6 mp7 mp8 mp9 parentid groupid

Function:
Defines a Q2 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDDD may be included between Q2 and elnum to indicate that the element is to be fully discontinuous.

Q3

Form:
Q3 elnum (contflag) mp1 mp2 mp3 mp4 mp5 mp6 mp7 mp8 mp9 parentid groupid

Function:
Defines a Q3 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDDD may be included between Q3 and elnum to indicate that the element is to be fully discontinuous.

Q38

Form:
Q38 elnum (contflag) mp1 mp2 mp3 mp4 mp5 mp6 mp7 mp8 mp9 parentid groupid

Function:
Defines a Q38 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDDD may be included between Q38 and elnum to indicate that the element is to be fully discontinuous.

T1

Form:
T1 elnum (contflag) mp1mp2 mp3 mp4 mp5 mp6 parentid groupid

Function:
Defines a T1 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDD may be included between T1 and elnum to indicate that the element is to be fully discontinous.

T2

Form:
T2 elnum (contflag) mp1mp2 mp3 mp4 mp5 mp6 parentid groupid

Function:
Defines a T2 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDD may be included between T2 and elnum to indicate that the element is to be fully discontinous.

T3

Form:
T3 elnum (contflag) mp1mp2 mp3 mp4 mp5 mp6 parentid groupid

Function:
Defines a T3 element

Use:
All elements must be defined.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS - MASTER

Parameters:
elnum : Identification number of the element

contflag: Optional: Flag for the continuity of the element

mpi : Mesh point number at the ith element mesh point location

The following fields are options but if they are included they must appear in the given order.

parentid: This is the element ID of the parent element - this is usually the same as the element id.

groupid: Output group ID - this is used to generate output groups (eg for GID post processing). This field is optional.

Default:
None

Remarks:
See BEM fundamentals section for description of element types, mesh point locations and notation. The characters DDD may be included between T3 and elnum to indicate that the element is to be fully discontinous.

SLAVE

Form:
SLAVE

Function:
Indicates the start of a list of the elements for which the current zone is the slave zone, i.e. elements which have been defined in the wrong direction for the zone. There are no keywords to list these elements. The following records list the element numbers only, with several element numbers on each record of the data file. No mesh point data is required as this was supplied in the master zone definition.

Use:
All elements for which this zone is slave zone must be listed. If there are no such elements then this keyword may be omitted.

Last command:
GENERAL DATA - DEFINE ZONE - ZONE ELEMENTS

Parameters:
None

Default:
There are no elements for which the current zone is slave.

Remarks:
Element identification numbers must start in the record immediately following the SLAVE keyword, and fill as many records as are required. The elements listed should be interface elements only.

ZONE DUAL ELEMENTS

Form:
ZONE DUAL ELEMENTS

Function:
Indicates the start of a list of the dual elements .

Use:
Optional.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There are no dual elements.

Remarks:
The dual elements must be a straight line of type L3 for 2D or a flat surface of type Q3_8 for 3D.

ZONE INITIAL CRACK ELEMENTS GROUP

Form:
ZONE INITIAL CRACK ELEMENTS GROUP

Function:
Indicates the start of a list of the dual elements at each crack group.

Use:
Compulsory for crack growth analysis.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no crack.

Remarks:
The crack elements must be a straight line of type L3 for 2D or a flat surface of type Q3_8 for 3D.

END ZONE INITIAL CRACK ELEMENTS GROUP

Form:
END ZONE INITIAL CRACK ELEMENTS GROUP

Function:
Indicates the end of a list of the dual elements at each crack group.

Use:
Compulsory for crack growth analysis.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no crack.

Remarks:
None

ZONE INITIAL CRACK TIP ELEMENTS

Form:
ZONE INITIAL CRACK TIP ELEMENTS

Function:
Indicates the list of crack tip elements.

Use:
Compulsory for 3D crack growth analysis.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no crack.

Remarks:
The first mesh point of the element should be at the crack tip.

ZONE INITIAL CRACK FRONT ELEMENTS

Form:
ZONE INITIAL CRACK FRONT ELEMENTS

Function:
Indicates the start of the list of crack front elements.

Use:
Compulsory for 3D crack growth analysis.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no crack.

Remarks:
Each register contains the id and the side of the element at the crack front.

END ZONE INITIAL CRACK FRONT ELEMENTS

Form:
END ZONE INITIAL CRACK FRONT ELEMENTS

Function:
Indicates the end of the list of crack front elements.

Use:
Compulsory for 3D crack growth analysis.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
None

Default:
There is no crack.

Remarks:
None.

ZONE INTERNAL POINTS

Form:
ZONE INTERNAL POINTS

Function:
Indicates the start of the data block in which all internal points in the current zone are defined. The records of the data file which follow this keyword define the coordinates of the internal points. Each point must occupy a separate record which takes the form: id-number x1 coord x2 coord x3 coord in which 'id-number' represents the (unique) identifying number of that internal point, and the other three terms specify the coordinates of the point in the (x,y,z), (r,q,z) or (r,z,q) axis system. For axisymmetric problems the (r,z,q) system is used. Note that some older BEASY versions used the (r,q,z) system for axisymmetric problems

Use:
Compulsory if internal points are to be defined.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
There are no internal points.

Remarks:
Internal point numbers may be any integer between +1 and +99999. No 'end-of-data' record is required to mark the end of the internal point definition records. The program automatically recognises the next keyword when it encounters it.

EXTERIOR PROBLEM

Form:
EXTERIOR PROBLEM

Function:
Indicates the zone is a fully infinite domain for an acoustic problem.

Use:
To define a zone which extends to infinity

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
The zone is assumed to be bounded.

Remarks:

INTERIOR PROBLEM

Form:
INTERIOR PROBLEM

Function:
Indicates that the zone is fully bounded for an acoustic problem

Use:
To define a zone that is fully enclosed.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
The above.

Remarks:

HARD HALF SPACE

Form:
HARD HALF SPACE

Function:
Indicates the boundary in an acoustic half space domain is hard surface.

Use:
To model an acoustic problem which has a fully reflective boundary. In this case the surface is automatically represented without describing elements on the plane. Similar to a symmetry plane

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
Full region

Remarks:
This facility has not been verified.

SOFT HALF SPACE

Form:
SOFT HALF SPACE

Function:
Indicates that the boundary in a half space acoustic domain is a soft boundary.

Use:
To model an acoustic problem which has a fully absorbing boundary. In this case the surface is automatically represented without describing elements on the plane. Similar to a symmetry plane

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
Full region

Remarks:

INFINITE DOMAIN

Form:
INFINITE DOMAIN

Function:
Indicates that the zone is a fully infinite domain

Use:
Compulsory if the problem zone is infinite.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
The zone is a fully bounded domain.

Remarks:
See BEM fundamentals section for details of modelling infinite and semi-infinite problems.

SEMI INFINITE DOMAIN

Form:
SEMI INFINITE DOMAIN

Function:
Indicates that the zone is a semi-infinite domain.

Use:
Compulsory if the zone is semi-infinite.

Last command:
GENERAL DATA - DEFINE ZONE

Parameters:
There are no parameters to be included in the same record as this keyword.

Default:
The zone is a fully bounded domain.

Remarks:
A semi-infinite domain is one which extends to infinity, but not in all directions. There will be boundary elements defining part of an external boundary, but these elements will be stopped at some point away from the area of interest. The domain will therefore not be closed. This is allowable in BEASY, but users should expect some loss of accuracy near the point where the boundary elements 'stop'. See BEM fundamentals section s for details of modeling infinite and semi-infinite problems.

LOADING DATA

Form:
LOADING DATA

Function:
Indicates the start of a sub-block of branch keywords which are used to define the loading to be considered in the analysis.

Use:
Compulsory

Last command:
GENERAL DATA

Parameters:
None

Default:
None

Remarks:
It should not be forgotten that such material properties as Youngs modulus and conductivity should be specified in this data block.

SOURCE POINTS

Form:
SOURCE POINTS

Function:
Indicates the start of a list of load point coordinates. A load point is simply a point in space which MAY later be used to define a source of flux or force. Records following this keyword are of the form spid x1 x2 x3 where 'spid' is the identification number of the source point, and x1, x2 and x3 are the coordinates of the load point in the (x,y,z) axis system. The number 'spid' may be any integer between +1 and +99999.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA

Parameters:
None

Default:
There are no load points.

Remarks:
Sources of flux may be specified by use of the POINT SOURCE keyword. Point forces are specified by use of the POINT FORCE keyword. Source points are not permitted in axisymmetric problems.

CONTACT CONTROL DATA

Form:
CONTACT CONTROL DATA

Function:
Indicates the start of a data block which defines the contact options for either non-conforming contact or for contact on crack faces.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA

Parameters:
None

Default:
The default contact options are used (see individual commands below)

Remarks:
None

NORMAL CONTACT STATE TOLERANCE

Form:
NORMAL CONTACT STATE TOLERANCE value

Function:
This option is used to determine if the contact state in a contact model has converged. This is defined to be a ratio (in % terms) of the number of nodes where the contact stage has changed and the number of nodes in contact at the current iteration. If the difference factor is below the defined tolerance then the normal state is said to have converged, ie it has converged when:

Increasing the tolerance may force the model to converge but may compromise the results.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - CONTACT CONTROL DATA

Parameters:
None

Default:
Default value = 0.015

Remarks:
None

TANG CONTACT STATE TOLERANCE

Form:
TANG CONTACT STATE TOLERANCE value

Function:
This option is used to determine if the contact state in a contact model has converged. This is defined to be a ratio (in % terms) of the number of nodes where the slip/stick contact stage has changed and the number of nodes in contact at the current iteration. If the difference factor is below the defined tolerance then the normal state is said to have converged, ie it has converged when:

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - CONTACT CONTROL DATA

Parameters:
None

Default:
Default value = 0.04 for 3D and 0.03 for 2D

Remarks:
None

DISPLACEMENT SOLUTION RATIO TOLERANCE

Form:
DISPLACEMENT SOLUTION RATIO TOLERANCE value

Function:
This defines a tolerance on displacement changes below which the model has been considered to have converged. The maximum displacement change is identified by searching the contact nodes and computing

Note: due to the normalising of the displacements, smaller elements require more stringent iterations giving smaller displacement changes.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - CONTACT CONTROL DATA

Parameters:
None

Default:
Default value = 0.0001

Remarks:
None

TRACTION SOLUTION RATIO TOLERANCE

Form:
TRACTION SOLUTION RATIO TOLERANCE value

Function:
 This defines a tolerance on traction changes below which the model has been considered to have converged.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - CONTACT CONTROL DATA

Parameters:
None

Default:
Default value = 0.0001

Remarks:
None

GAP ELEMENTS

Form:
GAP ELEMENTS

Function:
Indicates the start of a data block which defines the general control parameters for the contact analysis, and also the specific gap values.

Use:
Compulsory for gap elements

Last command:
GENERAL DATA - LOADING DATA

Parameters:
None

Default:
There are no gap elements.

Remarks:
None

MAXIMUM NUMBER OF CONTACT ITERATIONS

Form:
MAXIMUM NUMBER OF CONTACT ITERATIONS niter

Function:
BEASY solves contact problems using an iterative scheme. The load is gradually built up to the level applied by the user in the boundary condition data, using load increments. Within each load increment, BEASY iterates to find the true contact area between surfaces. This keyword puts a limit on the number of iterations used, allowing the user to limit the run time taken by the job.

Use:
Optional

Last command:

This command can occur in a number of places.

For conforming contact it will be in:
GENERAL DATA - LOADING DATA - GAP ELEMENTS

For non conforming contact it will be in:

GENERAL DATA - LOADING DATA – CONTACT CONTROL DATA

Or in a root file for fracture it will be in the CRACK ADDER private data section.

Parameters:
niter : Maximum number of iterations to be used.

Default:
niter = 15

Remarks:
None

MAXIMUM NUMBER OF CONTACT LOAD STEPS

Form:
MAXIMUM NUMBER OF CONTACT LOAD STEPS nstep

Function:
BEASY solves contact problems using an iterative scheme. The load is gradually built up to the level applied by the user in the boundary condition data, using load increments. Within each load increment, BEASY iterates to find the true contact area between surfaces. This keyword puts a limit on the number of load steps used, allowing the user to limit the run time taken by the job.

Use:
Optional

Last command:

This command can occur in a number of places.

For conforming contact it will be in:
GENERAL DATA - LOADING DATA - GAP ELEMENTS

For non conforming contact it will be in:

GENERAL DATA - LOADING DATA – CONTACT CONTROL DATA

Or in a root file for fracture it will be in the CRACK ADDER private data section.

Parameters:
nstep : Maximum number of load steps to be used.

Default:
nstep = 15

Remarks:
None

GAP ID

Form:
GAP ID elem psid dir (elem2)

Function:
Specifies that a gap exists over a given element in a given direction or directions, and assigns a gap element property set id to the element in the specified direction(s), which contains information about friction conditions which apply when the surfaces are in contact.

Use:
Compulsory for gap elements.

Last command:
GENERAL DATA - LOADING DATA - GAP ELEMENTS

Parameters:
elem : Master element id number

psid : Gap element property set id

dir : Direction(s) of gap

dir = 1 : normal

dir = 2 : 1st tangential

dir = 4 : 2nd tangential

elem2 : (optional) 'slave' element for other zone which is in contact with elem.

Sum dir values for gaps in two or more directions.

Default:
None

Remarks:
The friction conditions for each gap element property set id are defined in the PROPERTY SET FOR GAP ELEMENTS data block . Parameter elem2 should be omitted for the condition of contact with an external rigid surface. It should be given for contact between two parts of the BEASY model. The terms 'master' and 'slave' do not relate to the line or patch directions as for interface elements; instead they simply show the element (master) for which the value of the initial gap is given for each pair of contacting elements. This is specified in the INITIAL GAP keyword .

In some cases it does not matter which element is the master and which is the slave but in some cases changing the order may prevent singular matricies. In general the master element should be in the zone that is defined first, this is done automatically when using either BEASY-IMS or PATRAN to create the model.

INITIAL GAP

Form:
INITIAL GAP elem dir gap1...gapn

Function:
Specifies the value of the gap on an element in a given direction or directions.

Use:
Compulsory for master gap elements.

Last command:
GENERAL DATA - LOADING DATA - GAP ELEMENTS - GAP ID

Parameters:
elem : Element id number

dir : Direction(s) of gap

dir = 1 : normal

dir = 2 : 1st tangential

dir = 4 : 2nd tangential

gap1...gapn : values of the gap at the n mesh points of the element

Sum dir values for identical gaps in two or more directions.

Default:
None

Remarks:
For contact with an external rigid surface this keyword should give the value of the initial gap. For contact between two elements, this keyword should be present only for the master of the two elements, i.e. that specified as elem1 in the GAP ID keyword.

LOAD SET

Form:
LOAD SET setid

Function:
Indicates the start of a sub-block of branch keywords which are used to define the loading comprising load set number setid. This record may be followed by an optional record containing a description of the load set in A80 format.

Use:
Compulsory

Last command:
GENERAL DATA - LOADING DATA

Parameters:
setid : Identification number of the load set to be defined.

Default:
None

Remarks:
It is this value of setid which is referred to in the LOAD AND B COND SET keyword in order to select which load case is to be analysed. This keyword (and its associated data block) may be given several times in the data file, allowing the user to specify a number of load cases before running the program.

ROTATIONAL CYCLIC SYMMETRY

Form
ROTATIONAL CYCLIC SYMMETRY

Function:
This indicates the start of the cyclic symmetry data block.

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:
General data - loading data

Parameters:
None

Default:
None

Remarks:

Only one rotational cyclic symmetry data block is allowed for any problems.

The mesh point pairs must form a complete set of elements.

The master and slave cyclic symmetry elements must be geometrically identical.

Position On Rotational Cyclic Symmetry Axis

Form
POSITION ON ROTATIONAL CYCLIC SYMMETRY AXIS

Function:
Header record for the data block

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY

Parameters:
None

Default:
None

Remarks:
None

Xpos Ypos Zpos

Form
Xpos Ypos Zpos

Function:
This record gives the global cartisan coordinates of a position through which the axis passes

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - POSITION ON ROTATIONAL CYCLIC SYMMETRY AXIS

Parameters:
None

Default:
None

Remarks:
None

END CYCLIC POSITION

Form
End CYCLE Position

Function:
This record identifies the end of the data block

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - Xpos Ypos Zpos

Parameters:
None

Default:
None

Remarks:
None

Vector Along Rotational Cyclic Symmetry Axis

Form
Vector Along Rotation Cyclic Symmetry Axis

Function:
Header record for the data block

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY

Parameters:
None

Default:
None

Remarks:
None

Vx Vy Vz

Form
Vx Vy Vz

Function:
This gives components of a vector along the axis. The vector is orientated such that rotation from a master mesh point to its slave mesh poimt corresponds to a positive rotation around the vector.

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLC SYMMETRY - VECTOR ALONG ROTATIONAL CYCLIC SYMMETRY AXIS

Parameters:
None

Default:
None

Remarks:
None

END CYCLIC VECTOR

Form
End CYCLIC Vector

Function:
This record identifies the end of the data block

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - Vx Vy Vz

Parameters:
None

Default:
None

Remarks:
None

Cyclic Symmetry Master Slave Mesh Point Pairs

Form

CYCLIC SYMMETRY MASTER SLAVE MESH POINT PAIRS

Function:
HEADER OF THE DATA BLOCK CONTAINING ONLY mesh point pairs AS:

Master Mesh Point ID Slave Mesh Point ID

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY

Parameters:
None

Default:
None

Remarks:
None

Master Mesh Point ID Slave Mesh Point ID

Form
Master mesh Point ID Slave Mesh Point ID

Function:
Gives ID numbers of a pair of mesh points. This keyword is repeated as required.

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - CYCLIC SYMMETRY MASTER SLAVE MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
See remarks for Rotational Cyclic Symmetry command.

END MESH POINT PAIRS

Form
END MESH POINT PAIRS

Function:
This record identifies the end of the data block.

Use:

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - MASTER MESH POINT ID SLAVE MESH POINT ID

Parameters:
None

Default:
None

Remarks:
None

End Rotational Cyclic Symmetry

Form
End Rotation Cyclic Symmetry

Function:
This record identidfies the end of the Cyclic Symmetry Data Block.

Use:

Compulsory if cyclic symmetry is to be defined.

Last command:

GENERAL DATA - LOADING DATA - ROTATIONAL CYCLIC SYMMETRY - END MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
None

Elements Rigid Links

Form
ELEMENTS RIGID LINKS

Function:
This indicates the start of the Elements Rigid Links data block

Use:

COMPULSORY IF ELEMENTS RIGID LINKS ARE TO BE DEFINED.
Last command:

GENERAL DATA - LOADING DATA

Parameters:
None

Default:
None

Remarks:

Only one Elements Rigid Links Data Block allowed for any problem

The mesh point pairs must form a complete set of elements

The master and slave rigid link elements must be geometrically identical

RIGID LINKS MASTER SLAVE MESH POINT PAIRS

Form
RIGID LINKS MASTER SLAVE MESH POINT PAIRS

Function:
HEADER OF A DATA BLOCK CONTAING ONLY MESH POINT PAIRS AS FOLLOWS.

Use:

COMPULSORY IF ELEMENTS RIGID LINKS ARE TO BE DEFINED.
Last command:

GENERAL DATA - LOADING DATA - ELEMENTS RIGID LINKS

Parameters:
None

Default:
None

Remarks:
None

Master Mesh Point ID Slave Mesh Point ID

Form
Master Mesh Point ID Slave Mesh Point ID

Function:
Gives ID numbers of a pair of mesh points. This keyword is repeated as required

Use:

COMPULSORY IF ELEMENTS RIGID LINKS ARE TO BE DEFINED.
Last command:

GENERAL DATA - LOADING DATA - ELEMENTS RIGID LINKS - RIGID LINKS MASTER SLAVE MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
See remarks on Elements Rigid Links command.

End Mesh Point pairs

Form
END MESH POINT PAIRS

Function:
This record identifies the end of the data block.

Use:
COMPULSORY IF ELEMENTS RIGID LINKS ARE TO BE DEFINED.
Last command:
GENERAL DATA - LOADING DATA - ELEMENTS RIGID LINKS - Master Mesh Point ID Slave Mesh Point ID

Parameters:
None

Default:
None

Remarks:
None

End Elements Rigid Links

Form:
END ELEMENTS RIGID LINKS

Function:
This record identifies the End of the Elements Rigid Links Data Block

Use:

COMPULSORY IF ELEMENTS RIGID LINKS ARE TO BE DEFINED.
Last command:

GENERAL DATA - LOADING DATA - ELEMENTS RIGID LINKS - END MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
None

Group Rigid Links

Form:
GROUP RIGID LINKS groupid

Function:
This defines a Group Rigid Links data Block which is identified by its ID

Use:

Compulsory if group rigid links are to be defined.

Last command:

GENERAL DATA - LOADING DATA

Parameters:
groupid : Group id number

Default:
None

Remarks:

There may be more than one group rigid links data block defined for any problem

The master and slave elements must be geometrically identical

The mesh point list must form a complete set of elements

Each element can only be defined in only one GROUP RIGID LINK data block

The variable type can only be a primary variable ( i.e displacement, potential etc)

Variable Type

Form:
VARIABLE TYPE "variable name"

Function:
This defines the variable type which are rigidly linked. The variable name can be "Potential", "displaceMENT" etc

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINKS

Parameters:
Variable name : defines the primary variable name.

Default:
None

Remarks:
None

Links Coordinate System

Form:
LINKS COORDINATE SYSTEM "Coord System ID"

Function:
This defines the coordinate system in which the link is defined.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINK

Parameters:
Coord System ID

Default:
None

Remarks:
None

Links Directions

Form:
LINKS DIRECTIONS "X1" AND/OR "X2" AND/OR "X3"

Function:
This defines the direction(s) of the link.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINK

Parameters:
X1 X2 X3

Default:
None

Remarks:
None

Links Constants

Form:
LINKS CONSTANTS "Constant X1", "Constant X2", "Constant X3"

Function:
Defines the equilibrium constant in three directions (default is set to zero)

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINK

Parameters:
Constant X1 X2 X3

Default:
Zero

Remarks:
None

Links Mesh Point List

Form:
LINKS MESH POINT LIST

Function:
Header of a data block containing the list of the mesh points which are rigidly linked.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINKS

Parameters:
None

Default:
None

Remarks:
None

List of Mesh Point ID's

Form:
List Of Mesh Point ID's

Function:
Gives mesh point ID numbers which belong to the link.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINKS - LINKS MESH POINT LIST

Parameters:
None

Default:
None

Remarks:
None

End Mesh Points List

Form:
END MESH POINTS LIST

Function:
Indicates the end of the mesh point list.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINKS - List of Mesh Point ID's

Parameters:
None

Default:
None

Remarks:
None

End Group Rigid Links

Form:
END GROUP RIGID LINKS

Function:
This record identifies the end of the group rigid link data block.

Last command:

GENERAL DATA - LOADING DATA - GROUP RIGID LINKS - END MESH POINTS LIST

Parameters:
None

Default:
None

Remarks:
None

Pair Rigid Links

Form:
PAIR RIGID LINKS id

Function:
This defines a pair rigid links data block which is identified by its ID.

Use:

Compulsory if pair rigid links are to be defined.

Last command:

GENERAL DATA - LOADING DATA

Parameters:
pairid : pair id number

Default:
None

Remarks:

There may be more than one pair rigid link data block defined for any problem

The mesh point pairs must form a complete set of elements

The master and slave elements must be geometrically identical

Each element can only be identified in one pair rigid link data block.

Links Coordinate System

Form:
LINKS COORDINATE SYSTEM "Coord System id"

Function:
This defines the cordinate system in which the link is defined.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS

Parameters:
Coord System id

Default:
None

Remarks:
None

Links Directions

Form:
LINKS DIRECTIONS "X1" and/or "X2" and/or "X3"

Function:
This defines the direction(s) of the link.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS

Parameters:
X1 X2 X3

Default:
None

Remarks:
None

Links Constants

Form:
LINKS CONSTANTS "Constant X1", "Constant X2", "Constant X3"

Function:
This defines the links equilibrium constants in 3 directions ( defaults set to zero).

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS

Parameters:
Constant X1 X2 X3

Default:
None

Remarks:
None

Links Master Slave Mesh Point Pairs

Form:
LINKS MASTER SLAVE MESH POINT PAIRS

Function:
Header of a data block containing only mesh pairs as in the next entry.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS

Parameters:
None

Default:
None

Remarks:
None

Master Mesh Point ID Slave Mesh Point ID

Form:
MASTER MESH POINT ID SLAVE MESH POINT ID

Function:
Gives ID numbers of a pair of mesh points. This keyword is repeated as required.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS - LINKS MASTER SLAVE MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
None

End Mesh Point Pairs

Form:
END MESH POINT PAIRS

Function:
This record identifies the end of the data block.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS - Master Mesh Point ID Slave Mesh Point ID

Parameters:
None

Default:
None

Remarks:
None

End Pair Rigid Links

Form:
END PAIR RIGID LINKS

Function:
This record identifies the end of the pair rigid links data block.

Last command:

GENERAL DATA - LOADING DATA - PAIR RIGID LINKS - END MESH POINT PAIRS

Parameters:
None

Default:
None

Remarks:
None

DEFINE BOUNDARY AND INTERFACE CONDITIONS

Form:
DEFINE BOUNDARY AND INTERFACE CONDITIONS

Function:
Indicates the start of a data block in which all boundary conditions and interface conditions are to be specified for this load set.

The general form of data input in this data block is a keyword followed by parameters in free format, where the keyword starts in column 1 and the parameters may extend over two or more records if required. Each keyword specifies a single quantity such as potential, displacement in the x2-direction, etc.

Each keyword is made up of a 'loadkey' plus any additional characters as may be required. These additional characters may be

' NODAL' in which case the boundary condition applies to a single node

' SLAVE' in which case an interface boundary condition is applied to the slave zone instead of the default case of the master zone.

Note the blank space at the start of the additional characters above. The table on the following pages gives a full list of the loadkeys with a brief description of their function and their availability for defining element, nodal and interface boundary conditions. The parameters for the input of element boundary conditions take the form

elnum value1 ... valuei

where elnum is the identifying number of the element and value1 ... valuei are the values of the boundary condition at the i mesh points on the element. The parameters for the input of nodal boundary conditions take the form

elnum nodnum value

where elnum is the element number, nodnum is the local node number and value is the value of the boundary condition to be applied at the node.

Use:
Compulsory

Last command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
None on this record. Boundary and interface condition data appears on following records.

Default:
Normal flux = 0

All tractions = 0

Physical continuity across all interfaces

Ambient potential = 0

Remarks:
This keyword must be included even if no boundary conditions are present. Nodal conditions may not be applied on interfaces. It is essential in a potential (thermal) analysis that at least one value of potential (temperature) is supplied. In a stress analysis, at least one displacement restraint should be given in each direction to suppress rigid body translation, although in some cases a symmetry condition may render this unnecessary. Additional displacement constraints may be necessary to suppress rigid body rotation. For axisymmetric problems the x1 and x2 directions refer to r and z respectively. Note for older BEASY versions these were represented by x1 and x3 (see the remarks for the SOLUTION TYPE keyword). For details of individual boundary and interface condition types, see BEM fundamentals section The following tables give details of the loadkey types and their availability for specifying different types of boundary conditions.

LOADKEY | DESCRIPTION | EB | NB | IB
POTENTIAL | Potential (a scalar quantity) | * | * | *
NORMALFLUX | Flux density normal to surface (positive into body) | * |  |
AMBIENTPOT | Ambient potential (a scalar quantity) | * |  | *
TRANSCOEFF | Heat transfer coefficient (a scalar quantity) | * |  | *
DISPLX1 | Displacement in current x1-direction | * | * | *
DISPLX2 | Displacement in current x2-direction | * | * | *
DISPLX3 | Displacement in current x3-direction | * | * | *
TRACTX1 | Traction in current x1-direction | * |  |
TRACTX2 | Traction in current x2-direction | * |  |
TRACTX3 | Traction in current x3-direction | * |  |
NORMALDISP | Displacement normal to surface (positive out of body) | * | * | *
NORMALTRAC | Traction normal to surface (suction positive) | * |  |
TANGDISP1 | Displacement in first tangential local direction | * | * | *
TANGDISP2 | Displacement in second tangential local direction | * | * | *
TANGTRAC1 | Traction (+ve) in first tangential local direction | * |  |
TANGTRAC2 | Traction (+ve) in second tangential local direction | * |  |
ADDFLUXD | Flux density input to the system at an interface |  |  | *
MEMBRANE | Thermally resistant membrane separating two zones |  |  | *
ADDTRACX1 | Traction on master zone at interface in x1-direction |  |  | *
ADDTRACX2 | Traction on master zone at interface in x2-direction |  |  | *
ADDTRACX3 | Traction on master zone at interface in x3-direction |  |  | *
ADDTRACNORM | Normal outward traction on master zone at interface |  |  | *
ADDTANGTRAC1 | Traction in first tangential direction at interface |  |  | *
ADDTANGTRAC2 | Traction in second tangential direction at interface |  |  | *
SLIDER | Sliding boundary condition on interface |  |  | *
GSPRING1 | X1X1 spring stiffness in current coordinate system | * |  | *
GSPRING2 | X2X2 spring stiffness in current coordinate system | * |  | *
GSPRING3 | X3X3 spring stiffness in current coordinate system | * |  | *
NORMALSPRING | Spring stiffness in direction normal to the surface | * |  | *
TANGSPRING1 | Spring stiffness in first tangential direction | * |  | *
TANGSPRING2 | Spring stiffness in second tangential direction | * |  | *
ISPRING1 | Internal spring stiffness in current x1-direction |  |  | *
ISPRING2 | Internal spring stiffness in current x2-direction |  |  | *
ISPRING3 | Internal spring stiffness in current x3-direction |  |  | *
ISPRINGNORM | Internal spring stiffness in normal direction |  |  | *
ISPRINGTANG1 | Internal spring stiffness in 1st tangential direction |  |  | *
ISPRINGTANG2 | Internal spring stiffness in 2nd tangential direction |  |  | *
PHYSCONT1 | Physical continuity at interface in x1-direction |  |  | *
PHYSCONT2 | Physical continuity at interface in x2-direction |  |  | *
PHYSCONT3 | Physical continuity at interface in x3-direction |  |  | *
INIDISPX1 | Initial displacement in x1-direction | * |  |
INIDISPX2 | Initial displacement in x2-direction | * |  |
INIDISPX3 | Initial displacement in x3-direction | * |  |
INIDISNORM | Initial displacement in normal direction | * |  |
INIDISTANG1 | Initial disp. in first tang. direction | * |  |
INIDISTANG2 | Initial disp. in second tang. direction | * |  |
RADAMBPOTEN | Radiative ambient potential | * |  | *
RADEXCHFAC | Radiative exchange factor | * |  |
IRADEXCHFAC | Radiative exchange factor on interface |  |  | *
DEFTRACX1 | Default traction in x1-direction | * |  |
DEFTRACX2 | Default traction in x2-direction | * |  |
DEFTRACX3 | Default traction in x3-direction | * |  |
NORMDEFTRAC | Default traction in normal direction | * |  |
TANGDEFTRAC1 | Default trac in first tang. direction | * |  |
TANGDEFTRAC2 | Default trac in second tang. direction | * |  |
SURFSOURCE | Surface source | * |  |
PRESFITX1 | Press fit condition in current x1-direction |  |  | *
PRESFITX2 | Press fit condition in current x2-direction |  |  | *
PRESFITX3 | Press fit condition in current x3-direction |  |  | *
NORMPRESFIT | Press fit condition in normal direction |  |  | *
TANGPRESFIT1 | Press fit in first tang. direction |  |  | *
TANGPRESFIT2 | Press fit in second tang. direction |  |  | *
IINIDISPX1 | Initial x1-displacment on interface |  |  | *
IINIDISPX2 | Initial x2-displacment on interface |  |  | *
IINIDISPX3 | Initial x3-displacment on interface |  |  | *
IINIDISNORM | Initial normal displacment on interface |  |  | *
IINIDISTANG1 | Initial disp. in first tang. direc on interface |  |  | *
IINIDISTANG2 | Initial disp. in second tang. direc on interface |  |  | *
IDEFTRACX1 | Default traction in x1-direction on interface |  |  | *
IDEFTRACX2 | Default traction in x2-direction on interface |  |  | *
IDEFTRACX3 | Default traction in x3-direction on interface |  |  | *
IDEFTRCNORM | Default trac in normal direction on interface |  |  | *
IDEFTRCTANG1 | Default trac in 1st tang. direc. on interface |  |  | *
IDEFTRCTANG2 | Default trac in 2nd tang. direc. on interface |  |  | *
POTENTJUMP | Potential difference across interface |  |  | *
ISURFSOURCE | Surface source on interface |  |  | *
R-EFIELDX1 | Real part of the electric potential in current x1 direc. |  |  |
I-EFIELDX1 | Imag. part of the electric potential in current x1 direc. |  |  |
R-EFIELDX2 | Real part of the electric potential in current x2 direc. |  |  |
I-EFIELDX2 | Imag. part of the electric potential in current x2 direc. |  |  |
R-EFIELDX3 | Real part of the electric potential in current x3 direc. |  |  |
I-EFIELDX3 | Imag. part of the electric potential in current x3 direc. |  |  |
R-NDRVEFLDX1 | Real part of the norm. derivative of the electric potential in current x1 direction |  |  |
I-NDRVEFLDX1 | Imag. part of the norm. derivative of the electric potential in current x1 direction |  |  |
R-NDRVEFLDX2 | Real part of the norm. derivative of the electric potential in current x2 direction |  |  |
I-NDRVEFLDX2 | Imag. part of the norm. derivative of the electric potential in current x2 direction |  |  |
R-NDRVEFLDX3 | Real part of the norm. derivative of the electric potential in current x3 direction |  |  |
I-NDRVEFLDX3 | Imag. part of the norm. derivative of the electric potential in current x3 direction |  |  |
R-NORMEFLDN | Real part of the electric potential in norm. direction |  |  |
I-NORMEFLDN | Imag. part of the electric potential in norm. direction |  |  |
R-TANGEFLDN1 | Real part of the electric potential in the first tangential direction |  |  |
I-TANGEFLDN1 | Imag. part of the electric potential in the first tangential direction |  |  |
R-TANGEFLDN2 | Real part of the electric potential in the second tangential direction |  |  |
I-TANGEFLDN2 | Imag. part of the electric potential in the second tangential direction |  |  |
R-NDRVNORME | Real part of norm. derivative of norm. electric potential |  |  |
I-NDRVNORME | Imag. part of norm. derivative of norm. electric potential |  |  |
R-NDRVTANGE1 | Real part of norm. derivative of electric potential in first tangential direction |  |  |
I-NDRVTANGE1 | Imag. part of norm. derivative of electric potential in first tangential direction |  |  |
R-NDRVTANGE2 | Real part of the norm. derivative of electric potential in second tangential direction |  |  |
I-NDRVTANGE2 | Imag. part of the norm. derivative of electric potential in second tangential direction |  |  |
R-VELOPOTEN | Real part of velocity potential |  |  |
I-VELOPOTEN | Imag. part of velocity potential |  |  |
R-NORMALVELO | Real part of normal velocity |  |  |
I-NORMALVELO | Imaginary part of normal velocity |  |  |
R-ACOUAMBPRS | Real part of acoustic ambient pressure |  |  |
I-ACOUAMBPRS | Imaginary part of acoustic ambient pressure |  |  |
R-ACOUADMIT | Real part of acoustic admittance |  |  |
I-ACOUADMIT | Imaginary part of acoustic admittance |  |  |
R-ACOUSPRESS | Real part of acoustic pressure |  |  |
I-ACOUSPRESS | Imaginary part of acoustic pressure |  |  |
R-ACOUIMPDNC | Real part of acoustic impedance |  |  |
I-ACOUIMPDNC | Imaginary part of acoustic impedance |  |  |
R-NORMALACC | Real part of normal acceleration |  |  |
I-NORMALACC | Imaginary part of normal acceleration |  |  |
POLARISATION | Element on POLARISATION |  |  |
R-ACOUSTRVLO | Real part of acoustic structural norm. velocity |  |  |
I-ACOUSTRVLO | Imag. part of acoustic structural norm. velocity |  |  |

Table 1 Loadkey types and availability

In the above table, an asterisk (*) in the column labelled 'EB' indicates that the boundary condition is available for use as an element boundary condition. An asterisk in the 'NB' column indicates that the nodal boundary condition is available, and an asterisk in the 'IB' column indicates that the interface boundary condition is available.

BODY FORCES

Form:
BODY FORCES

Function:
Indicates the start of a sub-block of branch keywords which may be used to define any body forces acting on the body.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
None

Default:
There are no body forces.

Remarks:
None

ZONE ID

Form:
ZONE ID zoneid

Function:
Body forces must be defined on a zone-by-zone basis. This keyword indicates the start of the data block defining the body forces acting on zone number zoneid.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES

Parameters:
zoneid : The identification number of the zone for which the body forces are being defined.

Default:
None

Remarks:
All body force data for a zone must be input in one such data block. It is not permissible to define body forces on a single zone in more than one BODY FORCES - ZONE ID data block.

ROTATION

Form:
ROTATION rx1 rx2 rx3

Function:
Defines centrifugal loads by specifying speeds of rotation about up to three axes.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
rx1,rx2,rx3 : Rotation speeds (in radians per second) about Cartesian axes x1, x2 and x3 respectively.

Default:
There is no rotation.

Remarks:
For axisymmetric applications, rx1 and rx3 MUST always be zero. rx2 corresponds to rotation speed about the axis of symmetry. Note that for some old BEASY versions (3.0 to 3.3), it was rx3 which defined rotation around the axis of symmetry. For 2D and 3D applications, rotation around all three axes is permissible. However, for 2D problems the axis of rotation must be completely in the plane of the model or exactly normal to the plane. This means that if rx3 is non-zero, then both rx1 and rx2 must be zero.

ACCELERATION

Form:
ACCELERATION ax1 ax2 ax3

Function:
Defines a constant acceleration field (such as gravitation) acting on the current zone.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
ax1,ax2,ax3 : Components of acceleration acting in the positive directions of the x1, x2 and x3 axes respectively.

Default:
There is no acceleration.

Remarks:
For axisymmetric applications, the only permissible direction for acceleration is the x2 axis (i.e. the axis of geometric rotation). Note that for some old BEASY versions (3.0 to 3.3), x3 was the axis of rotation.

VOLUME SOURCE

Form:
VOLUME SOURCE str

Function:
Defines a volume source of flux. The strength is constant throughout the current zone.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
str : Source strength of the volume source per unit volume.

Default:
No volume sources.

Remarks:
Volume sources are available for 2D and 3D problems only. Volume sources are not available for 3D thermal stress problems.

POINT SOURCE

Form:
POINT SOURCE spid str

Function:
Defines a point source of flux.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
spid : Identification number of the load point which was defined using the SOURCE POINTS keyword.

str : Source strength of the source of flux. A negative value of str indicates a sink.

Default:
No point sources.

Remarks:
See BEM fundamentals section for details of permissible positions for point sources. Point sources are available for 2D and 3D applications only.

SL2D1

Form:
SL2D1 lsid spid1 spid2 str

Function:
Defines a line source between two load points, along which the source strength is constant.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
lsid : Identification number of the line source.

spid1 : Identification number of a load point at one end of the
line

spid2 : Identification number of a load point at the other end of the line str : source strength per unit length

Default:
No source lines

Remarks:
See BEM fundamentals section for details on permissible positions of line sources. Line sources are available for 2D and 3D problems only.

SL2D2

Form:
SL2D2 lsid spid1 spid2 str1 str2

Function:
Defines a line source between two load points, along which the source strength varies linearly.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
lsid : Identification number of the line source.

spid1 : Identification number of a load point at one end of the line

spid2 : Identification number of a load point at the other end of the line

str1 : source strength per unit length at load point spid1

str2 : source strength per unit length at load point spid2

Default:
No source lines

Remarks:
See BEM fundamentals section for details on permissible positions for line sources. Line sources are available for 2D and 3D problems only.

SL3D3

Form:
SL3D3 lsid spid1 spid2 spid3 str1 str2 str3

Function:
Defines a line source using three load points, along which the source strength varies quadratically.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
lsid : Identification number of the line source.

pid1 : Identification number of a load point at one end of the line

pid2 : Identification number of a load point at the other end of the line

spid3 : Identification number of a load point at the middle of the line

str1 : source strength per unit length at load point spid1

str2 : source strength per unit length at load point spid2

str3 : source strength per unit length at load point spid3

Default:
No source lines

Remarks:
See BEM fundamentals section for details on permissible positions for line sources. Line sources are available for 2D and 3D problems only.

POINT FORCE

Form:
POINT FORCE spid valx valy valz

Function:
Defines a point force

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters :
spid : identification number of the load point which was defined using the SOURCE POINTS keyword.

valx, valy, valz : x, y and z components of the force

Default:
No point forces

Remarks:
See BEM fundamentals section for details on permissible positions for point forces. Point forces are available for 2D and 3D applications only.

LINE FORCE

Form:
LINE FORCE

Function:
Indicates the start of a sub-block of branch keywords which may be used to define any line forces acting on the body.

Use:
Optional

Last Command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
None

Default:
There are no line forces.

Remarks:
See BEM fundamentals section for details of permissible positions for line forces. Line forces are available for 2D and 3D problems only.

FL2D1

Form:
FL2D1 lsid spid1 spid2 valx valy valz

Function:
Defines a line force between two "load points" along which the force is constant.

Use:
Optional

Last Command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID - LINE FORCE

Parameters:
lsid : Identification number of the line force element

spid1 : Identification number of a load point at one end of the line

spid2 : Identification number of a load point at the other end of the line

valx, valy, valz : x, y and z components of force per unit length

Default:
No line forces

Remarks:
See BEM fundamentals section for details of permissible positions for line forces. Line forces are available for 2D and 3D problems only.

FL2D2

Form:
FL2D2 lsid spid1 spid2 valx1 valy1 valz1 valx2 valy2 valz2

Function:
Defines a line force between two "load points" along which the force varies in a linear manner.

Use:
Optional

Last Command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID - LINE FORCE

Parameters:
lsid : Identification number of the line force element

spid1 : Identification number of a load point at one end of the line

spid2 : Identification number of load point at the other end of the line

valx1, valy1, valz1 : x, y and z components of force per unit length at load point spid1

valx2, valy2, valz2 : x, y and z components of force per unit length at load point spid2

Default:
No line forces

Remarks:
See BEM fundamentals section for details of permissible positions for line forces. Line forces are available for 2D and 3D problems only. This keyword occupies two records as shown under Form.

FL3D3

Form:
FL3D3 lsid spid1 spid2 spid3 valx1 valy1 valz1 valx2 valy2 valz2 valx3 valy3 valz3

Function:
Defines a line force using three "load points" along which the force varies quadratically.

Use:
Optional

Last Command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID - LINE FORCE

Parameters:
lsid : Identification number of the line force

spid1 : Identification number of a load point at one end of the line

spid2 : Identification number of a load point at the other end of the line

spid3 : Identification number of a load point at the middle of the line

valx1, valy1, valz1 : x, y and z components of force per unit length at load point spid1

valx2, valy2, valz2 : x, y and z components of force per unit length at load point spid2

valx3, valy3, valz3 : x, y and z components of force per unit length at load point spid3

Default:
No line forces

Remarks:
See BEM fundamentals section for details of permissible positions for line forces. Line forces are available for 2D and 3D problems only. This keyword occupies three records as shown under Form.

CONSTANT TEMPERATURE DISTRIBUTION

Form:
CONSTANT TEMPERATURE DISTRIBUTION temp

Function:
Specifies that the temperature everywhere in the current zone is at a value of temp.

Use:
Optional. This keyword may only be used for SOLUTION TYPE PP + TE, i.e. a thermal stress analysis.

Last Command:
GENERAL DATA - LOADING DATA - LOAD SET - BODY FORCES - ZONE ID

Parameters:
temp : constant temperature

Remarks:
For thermal stress analysis only. This keyword removes the need to specify potential boundary conditions and to carry out a potential analysis for a problem which has a trivial potential solution. This keyword must be included for all zones in the problem if used.

ZONE PROPERTIES

Form:
ZONE PROPERTIES

Function:
Indicates the start of a sub-block of branch keywords which define certain zone properties.

Use:
Compulsory

Last command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
None

Default:
None

Remarks:
None

ZONE ID

Form:
ZONE ID zoneid zone label

Function:
Zone properties must be defined on a zone-by-zone basis. This keyword indicates the start of the data block defining the properties of zone number zoneid.

Use:
Compulsory

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
zoneid : Identification number of the zone for which the properties are to be defined.

zone label: Identification label for the zone (up to 10 characters which could be left blank)

Default:
None

Remarks:
None

CONDUCTIVITY

Form:
CONDUCTIVITY cond

Function:
Defines the conductivity of the zone material.

Use:
Compulsory in a potential analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
cond : conductivity of the zone material, which is assumed to be constant throughout the zone.

Default:
None

Remarks:
None

YOUNGS MODULUS

Form:
YOUNGS MODULUS emod

Function:
Defines the Youngs modulus (elastic modulus) of the zone material.

Use:
Compulsory in a stress analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
emod : Youngs modulus of the zone material, which is assumed to be constant throughout the zone.

Default:
None

Remarks:
Temperature dependant Young's Modulus values are available for a combined thermal and stress analysis case. In this case a series of keywords defining the Youngs modulus values can be given for a series of temperatures. The keyword in this case takes the form:

YOUNGS MODULUS emod_i theta_i

where emod_i is the Youngs modulus value at temperature theta_i.

The analysis will then take the bulk temperature of the zone and perform a linear interpolation between the two values given for the closest temperatures. This will give a new value for Youngs modulus which will be used in the stress analysis. The value used will be reported to the log file and the results files.

POISSONS RATIO

Form:
POISSONS RATIO rnu

Function:
Defines the Poisson's ratio value of the zone material.

Use:
Compulsory in a stress analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
rnu : Poisson's ratio value of the zone material, which is assumed to be constant throughout the zone.

Default:
None

Remarks:
Temperature dependant Poisson's ratio values are available for a combined thermal and stress analysis case. In this case a series of keywords defining the Youngs modulus values can be given for a series of temperatures. The keyword in this case takes the form:

POISSONS RATIO rnu_i theta_i

where rnu_i is the Poisson's ratio value at temperature theta_i.

The analysis will then take the bulk temperature of the zone and perform a linear interpolation between the two values given for the closest temperatures. This will give a new value for Poisson's ratio which will be used in the stress analysis. The value used will be reported to the log file and the results files.

EXPANSION COEFF

Form:
EXPANSION COEFF alpha

Function:
Defines the coefficient of linear expansion of the zone material.

Use:
Compulsory in a thermal stress analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
alpha : Coefficient of linear expansion of the zone material, which is assumed to be constant throughout the zone.

Default:
None

Remarks:
None

DENSITY

Form:
DENSITY dens

Function:
Defines the mass density of the zone material.

Use:
Compulsory if rotational or gravitational loads are to be applied.

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
dens : Density of the zone material, which is assumed to be constant throughout the zone.

Default:
None

Remarks:
None

REF TEMPERATURE

Form:
REF TEMPERATURE temp

Function:
Defines the stress-free reference temperature of the zone material.

Use:
Optional

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES - ZONE ID

Parameters:
temp : Temperature at which the unloaded and undisplaced body is stress free.

Default:
temp = 0

Remarks:
None

XX-YOUNGS MODULUS

XX-YOUNGS MODULUS

XX-YOUNGS MODULUS

Form:
XX-YOUNGS MODULUS "Value"

Function:
Defines the zone's Young's modulus in XX direction

Use:
Compulsory for Non-Isotropic stress problem of xx_xx_ETA term is not used.

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Young modulus value

Default:
None

Remarks:
None.

YY-YOUNGS MODULUS

Form:
YY-YOUNGS MODULUS "Value"

Function:
Defines the zone's Young's modulus in YY direction

Use:
Compulsory for Non-Isotropic stress problem of yy_yy_ETA term is not used.

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Young modulus value

Default:
None

Remarks:
None.

ZZ-YOUNGS MODULUS

Form:
ZZ-YOUNGS MODULUS "Value"

Function:
Defines the zone's Young's modulus in ZZ direction

Use:
Compulsory for Non-Isotropic stress problem of zz_zz_ETA term is not used.

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Young modulus value

Default:
None

Remarks:
None.

XX-XX-ETA

Form:
XX-XX-ETA "Value"

Function:
Defines the XX_XX flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

XX-YY-ETA

Form:
XX-YY-ETA "Value"

Function:
Defines the XX_YY flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

XX-ZZ-ETA

Form:
XX-ZZ-ETA "Value"

Function:
Defines the XX_ZZ flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

YY-YY-ETA

Form:
YY-YY-ETA "Value"

Function:
Defines the YY_YY flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

YY-ZZ-ETA

Form:
YY-ZZ-ETA "Value"

Function:
Defines the YY_ZZ flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

ZZ-ZZ-ETA

Form:
ZZ-ZZ-ETA "Value"

Function:
Defines the ZZ_ZZ flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

XX-XY-ETA

Form:
XX-XY-ETA "Value"

Function:
Defines the XX_XY flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

YY-XY-ETA

Form:
YY-XY-ETA "Value"

Function:
Defines the YY_XY flexibility term

Use:
Compulsory for non-isotropic stress analysis problem

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Flexibility value

Default:
None

Remarks:
None

MAGNETIC PERMEABILITY

Form:
MAGNETIC PERMEABILTY "Value"

Function:
Defines zones magnetic permeability

Use:
Compulsory for magnetic analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Magnetic permeability

Default:
None

Remarks:
None.

DIELECTRIC PERMEABILTY

Form:
DIELECTRIC PERMEABILTY "Value"

Function:
Defines the zones Dielectric Permeability

Use:
Compulsory for magnetic analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
Dielectric permeability value

Default:
None

Remarks:
None

CHARGE DENSITY

Form:
CHARGE DENSITY "Value"

Function:
Defines zone's charge density

Use:
Compulsory for magnetic analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
Charge density value

Default:
None

Remarks:
Will be available from BEASY Version 6.0

REAL PART SPEED OF SOUND

Form:
REAL PART SPEED OF SOUND "Value"

Function:
Defines real part of the speed of sound in the zone

Use:
Compulsory for acoustic problems

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
The value of the real part of speed of sound

Default:
None

Remarks:
None

REAL PART AIR DENSITY

Form:
REAL PART AIR DENSITY "value"

Function:
Define real part of the air the density of the zone

Use:
Compulsory for acoustic analysis

Last command:
GENERAL DATA - LOADING DATA - LOAD SET - ZONE PROPERTIES

Parameters:
The value of the real part of the air density

Default:
None

Remarks:
None

END LOAD SET

Form:
END LOAD SET

Function:
Terminates description of the current load set.

Use:
Compulsory

Last command:
GENERAL DATA - LOADING DATA - LOAD SET

Parameters:
None

Default:
None

Remarks:
This keyword is required to end the description of every loadcase specified by the LOAD SET keyword.

END

Form:
END

Function:
Terminates the BEASY data file.

Use:
Compulsory.

Last command:
None. Main keyword.

Parameters:
None

Default:
None

Remarks:
Correct order of the four main keywords must be observed.

Private data sections

Group Tool Data

This data section is generally placed at the very end of the BEASY data file, after the final END keyword. The data section is used to define groups of elements and mesh points to be used in either the solver or (more commonly) in one of the additional add-on tools. This section can either be created using one of the support pre-processing tools, using the wizards or it can be created manually. The section starts with the keyword

START PRIVATE DATA FOR GROUPS TOOL

and ends with the keyword

END PRIVATE DATA FOR GROUPS TOOL

Group tool format

The group tool section has a simple format and can contain a number of different groups. All groups defined start with the line

START GROUP group name

And end with the line

END GROUP group name

Within each group, different entity types can be listed. Currently the solver supports just elements and mesh points, however further entities may be added in future versions. In each group both element and mesh point groups can be included. Element groups start and end with the lines

START ELEMENTS

END ELEMENTS

Mesh point groups start and end with the lines

START MESH POINTS

END MESH POINTS

Internal point groups start and end with the lines

START INTERNAL POINTS

END INTERNAL POINTS

Within both of these sections, the mesh points, internal points and elements are listed as a simple space delimited set of data with lines of up to 80 characters. Multiple lines can be used as required.

==========Endof document=================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Accuracy. Aspects to consider

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msh_accuracy\msh_accuracy.htm

Aspects to consider to ensure accurate solutions

Aspect ratio

Distorted elements

Elements too close together

Aspect ratio

Boundary elements can become inefficient and inaccurate when they have extreme aspect ratios. In general, you should keep all elements within the advised limit on aspect ratio of 5:1.

Distorted elements

Distorted elements may cause inaccuracies. Avoid distorted elements. The log file reports a list of distorted elements. Check the log searching for distorted elements and correct the mesh.

Elements too close together

Elements too close together may cause inaccurate results, slow convergence and high error in flux balance. Check in the log file for report on "closeness of nodes". If nodes are too close together, try to enlarge the number of elements on the localised region. If this is not possible consider alternative ways of modelling such as dividing the problem in two different zones, using of dual elements, etc.

As a rule, the distance between nodes on two different elements "d" should be greater than a tenth of the characteristic distance "s" shown in Figure 1 measured in an element.

Figure 1: Distance between elements

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Mesh

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msh_index\msh_index.htm

Geometry and Mesh

The model geometry must be supplied as an input to the CP Builder in a discretized mesh file (".bzmsh"). Mesh file format.

Introduction

The ".bzmsh" mesh file

Meshing

Introduction

The process of dividing or covering the surfaces enclosing the electrolyte with elements is called "meshing".

In general, the geometry is defined by points, lines and surfaces and the mesh by elements and mesh points:

Normal directions to surfaces

The orientation of the normal vectors to surfaces is critical in BEASY CP. The rule is that the normal direction to a surface (in a 3D model) should point out of the electrolyte (or zone) being modelled.

  • Normal directions to surfaces

The ".bzmsh" mesh file

The ".bzmsh" mesh file contains information of the mesh points, elements and groups of elements. The ".bzmsh" mesh file is exported by the 3D graphical interface.

Meshing

All the surfaces representing the external boundaries in a 3D model (or lines in a 2D model) need to be divided and covered with elements, as well as any interface surfaces (or lines in a 2D model) between sub-regions of the model.

For a 3D model elements are usually either triangular or quadrilateral shapes:

  • Commonly used type of elements

  • Mesh size

  • Aspects to consider when creating the mes h

  • Dual Elements

  • Tube elements

  • Internal points

  • Sacrificial anodes

For GiD users, follow the link to show meshing guidelines on the GiD user interface.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Mesh guidelines

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msh_size\msh_size.htm

Mesh size for BEASY CP

Where to concentrate elements

Grading

How many elements should I use?

Where to concentrate elements

In general allocate more elements in regions where the solution is expected to change rapidly. In these regions, smaller elements are required to capture the variations of the solution. Elements may then be graded away to larger sizes in parts of the model over which the behaviour is more stead. Therefore, concentrate elements where the geometry or the boundary conditions change abruptly.

Figure 1 shows concentration of elements in regions where the geometry changes or where the materials change. Away from these areas the mesh is coarser.

Figure 1: Element size

Grading

While it is often desirable to have small and large elements in the same model, take care that adjacent elements do not have very different sizes. This will involve grading of element sizes from small to large in a more gradual way.

Avoid very extreme changes in mesh size as shown in the left in Figure 2. Allow the mesh to transition smoothly.

Figure 2: Mesh grading

How many elements should I use?

The answer to this question clearly depends on the problem you are analysing. However, you can start by using the correct number of elements to satisfy the criteria listed above to mesh the sensitive areas. The rest of the model can be meshed from there by satisfying the mesh grading criteria when creating larger elements. This should leave you with a boundary element model with significantly fewer elements. It is best to focus on local refinement of elements around key areas of the model in which you are interested in.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Common Element Types

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msheltype_common\msheltype_common.htm

Element types

Mesh elements on surfaces

Order of the elements in the geometry mesh

Order of the elements in the solution mesh

Result Elements

Mesh elements on surfaces

Elements of common use in the input file to the CP Solver (*.dat file) for a 3D problem are listed in Table 1.

 |  | Geometry |  | Solution
Element Type in the .dat file | Element Shape | Number of mesh-points | Element order in geometry | Number of nodes | Element order in calculation
U1 | Line | 3 | Quadratic | 1 | Constant
Q1 | Quadrilateral | 9 | Quadratic | 1 | Constant
T1 | Triangular | 6 | Quadratic | 1 | Constant
T2 | Triangular | 6 | Quadratic | 3 | Linear
Q2 | Quadrilateral | 9 | Quadratic | 6 | Linear

Table 1 Element types used by the solver

Order of the elements in the geometry mesh

The order of the mesh elements in the geometry mesh needs to be quadratic (i.e. elements with 3, 6 or 9 mesh points per element).

Important: Note that you need to set up the 3D graphical interface to generate elements of quadratic order for BEASY CP. For GiD users, follow the link to show how this is done.

Order of the elements in the solution mesh

The order of mesh elements used for the simulation is selected by the user.

By default, the order of the elements used for the calculation is constant (i.e. 1 node per element).

The order for the simulation can be adjusted by the user while using the CP Model Editor.

The choice of element order has a major impact on the size of the model and hence the number of nodes. The number of nodes directly relates to the number of equations to be solved, i.e. to the number of degrees of freedom

Note that:

  • Constant elements are fastest but least accurate

  • Quadratic elements are slowest but more accurate

For CP simulations constant elements give very satisfactory results.

Figure 1 shows quadratic order elements and mesh points in the geometry in green and names used for constant elements and mesh points in the dat file and in the solution mesh shown in black:

Figure 1 Element names in the dat file

NOTE that if your model has a multi-layered zone, linear or quadratic elements are not supported.

Result Elements

Result elements are created for displaying results within the electrolyte and their corresponding mesh points are internal points.

Table 2 shows element names in the input file to the CP Solver (*.dat file) for display surfaces, lines or points used as result elements.

Result elements are created by the 3D graphical interface equipped with the BEASY plugin. However, the mesh file does not distinguish between result elements and model elements.

Groups containing result elements need to be identified as "internal points" using the "Group Definitions" tab on the CP model Editor .

 |  | Geometry
Element Type in the .dat file | Element Shape | Number of mesh-points | Element order in geometry
BAR3 | Line | 3 | Quadratic
QUAD9 | Quadrilateral | 9 | Quadratic
TRIA3 | Triangular | 6 | Quadratic

Table 2 Common element types for result elements

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Dual Elements

Dual Elements

Use of dual elements

How to create the geometry for dual elements

Dual Elements

"Dual elements" are 2D elements (triangular or quadrilateral) which allow different potential (V) and normal current density (q) solutions on opposite sides (Figure 1)

Figure 1: Dual Elements

Dual elements are used to model thin surfaces (e.g. thin plates) submerged in a 3D electrolyte. The thickness of the plate must be negligible compared to the other dimensions as illustrated in Figure 2 .

Figure 2: Thin surfaces fully immersed in the electrolyte

The alternative way for representing thin surfaces is either representing the full 3D equivalent plate, or dividing the model into zones.

Use of dual elements

Dual elements can be used to represent flat structures minimising the number of degrees of freedom involved in the model. Note that regardless of the expected variation of the solution on the surface, in the traditional representation, the number of elements on the faces is determined by the thickness of the structure (in order to ensure a good aspect ratio) as illustrated in Figure 3.

Figure 3: Showing traditional representation on the right and representation using dual elements on the left.

How to create the geometry for dual elements

Using the 3D graphical interface, define a 2D object representing the surface of interest parallel to the faces of the thin structure but located at the middle between both faces. Define a group (or layer) to identify the surface. Export the mesh.

Later, while assigning properties with the CP Model Editor, you need to identify the group as "Dual" using the "Group Definitions" tab

Note: Dual elements are not supported in multi-layer zones.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Internal Points

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msheltype_internalpts\msheltype_internalpts.htm

Internal Points

How to define internal points

How to define result elements

Display results

Internal points are points which lie inside the electrolyte. The CP Solver finds the potential and current density results at these mesh points at the end of the analysis run.

Internal points are used to get results at reference electrode locations or at survey locations. In some cases, it may be of interest to know the solution along a line or a surface located within the electrolyte.

Result elements are created for displaying results within the electrolyte.

How to define internal points

There are alternative methods that can be used to define internal points:

  • Internal points can be defined while creating the geometry in the GiD graphical interface equipped with the BEASY GiD plugin using the tool for survey points.

  • Internal points can be created using the CP Model Editor : Use the " Internal Points " tab to create single points or points along lines or grids of points on planes.

  • Internal points can be added to (or deleted from) an already created *.dat file using the IP Editor . In this way you can delete or add individual points, or add points along lines or grids.

How to define result elements

Result elements are created using the 3D graphical interface. Depending on the product you are using,

  • Result elements on lines or surfaces can be defined while creating the geometry in the GiD graphical interface equipped with the BEASY GiD plugin.

  • Result elements on surfaces can be defined while creating the geometry in SOLIDWORKS graphical interface equipped with the BEASY CP Add in.

In both interfaces you need to create the geometrical entity (line or surface) and assign a group to it. Then, while using the CP Model Editor select "INTERNAL POINTS" in the "Group Type" column on the "Group Definitions" tab.

Display results

If internal points are defined using the Internal Points tab in the CP Model Editor or using the IP Editor, then the solution is displayed on a cloud of individual as shown at the left in Figure 1 .

Defining result elements in the pre-processing stage allows visualising the results as contour plot as shown at the right in Figure 1.

Figure 1: Post processing internal points (left) and result elements (right).

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Tube Elements

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\msheltype_tubes\msheltype_tubes.htm

Tube Elements

Introduction

Use of tube elements

How to create the geometry of tube elements

Introduction

A tube element represents a thin cylindrical cavity in the electrolyte. It is important to note that the solution is constant around the circumference, though it may change in the axial direction.

It has three major uses:

  • To model members of offshore platforms.

  • To model cylindrical anodes

  • To model pipelines

Figure 1: Tube element

Use of tube elements for problems like these significantly reduces the problem size.

Use of tube elements

It is important to note that this approximation is suitable if the variations of the physical quantities in the angular direction are expected to be negligible as this representation leads to constant potentials and current densities along the tangential direction.

It is also worth mentioning that the use of tube elements can give more accurate results than the 3D representation, if the pipes are extremely thin (i.e. if the diameter is less than 1% of the length).

How to create the geometry of tube elements

Using the 3D graphical interface, define a line object (the line can be straight or curve). Define a group (or layer) to identify the line or lines with the same diameter. Export the mesh.

Later, while assigning properties with the CP Model Editor, you need to identify the group as "Line" using the column "Geometry Type" in the "Group Definitions" tab as well as entering the tube diameter in the column "Diameter"

Pre-processing tools for tube elements

Follow the following links for documentation showing additional tools available for modelling structures with tube elements for the users of the 3D graphical interface GiD.

  • Tools for jacket structures

  • Tools for pipelines

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Normal Vectors to Surfaces

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\mshnormals\mshnormals.htm

Normal vectors to Surfaces

Introduction

Normal directions in surfaces enclosing a zone

Normal directions on surfaces on a metallic structure

Introduction

The orientation of the normal vectors to surfaces is critical in BEASY CP. The rule is that the normal direction to a surface (in a 3D model) should point out of the electrolyte (or zone) being modelled.

Consider the sphere located at the left in Figure 1. The normal vectors to the sphere are pointing away from the sphere's centre meaning that the interior volume will be modelled, i.e. the electrolyte is located in the interior. Whereas in the sphere located at the right in Figure 1, the normal vectors to the sphere are pointing to the sphere's centre, meaning that the electrolyte is located on the outside of the sphere and the exterior problem will be modelled.

Figure 1: Spherical object and normal vectors directions

Normal directions in surfaces enclosing a zone

Surfaces enclosing a zone need to have normal vector directions pointing outwards the electrolyte as shown in Figure 2.

Figure 2 Normal vector directions point outwards the electrolyte in 3D model

In a 2D problem, the convention for the orientation of the normal vectors to lines is shown in Figure 2

Figure 3 Normal vector directions point outwards the electrolyte in 2D model

Note that in a single zone model all the normals point on the same direction, outwards, whereas in a multi zone model, the orientation of the normal on the interface is such that it points from master (zone 1) to slave (zone 2) as shown in Figure 4.

Figure 4 Normal vector directions in a single and multi zone models

Normal directions on surfaces on a metallic structure

Figure 5 shows the simplified geometry of a section of a mono-pile exposed externally to seawater and mud. The normal directions should point outwards the electrolyte. Normal vectors to surfaces are shown with pink arrows and with coloured surfaces.

Figure 5 Mono-pile wetted and buried surfaces and normal vectors to surfaces

Since there are two different conductivities involved (seawater and mud below seabed) two zones can be used to describe this problem.

To prescribe null current density at infinity, a large box (cylinders in this example) encloses each zone. The normal directions on the different surfaces are illustrated in Figure 5 to Figure 7.

Figure 5 shows normal directions set up to model the mono-pile externally wetted.

Figure 6 shows the external surfaces that define zone 1 (seawater), i.e. wetted mono-pile, bounding surfaces (cyan), interface between zone 1 and zone 2 (ochre).

Figure 7 shows the buried mono-pile and bounding surfaces to zone 2 (mud)

Figure 6 Mono-pile wetted surfaces and bounding surfaces for zone 1

Figure 7 Mono-pile buried surfaces and bounding surfaces for zone 2

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Geometry of Sacrifiicial Anodes

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\geometry\mshsacanode\mshsacanode.htm

Geometry of sacrificial anodes

Sacrificial anodes

Cuboid shape anodes

Cylinder

How to create the geometry for sacrificial anodes

Sacrificial anodes

The geometry of the sacrificial anodes needs to be created according to the anode type:

Cuboid shape anodes

  • These anodes are represented by cuboids.

  • Use quadrilateral elements.

  • There are different types of cuboid anodes (sacrificial anodes). The different types assume different approaches to model anode consumption. The anode type is defined with the CP Model Editor (Sacrificial Anodes tab). But you have to consider which type of anode you would create while defining the geometry.

  • To create BRICK and BRICK_FLUSH_MOUNTED anode types, you need to define two different groups, one for the bottom surface and one for the top surfaces.

Top surfaces of different individual anodes of the same properties and geometry (i.e. same anode type) can be put into one group. The same applies for the bottom surfaces.

  • To create STAND_OFF anodes you can place all surfaces of the different anodes in one group

Surfaces of different individual anodes of the same properties and geometry (i.e. same anode type) can be put into one group.

Cylinder

  • These anodes are represented by lines with tube element properties assigned

How to create the geometry for sacrificial anodes

Follow a tutorial illustrating how to create different anode types in GiD.

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Adding a new material into the database

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_addnewmaterial\poldat_addnewmaterial.htm

Adding a new material to the polarisation database

Follow the steps described in this document to add a new material to the database

Open the polarisation database by double clicking in the corresponding icon in the BEASY CP Desktop.

First, you must enable macros

Before you can add a new material, you MUST have write access to the polarisation database file. The file is normally stored as:

C:\Program Files\Beasy\beasy10.0r19\data\CP_Polarisation\databasepolar.xls

In addition:

  • You are advised to make sure the reference electrode used for your new data corresponds to the reference electrode used for other materials in the database

  • The reference electrode used in the database materials supplied is Ag/AgCl/seawater

Then press the Introduce new material button

Figure 1: Introduce New Material

Select the New material radio button

Figure 2: Select New Material

Check the units of the database are suitable, and if not, change the units of the database. Then press OK

Then, identify material name and acronym. If you wish, add text identifying the data source.Then press the OK button

Figure 3: Input Metal name

Notice the reminder, then press OK

Figure 4: Sheet to enter the data

Add potential and current density values as shown here

Then press the End Input data button

Now you can check the data by viewing its plot. Press the Plot curves button

Select the new material and then press OK

To see a graph of the data, press the Experimental curve button

When ready, press the Main sheet button to return to the menu window

When you write a material file, you will now be able to select the new material you have defined

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Atlas of Polarisation Diagrams

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_atlascp\poldat_atlascp.htm

Carderock Division

Naval Surface WarfareCenter

Bethesda,Md.20084-5000

CARDIVNSWC-TR-61-94/44 April 1995

Survivability, Structures, and Materials Directorate

Technical Report

Atlas of Polarization Diagrams for Naval Materials in

Seawater

by Harvey P. Hack

Approved for public release; distributionis unlimited.

ABSTRACT

Polarization curves were developedin seawater at low (quiescent)flow and at 2.4 misflow for nine structuralalloys.Potentiostatically generatedcurvesfor up to 120 days are compared with potentiodynamically generatedcurves atfour scan rates withfreely corrodingpre-exposures of 1 or 120 days. Smoothed curves successfully used in comput er model predictions of cathodic protection current and potential distributions are also presented. These curves are comparedwith previouslypublished data available for 800 days exposure and with cathodic protection current density design guidelines. Corrosion rate data as afunction of potentialafter up to 120 days exposure are also presented.

CARDIVNSWC-TR-61- 94/44 iii

CONTENTS

Page

Abstract.............................................................................................................................................. iii

Administrative Information....................................................................................................................................................................... VI

Acknowledgments............................................................................................................................................................................................ VI

Abbreviations....................................................................................................................................................................................................... VI

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Materials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .... . . . . . . . . . . . . . . . . . . . . . . . .

Apparatus and Procedure.................................................................................................................. 3

Quiescent Flow, Potentiostatic Tests......................................................................................... 3

Quiescent Flow, Potentiodynamic Tests.................................................................................... 3

Flowing Tests................................................................................................................................... 6

Data Analysis Techniques................................................................................................................ 7

Results and Discussion..................................................................................................................... 9

Conclusions....................................................................................................................................... 10

References.......................................................................................................................................... 11

Appendix A. Polarization Curves From This Study for HY-80 Steel 13

Appendix B. Polarization Curves From This Study for 90-10

Copper-Nickel....................................................................................................... 25

Appendix C. Polarization Curves From This Study for 70-30

Copper-Nickel....................................................................................................... 37

Appendix D. Polarization Curves From This Study for Navy Type M

Bronze.................................................................................................................... 47

Appendix E. Polarization Curves From This Study for Nickel-Aluminum

Bronze.................................................................................................................... 59

Appendix F. Polarization Curves From This Study for Mone)................................................... 71

Appendix G. Polarization Curves From This Study for Alloy 625........................................ 83

Appendix H. Polarization Curves From This Study for Titanium 50.................................. 95

Appendix I. Polarization Curves From This Study for Anode Grade Zinc . . . 105 Appendix J. Corrosion Rates From Potentiostatic Tests in This Study 115

Appendix K. Smoothed Polarization Curves Used in Boundary Element

Study.................................................................................................................... 131

Appendix L. Foster and Moores' 800-Day Polarization Data.................................................. 135

Appendix M. Cathodic Protection Design Data for Steel.................................................... 149

Initial Distribution............................................................................................................................ 153

Standard Form 298........................................................................................... 155

CARDIVNSWC-TR-61-94/44

1.

FIGURES

Exposure vessels for quiescent tests. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

4

2.

Specimen mounting for quiescent tests. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

5

3.

Flowing test cell design. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

7

4.

One flowing cell test loop. . . . . . . . . . . . . . ... . . . . . . . . . . . . . . . . . . . . . . . . . . .

8

5.

Four flowing cell test loops. . . . . . . . . . . . . . . . . . . .... . . . . . . . . . . . . . . . . . . .

8

TABLE

Nominal composition of alloystested. 2

ADMINISTRATIVE INFORMATION

This projectwas funded under the Surface Ship Materials Technology Program sponsored by the Office of Naval Research (ONR) and managed by Mr. Ivan Caplan. The work was performed under program element 62761N, task area SF61541-591, work units 1-2803-162 and 1-2803-164. Work was conducted in the Marine Corrosion Branch un der the direction of Mr.Robert J. Ferrara.

ACKNOWLEDGMENT S

I wish to particularly acknowledge the contributions of Dr. John R. Scully, who per formed many of the experiments described herein. Also acknowledged is the staff at the LaQue Center for CorrosionTechnology for help in the design and conduct of these ex periments.

ASTM

ABBREVIATIONS

American Societyfor Testing and Materials

CARDEROCKDIV, NSWC Carderock Division , Naval Surface Warfare Center EG&G PAR EG&G Princeton Applied Research

IR Current X Resistance

rms

root mean square

1j CARDIVNSWC-TR-61-94/44

N .. Table-Nominal composition of alloys tested.

SAE/ ASTM

UNS Purchase

Material Number Specification Cu

9<HO C70600 MIL-C--15726Ea 88.04

Ni 10.2

Fe 1.45

c

-

Mn 0.10

p

<0.02

s

<0.02

Al

-

Zn 0.13

n

-

Sn

-

Pb

<0.2

Mo

Si

Others

CuNi

MoneI N04400 Q 400

Q-N-281Db 31.43

65.55

1.63

0.11

1.08

-

0.006

0.020

-

-

-

-

-

0.17

lnconel N06625 ASTM-B443C -

625

62.15

3.46

0.02

0.16

0.013

-

0.16

-

0.26

-

-

8.41

0.25

21.46 Cr 3.66

Cb & Ta

M- C92200 MIL-B-16541d 86.91

Bronze

0.45

0.09

-

-

-

-

-

4.74

-

6.05

1.7

-

-

0.06

NiAl C95800 MI

Bronze

L-B-21230Ae 79.85

4.88

4.24

-

1.49

-

-

9.36

0.07

-

0.04

0.02

HY-80 - MI

Steel

L-S-16216H' 0.046

2.83

bal

0.15

0.23

0.012

0.020

-

-

0.001

-

-

0.47

0.27

<0.001 v

1.61 Cr

Tita- R50400 MIL-T-79939 -

nium50

0.1

0.3

0.10

-

-

-

-

-

bal

-

-

-

-

0.250

7Q-30 CA7150

CuNi 0

- 68.02

30.34

0.60

<0.03

0.77

0.01

0.006

-

0.09

-

-

0.01

Anode - MIL

-STD-18001J 0.05

-

0.05

-

-

-

-

0.1 to

bal

-

-

0.06

-

0.125

0.025 Cd

Grade

max

max

0.5

max

max

max

Zinc

(") I

a•eopper-Nickel Alloy,Sheet Plate,Strip,Bar,Rod,andWire."

bwNickel-CopperAlloy Bar,Rod,Plate, Sheet,Strip,Wire, Forgings, and Structuraland SpecialShaped Sections" (QQindicates a Federal specification). eostandard Specification for Nickel-Chromium-Molybdenum Columbium Alloy (UNS N06625) Plate, Sheet,and Str p."

d-Bronze, Valve Casting."

ewBronze,Nickel Aluminum,and Manganese-Nickel Aluminum: Castings,Ship Propeller Application."

)> "'Steel Plate,Alloy,Structural,High Yield Strength (HY-80 and HY-100)."

ll !l"litanium,Sheet,Strip and Plate (Unalloyed)."

0

<z

rn

:E

ll

6,

......

cIo

:..

:..

INTRODUCTION

Predicting the amount of galvanic corrosionand the current demand for cathodic protection in seawater requires accurate polarization data for the materialsinvolved. Computer models that predict the distribution of galvanic corrosion, stray current corro sion, and cathodic protection also require accurate polarization data.

Rates of galvanic corrosion are commonly predicted using tables of galvanic com patibility, 1 differences in corrosion potential between members of the galvanic couple where the corrosion potentials are obtainedfrom a list or chart,2 or by conducting rela tively short-term exposures or electrochemical tests and extrapolating the results to apply to the item in service.3·4 The first two methods are qualitative, providingonly an indica tion of the tendency for corrosion damage in the galvanic couple.Unfortunately,

polarization curves for most structural materials in seawater are exposure-time dependent and scan-rate dependent, making quantitative prediction from short-term exposures inac curate.

Current densities for cathodic protection are frequently predictedfrom values found in standards.5, 6 These values, although based on long-term exposures, are not complete polarization curves and are, therefore, not adequate for use in computer modeling.

The need for a singlesource of polarization curves for commonly used materials in seawater and for a quantification of exposure time and scan rate effects led to this inves tigation. Although portions of these data have been presentedelsewhere,7-12 this document presentsall of the data collected over the course of the investigation.

MATERIALS

Materials in this study were selected to be representative of the major classes of structuralmaterials used by the Navy for seawater systemson ships.The following mate rials were studied:

• HY-80 steel (MIL-S-I62l6H*)

• 90-10 copper-nickel (C70600)

• 70-30 copper-nickel (C71500)

• Monel 400 (C92200)

• Nickel-aluminum bronze (C95800)

• Bronze composition M (C92200)

• Titanium grade 50 (R50400)

• Alloy 625 (N06625)

• Anode grade zinc (MIL-A-18001J**).

Nominal compositions of the alloys tested appear in the following table. Corrosion sam ples were prepared by rough cutting blanks from the supplied bars or plates, milling to

*"Steel Plate,Alloy, Structural, High Yield Strength(HY-80 and HY-100)."

**"Anodes. Sacrificial Zinc Alloy."

CARDIVNSWC-TR-61-94/44

approximatedimensions, and grinding to final dimensions-yielding a 32-rms (approxi mately 120-grit) finishon all surfaces.

APPARATUS AND PROCEDURE

QUIESCENT FLOW, POTENTIOSTATIC TESTS

For the short-term exposures(5 min and 1day), specimens were 12.7 mm square bJ

6.2 mm thick. Exposures were performed sequentially in beakers of fully oxygenated nat ural seawater heated to a constant 30 °C. For the long-termexposures, specimens were

25.4 mm square by 6.2 mm thick. Three specimens of identical materialwere exposed at the same potential for different lengths of time connected to the same potentiostat. In this way, all 30-, 60-, and 120-day exposures were conducted simultaneously. A series of in dividual exposure vessels was used to avoid ground loops or stray current effects (see Figure I ). One hundred eight 4-L vesselswere fitted into two wooden boxes lined with thermal insulation. Heated, filtered natural seawater was drip-fed into each container to maintain oxygen levels in the bulk solution at saturation and temperatures at 30 °C. Quiescent flow was maintained via the low refreshment rate. Corrosion coupons were suspended in the exposure vessels by means of a threaded rod screwed into a hole tapped into the specimen edge. This rod was also used for electrical contact to the specimen (see Figure 2). Water was excluded from the electrical contact/mounting rod by means of a glass tube and Teflon gasket. Platinum-coated counter electrodes were placed adjacent to the specimen faces. Ag/AgCl referenceelectrodes were placed in the plane of the corro sion coupons, directly below the specimens. Some vessels contained three identical, freely corroding specimens of each material for sequential removal at 30, 60, and 120 days. These vesselsalso containedreference electrodes, but no counter electrodes .

Abank of 70 potentiostatsconstructed for this experiment was located in an adja cent temperature-controlled room and was connectedto the test cells through insulated electrical leads.Potential and current readings were taken by a computerized data ac quisition system. For the potentiostats employed, a plus or minus 5-mV variation in set potential was maintained. A thermal instability coefficient of about 1 mV/°C air tempera ture and IR (Current X Resistance) drop through the cabling was identified as the source of these variations. Electrical leads from the specimen groups of three were connected in series to I-ohm resistorsfor current measurementas potential drop.

Fifteen to seventeen potentials were chosen for each material in potentiostatic polar· ization experiments. Exposureswere conducted in several runs, each run consisting of simultaneous testing of all materials over the 120-day period. Currents, potential s, and temperatureswere recorded once a minute for the first day of exposure, every I 0 minutes for the first week, and three times daily thereafter.

ASTM-recommended procedures for cleaning , drying, and massing were followed for mass loss determinations. 13 Special care was takento ensure that the threaded hole was dry prior to massing.Massing was performed to the nearest 0.1 mg.

QUIESCENT FLOW, POTENTIODYNAMIC TESTS

Exposure vessels and coupon mounting were the same as the potentiostatic expo sures. Specimens were 12.7 mm square by 6.2 mm thick. Platinum-coated counter

CARDIVNSWC-TR-61-94/44

$2

If)

Qi

If)

If)

Q)

>

:J

If)

0

0x..

UJ

4 CARDIVNSWC-TR-61-94/44

Figure 2. Specimenmounting for quiescent tests.

ARDIVNSWC-TR-61-94/44

electrodes and a saturated calomel reference electrode with Luggin probe were used. Instrumentation consisted of an EG&G PAR (Princeton Applied Research) model 173 potentiostat with a log current converterand a model 175 programmer. An Apple com puter was used for analog-to-digital conversionsand for data storage and retrieval.

Specimens were studied under two conditions: 1-hr or 120-day pre-exposure at open circuit potential in natural seawater. In general,test procedures followed ASTM Standard G5.14 Separate specimens were independently polarizedanodically and cathodically

starting at the corrosion potential. Duplicate specimens were tested at most scan rates. The following four scan rates were used:

1. 0.5 V/hr (0.14 mV/s)

2. 5 V/hr (l.4 mV/s) 3.50 V/hr(14 mV/s)

4.100 V/hr (28mV/s).

FLOWING TESTS

The test cell design for flowing seawater exposuresis shown in Figures 3 to 5.The direction of flow was parallel to the specimen length through a rectangular channel 2.54 cmhigh by 0.635 cm wide. Eight 1-cm square working electrodes and eight platinum counter electrodes were mounted flush againstthe interior wall of the rectangular cross section facing each other across opposite walls (see Figure 3). An insulated electrical lead was attached to the dry back face of both counter and working electrodes.The same ar rangement was used for potentiostatic and potentiodynamic testing. Reference electrode ports were drilled through the top interior wall of all parallel plate cell position s(see Fig ure 3). Hydrostatic pressure forced seawater through a vinyl tubecontaining microelectrodes. A 0.42-cm diameter Ag/AgCl microreference electrode was positioned above the reference electrode port. A valve was positioned between the port and the ref erence electrode to allow air bubble removal.

Figure 4 shows a single flow-through cell test loop. Heated natural seawater was pumped from a 70-L (17-gal) holding tank through the test cell and back to thetank. Fil tered (8 µm) natural seawater for refreshment was fed from a common 200-L (50-gal)preheated makeup tank at a rate of 5 Umin to each holding tankin each loop, where it was heated to30 °C plus or minus 3 °C, and the excess allowedto overflow. The flow velocity in the test cells was 2.4 mis. Four flow-through cells were used (see Figure 5). Concern for electrodeposition on a specimen "downstream" of metal lost from a speci men"upstream" led to careful consideration of specimen placement within each cell and between the four test loops. Aluminum gutters were also placed in each holding tank.

Flowin this test setup was determined to be turbulent by Reynoldsnumber analysis. Wall shear stress was calculated to be 17.4to 18.7 N/m2.

Six to nine potentials were chosen for each material in the potentiostatic tests. Only single 120-day potentiostatic specimens were exposed. Anodically and cathodically po larized potentiodynamic specimens, pre-exposed for 120 days, were exposed in separate cells.One-hour, pre-exposed potentiodynamic specimens were exposed in individual flow-through cells. Potentiodynamic scans were conducted at two scan rates:0.5 and 5 V/hr (0.14 and 1.4 mV/s, respectively) .

6 CARDIVNSWC-TR-61-94/44

REFERENCE ELECTRODEPORT 14 • SPACING BETWEENSPECIMENS

EPOXY MOUNT FOR ORTHOGONAL SPECIMEN MOUNTED PARALLELTO FLOW 11"DIAMETER MOUNT, 1 cm2 SURFACEAREA SPECIMEN!

ENTRY LENGTH

INLET FLOW

Figure 3. Flowing test cell design.

DATA ANALYSIS TECHNIQUES

Potential variability was plus or minuslO mV. Where the actual potentialdeviated significantly from the set potential, the actual potential value was used at the time period being analyzed. Current resolution was better than I percentof the reported values for

5-min exposures, better than 1 µA/cm2 for I-day exposures,and better than 0.1 to 0.6

µA/cm2 for longer exposures,depending on the number of specimens in test. In some cases, data averaging or curve fitting was used to reduce the quantity of data handled . To obtain current densities,the current vs. time plotswere hand-fitted with smooth curves and values picked off at the appropriate exposuretimes, normalizing for the number of specimens remaining in test at that time. Where duplicatespecimen data were available, a composite curvewas constructed. In some cases,due to rapid fluctuations, current was numericallyintegrated over the exposure period of interest to get an average value. Depth of attack measurements made on some specimens after the test duration were linearly ex-

:::ARDIVNSWC-TR-61-94/44

THERMOCOUPLE CONTROL 309C

RECIRCULATION LOOP

FILTER

AWMINUM

Cu+ + ION COUECT'ORS

Fl.OW METER AND/OR ORAFICE PLATE

OPTIONAL "-DISCHARGE

AND CHEMICAL ANALYSIS PORT

t Fl.OW METER

Lrn ""'""o"""'AHO OAS

Figure 4. One flowingcell test loop.

FROM MULTIMEDIA FILTER 8 I'm

FlOW METER REFRESHMENT

CELL 1

CELL 2

CELL 3

CELL 4

FlOW METER CELL

Figure 5. Four flowing cell testloops.

CARDIVNSWC-TR-61-94/44

trapolated to estimate attack depths after I yr. Corrosion rates reported are based on metal lossand surface area and, therefore, do not reflect localization of corrosion.

RESULTS AND DISCUSSION

The resultsof this investigation are contained in the polarization curves in Appen dixes A through I. Detailed descriptions of the behavior of each material,flow, type of polarization, exposure duration, scan rate, etc., would be too lengthy to state here. Some general results are that scan rate and pre-exposure time have a significant effect on poten tiodynamic polarization behavior. Exposuretime has a large effecton potentiostatic polarization behavior. The polarization current usually levels out after 30 days under quiescent conditions, except at the most negative potentials where the assumed buildup of calcareous deposits allows for continued current decay, even up to 120 days. Under quiescent conditions, the cathodic behaviorof allmaterials is roughly the same, with a

constant current density of about 10 µA/cm2 at potentials well below the corrosion poten

tial and above approximately -900 mV. Flowing potentiostatic data have too much scatter to make many conclusions other than that current densities are typically significantly higher than under quiescentconditions. None of the potentiodynamic curves, even those after a 120-day pre-exposure, resemble the long-termpotentiostatic curves sufficiently to be used for accurate prediction of galvanic or cathodic protection behavior.

Appendix J contains curves showingcorrosion rate from mass loss, normalized to 1 yr,of each material except Ti-50 and Alloy 625, which had no measurable mass loss un derquiescent flow conditionsas a function of exposure time and potential.

Appendix K contains the smoothed 120-day potentiostatic polarization curves used asboundary conditions for a boundary element model of a 16-m-long, cathodically pro tected barge in seawater.15 In that paper, the potential and current distributions predicted

by the boundary element model accurately matched those measured on a real barge. This means that the curves used in the model were representative of the long-term perfor mance of the materialson the barge.

Another study was performed on many of the same materials as this study by Foster and Moores at the Defence ResearchEstablishment Pacific in Canada.16 Their study was conducted in water at 9 °C for time periods up to 2,000 daysexposure, althoughonly data up to 800 days were reported.Potentials used were as low as -1,100 mV vs. Ag/AgCI. Only average currentdensities over the entire test were reported. These are replotted in a format consistent with the data generatedin this study in Appendix L. Foster and

Moores' data are very similar to the long-termpotentiostatic data generated here, but their-1,100-mV specimens usually had significantly higher current densities than the

-1,I 00-mV specimens from the currentstudy reported in Appendixes A through I.

Comparison of HY-80 steel data from these studies to actual cathodic protection design current density and potential rangesfor steel is instructive. Design data from NACEIntemational,5 technical guidance from the Naval Sea Systems Command,6 and

several Norwegian and United Kingdom design guidelines, as reported by Wyatt,17 are

shown in Appendix M. Whileall design guidelines recommend protection to -800 mV vs. Ag/AgCl, the design current densitiesused range over more than an order of magni tude, centered roughly around the 10-µA/cm2 value from the steel data in Appendix A. The data in Appendix A are, therefore, consistent with design practice.

CARDIVNSWC-TR-61-94/44 q

CONCLUSIONS

None of the potentiodynamic curves resembles the long-term potentiostatic curves sufficiently to be used for accurate prediction of galvanicor cathodic protection behavior. Adequate prediction requires the use of long-term,potentiostatically derived polarization curves. Data are presentedthat have been successfully used to predictcathodic protection current and potential distribution on a large structure. Data from this study are in agree ment with data from other investigators and with cathodicprotection current density design guidelines from several countries.

10 CARDIVNSWC-TR-61-94/44

REFERENCES

1. NACE CorrosionEngineer's Reference Book, R.S. Treseder, Ed., NACE Interna tional, Houston, Tex., p. 62 (1980).

2. LaQue, F.L., Marine Corrosion-Causes and Prevention, John Wileyand Sons, Inc., New York, N.Y., p. 179 (1975).

3. Aylor, D.M., and H.P. Hack, "Comparative Galvanic Corrosion Effects of Noble Metals on Bronze in Seawater,"CORROSION/82, Paper No. 61, NACEInterna tional, Houston, Tex. (1982).

4. Hack, H.P., and W.L. Adamson, "Analysis of Galvanic Corrosion Between a Ti tanium Condenser and Copper-Nickel PipingSystem,"CARDEROCKDIV, NSWC Report4553 (Jan 1976).

5. "Standard Recommended Practice-Corrosion Control ofSteel, Fixed Offshore Platforms Associated With PetroleumProduction," Standard RPOI76, NACE International, Houston, Tex. (I983).

6. Naval Ships' Technical Manual,Chapter 633, "Cathodic Protection ,"

S9086-VF-STM-OIO/CH-633, Naval Sea SystemsCommand, Crystal City,Va. (Dec 1991).

7. Hack, H.P., "Galvanic Corrosion Prediction Using Long-TermPotentiostatic Po larization Curves," CORROSION/83, Paper No. 73, NACE International, Houston, Tex. (1983).

8. Hack, H.P., "Exposure Time Effects on Current Densities of Polarized Marine Materials," CORROSION/83, Paper No. 210, NACE International, Houston, Tex. (1983).

9. Scully, J.R., andH.P.Hack, "Galvanic Corrosion Prediction Using Long and Short Term Polarization Curves," CORROSION/84, Paper No. 34,NACE In ternational, Houston, Tex. (1984).

10. Scully, J.R., and H.P. Hack, "Effect of Exposure Time on the Polarization Behav ior of Marine Alloys Under Flowing and Quiescent Conditions," CORROSION/85,Paper No. 214, NACE International, Houston,Tex.(1985).

1I . Hack, H.P., and J.R. Scully,"Galvanic Corrosion Prediction Using Long- and Short-Term Polarization Curves," Corrosion, Vol. 42, No. 2, pp. 79-90(Feb

1986).

12. Scully, J.R., H.P. Hack, and D.G. Tipton, "Effect of Exposure Timeon the Polar ization Behavior of Marine Alloys Under Flowing and Quiescent Conditions," Corrosion, Vol 42, No. 8, pp. 462-469 (Aug I 986).

13. "Standard Practice for Preparing, Cleaning, and Evaluating CorrosionTest Speci mens," Standard GI , ASTM Bookof Standards, Vol 03.02, Philadelphia, Pa (1986).

CARDIVNSWC-TR-61-94/44

14. "Reference Test Method for Making Potentiostatic and Potentiodynamic Anodic Polarization Measurements, "Standard G5, ASTM Book of Standards, Vol 03.02, Philadelphia, Pa (1986).

15. Hack, H.P., and R.M.Janeczko, "Verification of the Boundary ElementModel ling Technique for Cathodic Protectionof Large Ship Structures," CARDEROCKDIV, NSWC Report CARDIVNSWC-TR-61-93/02 (Dec 1993).

16. Foster, T., and J.G. Moores, "Cathodic Protection Current Demand of Various Alloys in Sea Water,"CORROSION/86, PaperNo. 295, NACE International, Houston, Tex. (1986).

17. Wyatt, B.S., "Cathodic Protection Monitoring and Survey Requirements for Off shore Platforms and Pipelines:Part l,"Anti- Corrosion (Jun 1985).

12 CARDIVNSWC-TR-61-94/44

APPENDIX A

POLARIZATION CURVES FROM THIS STUDY FOR HY-80 STEEL

CARDIVNSWC-TR-61 -94/44 13

APPENDIX B

POLARIZATION CURVES FROM THIS STUDY FOR 90-10 COPPER-NICKEL

:ARDIVNSWC-TR-61-94/44

u

)>

:0

0

<z

(/)

:0

J..i.

cIo

.f:>.

.f:>.

0-

C)

C)

<(.

">'

>

E

0

-200

-400

(t-'otent1odynamic)

HY - 80 STEEL

1hr Pre"e"" xposure 5 V/hr 1 hr Preexposure 50 V/hr

1 hr Preexposure 100 V/hr

Quiescent Flow

...

-

..J
<(

I z- w I- 0 CL

-soo Lr _ - -

; ;; :zt - -- -·

==-;

-800

-1000

-1200 L----'- _.

_._ --'.

---'- _.

--'

-.fl

104 10·3 10·2 10·1 10° 101

C.URRENT DENSITY. mA/cm2

I

() (Potentiodynam1c)
)>

:0

0

<z

(/)

()

:0

I

I

<O

HY - 80 STEEL

Quiescent Flow

""° I O 11120 days Preexposure 0,5 V/hr

""° 0-

120 days Preexposure 5 V/hr

0) 120 days Preexposure 50 V/hr

-200

0)

<t.

">' -400

>

E

.... -600

..J

<t

z -800

UJ

I-

0a.. -1000

-1200 104 10·3 10·2 10-t 10° 101

._...,. I CURRENT DENSITY, mA/cm2

()

)>

::n

0

<z

(/)

()

::n

6,

......

J,

-- I

0-

C')

C')

<C

•

">'

>

E

..J""

-<..C..

z

w....

00..

0

-200

-400

-600

-800

-1000

(Potentiodynamic)

HY - 80 STEEL

Flowing at 8.0 ft/s

-1200 , ._

_._

..

........

--'-

....._

10-4

10-3

10-2

10"1

10°

101

.0

CURRENT DENSITY. mA/cm2

(Potentiostatic)

HY - 80 STEEL

QuiescentFlow

················ Anodic Current

Cathodic Current 1 hr Exposure

1 day Exposure

30 days Exposure 60 days Exposure 120 days Exposure

0

-200

J

: ;

:

...·.l_.....

.

.-·....·
..··...·

-400 t- /......

'"... ................................................... ......................"! ·••••:.:::::::::.<:::.:: ::.·

-600 I- -----........;· -""-'";..•.".fiNU•;:;w:;.·.· ::::::...•....•••

-800

-1000

.., n- w:;.-.-.....-...-.......-:.......- ...._.....,.....,..-

I .,.

-1200 '--_._ ...._ ---'"-- -'- -'- ---' --'

10·4 10·3 10·2 10·1 100 101

CURRENT DENSITY,mA/cm2

)>

lJ (Potentiostatic)
JJ

0

<z

(/)

::E

()

JJ

I

cIo

..,. I

HY - 80 STEEL

Flowing at 8.0 ft/s

- Cathodic Current

0 ·•·············Anodic Current
0 .,,...

C) •, :r'

1day Exposure

-200 30 days Exposure

C) 60 days Exposure

<(.

>

0 -400
>

_E.... -600

<(

120 days Exposure

z

w....

-800

0c. -1000

-1200

10-4 10·3 10·2 10·1 10° 101

N..,,

I CURRENT DENSITY, mA/cm2

0

:t>

:0

0

<z

(Potentiodynamic)

90 - 10 COPPER - NICKEL

U>

:0

6 i.

I

'D

-

o C)

Quiescent Flow

0

F ---

'-'t--

0<(,

<(.

>

">'

-200 \ --

-400

E -soo

..J"'

<(

j::

z

w

1hour Preexposure 5 V/hr 1 hour Preexposure 50 V/hr

1hour Preexposure 100 V/hr

lo-

-800

c.. -1000

-1200 .... ....._ _._ . ,_ -'- ......_ 1 1 1 1 1 1

-J

CURRENT DENSITY, mA/cm2
-J

()

)>

0

JJ
<z

(/)

:E

()

(Potentiodynamic)

90 - 10 COPPER- NICKEL

Quiescent Flow

JJ I O....>..

1

I

..,,,,..

0-

en

en

<(.

">'

>

E

...

..J

<-(

I z-

w

I-

0

Q.

O

-200

-400

-600

-800

-1000

-1200 ...._-'-

...........

.L-

.

--'-

....._

-'

10-4

10·3

10"2

10"1

10°

101

CURRENT DENSITY. mA/cm2

0

)>

:D 0

<z

en

()

:D I O.....l.

I

(!)

-0

C)

C)

<.

>

">'
_E....

<-

tz-

w

t-

0

a..

0

-200

-400

-600

-800

-1000

(Potentiodynamic)

90 - 10 COPPER - NICKEL

Flowing at 8.0 ft/s

-1200.. _._

-'--

,

--L

--'-

_._

104

103

102

101

10°

101

CURRENT DENSITY, mA/cm2

0

)>

:Il

0

<z

(/)

:!

?

(Potentiostatic)

90 - 10 COPPER-NICKEL

Quiescent Flow

-i

:Il

I

I

I -

<D

.j:>

.j:>

===:•..

.i ·:.·.·,·.··..4·1·##·1 ..........

llJl1111:::1•••• ... •••••

0

tJ)

•!l!!iflCl= -..UN'<

0

-•

•.: :::!. ..':- .....······

1111m·:::::."··'"··.'.··''··"-"··'·.·.··."-··•·•••·•·•··••-•••"""''\\''c:;,..••'' ···

tJ)

<(.

>

">'
E

...

..J

<(

i== z w

I-

0Q.

-200

-400

-600

-800

-1000

:s- =............,,...,,,,... -

,

···•············ Anodic Current

Cathodic Current E:xros ·e

1day Exposure 30 days Exposure

60 days Exposure

120davs Exposure

-1200'---'- ""'-- ---' ......._ ..

-'-    --'

10-4 103 10·2 10·1 10° 101

w

w CURRENT DENSITY, mA/cm2

(')

)>

JJ 0

<z

(/)

()

i.i

(Potentiostatic)

90 - 10 COPPER - NICKEL

Flowing at 8.0 ft/s

:::J

I

(...)..).

I

CD

I

.,.

-

0 I: .................... _ ,,
0

C)

.....

················ Anodic Current

---- Cathodic Current

pf . .XI •OSUre

1 day Exposure

30 days Exposure

60 days Exposure

120 days Exposure

.........:::·.-.

C)

<C.

">'

>

_.

E
...

-

<C
I-

z w I- 0

a..

-200 I rm:......... ........._

-=::::::::::: 1

-400

-600

-800

-1000

-1200 . ._

....._ .    ,_        ---' --------- I

,_,,

10 4 10·3 10·2 10"1 10° 101

CURRENT DENSITY. mA/cm2

APPENDIX C

POLARIZATION CURVES FROM THIS STUDY FOR 70-30 COPPER-NICKEL

CARDIVNSWC-TR-61-94/44

0

]J

0

<z

(/)

]J

I

cIo

0-

C')

(Potentiodynamic)

70 - 30 COPPER NICKEL

Quiescent Flow

/

C')

<(.

">' -400

>

E

J -600

<(

t:=

z -800

w I- 0

a. -1000

1hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

\.,
\

\),

.\

\.

' \)
"'

-1200 '---'- _,

----'- -L- --''-- -'- -'

10·4 10·3 10-2 10-1 100 101

\0

<» CURRENT DENSITY, mA/cm2

(Potentiodynamic)

70 - 30 COPPERNICKEL

Flowing at 8.0 ft/s

0

-200 1==;;;;i :m:..;,_

-400

-600

-800

-1000

1 hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

-1200 L---'-

--L

-'--

-1-

---'-

"'-

1

1

1

1

1

1

120 daysPreexposure 5 V/hr

CURRENT DENSITY, mA/cm2

0

)>

:IJ

0

<z

(/)

()

JJ

I

.

Ol

(Potentiostatic)

70 - 30 COPPER NICKEL

Quiescent Flow

cIo

0 t- ··

······....

..

'•..,·

·..···:-

.

..· ....

·

"""
I

- ia:······................."'"'""""'""""""'""'"'"' ,:;,.. ..'..

··

···

"""

0 ·'·

...·.··.·.·.·.............\._,,..........................................············"

C)

C)

<

•

">'

>

E

....

-

..J
<....

z w.... 0

c..

-200 ............,,,.... .. ... ·····

a:::: < < .....

-400

-600

···············Anodic Current

---- Cathodic Current

'iO .J r .xpo Ure

1day Exposure 30 days Exposure

60 days Exposure

120 days Exposure

-800

..

\
-1000

-1200 L----L----------'--------------L----------..J--------------'--------------'-- 1

104 10"3 10·2 10·1 10° 101

".»'

CURRENT DENSITY. mA/cm2

0

)>

J)

0

<z

ff)

0

JJ

(Potentiostatic)

70 - 30 COPPER NICKEL

Flowing at 8.0 ft/s

<D

I
...... I

0

C)

C)

<(.

">'

>

E

..J

<(

t:= z w

I-

0

0.

0 t-

-200 .,..._.... ic::::::: ......_ .::

-400

-600

-800

-1000

·········•·····Anodic Current

- --- Cathodic Current

• our f;.xposure 1 day Exposure

30 days Exposure

60 days Exposure

120 days Exposure

-··

\;

.........

-1200'---'- ---'        -'-     -'-       ..

.......

...

"'

104 103 102 101 10°       101

CURRENTDENSITY, mA/cm2

APPENDIX D

POLARIZATION CURVES FROM THIS STUDY FOR NAVY TYPE M BRONZE

CARDIVNSWC-TR-61-94/44                                                   47

,

)>

:0

0

<z

(/)

:E

0

:0

I

O.....l.

cIo

t

<c

•

::::.

E...

-J

i==

:2::

0

0.

(Potentiodynamic)

NAVY TYPE M BRONZE

Quiescent Flow

0

-200        ----------

-400

-600

1 hour Preexposure 5 V/hr 1 hour Preexposure 50 V/hr

1 hour Preexposure 100 V/hr

-800

-1000

".0"

-1200....._-'- ....1- ""-     ---L      -'-      ....._ 104 1o-3 10-2 1o·1 1o0 1o1

CURRENT DENSITY. mA/cm2

0 (Potentiodynamic)

)>

JJ

0

en

z< NAVY TYPE M BRONZE

0

:E Quiescent Flow
JJ

I

CD

.i..

.i..

-0

tn

.

tn
<(

en

>

>

E...

...J

<(

i== z

UJ I- 0

a.

0

-200

-400

-600

-800

-1000

I_ - ,· 1fF _

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

120 days Preexposure 50 V/hr

-1200 '---'-

_._

---L

-'-

'--

-'-

--I

10·4

10·3

10·2

10·1

100

101

CURRENT DENSITY, mA/cm2

0

·200

(Potentiodynamic)

NAVY TYPE M BRONZE

Flowing at 8.0 ft/s

-400

-600

-800

-1000

-1200 '-----'-

--

---

........_

.._

...._

10·4

10·3

10·2

10·1

10°

101

w

VI CURRENT DENSITY. mA/cm2

()

)>

'.Il

0

<z

en

()

'.Il

6,

.....

I

:0

-

""' I
""' 0

en

(Potentiostatic)

NAVY TYPEM BRONZE

Quiescent Flow

0

•·········............................

,..,,,,.,...-.-u..,)"f!f/i;1;11111::::••• ffln''"'""'"""'"""'""" . _!:::::::.....:·••·-··

en

ct.

>

">'
E

....

..J

················Anodic Current

---- Cathodic Current

1 day Exposure

30 days Exposure

60 days Exposure

120 days Exposure

c-t

-200

-400

-600

a - 57

I z- -800

w

I-

0a.

-1000

-1200 . ._ _._ .. . _... ....._

104 10·3 10-2 10·1 10° 101

JI

JI CURRENT DENSITY._ mA/cm2

0

)>

:0

0

<z

en

::!

0

(Potentiostatic)

NAVY TYPE M BRONZE

Flowing at 8.0 ft/s

:0

I

O.....l.

cIo

I

-0

C)

C)

<C

"'

•
>

>

E..

..J

0

-200

-400

-600

-<C

z

t- -800
w

t-

Q.

0 -1000

-1200

JI

-i

10-4 10"3 10"2 10·1 10° 101

CURRENT DENSITY. mA/cm2

APPENDIX E

POLARIZATION CURVES FROM THIS STUDY FOR NICKEL-ALUMINUM BRONZE

CARDIVNSWC-TR-61-94/44

(")

)>

JJ

0

<z

(()

,...,

!..:

:;o

I I (0

......

(Potentiodynamic)

NICKEL - ALUMINUM BRONZE

QuiescentFlow

1 C 1 r '""C

-

(.)

C)

0 t- I 1 hour Preexposure 5 V/hr

1hour Preexposure 50 V/hr

1 hour Preexposure 100 V/hr

C)

<C.

">'

>

E...

..J

<C

zi==

w

t- 0 CL

-200

-600

-800

-1000

-1200 --_._

.........

...._

........

...._

--

,

10-4

10-3

10-2

10-1

10°

101

°.....'.

CURRENT DENSITY. mA/cm2

(')

)>

JJ

0

<

z

en

0

JJ

I

O...l.

cIo

..,.

(.)

C)

<.......,;

C)

<(

0

-200

(Potentiodynamic)

NICKEL- ALUMINUM BRONZE

Quiescent Flow

ui -400

>

>

E...

...J

<

z w ol-

-soo

-800

a. -1000

°<.»'

-1200

1 1 1 1 1 1

CURRENT DENSITY. mA/cm2

:'.")

D

:J

<z

J)

:E

i>

-;

D

:n

I

!)

"f"

0-

<CC')

0,

<C

ui

>

>

0

-200

-400

(Potentiodynamic)

NICKEL - ALUMINUM BRONZE

Flowing at 8.0 ft/s

.E..r -600

<C

z w ol-

-800

a. -1000

-1200 .... ._

...._

--'-

._

....._

10-4

10-3

10-2

10-1

10°

101

".11

CURRENT DENSITY. mA/cm2

0

)>

::D

0

<z

(/)

0

::D I O....l.

I

(()

-

"""
""" 0

(Potentiostatic)

NICKEL - ALUMINUM BRONZE

QuiescentFlow

0

::;::::·......,, :............... . :::,...·

C)

C)

<

tn•

>

>

E...

...J

-<I-

z

w

I-

·············· Anodic Current

Cathodic Current

1day Exposure 30 days Exposure 60 days Exposure

120 days Exposure

0

-200

-400

-600

-800

=== == =·:·::·:········-\\""'""--·-::=:---.. ·-.:O··-··········::::.-····, .•

'.Jf............

6 ••••

................................

0.. -1000

0\

-.J

-1200 L-----'- -'-       .1.-    --'        --'-      -L-    -I 10-4 10-3 10-2 10-1 10° 101

CURRENT DENSITY. mA/cm2

::">

l> D CJ

<z

(/)

("')

lJ

I

6..,.
(0

I -

""
"" 0

(Potentiostatic)

NICKEL -ALUMINUM BRONZE

Flowing at 8.0 ft/s

.----- - Anodic Current

0 ........·•..··:····.··.··.··.··.··.·.·.······::.:·,·,,·,\····r.·· -.. =----:--:----------

C)

-200

,................·...·.·.·..·..·.·..·...·.·"··"·'··"·"·"···'·.;,;.. .

··········

··········-·························· ··

....... Cathodic Current 1 day Exposure

C)

<t.

30 days Exposure

60 days Exposure

120 days Exposure

>

">'
E

....

-

...I
<(

-400

-600

z

t- -800
w

t-

0a..

-1000

-1200 ...._-'-

-L-

.l...-

---L

......L..

...L-

1

1

1

1

1

1

°IC'

CURRENT DENSITY. mA/cm2

APPENDIX F

POLARIZATION CURVESFROM THIS STUDYFOR MONEL

CARDIVNSWC-TR-61-94/44 7 1

I

() (Potentlodynamic)
;t>

:rJ 0

<z

U>

()

.!.;

JJ

I

I

MONEL

QuiescentFlow

.I:> -

<D I al  _ ,,=-/0..-
0

C')

C') -200 . T .,,c;;:

<C.

">' -400

>

E

• . , cX1Jusurn IJ.5 V/hr 1hr Preexposure 5 V/hr 1hr Preexposure 50 V/hr 1hr Preexposure 100 V/hr

..J

<C

i== z w

I-

-600

-800

0a. -1000

-1200 10 4 10 3 10-2 10·1 10° 101

VJ

-.l I CURRENT DENSITY, mA/cm2

)>

() I (Potentiodynamic)
JJ 0

<z

(/)

JJ I 0...)..

I

(0

I

-

0
0

C)

-200

C)

<.

MONEL

Flowing at 8.0 ft/s

">' -400

>

E

..J"' -600

-

<
I z- -800

w

I-

0a. -1000

-1200

-..]

-..] I. CURRENT DENSITY. mA/cm2

)>

() I (Potentiodynamic)
JJ 0

<z

(/)

JJ I 0...)..

I

(0

I

-

0
0

C)

-200

C)

<.

MONEL

Flowing at 8.0 ft/s

">' -400

>

E

..J"' -600

-

<
I z- -800

w

I-

0a. -1000

-1200

-..]

-..] I. CURRENT DENSITY. mA/cm2

0

)>

JJ

0

<z

(/)

()

I

-l

::;:;

I

b......
(0

..._

0

················ Anodic Current

---- Cathodic Current

1day Exposure 30 days Exposure

60 days Exposure

120days Exposure

(.)

(Potentiostatic)

MONEL

QuiescentFlow

········............................................. .....,,.....

·mfttcctnKiiiiiiCiuon1•""'

'Jlii1nntUJU'"""'"""'"•"..... . !t -"" "....·

C)

C)

•

<
">'

>

E

...

-I

<-

tz-

w t- 0

c..

-200

-400

-600

-800

-1000

µ••·•··········

-1200 L.......--L--------......L...---------'----------'----------'---------....L.. 1

104 103 102 101 10°       101

._J

'Ci

CURRENT DENSITY. mA/cm2

(Potent1ostat1c)

MONEL

Flowing at 8.0 ft/s

-2

-4

-60

-80

-10

0-0

-12

104 10·3 10·2 10·1 10° 101

CURRENT D.ENSITV. mA/cm2

APPENDIX G

POLARIZATION CURVES FROM THIS STUDY FOR ALLOY 625

CARDIVNSWC-TR-61-94/44 83

(Potentiodynamic)

ALLOY 625

Quiescent Flow

-1200'---'- ....._ --" -'- .

-'-    --'

10·4 10·3 10-2 10-1 100 101

U\

00 CURRENT DENSITY, mA/cm2

0

)>

::0

0

<z

en

:'E

0

.!.i

(Potentiodynamic)

ALLOY 625

Quiescent Flow

JJ

I

I

.

<D
.I!>

.I!>

0-

CJ)

CJ)

<(.

>

">'
E

....

..J

<(

i= z w

I-

0

a..

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

120 days Preexposure 50 V/hr

e

0

-200 ""4 I ==--

-400

-600

-800

-1000

0_0,

-1200 ..._........ ...._ ........ ..._ . .. .

10·4 10·3 10·2 10·1 100 101

CURRENT DENSITY, mA/cm2

(Potentlodynamic)

ALLOY 625

Flowing at 8.0 ft/s

l

.) \

1hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

0

-200.•

-400

-600

-800

-1000

-1200L----L --'- ...1....-

.JL.....-     --L      .....L...    -J

104 10-3 10-2 10-1 10° 101

\D

00 CURRENT DENSITY. mA/cm2

0

)>

Jl

0

<z

(j)

:E

0

Jl

I

-

J,
.i:.

0

.i:. I

(Potentiostatic}

ALLOY 625

Quiescent Flow

0

C)

C)

<(.

tn

>

>

E

...J

<(

i== z w

I-

0

-200

-400

-600

-800

•...

·::::•••:::: "' '••U••••••••W

c.. -1000

-12001...- J,.,-----------'---------------''---------------'-----------------..._--------------L--------------' 104 10"3 102 10"1 10°       101

CURRENT DENSITY,mA/cm2

0 (Potentiostatic)

JJ

z<

0 AL LOY 625

(/)

0

JJ

l

I -(..)

C)

C)

<(.

0

>

>

E

..J"'

·•··············Anodic Current

---- Cathodic Current 1 11our Exposure (no data) 1day Exposure

30 days Exposure

60 days Exposure

120 days Exposure

<-(

0

-200

-400

-600

Flowing at 8.0 ft/s

I z- -800

w

I-

0CL.

-1000

-1200 L----'- ---....L....- --"-- ----L-----'- ---........_ .....J                                                                                                                   10"4 10-3 10·2 10-1 10° 101

'° CURRENT DENSITY. mA/cm2

APPENDIX H

POLARIZATION CURVES FROM THISSTUDY FOR TITANIUM50

CARDIVNSWC-TR-61-94/44 Q<i

()

)>

:n

0

<z

CJ)

()

:n

b.....

cIo

....,,..

0-

C')

C')

<C.

">'

>

E

..J"'

0

-200 ·-· .

-400

-600

(Potentiodynam1c)

TITANIUM 50

t r. sure O b V/h1

1hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

Quiescent Flow

-<C

z

t- -800
w

t-

0

D.. -1000

-1200 .... ,_ _._ ....._ ......_ ..._

10-4 10-3 10-2 10-1 1o0 101

-'.°I

CURRENT DENSITY. mA/cm2

0

>

lJ

0

<z

(/)

lJ

J i.

.,.

1 hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

···········-

(Potentiodynamic)

TITANIUM 50

Flowing at 8.0 ft/s

.,.

'

0 i.:......-.

-

0

...·,..-···········..··.1.

-

en

en

<.

">'

>

E

....

...J

-<.....

z

w

.....

0

-200

-400

-600

-800

1•-•---·---··-·····

CL -1000

-1200.   -'-     ...._        "--

.,

104 10-3 10·2 10-1 10°       101

\0

\0 CURRENT DENSITY. mA/cm2

)>

0
:n

0

<z

(fJ

:n

I

CD

.I,.
.,.

o i:-

0

Cl

-200

Cl

···············Anodic Current

---- Cathodic Current

1 hour Exposure

1day Exposure

30 days Exposure

60 days Exposure

120 days Exposure

<.

(Potentiostatic)

TITANIUM 50

Quiescent Flow

">'

>

E

...J"'

<

i== z w

t-

0

-400 ·----.....

-600

-800

a. -1000

-1200 '---'- ---''-- -'- ---L ...._ --L --I

10·4 10·3 10·2 10·1 1oo 101

0 CURRENT DENSITY, mA/cm2

0

)>

:D

0

<z

en

:D

6 i.

cIo

"" I

0-

C)

C)

•

<
">'

>

E...

..J

<-

tz-

w

t-

0

o

-200

-400

-600

-800

(Potentiostatic)

TITANIUM50

Flowing at 8.0 ft/s

Q. -1000

::>

.;J

-1200 .... ._ ......_ .. . ......... _.

104 10·3 10·2 10·1 10° 101

C_URRENT DENSITY. mA/cm2

APPENDIX I

POLARIZATION CURVESFROM THIS STUDY FOR ANODE GRADE ZINC

CARDIVNSWC-TR-61-94/44 11\C

()

)>

:D

0

<z

(/)

:E

()

:D

J,

......

cIo

.i>- I

(Potentiodynamic)

ANODE GRADE ZINC

Quiescent Flow

-

0
0 1 hour Preexposure 5 V/hr

C)

C)

<.

">'

>

E

...I

"'
<I-

z

w

I-

-200

-400

-600

-800

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

·'

//

CL

0 -1000 b ::::<-

..----

- ' SC::: <::::::::

-

0_,

-1200 '----'- ....._ .,---- .._... ....._ ----'-- -'- -' 104 10·3 10·2 10·1 10° 101

CURRENT DENSITY. mA/cm2

:->

)>

D

:J

<z

(Potentiodynamic)

ANODE GRADE ZINC

1hour Preexposure 5 V/hr

120 days Preexposure 0.5 V/hr

120 days Preexposure 5 V/hr

J)

)>

!D"."".,

1

I

-0

en

en

<.

U)

>

>

E

-

.J"'
<

I-

z

w

I-

0

0

-200

-400

-600

-800

Flowing at 8.0 ft/s

Q. -1000

- -..,... l:.J:r JJ..t ,. · -· · ·

-1200 "---'- -"- --L -'-'""- D.a... ---'- -I

104 10-3 10-2 10"1 10° 101

CURRENT DENSITY. mA/cm2

()

}>

JJ 0

<z

(f)

(Potentiostatic)

ANODE GRADE ZINC

QuiescentFlow

......

I

co

-

I
0

C)

C)

<t.

">'

>

E

...

-

..J
<t

I z-

w

I-

0

O t- I ················Anodic Current

---- Cathodic Current

r.

1 day Exposure

-200 t- I 30 days Exposure

60 days Exposure

120 days Exposure

-400

-600

-800

m.'.'...t....m......u.·m..m...m...»I.N..>..N..ll.;;N.m..)»:;.)>»>»»»>>»

,..,.,.·····-·'

.. ::.-;.•.•·........._...-

.

/l
·

;

....

a. -1000

.........,..,A;=:: ·-··••Y·V""'-'""" (;¢

is:_-•"'""°'""'''"

.

:::

-1200 . ---'- _._- - .r-.. ----"- --L- _._- --' 10-4 10·3 10"2 10"1 10° 101

CURRENT DENSITY. mA/cm2

APPENDIX J

CORROSION RATES FROM POTENTIOSTATIC TESTS IN THIS STUDY

CARDIVNSWC-TR-61-94/44 11c;

0

l>

:0

0

<z

(/)

I CORROSION OF HY-80 STEEL

0

I

.!..i
:IJ I 0....).

I

<D I

100

- 0

.:>. (..)

tn -100

tn

<C.

">'

-200

-300

> -400

E

.... -500

-I

-<C -600

z I-

0 oot

w

-700

I- 30 days Exposure

Q. 60 days Exposure

-900 120 days Exposure

-100 0-2 2 3 5 710-1 2 3 5 7100 2 3 5 7 101 2 3 5 7 102 2 3 5

---.J CORROSION RATE mm/yr

()

)>

:D

0

<z

(/)

:'E

()

I

:D I 100

I

O.....l.

CORROSION OF

90 - 10 COPPER NICKEL

t

-

<D 0
.;:. I 0

C) -100

C)

<(.

">'

-200

-300

> -400

E.. -500

...J

<(

-t-

-600

oot 30 days Exposure

w

z -700
t-

0

c.. 60 days Exposure

-900

120 days Exposure

10-2

-1000 2 3 5 710-1 2 3 5 7 100 2 3 5 7 101 2 3 5 7102 2 3

:0 CORROSION RATE mm/yr

,_ lJ 0

<z

rn

::E

0

I

lJ I 100
O....l.

CORROSION OF

70 - 30 COPPER NICKEL

-

0

I
CD

.p..

.p.. 0

I

en -100

en

<C.

tn

>

-200

-300

> -400

E

<(

..J"' -500

....

-600

w oot

z -700
....

0

30 days Exposure

0. 60 days Exposure

-900

-1000

10-2

120 days Exposure

2 3 5 710-1 2 3 5 7 100 2 3 57 101 2 3 57102 2 3

tv I CORROSION RATE mm/yr

,_ lJ 0

<z

rn

::E

0

I

lJ I 100
O....l.

CORROSION OF

70 - 30 COPPER NICKEL

-

0

I
CD

.p..

.p.. 0

I

en -100

en

<C.

tn

>

-200

-300

> -400

E

<(

..J"' -500

....

-600

w oot

z -700
....

0

30 days Exposure

0. 60 days Exposure

-900

-1000

10-2

120 days Exposure

2 3 5 710-1 2 3 5 7 100 2 3 57 101 2 3 57102 2 3

tv I CORROSION RATE mm/yr

l}

)>

:D

0

<z

(/)

()

:D

I

(...j...

I

I CORROSION OF M BRONZE

I 100

0

<O -

::;: I

0

°'

<°'

-100

-200

. -300

">'

> -400

E... -500

...J

<I-

-600

w

z -700
I- 30 daysExposure

Q.

0 -soo t

60 days Exposure

-900 120 days Exposure

-1000

10-2

2 3 5710-1 2 3 5 7100 2 3 5 7 101 2 3 5 7102 2 3 5

I CORROSION RATE mm/yr

.....
t-.)

L>l

()

)>

0

<

JJ CORROSION OF Ni-Al-BRONZE
z

U>

JJ

I

(...)..

I

<.o

100

-

0
0

C) -100

C) -200

"'

<. -300
>

> -400

E

.... -500

..J

t

< -600
z-

w -700

t-

0 oo

30 days Exposure

Q. 60 days Exposure

-900 120 days Exposure

-1000

10-2 2 3 5 710-1 2 3 5 7 100 2 3 5 7 101 2 3 5 7 102 2 3 5

v.

tv CORROSION RATE mm/yr

"l>

:n

0

<z

(J)

:i!

0

I

-:ni I

91

I

CORROSION OF ANODE GRADE ZINC

-100 - ..............""T""T"1"TTT'""---r--T-rr"TTTirr---.-"""T"""'rTTTTTT-T"""llTirrnTf""*---r-.-.-

(()

"""""" I

0

C')

-200

-300

--- 30 days Exposure

--- 60 days Exposure

--- 120 days Exposure

;::::;

'O

C')

.

">'

>

E

..J

i= z w

I-

0

c..

-400

-500

-600

-700

-800

-900

-1000 b: w"'

-1100

-1200

10·2 2 3 5 7 10-1 2 3 5 7 100 2 3 5 7 101 2 3 5 7 102 2 3

CORROSIONRATE mm/yr

I HY-80 STEEL

Quiescent Flow - Boundary Element Curve

I I T I T I

(.)

0 .....

-

•••·••••••••••• Anodic Current120 days

Cathodic Current 120 days

-

C>
<( -200 t- -

()

)>

JJ 1 ·

C>

<(.

">"

>

E..

..J

<-(

Iz-

w

I-

< a.

0

-400 t- -

-600 -

1

-800 ..... -

0

z

(/)

()

!.i

JJ

I

<O

A

A

-1000 t- -

-1200 10-4 10·3 10·2 10·1 100 101

CURRENT DENSITY,mA/cm2

APPENDIX K

SMOOTHED POLARIZATION CURVES USED IN BOUNDARY ELEMENTSTUDY

CARDIVNSWC-TR- 61-94/44 13 1

)>

0

0

z<

:n 90 - 10 COPPERNICKEL
en Quiescent Flow - Boundary Element Curve

:n

6....,.

cIo

t

-(..)

C>

<.....(_

C>

<(

u>i

>

E

0

-200

-400

... -600

...J

<(

zi==

w

to-

-800

r:l. -1000

-120Q L---'-

_._

-'-

...._

..

---''--

--'

104

10-3

10-2

10-1

10°

101

CURRENT DENSITY,mA/cm2

;)

;)

<..>

"" ANODE GRADE ZINC
Quiescent Flow -Boundary Element Curve

-(.)

C>

<-C>
<.

en

>

>

E

...J"'

<-

0 ••••••••••••••• Anodic Current 120 days

---- Cathodic Current 120 days

-200

-400

-600

Iz-

w

I

0

() I-
)>

< a.

J)

-800

-1000 .......

......

D

z

en

::E

J) I O....>..

I

IO

t>.

t>.

·····•        ··    •··········•·····                     ·••••

-1200'---'- -- .. ._ _._ -'- ....1 10"" 10 3 10·2 10·1 10° 101

CURRENT DENSITY, mA/cm2

APPENDIX L

FOSTER AND MOORES' 800-DAY POLARIZATION DATA

CARDIVNSWC-TR- 61-94/44

u (J-'otent1ostat1c)

)>

JJ

0

en

z< STEEL

()

:E Quiescent Flow 9°C*

I

co

-

t
0

C'>

C'>

<(.

">'

>

E

...J

<(

z

w

I-

0

Q.

0

-200

-400

-600

-800

-1000

--- 50 days averaged

100 days averaged

800 days averaged

-1200    ---- ----....._          ..

.          -------

10·4 10·3 10·2 10·1 1o0 101

_,,

-.J

CURRENT DENSITY, mA/cm2

* after Foster and Moores

0

)>

:D

0

<z

(J)

()

:D

I

.i:.

cIo
::;;:

.i:.

0

0)

0)

<(.

>

">'
E

...J

<(

j:: z w

I-

0

Q.

0

-200

-400

-600

-800

-1000

(Potentiostatic)

70 -30 COPPER NICKEL

Quiescent Flow 9°C*

- -- 50 daysaveraged

- -- 100 daysaveraged

--- 800 daysaveraged

-1200 '---'- _._ ---''-- -'- _._ ---''-- --'

10·4 10·3 10·2 10·1 100 101

""'"

CURRENT DENSITY, mA/cm2

* after Foster and Moores

0

)>

:D

0

<z

(J)

()

:D

I

.i:.

cIo
::;;:

.i:.

0

0)

0)

<(.

>

">'
E

...J

<(

j:: z w

I-

0

Q.

0

-200

-400

-600

-800

-1000

(Potentiostatic)

70 -30 COPPER NICKEL

Quiescent Flow 9°C*

- -- 50 daysaveraged

- -- 100 daysaveraged

--- 800 daysaveraged

-1200 '---'- _._ ---''-- -'- _._ ---''-- --'

10·4 10·3 10·2 10·1 100 101

""'"

CURRENT DENSITY, mA/cm2

* after Foster and Moores

0

)>

:0

CJ

<z

(/)

::E

0

:0

I

-

cIo

0

.;..
.;..

(Potentiostatic)

ALUMINUM BRONZE

Quiescent Flow 9°C*

50 days averaged

0

C)

C)

<(.

">'

>

E

..J

<(

t:= z w

0

-200

-400

-600

-800

100 days averaged

---800days averaged

c. -1000

-1200'--_._ --'-      _._       ...

--'- --'-    --'

'...j;,',.

104 103 10·2 101 10° 101

CURRENT DENSITY, mA/cm2

* after Foster and Moores

(Potentiostatic)

MONEL

Quiescent Flow 9°C*

0

-200

-400

-600

-800

-1000

-1200 '----'-

-'-

----'

-'--

...

_._

----'

10·4

10·3

10·2

10·1

100

101

u. CURRENT DENSITY, mA/cm2

* after Foster and Moores

()

)>

JJ

0

<z

(/)

()

JJ

I

I

tO

-!=>

I

0-

C')

C')

<(.

ti)

>

>

E

...J"'

<(

t= z w r-

0

0

-200

-400

-600

-800

(Potentiostatic)

TITANIUM

QuiescentFlow 9°C*

--- 50 days averaged

--- 100 days averaged

--- 800 days averaged

a. -1000

-1200 . ----'- -'- .

----'- -'- .

---'

j:,.

._J

104 10·3 102 10·1 10° 101

CURRENT DENSITY, mA/cm2

* after Foster and Moore

-STEEL

0

Design Guidelines for Cathodic Protection*

lJ

6.....

I

ID

:>.

0-

C)

C)

<(.

0

-200

>

U) -400
>

E...

<(

..J

-I-

z w I-

-600

-800

0a. -1000

-1200

-JI

CURRENT DENSITY, mA/cm2

* after Wyatt

APPENDIX M

CATHODIC PROTECTION DESIGNDATA FOR STEEL

CARDIVNSWC-TR-61-94/44 14Q

INITIAL DISTRIBUTION

Copies CENTER DISTRIBUTION

Copies

I

Code 011

Name

0113

0114

Oll5

(Caplan)

2020

(Ouimette)

3412

(Rice)

3422

TIC

60

(Wacker)

601

(Ventriglio)

602

(Morton)

603

(Cavallaro)

603

(Hardy)

61

(Holsberg)

6ls

(Warf)

l

611

(Palko)

I

612

(Aprigliano)

3

613

(Ferrara)

613

(Aylor)

613

(Bieberich)

I

613

(Clarke)

l

613

(Davis)

30

613

(Hack)

613

(Hays)

613

(Jackovic)

613

(Mantel)

613

(Murray)

613

(O'Connor)

614

(Montemarano)

614

(Czyryca)

615

(DeNale)

62

(Eichinger)

624

(Bardsley)

624

(Clayton)

624

(DiGiovanni)

63

(Alig)

64

(Fischer)

I Naval Research Laboratory KeyWest, Fla.
2 Naval Research Laboratory Washington, D.C.

1 Code6130 (Thomas)

l Code 6382 (DeGeorgi)

10 NavalSea SystemsCommand

1 SEA03M (Kaznoft) SEA03Ml (Parks) SEA 03U3

SEA03X72

SEA 08 (Berger) SEA 08S (Kennedy) SEA 350T (Peterson) PMS 390

PMS 390T SEA 92R

4 Office of Naval Research ONR332 (Sedriks) ONR332 (Sloter) ONR 334 (Gagorik) ONR 334 (Vogelsong)

2 Naval Civil Engineering Laboratory,

2 NCELL43 (Jenkins)

4 DTIC

CARDIVNSWC-TR-61-94/44

--

REPORT DOCUMENTATION PAGE

Form Approved OMB No. 0704-0188

Public rflPOrting burden for thi5 coll«:tion of inform•tion is estimated toat-Wrage 1 hour per 1esponse, including the time for re.newing instrvction.s, searching existing dara sources, oarhering and maintaining the data nHdtsd, and com,,-r;ng and reviflwing the collection of information. Ssnd commMts regarding thisburden estimate or any other aspect of this collection of information, including suwestions for rwducing this burden. to Washklgton HBadquatters Semc.s, Directorate for Information Operations and Rf1PO'ls, 1215 Jefferson Davis Highway. Suite 1204, Arlington, VA 22202·<302. and to In.Offic<I ol Mllna-t and Budget, Paperworlr Raduction Project (0704-0 t88}, Washington, OC 20503.

1. AGENCY USE ONLY (Leave blank) ,2. REPORT DATE ,3. REPORT TYPE AND DATES COVERED

April 1995 Final

4. TITLE AND SUBTITLE

Atlas of Polarization Diagrams for Naval Materials in Seawater

5. FUNDING NUMBERS

Program Element 62761N Task Area SF61541-591 Work Units 1-2803-162;

1-2803-164

6. AUTHOR(S)

Harvey P. Hack

7. PERFORMING ORGANIZATION NAME(S) AND ADDRESS(ES)

Carderock Division

Naval Surface Warfare Center Bethesda, Md. 20084-5000

8. PERFORMING ORGANIZATION REPORT NUMBER

CARDIVNSWC-TR-61-94/44

9. SPONSORING / MONITORING AGENCY NAME(S) AND ADDRESS(ES)

Office of Naval Research 800 N. Quincy St.

Arlington , Va. 22217-5000

10. SPONSORING/ MONITORING AGENCY REPORT NUMBER

11. SUPPLEMENTARY NOTES

12a. DISTRIBUTION/AVAILABILITY STATEMENT

Approved for public release; distribution is unlimited.

12b. DISTRIBUTION CODE

13. ABSTRACT (Maximum 200 words)

Polarization curves were developed in seawater at low (quiescent) flow and at 2.4 mis flow for nine structural alloys. Potentiostatically generated curves for up to 120 days are compared with potentiodynarnically generated curves at four scan rates with freely corroding pre-exposures of 1or 120 days. Smoothed curves successfully used in computer model pre- dictions of cathodic protection current and potential distributions are also presented. These curves are compared with previously published data available for 800 days exposure and

with cathodic protection current density design guidelines. Corrosion rate data as a function of potential after up to 120 days exposure are also presented.

14. SUBJECT TERMS

Polarization curves, Seawater, Cathodic protection , Galvanic corrosion , Cor- rosion rate, Corrosion, Computer modeling, Stray current corrosion, Steel, Copper-nickel, Bronze, Titanium, Alloy 625.Zinc

15. NUMBER OF PAGES

162

16. PRICE CODE

17. SECURITY CLASSIFICATION OF REPORT

Unclassified

18. SECURITY CLASSIFICATION OF THIS PAGE

Unclassified

19. SECURITY CLASSIFICATION OF ABSTRACT

Unclassified

20. LIMITATION OF ABSTRACT

Same as Report

I

Ii

I

I

.

NSN 7540-01-280-5500 ::.tanaara rorm "o \Hev.-.t.-01

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Database and Mat Management

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_database\poldat_database.htm

Polarisation Database

This document describes the uses and applications of the polarisation database tool and explains how to use the functionalities of the tool

CONTENTS

Introduction

Where to find it.

Main Page

Add new material data

Grouping the data in the database

Considerations to add the data in the database

How to add new material data

How to add a New Season or New Depth for a material already introduced in the database

How to add a new Formation for a Depth and Formation already in the database

Plot curves

Experimental Curve

Export, Import Files

Create Mat File

Export the Data

Import Data to the database

Add or Remove Data

Remove Data

Add new data

Modify Data

Modify material definition

Modify polarisation curve values

Delete Season, Depth, Formation or Material

Delete Formation

Delete Depth and Season

Delete Material

Data structure within the database

Material Data

Introduction

The polarisation database is a tool developed in order to store polarisation data and export them to a material file (mat_cp).

  • The polarisation database software has been developed in Microsoft Excel to simplify the selection, input, output and maintenance of electrochemical data for use with BEASY CP software.

  • This database will allow information of many different materials to be stored.

  • It will allow the easy creation of the mat file either for dependent or independent analysis.

The data can depend on three different parameters:

  • Depth

  • Season: Interval time, season time or another parameter.

  • Formation: Calcareous formation.

A maximum of 50 potential and current density values can be stored for each value of the formation parameter

The following section describes the different steps that should be followed in order to input, modify, add and chart the data.

Where to find it.

The polarisation database software is found within the BEASY installation directory under the following path: …\beasy\Tools\CP_Polarisation\databasepolar.xls

It could be used directly from this directory or a copy can be made into any directory

Main Page

The Main page of this Polarisation Database shows the different options available inside the Database

Figure 1: Main Page

Main Menu

The Main Menu is composed of the following labels

  1. Introduce New Material Data.

  2. Plot Curves

  3. Export, Import Files.

  4. Add or Remove Values

  5. Modify Data

  6. Delete Season, Depth, Formation or Material

Figure 2: Main page, page selection

  1. Introduce New Material Data. Introduce new material data and define the values of current and potential in the Polarisation Curve.

  2. Plot Curves. Chart and display a material. The experimental data can be charted.

  3. Export, Import files. Creation of mat files or export the database to a text file.

  4. Add or Remove Data. Remove or add data to the database.

  5. Modify data. Modify the material name, constants, formation, experimental polarisation data, etc.

  6. Delete Season, Depth, Formation or Material. Delete season, depth, formation or even an entire material.

Secondary Menu

The secondary menu assists the user in several actions, including extracting information from the database

Information material button

This icon will provide the complete information about one material inside the database. The Excel page where the data material is stored located is displayed

Check Mat file button

This icon will facilitate checking and finding mistakes in a Mat file that has been created earlier.

Formation check button

This icon will check the material data inside the database. Especially important in case of a time dependent simulation in which the data for all the seasons, formation, etc., must be consistent.

Change units button.

This icon button will change the units of the database. This facilitates inputting the experimental data into the database.

Save database button.

This button will save the database in the hard drive.

Exit database button.

This button will close the database.

Add new material data

This section describes the process of adding material data to the database. Click on the button labelled "Introduce New Material Data", which opens a dialog box called "Options, Input Material Data", as shown the figure below, where there are different options to introduce the data.

Figure 3: Input material data menu

The option "See materials available in the database" displays the dialog box shown in Figure 4 which allows the selection of materials. For instance; if a material is chosen in the first list labelled "Material", the variables seasons and depths available for this material will be displayed in the list labelled "Depth and Season". Hence, for each depth and season selected, the formations will also be displayed.

Figure 4: Material selection menu

The item on the panel "Options, Input Material Data" enables the system of units used in the database to be changed. The required units should be selected here before introducing the data.

Figure 5: Units selection menu

Grouping the data in the database

Data in the database is stored as depth and season data groups and formation groups within the depth and season data groups. A scheme of the structure is showed below.

The data are split into groups of depth and season (green zones in the graphic); also inside these groups are stored the formation values in each column (blue zones in the graphic).

If a time independent analysis is to carry out, only one value of depth, season and formation is necessary

Figure 6: Data distribution on Excel spreadsheet

Formations

If an interpolation among data is required, as it is the normal case of a time dependent analysis, the stored data must be consistent. For instance, the same stages of formations must be stored for all the depth and season groups of a certain material.

Figure 7: Formations inside the database

Considerations to add the data in the database

It is important to consider the following when data are introduced in the database.

  • The Potential and Current Density columns must have the same amount of values.

  • The Current Density values have to be in increasing order, i.e. anodic ® cathodic.

  • Make sure the signs of the values are correct.

  • Make sure the units of the data are correct.

How to add new material data

Let’s introduce a new material into the database. Click on the first option labelled "New Material.

Input material data window:

The fields marked "*" have to be completed (Figure 8). These fields are "Metal Name" and "Acronym Name". Other fields such as "Constants", "Depth", "Season" and "Formation" are already filled up with default values.

Click on the button labelled "list" to display a menu (Figure 4) with the materials, seasons, depths and formations inside the database.

The label "Metal Name", cannot contain more than 31 characters or any special characters, e.g ". \, /, ?, *, #".

The label "Acronym Name" cannot contain the character: "#".

In the field "Data Source", it is possible to specify the source of the data. E.g. ‘Atlas of Polarisation Diagrams for Naval Materials in Seawater (Page 19)

In the middle section of the panel, the material constants, for the anode and for the cathode, can be specified (Figure 8).

Finally, at the bottom of this window (Figure 8), it is necessary to set the depth, season and formation for these new data. There, the fields "Depth and Season introduced so far" in red, "Formation Introduced" in blue and "Total Formation" in red show the depth and season and formation inside the database for this material.

Figure 8: Input material menu

Once this window has been completed Press ‘OK’. A message will be displayed indicating that the Current Density values have to be in increasing order. The Figure 9 will be shown on the screen.

Potential and current density data can now be introduced into this work sheet. Click on the button "End Input data" to finish inputting data and automatically it will return to the Main Menu.

Figure 9: Add data material sheet

Logarithmic Scale:

Typically, polarisation data is displayed on a logarithmic scale. To simplify the introduction of the data click on the button labelled "x logarithmic scale" and it displays the following window, shown in Figure 10

In this window, the data can be automatically translated from one scale to another, once the required data is configured. The ‘Initial Reference Point’, the ‘Final Reference Point’ and the ‘Distance between these two reference points’ must be entered (Figure 10).

Figure 10: Logarithm scale panel

Press ‘OK’ and a new work sheet is shown where you can introduce the data inside in your reference scale. Figure 11 shows this work sheet already filled. Click on the "Update Data" button to automatically translate from the metric scale to the current density values (Figure 12).

Figure 11: Current Density set with a metric scale

Figure 12: Data already scaled

Make sure the signs of the data are correct. Click on "Material Sheet" to go to the main sheet for this material.(Figure 13).

Click on the button labelled with "End Input data" (Figure 13) and data will be saved. Data will be checked to ensure that it does not contain format errors.

Figure 13: Data sheet for the material Nickel-Aluminum Bronze

How to add a New Season or New Depth for a material already introduced in the database

In the menu called "Options, Input Material Data", let’s choose the option "New Season or New Depth", this option enables to introduce season and depth data for one material already in the database. The menu of Figure 14 appears

Figure 14: Material menu

Now, the Figure 14 is displayed and a material must be chosen. Let’s choose for example the material "Nickel Aluminium Bronze (Q.F.) Ni-Al (Quiescent Flow)". The menu "Input Material Data", showed in the Figure 15 is displayed now. The depth and season groups already in the database are displayed in this menu to inform and to avoid introducing the same value of depth and season.

Figure 15: Menu input material data for new season and depth

Click ‘OK’ to add data of this new depth and season. Figure 16 shows what this sheet looks like.

The Current density data have to be completed until the total number of Potential data is reached. They have to be in increasing order.

Figure 16: Excel spreadsheet, introduce new season and depth

How to add a new Formation for a Depth and Formation already in the database

In the menu called "Options, Input Material Data" (Figure 3) choose the option "New Formation for a material already in the database", this option will allow adding a new formation data for a season or depth already in the database. The menu showed in Figure 14 is displayed. Choose a material to work with, for instance, "Nickel Aluminium Bronze (Q.F.) Ni-Al (Quiescent Flow)". The depth and season where the new formation is going to be fitted must be set. The conditions depth: 100 and season: 1 have been selected.

Figure 17: Depth and Season selection menu

The menu "Input Material Data", with the depth and season in Figure 18 is displayed.

Figure 18: Menu input material data for new formation of a season and depth already inside the database

The number of formations available for this material are displayed at the field ‘Total formation for this material’ (colour red). The field ‘Formations for this group of Depth and Season’ (colour blue) shows the formations available, introduced up to then, for the depth and season selected

Click ‘OK’ and the new data for this new formation can be added in the following sheet. This work sheet (Figure 19) shows two columns where the potential data is displayed, nevertheless the one on the right hand side is only an assistant to make adding data easier. Introduce the data and click on ‘End Input data’ to go to the main menu.

Figure 19: Excel sheet to introduce the current density values for the new value of the formation parameter

Plot curves

The experimental curve for a material can be plot in this section.

At the main menu, click on "Plot Curves" to display the menu "List of Materials" (Figure 20). Choose a material at the first list labelled "Material". The season and depth groups for this material are displayed in the list labelled "Depth and Season". Choose one depth and season, the formations for this ‘depth and season’ will be displayed in the list at the bottom. Press ‘OK’ to continue.

Figure 20: List of materials menu

Figure 21: Work sheet to display the experimental curve

A new work sheet is displayed (Figure 21); the experimental data is shown on the screen. On the left top corner of this sheet, the material description is indicated, in this case; material name, the acronym name, formation, depth and season. The experimental data is beneath in two columns. On the right several options buttons are displayed, such as "Experimental Curve" in blue colour and "RESET" and "Main Sheet" in red colour.

Each one of these buttons has a special task, which is explained bellow:

  • Experimental Data: Click on this button to plot the Experimental Curve from experimental data.

  • Reset: Click on this button to reset the sheet

  • Main Sheet: Click on this button to reset the sheet and go back to the "Main" sheet

Experimental Curve

Click on the button labelled "Experimental Curve" in order to plot the experimental curve (Figure 21), which represents the Potential versus Current Density. The Current Density is [image] plotted in the x axis and the Potential is plotted in the y axis. If it is desired to enlarge the curve, the magnifying glass shown on the right top corner of this chart can be used for this purpose.

Export, Import Files

This section allows exporting and importing the polarisation data. When the button labelled "Export, Import Files" is pressed the menu shown in Figure 22 is displayed

Figure 22: Export, import files menu

Three options are available, "Create Mat file", "Export Database to data file (.pdb)" and "Import data file (.pdb) to Database".

  • Create Mat file.- Create a ‘.mat_cp’ file to use with BEASY CP software

  • Export Database to data file (.pdb).- Create a ‘.pdb’ file, which permits to exports all the data inside the database to a text file

  • Import data file (.pdb) to Database.- Import a ‘.pdb’, file

Create Mat File

Select the first option "Create Mat file". The ‘folders menu’ is displayed permitting the selection of the name of the mat file.

The menu ‘Options Mat. File Data’ is displayed (Figure 23)

  1. Choose the material or materials to use in the model

  2. Introduce the environment conductivity to be written in the mat file

  3. The system of units of the data which are about to be saved will be saved in the mat file

Make sure the data are in the correct units otherwise the results of your model could be wrong

Figure 23: Mat file material selection menu

Click ‘OK’ and the menu in Figure 24 is shown.

  1. It must be specified if it is a cathodic or anodic material. Select the option ‘Cathodic material’ if it is not known whether the material is to behave as cathodic or anodic.

  2. A Total Mat File can be saved with all the conditions of season, depth and formation (typical option in a time dependent analysis). In addition, a specific Mat File with one value of season, depth and formation can be saved

  3. For ‘Specific options of Mat. File’; choose the Season, Depths and Formation, which are required to be in the mat file in the list boxes placed at the bottom of this menu

Figure 24: Mat file season, depth and formation options

Save mat file

Click ‘OK’, the menu "Mat. File Data" (Figure 25) allows setting several characteristics, such as ‘Title of the Material data’ and ‘Description of the cathodic material button’. Make sure the field Identification label in the file is filled; this is the name that BEASY Software identifies as the material label. This file can be saved totally, the anode data only, or the cathode data only as it is shown at the "Mat. File Data" menu. These options will always be enabled when the mat file to save has only one condition of depth, season and formation

  • The reference electrode used to measure those data could be inputted as additional information (Not defined as default).

  • A description of the cathodic material could be inputted as additional information

  • A description of the Mat file could be inputted as additional information (Not defined as default)

  • A proportional value of the current density can be also applied. The proportional value will be multiplied by each one of the values of the current density of the material to save in the mat file

Figure 25: Mat file options menu

Figure 26 shows the reference electrode and Mat. file description already filled up

Figure 26: Mat file options menu filled up

Press ‘Write & go to next material’ to finish writing the material file. A model of mat file is shown below

Material File: Pot(mV), Cur. density(mA/m^2)

-1

-2 1

-3 1.0000E+00

-4

-5 1

-6 1 1 4.0000E+00

-7 1.0000E+02

-8

Cathodic material, Nickel Aluminum Bronze

-9NAB 1 16 1 1 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-10 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-11 1 1 1 1 -7.210E+04 2 1 1 1 -4.002E+04 3 1 1 1 -1.602E+04

-11 4 1 1 1 -6.203E+03 5 1 1 1 -2.738E+03 6 1 1 1 -1.570E+03

-11 7 1 1 1 -6.494E+02 8 1 1 1 -1.814E+02 9 1 1 1 1.2010E+01

-11 10 1 1 1 2.8110E+01 11 1 1 1 1.8135E+02 12 1 1 1 5.2673E+02

-11 13 1 1 1 1.2168E+03 14 1 1 1 1.9235E+03 15 1 1 1 2.2505E+03

-11 16 1 1 1 2.4825E+03

-12-2.7068E+01-7.2180E+01-1.1729E+02-1.6241E+02-1.9850E+02-2.5263E+02-2.9774E+02

-12-3.4105E+02-3.6992E+02-3.7444E+02-4.0602E+02-4.3308E+02-5.1880E+02-6.0902E+02

-12-6.9925E+02-9.2030E+02

Figure 27: Mat file example

If you want to include in the same file different breakdown factors for one material you can proceed by pressing the ‘Write’ button instead

In this case, you can select the same material and then introduce a different proportional value. This is illustrated in Figure 28 and Figure 29

The mat file produced is shown in Figure 30.

Figure 28: Press ‘Write’ and continue introducing a different breakdown factor of the same material

Figure 29: Introduce a different breakdown factor for the same material

Figure 30: Mat file example with two different breakdown factors for the same material.

Export the Data

It is possible to save the data stored in the database to a external text file. It is suitable in order to keep safe our data in an external file or in order to take this data to other database.

Click on the second option "Export Database to data file (.pdb)" (Figure 22) and the ‘folders menu’ will be displayed. Select the name of the file to save the data, extension .pdb. The data will be saved.

Import Data to the database

Data can be imported to the database by pressing the third option "Import data file (.pdb) to database" (Figure 22) and the ‘folders menu’ will be displayed to select the name of the file to read, extension .pdb. The data will be read and kept inside the database. Keep in mind that all data previously stored will be deleted

Add or Remove Data

Click on the button labelled "Add or Remove Values" in the main sheet of the database. Choose the material required to add or remove values (Figure 31)

Figure 31: Material selection menu

Remove Data

Tick ‘Remove data’ to eliminate values of the material selected. Rows of the Excel spreadsheet are to be deleted. These rows must be written separated by comma. If the numbers of the rows are unknown, click on the "Take a look" button to display the sheet where the data is.

Figure 32: Add or remove data menu

Once, the numbers of the rows have been written, click ‘OK’ and the marked rows will be removed from the database

Observations:

  • Actually, if more than one group of depth and season or formation are available for the material selected, all the rows that have the same potential data as the row selected will be removed too. For instance:

  • The identification number of the rows to input must be between 9-69 and it is only a reference to remove all the rows with the same potential in every group of data.

  • It will not be possible to remove the last two data stored in a table. If it is required to do so, remove the formation or season and depth group or even the material.

Add new data

Click on ‘Add new data’ (Figure 32) to add data to the database. The numbers of the rows have to be written separated by comma

  • When a row is added, it is added in all the groups you have in the database.

  • The numbers of the rows have to be introduced between 9-69 ( this is only a reference to add all the rows with the same potential in every group of data). If the number of the rows introduced is bigger than the number of rows existing in the database, it is created an input field at the end of the list.

  • The maximum number of data for each group has been fitted up to sixty-one, thus it is not possible to add more data (rows) than this number

Let’s introduce a new data for the "Nickel-Aluminum Bronze (Q.F.)" in the rows 13 and 17. Remember how it was done when the data were initially inserted

  • The Current Density values have to be in increasing order.

  • The sign of the data has to be set correctly.

  • The data can only be inserted in the yellow rows (Figure 33).

Figure 33: Add data inside the database

Modify Data

Click on "Modify Data", at the main sheet of the database. The ‘Material definition’ or the ‘experimental data’ can be modified in here (Figure 34)

  • Modify material definition.- Modify the material characteristics

    • Main material data: name, acronym name, data source and constants

    • Season, Depth and Formation: values of the seasons, depths and formations

  • Experimental data.- Modify the experimental data, current density and potential values

Figure 34: Modify data menu

Modify material definition

Click on "Modify material properties", red label at the top of the panel, in the menu shown in Figure 34. The menu "Material Selection" is shown. Choose the material required to modify the properties. Two options are shown:

  1. "Main material data" allows varying the name, acronym name, data source, and constants for the anode and the cathode of the selected material

  2. The second one "Season, Depth and Formation" allows varying the values of the seasons, depths and formations

Both options can be selected

Modify main material data

Tick the option "Main material data" in order to modify name, acronym name, data source and constants for the anode and for the cathode of the chosen material (Figure 35).

Figure 35: Modify options, material definition menu

The material definition is showed either on the left and the right side (Figure 36). The data on the right can be modified. The entire characteristic of the material can be modified here: metal name, acronym name, data source, the eleven constants for the cathode and the four constants for the anode. Change them if it is required and click ‘OK’ to return to the main menu

Figure 36: Modify material definition menu

Modify season, depth and formation

Check the option "Season, Depth and Formation" (Figure 35) in order to modify the values of the depths, seasons and formations.

Click ‘OK’, the menu "Modify season, depth and formation" is shown. The values of Depth and Season are on the left and the values of the formations are on the right (Figure 37). In this panel the previous and the new values are shown at the bottom and it is only necessary to change the value into the new one. Click on any of the ‘Depth and Season’ groups showed and the formations available in the database for the ‘Depth and Season’ group selected will appear on the right

Figure 37: Modify season, depth and formation menu

Modify polarisation curve values

Click on "Modify polarisation curve values", red label at the middle of the panel (Figure 34). In the following menu, choose the material and the conditions of depth, season and formation to modify the experimental data.

Two options are shown; the first one "Change Potential Data" enables to modify the Potential data (Figure 38). The second one "Change Current Density Data" enables to modify the Current Density data

Figure 38: Modify polarisation curve values menu

Figure 39: Work sheet to modify the potential values

Change Potential Data

Tick the option "Change Potential Data" to modify the Potential data. Change the data in the sheet and click on ‘End input data’ (Figure 39).

Some details have to be considered:

  • It is only necessary to modify the first group of the potential data, from row 9 to 69, column A. The other groups will be automatically modified.

  • It is not possible to add or remove data at this stage.

  • Follow the sign convention of the data already in the database.

  • Check the units of the data.

The Figure 40 shows the work sheet where the values can be modified. Press ‘End Input data’ to finish modifying data

Figure 40: Work sheet to modify the current density values

Delete Season, Depth, Formation or Material

On the main sheet, click on the "Delete Season, Depth, Formation or Material" button to delete all the data of any group inside the database. One or several formations can be deleted, one group of depth and season, or a complete material.

The menu "Material Selection" is shown to choose a material.

A menu with the depth, season and formation for the chosen material is shown (Figure 41). If it any depth and season is clicked on the left window, the formations for this depth and season will be displayed on the right window.

Figure 41: Delete menu

Delete Formation

If a formation is selected, click on delete formation to delete it.

Possible cases:

  • If this formation is the last one of a group of depth and season, the depth and season group will also be deleted

  • This depth and season could be the only one for this material, thus, if it is deleted, the material will also be deleted

Delete Depth and Season

Click on the button labelled "Delete Depth and Season", the chosen depth and season will be deleted. This depth and season group can be the only one for this material, if this is the case, the material will also be deleted.

Delete Material

Click on the button labelled "Delete Material", the selected material is deleted.

Data structure within the database

The structure of the data can be divided as follows:

  • Characteristics of the Material

  • Material Data

The three first rows of this sheet are used to store the characteristic of the material. The position of the data is given by the number of the row and the letter of the column

  • Position (1,B) (row=1, column=B): Name of the material

  • Position (1,E): Source of the data.

  • Positions (3,B), (3,D), (3,F), (3,H), (3,J), (3,L), (3,N), (3,P), (3,R), (3,T), (3,V): Constants for the cathode

  • Positions (4,B), (4,D), (4,F), (4,H): Constants for the anode

Material Data

From row five the data in the database is stored in the following way:

  • Row 5: Depth and Season data

  • Row 6: Blank

  • Row 7: Formation data, which is situated over the corresponding current density. These formations fit in the depth and season indicated in the row 5

From here, everything turns in a sequence, each 70th row. For instance:

  • Row 71: Depth and the Season data

  • Row 72: Blank

  • Row 73: Formation data, which is situated over the corresponding current density. These formations fit in the depth and season indicated in the row 71.

Figure 42: Characteristic of the material

Figure 43: Potential and current density values for depth 100, season 1 and formation

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_intro\poldat_intro.htm

CP Polarisation Data

Polarisation data and CP modelling

Polarisation Database and mat file management

How to add an new material to the database

MatFile Viewer

Atlas of polarisation curves

The mat file

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Material File

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_matfile\poldat_matfile.htm

Material Data file

This document describes the uses and format of the file containing polarisation data (material file) *.mat_cp

CONTENTS

Introduction

The Material Data File

Title Records

Season definition

Conductivity definition

Cathode polarisation data

Anode polarisation data

Introduction

The non-linear relationship between the potential and normal flux density, can be defined by the user and set in the Material File. These relationships represent the polarisation behaviour of the materials in the medium.

Different curves can be defined for the relevant materials in the problem via the material data file which is read by the CP Solver.

Additionally, for each material, a series of curves can be defined to describe the polarisation properties representing seasonal variations and depth variation for example.

The Material Data File

The material file format consists of a formatted file. The Mat File Viewer can be used to plot polarisation curves for materials included in a material data file.

The file contains lines which begin with a negative number, followed by specific information which must conform to a defined layout. The negative numbers are codes which describe the type of data on the line.

The layout of the lines is very precise. If a character is in the incorrect location by one column this could have the effect that the material properties and hence the results of the analysis could be incorrect.

An example "*.mat_cp" file is provided with every BEASY-CP installation or can be obtained from BEASY Support Service.

The following tables detail the layout of each line in the "*.mat_cp" file and gives a description of the format of the information that is required.

Title Records

The first two lines of the material data file are set aside so that a title can be defined.

These two lines must be included so that even if you do not particularly want to define a title, the first two lines in the file should be blank.

•Title Record 1

Field | Columns | Variable | Format | Description
1 | 1-80 |  | 80A1 | Title of material data file

•Title Record 2

Field | Columns | Variable | Format | Description
1 | 1-80 |  | 80A1 | Title of material data file

The format description ‘80A1’ means that a series of up to 80 characters can be defined on each line.

Season definition

The MAT file can reflect the fact that the conductivity of the medium (e.g. seawater) may change from season to season such as from summer to winter. In these lines you are defining the number and length of the seasons.

The tables refer to the following variables which defined below:

NT = The number of seasons up to a maximum of 20

SEA(I) = Value of the season length (I=1 to NT)

  • Season Definition 1

Field | Columns | Variable | Format | Description
1 | 1-3 | -1 | I3 | Start of season definition

  • Season Definition 2

Field | Columns | Variable | Format | Description
1 | 1-3 | -2 | I3 | Season definition data 2
2 | 4-7 | NT | I3 | Number of seasons

  • Season Definition 3

Field | Columns | Variable | Format | Description
1 | 1-3 | -3 | I3 | Season definition data 3
2-8 | 4-80 | SEA(I) | 7E11.4 | Value of season at index i=1, NT

The season definition data 3 would need to be repeated if the number of seasons NT is larger than 7.

The format description ‘I3’ means that the integer number (i.e. without decimal point) should be located at the right most column of its field which contains 3 columns. The format ‘7E11.4’ indicates that seven fields with eleven columns each contain a real number. As far as the number contains a decimal point, its value can be provided either in an exponential format (e.g. 3.6E+02) or in a real format (e.g. 360.) located anywhere inside the field of 11 columns.

For the majority of problems there will only be one season whose length may be 360 days for example. The 3rd to 5th lines of the file would then appear like this:

-1

-2 1

-3 3.6000E+02

Conductivity definition

The conductivity of the medium (e.g. seawater) is allowed to vary with depth and season. The reference depth on the model is the y=0 axis in 2d, z=0 in axisymmetric and 3d problems. The tables below define the following variables which may be referenced later on:

  • NR = The number of depth up to a maximum of 3

  • DEPCON(J) = the depth at index J (J=1,NR)

  • CONSEA(I,J) = the conductivity of the medium at each season (SEA(I)) and depth (DEPCON(J)) combination (I=1,NT; J=1,NR)

We have seen from the season definition lines that you can have up to 20 seasons, with 3 different depths, each with a different conductivity. So, to define all this information, the conductivity definition data number 3 would need to be repeated several times.

  • Conductivity Data 1

Field | Columns | Variable | Format | Description
1 | 1-3 | -4 | I3 | Start of Conductivity data

  • Conductivity Data 2

Field | Columns | Variable | Format | Description
1 | 1-3 | -5 | I3 | Conductivity data 2
2 | 4-7 | NR | I3 | Number of depth

  • Conductivity Data 3

Field | Columns | Variable | Format | Description
1 | 1-3 | -6 | I3 | Conductivity data 3
2 | 4-6 | I1 | I3 | Index of season in SEA(I) table
3 | 7-9 | J1 | I3 | Index of season in DEPCON(J) table
4 | 10-20 | CONSEA(I1,J1) | E11.4 | Conductivity at SEA(I), DEPCON(J)
5 | 21-23 | I2 | I3 |
6 | 24-26 | J2 | I3 |
7 | 27-37 | CONSEA(I2,J2) | E11.4 |
8 | 38-40 | I3 | I3 |
9 | 41-43 | J3 | I3 |
10 | 44-54 | CONSEA(I3,J3) | E11.4 |

The total number of conductivity data 3 is (NT*NR-1)/3 +1

  • Conductivity Data 4

Field | Columns | Variable | Format | Description
1 | 1-3 | -7 | I3 | Conductivity data 4
2-4 | 4-36 | DEPCON(J) | 3 E11.4 | Depth at index J=1,NR

For the majority of applications, the conductivity of the medium will be independent of the depth and season. i.e. there will only be one value and so lines beginning -4, -5, - 6 and -7 will appear like this:

-4

-5 1

-6 1 1 0.4348E+01

-7 0.0000E+00

where there is only one season and the conductivity is 4.348 at a depth of zero for example

Cathode polarisation data

The following tables define a series of curves which represent the non-linear relationship between the potential and current density on a cathodic material. It is possible to define a different set of curves to simulate different polarisation behaviour for different depths, season and value of a the variable known as the formation parameter. The formation parameter reflects the change in effectiveness of the cathode as deposits build up on its surface over a period of time. The following variables are referenced in the tables below:

MATAM = The name of the material defined in the BEASY data (DAT) file eg. STEL

MTYPE = The reference number for the material

ME = The total number of potential values up to a maximum of 8

MH = The total number of formation parameter values up to a maximum of 8

MD = The total number of depths up to a maximum of 3

CURR(I,J,K,L) = The current density level at each combination of potential (I=1,ME), formation parameter (J=1,MH), depth (K=1,MD) and time (L=1,NT) are specified.

ECUR(I) = The value of potential (I=1,ME)

FORM(J) = The value of formation parameter (J=1,MH)

DEPE(K) =The value of depth (K=1,MD)

In effect the following lines in the file define a matrix of all the combinations of potential and current density for different depth and formation parameter combinations.

  • Cathodic Material Data 1

Field | Columns | Variable | Format | Description
1 | 1-3 | -1 | I3 | Start of cathodic material data

  • Cathodic Material Data 2

Field | Columns | Variable | Format | Description
1 | 1-3 | -1 | 80A1 | Description of cathodic material data

  • Cathodic Material Data 3

Field | Columns | Variable | Format | Description
1 | 1-3 | -9 | I3 | Cathodic material data 3
2 | 4-7 | MATAM | A4 | Material name in DAT file
3 | 8-10 | MTYPE | I3 | Material identity number
4 | 11-13 | ME | I3 | Number of potential values
5 | 14-16 | MH | I3 | Number of formation parameter values
6 | 17-19 | MD | I3 | Number of depths
7 | 20-30 | C1 | E11.4 | Material Constants
8 | 31-41 | C2 | E11.4 | Material Constants
9 | 42-52 | C3 | E11.4 | Material Constants
10 | 53-63 | C4 | E11.4 | Material Constants
11 | 64-74 | C5 | E11.4 | Material Constants

In a time dependant analysis, the user can produce a program to model the effect of any other parameters on the polarisation behaviour of the materials. The material constants defined in cathode material data lines 3 and 4 may be used to input data to another program. For more details on how the formation parameter and the material constants can be used to simulate the formation of calcareous scale see section 5.6. For the vast majority of users this capability is not required and so fields 7 through 11 can be set to zero.

  • Cathodic Material Data 4

Field | Columns | Variable | Format | Description
1 | 1-3 | -10 | I3 | Cathodic material data 4
2 | 4-14 | C6 | E11.4 | Material Constant
3 | 15-25 | C7 | E11.4 | Material Constant
4 | 26-36 | C8 | E11.4 | Material Constant
5 | 37-47 | C9 | E11.4 | Material Constant
6 | 48-58 | C10 | E11.4 | Material Constant
7 | 59-69 | C11 | E11.4 | Material Constant

As described for data line 4, the material constants above may be used as input to a users own program. For the vast majority of users this capability is not required and so fields 2 through 7 can be set to zero.

  • Cathodic Material Data 5

Field | Columns | Variable | Format | Description
1 | 1-3 | -11 | I3 | Cathodic material data 5
2 | 4-6 | I | I3 | Position in the voltage tabel
3 | 7-9 | J | I3 | Position in the formation tabel
4 | 10-12 | K | I3 | Position in the depth table
5 | 13-15 | L | I3 | Position in the season tabel
6 | 16-26 | CURR(I,J,K,L) | I3 | Current density value
7-11 | 27-49 |  | I3 | Same as fields 2-6
12-16 | 50-72 |  | I3 | Same as fields 2-6

Three sets of data are given on each line, so fields 2-6 are repeated three times.

The total number of cathodic material data 5 is (ME*MH*MD*NT-1)/3 +1

  • Cathodic Material Data 6

Field | Columns | Variable | Format | Description
1 | 1-3 | -12 | I3 | Cathodic material data 6
2 | 4-80 | ECUR(I) | 7E11.4 | Value of potential at index I=1,ME

  • Cathodic Material Data 7

Field | Columns | Variable | Format | Description
1 | 1-3 | -13 | I3 | Cathodic material data 7
2 | 4-80 | FORM(J) | 7E11.4 | Value of formation at index J=1,MH

The total number of cathodic material data 7 is (MH-1)/7 +1

  • Cathodic Material Data 8

Field | Columns | Variable | Format | Description
1 | 1-3 | -14 | I3 | Cathodic material data 8
2 | 4-80 | DEPE(K) | 7E11.4 | Value of formation at index K=1,MD

There is an example at the end of this section of how some polarisation data for mild steel, acting as a cathode, would be presented in an MAT file.

There are six potential levels where the current density has been obtained for four values of formation parameter. The current density is independent of depth which is set to zero. The matrix of potential and current densities to be input to the MAT file is as below:

Potential mV | Current Density mA
 | Form1 | Form2 | Form3 | Form4
 | 8.958 | 215 | 430 | 6450
-830 | 323 | 92 | 21.5 | 0
-920 | 453 | 130 | 70 | 29.61
-980 | 715 | 452 | 420 | 49.35
-1010 | 947 | 796 | 796 | 59.22
-1048 | 1550 | 1550 | 1550 | 71.72
-1050 | 2010 | 2010 | 2010 | 2010

The lines in the "*.mat_cp" file that represent the first column of data will appear like this:

-8

MATERIAL TYPE : 1 STEEL

-9STEL 1 6 1 1 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-10 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-11 1 1 1 1 0.3230E+03 2 1 1 1 0.4530E+03 3 1 1 1 0.7150E+03

-11 4 1 1 1 0.9470E+03 5 1 1 1 0.1550E+04 6 1 1 1 0.2010E+04

-12-0.8300E+03-0.9200E+03-0.9800E+03-0.1010E+04-0.1048E+04-1.0500E+03

-13 8.9580E+03

-14 0.0000E+00

Anode polarisation data

The next group of lines define the polarisation behaviour of the anode in a similar way to that of the cathode. In the following tables the following variables are defined:

MATNAM = Name used to identify material in DAT file e.g. ZINC.

MTYPE = Identity number of the material.

ME = Number of potential values defined up to a maximum of 8.

MH = Number of formation parameter values up to a maximum of 8.

MD = Number of depths up to a maximum of 3.

UTIL = Utilisation factor

CURR(I,J,K,L) = The current density level. This must always be negative for anode materials.

ECUR(I) = The value of potential (I=1,ME)

FORM(J) = The value of formation parameter (J=1,MH)

DEPE(K) =The value of depth (K=1,MD).

The utilisation factor takes into account the efficiency of the anode and is expressed as a value between 0 and 1. The factor reflects the fact that only a percentage of the available surface area can be utilised to protect the structure.

  • Anode Material Data 1

Field | Columns | Variable | Format | Description
1 | 1-3 | -15 | I3 | Start of material data

  • Anode Material Data 2

Field | Columns | Variable | Format | Description
1 | 1-80 |  | 80A1 | Description of material data

  • Anode Material Data 3

Field | Columns | Variable | Format | Description
1 | 1-3 | -16 | I3 | Anode material data 3
2 | 4-7 | MATNAM | A4 | Anode material name from DAT file
3 | 8-10 | MTYPE | I3 | Identity number of the material
4 | 11-13 | ME | I3 | Number of potential values
5 | 14-16 | ME | I3 | Number of formation parameters
6 | 17-19 | ME | I3 | Number of depths
7 | 20-30 | ME | I3 | Utilisation factor for the anode material
8 | 31-41 | ME | I3 | Material constant
9 | 42-52 |  |  | Material constant
10 | 53-63 | ME | I3 | Material constant
11 | 64-74 | ME | I3 | Material constant

The material constants defined in cathode material data 3 may be used to input data to another program. For the vast majority of users this capability is not required and so fields 8 through 11 can be set to zero. For more information on using the material constants in a user defined program see section 5.6.

  • Anode Material Data 4

Field | Columns | Variable | Format | Description
1 | 1-3 | -17 | I3 | Anode material data 4
2 | 4-6 | I | A4 | Position in the voltage table
3 | 7-9 | J | I3 | Position in the formation table
4 | 10-12 | K | I3 | Position in the depth table
5 | 13-15 | L | I3 | Position in the time table
6 | 16-26 | CURR(I,J,K,L) | E11.4 | Current density value
7 -11 | 27-49 |  |  | Same field as 2-6
12-16 | 50-72 |  |  | Same field as 2-6

Three sets of data are given on each line, so items 2-6 are repeated three times.

The total number of anode material data 4 is (ME*MH*MD*NT-1)/3 +1

  • Anode Material Data 5

Field | Columns | Variable | Format | Description
1 | 1-3 | -17 | I3 | Anode material data 5
2-8 | 4-80 | ECUR(I) | 7E11.4 | Value of voltage at index I=1,ME

  • Anode Material Data 6

Field | Columns | Variable | Format | Description
1 | 1-3 | -17 | I3 | Anode material data 6
2-8 | 4-80 | FORM(J) | 7E11.4 | Value of formation at index J=1,MH

The total number of anode material data 6 is (MH-1)/7 +1

  • Anode Material Data 7

Field | Columns | Variable | Format | Description
1 | 1-3 | -17 | I3 | Anode material data 7
2-8 | 4-80 | DEPE(K) | 7E11.4 | Value of depth at index K=1,MD

Field | Columns | Variable | Format | Description
1 | 1-3 | -99 | I3 | End of file marker

The following is an example of how the polarisation data for a Zinc anode would appear in the MAT file. There are two potential levels where the current density has been obtained. The current density is independent of formation parameter and depth which are set to zero. The matrix of potential and current densities to be input to the MAT file is as below:

Potential mV | Current Densitiy mA
-1200 | 0
-1150 | 5000

The lines in the "*.mat_cp" file that represent the information above will appear like this:

-15

MATERIAL TYPE : 2 ZINC

-16ZINC 2 2 1 1 1.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-17 1 1 1 1 0.0000E+00 2 1 1 1-0.5000E+04

-18-0.1200E+04-0.1150E+04

-19 0.0000E+00

-20 0.0000E+00

-99

An example of a complete material data file is shown below:

MATERIAL FILE : Sample BEASY material file for mild steel and zinc.

-1

-2 1

-3 3.6000E+02

-4

-5 1

-6 1 1 0.4348E+01

-7 0.0000E+00

-8

MATERIAL TYPE : 1 STEEL

-9STEL 1 6 4 1 0.6450E+04 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-10 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00 0.0000E+0

-11 1 1 1 1 0.3230E+03 2 1 1 1 0.4530E+03 3 1 1 1 0.7150E+03

-11 4 1 1 1 0.9470E+03 5 1 1 1 0.1550E+04 6 1 1 1 0.2010E+04

-11 1 2 1 1 0.9200E+03 2 2 1 1 0.1300E+03 3 2 1 1 0.4520E+03

-11 4 2 1 1 0.7960E+03 5 2 1 1 0.1550E+04 6 2 1 1 0.2010E+04

-11 1 3 1 1 0.2150E+03 2 3 1 1 0.7000E+03 3 3 1 1 0.4200E+03

-11 4 3 1 1 0.7960E+03 5 3 1 1 0.1550E+04 6 3 1 1 0.2010E+04

-11 1 4 1 1 0.0000E+03 2 4 1 1 0.2961E+03 3 4 1 1 0.4935E+03

-11 4 4 1 1 0.5922E+03 5 4 1 1 0.7172E+04 6 4 1 1 0.2010E+04

-12-0.8300E+03-0.9200E+03-0.9800E+03-0.1010E+04-0.1048E+04-1.0500E+03

-13 0.8958E+03 0.2150E+03 0.4300E+03 0.6450E+04

-14 0.0000E+00

-15

MATERIAL TYPE : 2 ZINC

-16ZINC 2 2 1 1 1.0000E+00 0.0000E+00 0.0000E+00 0.0000E+00

-17 1 1 1 1 0.0000E+00 2 1 1 1-0.5000E+04

-18-0.1200E+04-0.1150E+04

-19 0.0000E+00

-20 0.0000E+00 -99

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Polarisation Data and CP

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_poldatcp\poldat_poldatcp.htm

Polarisation data and CP modelling

This document describes how the BEASY CP solver interprets and uses polarisation data.

CONTENTS

Polarisation curve

Factors modifying polarisation curves

Sign convention for the current density

Rules when defining polarisation data

Optimising the run

Results off the end of the polarisation curve

Polarisation data and convergence

1.1 Solution Tolerance

1.2 Number of iterations

1.3 Convergence Problems

Polarisation curves and Coatings

References

Polarisation curve

The relationship between potential and current density represent the polarisation behaviour of the material in the medium.

The relationship between the potential (ΔV) and the current density ( j ) is described by the polarisation curve. If this relation is linear j can be expressed as,

j = c ( V - V0 )

where c is the transfer coefficient and V0 is the potential on the metal.

The solver allows the user to define a non-linear relationship between potential and the current density, as shown in Figure 1 for example.

Figure 1: Polarisation curve for a material with label "WC00"

Factors modifying polarisation curves

Factors that modify the polarisation curves for one material are:

  • Coating

  • Scale

  • Age

  • The medium

  • Temperature

Sign convention for the current density

The CP solver adopts the following sign convention for current density:

  • For the anodic region, the current density is negative, i.e. j ≤ 0

Consequently, for the cathodic region the current density should be positive, as shown in Figure 2.

Figure 2: Sign convention for the current density

Rules when defining polarisation data

When adding a new material (i.e. a new polarisation curve) , the following rules have to be observed:

  1. Avoid sharp changes in the slope of the curve as this will introduce convergence problems.

    In order to avoid sudden change of slope between adjacent segments, you can add more points, as shown in Figure 3.

    Figure 3: Avoid sudden changes of slope by adding points

  2. The polarisation curve should not be "horizontal" or "vertical", because that would compromise the iterative scheme. In other words, avoid very steep of nearly zero gradients in the polarisation curve. (see Figure 4 and Figure 5)

    Figure 4: Avoid vertical slopes

    Figure 5: Avoid horizontal slopes

  3. If you don’t know whether the material will behave anodically or cathodically, when adding the material to the database use the "cathodic format", but include the entire polarisation curve as shown in Figure 6.

Figure 6: Polarisation curve covering anodic and cathodic regions

Optimising the run

To optimise the BEASY CP run and minimise the calculation time, you can redefine the range of the polarisation data. For example, if you don’t expect a material to become anodic, only include the cathodic part, and vice versa. Figure 7 shows an example.

If for practical purposes it is known that the potential will be in the range of say –700mv to –1100mv restrict the polarisation data to that range.

This avoids unnecessary iterations and improves convergence.

Note that CP solver will not force the solution to fit within that range. You can check if the range is exceeded in the results and modify the polarisation data accordingly.

Figure 7: To optimise the run you can redefine the range of the polarisation data for a material

Results off the end of the polarisation curve

If the solution turns out to be off the end of the polarisation curve:

  • BEASY CP solver assumes that the continuation of the curve is obtained by extrapolating the line obtained by joining the end two points, as shown in Figure 8.

  • It is better, if possible, to ensure that the curve defined covers all likely states for the material, so that extrapolation is not needed, as in general the material won't

Figure 8: Linear extrapolation at the end of the polarisation curve range

If the inputs in the model are fixed and results are off the range of the polarisation curve, then it is necessary to extend the range of the polarisation curve used, as in general, away that range the real behaviour would not extrapolate linearly.

Polarisation data and convergence

The CP solver solves the non-linear polarisation problem using an iterative method.

There are various controls which can be used to modify the procedure. These are managed by the CP Builder.

Solution Tolerance

The tolerance describes the maximum error allowed in fitting the polarisation curve.

Figure 10: Solution Tolerance.

Number of iterations

The maximum number of iterations is set by default to 40. When the maximum number of iterations is reached, the solver generates a solution and finishes the run.

In general, convergence is achieved before the maximum number of iterations that is reached, so the run finishes when the convergence is achieved.

Convergence Problems

Convergence problems may be caused by poor polarisation data. To avoid these problems be sure you are following the rules described above in section 4.

Polarisation curves and Coatings

The basic idea to dealing with coatings is that paint of some thickness can be simulated by scaling the current values in the polarisation curves for a particular material. [1]

DNV state that the coating breakdown factor ("bf") describes the anticipated reduction in cathodic current density due to the application of an electrically insulating coating.

When the bf = 0, the coating is 100% electrically insulating, so decreasing the cathodic current density to zero. A coating bf = 1 means that the coating has no current-reducing properties.

The coating breakdown factor is a function of coating properties, operational parameters, and time. As a simple engineering approach, the bf can be expressed as:

bf = a + b * t

Where "t" (years) is the age of the coating, and "a" and "b" are constants that depend on coating properties and the environment.

The constants "a" and "b" should be specified based on either practical experience of the coating system in the environment or experimental assessment of the coating performance. If no other data is available, the values suggested by DNV for a category 3 coating in a marine environment away from wave action are:

a = 0.02

b = 0.008

A category 3 coating is for example two or more layers of paint coating (epoxy, polyurethane) with film thickness 350 microns or more.

For instance, using the mentioned values for constants "a" and "b", a new coating will lead to bf=0.02.

And assuming a 10 year old coating system, the breakdown factor will be: bf = 0.02 + 10 * 0.008 = 0.1

Figure 11 shows the plot for different breakdown factors applied to material STEL (shown in red)

Figure 11 Polarisation curve of material "STEL" showing different breakdown factors

References

[1] Finite Resistivity and Shipboard Corrosion Prevention System Performance, V. G. DeGiorgi, Mechanics of Materials Branch Naval Research Laboratory.Washington, USA

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Sigmoidal Curve Method

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\input_data\polarisation_data\poldat_sigmoidal_method\poldat_sigmoidal_method.htm

Sigmoidal curve method for CP simulation of Offshore structures

This document provides an overview of the bases of the method of the sigmoidal curve for CP simulation of offshore structures.

CONTENTS

1 Introduction

2 Various published sigmoidal curves

2.1 Hartt[1]

2.2 Strommen [5]

3 Application of the sigmoidal long-term curve method for no-flow waters

3.1 Bare steel surfaces

3.2 Coated steel

4 Application of the sigmoidal curve method for tidal waters

4.1 Method to determine the build-up of calcareous deposits

4.2 Method to determine anode life

4.3 Method to determine most positive potentials

5 Selecting data

6 References

  1. Introduction

    A "sigmoidal curve" shows the long-term relationship between current density and potential on wetted steel surfaces on which calcareous deposits may form. Each point on the curve shows the current density which would eventually be reached if a sample of the metal was held at a particular potential for a long period of time, during which calcareous deposits would form.

    The term "sigmoidal" is used in a paper published by Hartt [1], which showed a curve shape as Figure 1, which was for water at 23 to 25 Celsius.

    The same type of sigmoidal curve was noted by Fischer et al [2] in their study in northern waters, but their paper did not include numerical values for the curve.

    Data published by Roe Strommen [5] for North Sea waters shows the same sigmoidal shape, but shows upper and lower limits experimentally observed on offshore structures.

    It seems appropriate to use the data by Strommen for CP simulation of North Sea structures, and the data by Hartt for simulation of structures in warmer waters.

    Details of the sigmoidal curves are shown in the following section.

  2. Various published sigmoidal curves

    1. Hartt[1]

      Hartt data, shown in Figure 1 and Table 1, is for zero water flow rate in sea water at 23 to 25 Celsius.

      Figure 1: Long term relationship between current density and potential, after Hartt [1]

      Current density

      [mA/m**2]

      Voltage

      [mV]

      1.06

      -612.81

      8.39

      -621.7

      18.09

      -631.75

      23.33

      -639.46

      31.19

      -651.02

      38

      -662.67

      45.34

      -679.7

      52.15

      -702.22

      56.62

      -726.29

      57.94

      -758.78

      56.12

      -784.75

      52.99

      -809.46

      46.73

      -841.24

      40.72

      -868.91

      33.4

      -899.41

      27.14

      -928.47

      23.48

      -950.51

      21.4

      -964.28

      19.57

      -982.09

      19.06

      -995.72

      19.06

      -1012.02

      20.91

      -1030.88

      24.32

      -1052.32

      28.25

      -1065.57

      31.92

      -1074.77

      37.16

      -1087.91

      45.29

      -1103.53

      Table 1: Long term relationship between current density and potential, after Hartt [1]

    2. Strommen [5]

    Strommen published a paper [5] from which Figure 2 has been duplicated. The extremes of the band in Figure 2 have been extracted and are shown in Figure 3 and Table 2.

    At present we have limited information about the paper (which we are in process of sourcing), but our understanding is as follows…

    The data is for North Sea waters, and was obtained from experimental measurements on a large number of structures. The curve A (in Figure 3) represents low water flow rate conditions, and curve B represents high water flow rate conditions.

    Figure 2: Chart from paper by Strommen [5]

    Figure 3: Extremes of long term relationship between current density and potential, after Strommen[5]

    Curve A

    Curve B

    j(mA/m**2)

    Pot (mV Ag/AgCl/seawater)

    j(mA/m**2)

    Pot (mV Ag/AgCl/seawater)

    37.14

    -672.54

    75.71

    -661.79

    39.52

    -680.90

    77.62

    -667.76

    42.14

    -695.22

    79.05

    -673.73

    43.33

    -710.75

    80.71

    -685.67

    44.76

    -731.04

    82.86

    -702.39

    44.29

    -756.12

    83.57

    -719.10

    42.14

    -790.75

    83.81

    -732.24

    39.76

    -814.63

    83.57

    -747.76

    37.86

    -837.31

    83.10

    -764.48

    36.43

    -857.61

    81.90

    -782.39

    35.48

    -880.30

    79.52

    -800.30

    35.00

    -901.79

    77.38

    -824.18

    34.76

    -919.70

    75.95

    -839.70

    34.76

    -942.39

    74.29

    -867.16

    35.24

    -960.30

    73.33

    -893.43

    36.19

    -974.63

    73.10

    -919.70

    37.38

    -992.54

    73.10

    -938.81

    37.86

    -1000.90

    74.05

    -961.49

    39.29

    -1014.03

    75.24

    -980.60

    41.43

    -1027.16

    76.67

    -996.12

    44.29

    -1043.88

    78.33

    -1006.87

    46.43

    -1055.82

    80.71

    -1021.19

    48.81

    -1066.57

    83.33

    -1034.33

    50.95

    -1076.12

    85.95

    -1043.88

    53.57

    -1086.87

    89.05

    -1053.43

    56.19

    -1096.42

    92.14

    -1062.98

    58.81

    -1103.58

    94.76

    -1071.34

    98.81

    -1080.90

    Table 2: Extremes of long term relationship between current density and potential, after Strommen[5]

  3. Application of the sigmoidal long-term curve method for no-flow waters

    1. Bare steel surfaces

      The approach is to use a selected "long-term sigmoidal curve" in combination with a pair of matching dynamic polarisation curves to iteratively determine the position on the long-term curve of each part of the structure.

      One of the dynamic polarisation curves represents behaviour with no calcareous deposits, and the other represents behaviour with good calcareous deposits.

      The "no calcareous deposits" dynamic polarisation curve is ideally based on an experimentally measured curve, with potentials adjusted if needed to match the open circuit potential implied by the selected long-term curve.

      To obtain the "good calcareous deposits" dynamic polarisation curve, the current densities of the "no calcareous deposits" dynamic polarisation curve are scaled until the resulting curve passes through the long-term curve at the position of the minimum of current density.

      If there are no calcareous deposits initially, the simulation first uses the "no calcareous deposits" dynamic polarisation curve to determine potential and current density on all parts of the structure.

      The resulting potential at any position on the structure gives an initial indication of the potential and current density which would eventually be reached if calcareous deposits form , and this ‘indication’ is provided by looking for the point on the long-term curve which has the same potential. To reach this point on the long-term curve, the software therefore increases the "amount" of calcareous deposit recorded for the position on the structure (and does this for the entire structure), and then obtains another solution.

      The simulation process is therefore iterative, and mimics the effects of the build-up of calcareous deposits, in the sense that calcareous deposits form first close to the anodes, and the deposits gradually "spread" further from the anodes, but only if the anodes are capable of providing enough current to get past the peak of current density which occurs at about -750 mV.

      If the CP system is well designed, so that the anodes are able to provide enough current, and distance of anodes from the polarising surfaces is suitable, the structure will polarise (ie develop calcareous deposits) so that most of the structure will be at potentials around -950 to -1000mV. Since this corresponds to the minimum of current density on the long-term curve, the "maintenance current" required if the anodes are to maintain the deposits can be small.

      If the anodes are not able to supply enough current the structure (or parts of it) may remain at the maximum of current density on the long-term curve at around -750mV. In this case the anode life may be reduced.

      When the simulation starts from some previously calculated calcareous deposits, the simulation process can mimic the effects of loss of calcareous deposits which may occur as the anodes reduce in size, or as the breakdown factor increases on any coated part of the structure.

      At present the methods used to predict loss of calcareous deposits are rather conservative in the sense that they assume the solution will drift back to the sigmoidal curve whenever the potential changes. In practice it is likely that other conditions are required for loss of calcareous deposits, such as reduction of current density below some critical level, or change of potential to more positive than some critical level.

      By using the "end-of-life" state of the anodes and coating breakdown factor but assuming no initial calcareous deposits, it is possible to determine whether/not the remains of the anodes are able to repolarise a structure in the event that calcareous deposits have been lost (for example as a consequence of a storm).

    2. Coated steel

    If the coating breakdown factor is regarded as a percentage bare area of steel, then the same basic methods can be used for coated surfaces, with the difference that the current densities of the various curves are scaled to take account of the coating breakdown factor.

    This approach seems to be entirely logical for high breakdown factors where presumably significant areas of coating have been completely lost. It also seems a reasonable approach for lower breakdown factors.

  4. Application of the sigmoidal curve method for tidal waters

    In any tidal area the water flow rate varies continuously throughout each day, and there is generally great geographical and monthly variation in the way flow rate varies with time.

    Consequently it is necessary to adapt the simulation methods so as to achieve:

    • Representative predictions of accumulation of calcareous deposits

    • Representative anode consumption rates and predictions of anode life

    • Representative predictions of the most positive potentials on the structure

    This section describes how these aims are achieved.

    1. Method to determine the build-up of calcareous deposits

      Because of the time-variation of flow rate during the monthly and daily tidal cycle, there are significant periods when the water flow rate will be low, and we make the assumptions that:

      • calcareous deposits will form during these periods of slack water

      • the calcareous deposits will not be removed during the subsequent higher-flow periods

      This allows us to use the methodology described in section 3 to determine the build-up of calcareous deposits on the structure. Presumably the build-up of calcareous deposits on the structure will take longer than for a structure in non-tidal waters, but the simulation simply determines the long-term condition.

      The simulation at zero water flow rate also provides the "best case" potentials on the structure. These potentials occur only at certain times during the tidal cycle.

    2. Method to determine anode life

      It would not be appropriate to use the zero-flow-rate results to predict anode mass loss rate and anode life, because doing so would over estimate anode life.

      Neither would it be appropriate to use the maximum water flow rate, because doing so would under estimate anode life.

      The point is that to achieve some particular potential on a metal requires current density which increases as the water flow rate increases.

      With this in mind, it is clear that anode life should be estimated using polarisation curves which correspond to the average water flow rate, and the water flow rate averaging should be done over at least a full month of tidal cycle.

      In an ideal world we would have experimental dynamic polarisation curves for surfaces with every "amount" of calcareous deposits which occurs on the structure, and at all water flow rates experienced by the structure, but this data is not available.

      The approach taken for a point on the structure is therefore to take the dynamic polarisation curve which corresponds to the "amount" of calcareous deposit (at the point on the structure) at zero water flow rate, and to increase the current densities to allow for non-zero water flow rate.

      Data published by Hack and Guanti [4] provides a scale factor for any selected flow rate, and current densities for the entire dynamic polarisation curve are scaled by the factor.

      Different factors are applied to steel with no calcareous deposits and steel with "good" calcareous deposits. For example the factor at flow-rate 1.2 m/sec is 2.11 with no calcareous deposits and 1.84 with calcareous deposits. Polarisation curves at intermediate flow rates or states of calcareous deposits are interpolated linearly.

      The flow-rate can be defined as a function of depth, so if a flow-rate versus depth profile is available it can be used.

      The simulation at time-averaged water flow rate provides the "time-averaged" potentials on the structure. These potentials occur only at certain times during the tidal cycle.

    3. Method to determine most positive potentials

    It would not be appropriate to use the zero-flow-rate results or the "time averaged" results to determine the most positive potentials on the structure, because doing so would suggest that potentials are more negative than they should be.

    If we wish to know the most positive potentials on the structure, then we need to use the dynamic polarisation curves which correspond to the highest water flow rates.

    The required dynamic polarisation curves are obtained in the same way as described in section 4.2, but obviously using the "time-maximum" water flow rates.

    The simulation at time-maximum water flow rate provides the most positive potentials on the structure, and these potentials occur only at certain times during the tidal cycle.

  5. Selecting data

    Although the flow-rates corresponding to curve A in Figure 3 is not known, it seems reasonable to use curve A as the long-term "zero flow rate" curve for N. Sea simulation work.

    Hack [3] has obtained a dynamic polarisation curve for bare steel with no calcareous deposits under no-flow conditions in warm water. If no better data is available, this source can be used as the "no calcareous deposits" curve mentioned in section 3.

    If "time-averaged" water flow rate or a "time maximum" flow rate are not available, it seems reasonable to use mean high water spring flow rates for simulation work.

  6. References

[1] Hartt W.H. and Chen S. "Galvanic anode cathodic polarisation of steel in seawater: Part 3 – Retrofit Cathodic Protection of Offshore Structures". Corrosion June 1999.

[2] Fischer K.P., Sydberger T. and Lye R. „Field testing of deep water cathodic protection on the Norwegian continental shelf". Corrosion March 1987.

[3] Hack H.P. "Atlas of polarisation diagrams for naval materials in seawater". Carderock Division, Naval Surface Warfare Centre, CARDIVNSWC-TR-61-94/44 April 1995.

[4] Hack H.P. and Guanti R.J. "Effect of high flow on calcareous deposits and cathodic protection current density". David Taylor Research Center. DTRC/SME-87/82 April 1988.

[5] Strommen R. "Review of Offshore CP Design Criteria based on In-situ current density measurements". Pages 195-211, Proceedings of the UK Corrosion 1985 Conference, Harrogate, 4-6 November 1985.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Input Data and Outputs

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\inputs_outputs\inputs_outputs.htm

Input Data and Outputs

The CP solver requires general data comprising physical properties such as conductivity values, geometrical data and polarisation data. After solving, results are available in text format and as contour plots for 3D visualisation.

Types of input data

Types of outputs

CP Solver input and output files

Types of input data

The input data can be divided into the following categories:

  • Geometry data: Geometry data refers to the mesh point coordinates, groups of elements and mesh connectivity

  • Polarisation data: Polarisation data refers to polarisation curves applied to surfaces in the model.

  • General Data: General data refers to model parameters such us:

- units,

- electrolyte conductivity/resistivity

- sacrificial anode data (anode mass, initial consumption factor, utilisation factor, etc.)

- inter-connecting resistances, resistivity values, etc.

- ICCP outputs

- solver options

Types of outputs

During an analysis, the CP Solver generates files, for example the log file, files with numeric results and files for 3D visualisation of results.

Numeric Results

Values of current density and potential for each element are available in the GDF file. Other numeric results are also available in the GDF file, for example metal voltage, protection potential, etc.

Additionally, other numeric results are placed in separate result files, such as anode remaining life or potential drop through a resistance.

3D visualisation of results

Results are available for 3D visualisation in GiD. (Result visualisation )

CP Solver input and output files

Input files

In most situations, the CP solver requires only two input files:

  • dat file: The dat file contains geometrical information and general data

  • mat_cp file:he mat_cp file has information about the polarisation curves used in the simulation.

Both files need to have the same root file name. Output files are generated using the same root file name.

Output files

The main output files are:

  • GiD post-processing files for 3D visualisation

  • Result files with numeric results

  • Log files

Input-Output files

From the CP solver point of view, this can be represented as shown in Figure 1

Figure 1 CP Solver main input and output files

Figure 2 shows a summary of the input and output files in a BEASY CP Analysis.

Figure 2 CP Solver input and output files

During an analysis, the solver produces some temporary files that are deleted when the analysis is finished. Other files produced by the solver that are not automatically deleted are listed in this section.

Input files

File name | Description
model.dat | This is the main input data file for the CP solver containing mesh data and general data and solver options.
model.mat_cp | This file contains the polarisation data for all materials used in the model

Log files

File name | Description
model.log | All analysis data will be written to this file. This will contain details on the model and any problems or information during the analysis will be reported here. After each analysis run, it is recommended that you review this file for any warnings, errors or notes.
model.lo2 | This file contains a register of the files that have been created or deleted during the analysis.
model.runlog1 | This is a copy of the output that is written to the screen for analyses that are run in "background" mode. This can provide additional information on the progress of the analysis.

Result files

file.sf1 | This is an ASCII file which contains basic information about the problem under analysis (for example, number of zones, number of degrees of freedom, etc.)
file.sf2 | This is the second results file, which is written in binary format. This file is needed to calculate solution at internal points using a solution calculated previously, for example.
file.gdf | This is the "generalised data format" output file. This is an ASCII file containing the model mesh and results in a standardised file structure.
file.post.msh & file.post.res | These files are created in order that the results can be imported directly into GID. The result file creation is turned on by a control line in the dat file. This file type only applies for customers with the BEASY-GID interface.

Optional Result files

Model.cp_anode_decay | If the model has sacrificial anode data defined, then this file with numeric results is created by the CP solver. The file contains results for each sacrificial anode including anode life and anode consumption factor
model.MVResults | If the model has a non-default circuit defined then an additional file with numeric results will be created by the CP solver
model.pipelines | If the model has a pipeline with internal resistance defined then an additional file with numeric results along the length of the pipeline will be created by the CP solver

Intermediate files

These files, in general can be deleted. It makes only sense to retain influence matrixes files if you are planning to re-run a model changing only polarising boundary conditions.

Model.h001

Model.h002

Each of these files contains an influence matrix per zone defined in the model. These files can normally be deleted. The only case in which you may keep them is if you want to re-run an analysis in which the only change to the model is the label on the polarising boundary conditions.

Note that these files are very big files and it is advisable to delete them after use.

The work files can all be deleted after a run.

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\introduction\introduction.htm

CP SOLVER

BEASY CP is designed to simulate the behaviour of galvanic corrosion problems and cathodic protection designs. Differences in the electrochemical properties of the materials involved trigger corrosion in onshore, offshore and marine structures. An electric current is induced and the material which acts as the anode is subject to corrosion. BEASY CP can be used to analyse this corrosion and monitor the protection systems employed.

Two common methods used to protect systems from corrosion are galvanic protection and impressed current protection. BEASY CP can simulate sacrificial anodes, ICCP anodes, rectifier units (TRU) power supplies.

BEASY CP can be used to predict corrosion rates, optimise cathodic protection designs and predict long term performance.

BEASY CP can also be used to predict stray current problems, for example the interaction between separate cathodic protection systems; as well as the impact of an external power system (railways, transmission equipment etc.) on CP system performance and corrosion rates.

Theoretical Background

Theoretical Background

Input data and outputs

Input data and outputs

Input Data

Input data can be divided into the following categories:

  • Geometry -Mesh

  • General Data

  • Polarisation Data

Results

Results

Modelling aspects

  • General guidance on CP modelling. Approach to modelling, aspects on model definition, modelling steps, solution of problems, causes of errors.

  • Meshing guidelines

  • Forward Time Stepping : How to set up a forward time stepping run

  • Modelling multi-layered zones: Reference

  • Sigmoidal curve method : Reference

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Forward Time Stepping

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\forward_time_stepping\forward_time_stepping.htm

Time Stepping

This document shows how to use the tool to launch time stepping runs. The forward on time runs are useful in any of the following cases: anode decay, degradation of coating, built up of calcareous deposits and flow rate variation with time.

Introduction

Create the initial data file

Launch the time stepping runs

Results folders

Post-process folder

Modelling anode decay

Breakdown factor changing during time

What happens if something goes wrong?

Introduction

During the time stepping procedure, it is possible to model the anode decay and/or the degradation of the coating on some parts of the structure along the design life.

When modelling anode decay the mass loss rate calculated at an initial time is used to change anode size during the time stepping process. The size of the sacrificial anode is automatically adjusted to reflect its remaining mass at the beginning of each time step.

If an individual anode has reached its defined Consumption Factor, it will automatically be recorded as "Non Active", and the model will therefore assume that it no longer contributes current (i.e. it is "switched off")

If modelling the increase of breakdown factor with time, then a different breakdown factor can be introduced at each time step for the selected materials.

Before starting with the time stepping runs, it is necessary to create the data file that represents the model. Then, the tool can be used to launch the runs.

Create the initial data file

Create the dat file using the CP Model Editor.

NOTE: If you want to analyse the anode decay, then you need to have "Sacrificial Anode Properties" properties defined. Follow a tutorial that illustrates how to do that.

Launch the time stepping runs

From the CP Desktop, start the Offshore Tools, click on "Perform forward time stepping solutions" and press "START".

The "Forward Time Stepping" panel is opened:

First browse to the dat file. For example, if you load the data file "modelA.dat", you need to have the material file "modelA.mat_cp" in the same folder.

Then, input parameters to define the time stepping,

  • the number of steps you would like to run, for example 4 if you wish to have 4 time steps in addition to results at the initial year.

  • the time interval, for example 5 if the runs are performed every 5 years.

  • the initial year, for example "2020" or "0" if preferred.

The input data is shown in Figure 3

The additional options allow including different effects in the analysis.

Tick on:

  • "1" to model anode decay.

  • "2" to increase the coating breakdown factor of some materials during time stepping.

  • "3" to model calcareous deposits using a long-term curve defined in a separate long-term file.

  • "4" to include a water flow-rate profile

NOTE: If you defined the sigmoidal curve in the mat file and you are not using separate long-term curve files, then you don't need to select "3"

NOTE: If you defined the sigmoidal curve in the mat file and you can not model flow profile. You should defined the long-term curves separately

On the last panel you can select either to launch the Solve (option 2) or to "Create batch file" (option 1). You will need to launch the batch file manually.

If you did not tick the check box "run in background" then you will see the runlog files for the different time steps. If you tick the check box "run in background" the process will run silently.

When the process is finished, you will see the folder structure as follows:

Results folders

Results for each step are saved in separate folders named as the corresponding year name. In this way, at the end of the process, the directory "0" contains the result files for the initial year, the directory "5" contains the results for year 5, and subsequently each number corresponds to the corresponding year.

In the result folders, the names are formed by the original model name followed by "_year" (e.g. modelA_0, modelA_5, etc.)

In addition, to the result files, there is one separate folder:"to_fwd_time", containing the files used to forward on time in

Post-process folder

The folder "postprocess" contains the *.post.res and *.post.res files for post-processing results for all runs at one go:

To visualise results you can open the GiD interface in post-process mode and go to "Files>Open multiple" and select the files

Modelling anode decay

NOTE: If you want to analyse the anode decay, then you need to have "Sacrificial Anode Properties" properties defined. Follow a tutorial that illustrates how to do that.

Breakdown factor changing during time

If you want to simulate the degradation of coating with time, you first need to prepare the material file with the materials representing the different coatings.

For example from the material "bare steel" we need to generate labels for the different years according to the initial bf and degradation factor. A sample of coating bf and labels applied on each step is shown in the table below:

Year | Breakdown factor | Label
0 | 0.020 | TP00
5 | 0.072 | TP05
10 | 0.124 | TP10
15 | 0.228 | TP15
20 | 0.280 | TP20

In this example, we should have prepared the data file with the CP Builder using the label "TP00".

The panel below automatically follows if you selected "Increase coating breakdown factor during time stepping"

Press on "Create a new set" and select the label of the coated material at year 0:

Then identify the label that will be used for the coated material at each time step.

The panel after identifying all the labels:

What happens if something goes wrong?

If something does not go as expected, check the following files:

  • *.forward_stepping_controller.log

  • *.run_timestep_batch.log

  • *_x.log where x is the value of the year ( 0,5,10,15 or 20 in our example)

  • *_x.forward_datfile.log

File *.forward_stepping_controller.log: This file reports on problems caused before launching the runs, in the process of generating the batch files to launch the runs. If everything went as expected the file ends with "COMPLETED SUCCESSFULLY"

File *.run_timestep_batch.log. This file contains the commands and outputs executed when running the whole process

File *_x.log. If there is an error during the execution of one time step, then the process will be interrupted. Check the log file in the corresponding year folder.

File *_x.forward_datfile.log. If there is an error when updating the data file with the new consumption factors for anode decay simulation or new labels if the coating breakdown factor increases during time; then it will be recorded in this file which is located in the corresponding year folder, sub-folder to_fwd_time.

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Files Format

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\filesformats\filesformats.htm

Files Format

This document is relevant for the modelling of jacket structures. It describes the format of the input files containing the jacket geometry..

The BEASY file (off file) format is described in Table 1 .The input ‘NAME’ is optional and can have a sequence of characters to identify the member or the members type.

Table 2 shows an example of off file.

Table 3 shows and example of MICROSAS format.

*BEASY OFFSHORE FORMAT1 FILE

STRUCTURAL NODE COORDINATES

Coordinate ID X Coordinate Y coordinate Z coordinate

……………..

……………..

END

STRUCTURAL MEMBERS

Member ID Member Diameter Node1 ID Node2 ID NAME

……………..

END

Table 1: BEASY *.off file format

*BEASY OFFSHORE FORMAT1 FILE

STRUCTURAL NODE COORDINATES

1 0.0000000E+00 0.0000000E+00 0.0000000E+00

2 0.0000000E+00 0.0000000E+00 0.1000000E+02

3 0.5444700E+00 0.0000000E+00 0.1088890E+01

……………..

……………..

END

STRUCTURAL MEMBERS

1 0.2000000E+01 1 2 NAME1

2 0.1000000E+01 3 4 NAME2

……………..

……………..

END

Table 2: Example of BEASY *.off file format

……………..

……………..

JOINT COORDINATES

100 X -18.8595 Y -47.6020 Z 12.7635

101 X 0.0000 Y -47.6020 Z 12.7635

……………..

……………..

MEMBER INCIDENCES TYPE TUBE

100 L101 125

102 L103 148

……………..

……………..

SECTION PROPERTIES TYPE TUBE

10-0365 D 273.0505 T 9.271019

10-0500 D 273.0505 T 12.700024

10-0750 D 273.0505 T 19.050038

…………………..

Table 3: MICRO-SAS file format

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Geometrical Tansformation

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\geometrytransformations\geometrytransformations.htm

Offshore Tools. Geometrical Transformations

This document is relevant for the modelling of jacket structures. It shows how to use the geometrical transformations available in the Offshore Tools to orientate the jacket structure according with BEASY conventions. The jacket geometry needs to be in any of the following file formats: BEASY offshore file (off), Micro-SAS; IMS out file.

In order to build a BEASY model it is convenient to consider the following rules:

  • Orientate the main axis of jacket structure parallel to the z coordinate.

  • Define the z origin coincident with the sea surface.

  • Orientate the z coordinate pointing towards the seabed, i.e. all the points having positive z coordinates.

After having a look at the imported structure we need to identify if geometric transformations are required. If the original structure is orientated along y axis for example, we may use the geometric transformations to:

a) Rotate the structure so it is oriented according to BEASY convention (Origin at sea surface, with z coordinate pointing to seabed)

b) Translate it if necessary, to have the sea level at z=0 in our model.

c) Cut off the structure at sea level and delete all members above sea level.

You can perform all these tasks in the 3D geometrical interface you are using. But, you can also do it using the "Offshore Tools". If using the "Offshore tools", click on ‘Apply geometric transformation’ and then press ‘Next’ (Figure 1)

Figure 1: Apply geometric transformations

The panel will look as shown in Figure 2.

Figure 2: Geometric transformations

In order to orientate the z coordinate parallel to the main axis of the structure, you may need to rotate the structure 90 degrees about the x axis. This action is shown in Figure 3

Figure 3: Geometric transformations. Select ‘Rotate 90 degrees about x axis’

After pressing ‘CONVERT’, select a name for the output files (MODEL_rot, for example).

The next step could be to cut the structure up to sea surface. However, both steps could have been done in a single transformation.

When performing both operations together (rotation and cut), the cut of the structure is done sequentially after the rotation, so the cut planes specified should take into consideration that the structure has already been rotated.

If the sea surface is not coincident with plane z=0, it can be convenient to apply a translation in z direction before cutting.

In addition, if the units of the model need to be transformed, the model can be scaled at this stage, using the scale transformation.

Note that these geometric operations can also been performed in IMS or GID. However, it is simpler and straight forward to do all the transformations using the tool.

Any problem that may have occurred during the transformations is reported in the file *.offshore_trans.log

Once all the transformations are done, the geometry is ready to be trimmed.

If wanted, if there are points remaining above the sea surface, they can be deleted. This is not necessary, but it can be done just to tidy up the model.

Figure 4 shows an example of a tripod jacket and the transformations applied to reach a final state suitable to be the starting point for our BEASY model.

Figure 4: Transformation applied to a tripod jacket

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


MICRO-SAS

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\microsas\microsas.htm

Translate a MICRO-SAS file into a BEASY Offshore file

This document is relevant for the modelling of jacket structures. It shows how to translate a MicroSas file into a BEASY Offshore file ready to be imported into the 3D User interface.

If a structural model is available in MICRO-SAS format translate the input file into a BEASY format file (*.off file) using the Offshore tools.

Access the Offshore tools from the BEASY CP Desktop.

As an example, the initial file in Micro-SAS format is referred as MODEL.TXT

Select the process ‘Translate geometry’ as shown in Figure 1.

Figure 1: Select ‘Translate geometry’ and then press ‘START’

After pressing ‘START’, select the format of the input file by choosing MICRO-SAS format.

Then press on "Load input file" and browse to the file containing the structural data.

Once the file is loaded the panel should look as it is shown in Figure 2.

Figure 2: ‘Translate geometry’ panel. MICRO-SAS file ‘MODEL.TXT’ has been loaded.

The translation is done by pressing the ‘Convert’ button as shown in Figure 3.

Figure 3: ‘Translate geometry’ panel. Translate the input file.

After pressing ‘Convert’ enter a name to save the translated model. Three files will be generated, but you need to use only the file with extension .off.

Note that if you do not define a different name for the converted file, all the converted files will be named as the original file but with the extension _trans.off, _trans.out and _trans.bch respectively. In this case, the information window in Figure 4 pops up.

The only file that is going to be used is the off file. So you can delete extra files produced at this stage if you want.

Figure 4: Information window

Now you can open the user interface and import the *.off file just generated as is shown in the following section.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

Assess input data

Importing the geometry

Anode creation

Trimming

Introduction

When modelling jacket structures, the elements or members are defined using "tube elements". In this way, from the geometry point of view, jacket members are lines with an associated property (its diameter).

In most cases, it is possible to previously have the jacket geometry in some digital format, whereas sometimes the only information available is through drawings and the geometry needs to be created from scratch.

The procedure involved in the building of a model of a jacket structure involves the following steps:

STEP 1 Asses input data and decide starting point for the build:

  1. PATH A: If the geometry is available through some digital format assess the way of importing the geometry into the graphical interface.

  2. PATH B: If only drawings are available, use them to build the structure made of lines and points. Then, define member properties, i.e. assign diameter values to the lines.

STEP 2: Import or create the geometry consisting of intersecting lines with member properties defined.

STEP 3: Define and incorporate anodes to the model.

STEP 4: Trim the structure. To avoid intersections between pipes at the joints and preserve the steel surface area, trim the members at the intersections.

Assess input data

If a structural file is available then the main objective at this stage is to import the geometry into the graphical interface. You can import an IGES file or a BEASY offshore format file (".off file).

Alternatively, you can translate the input file into an off file so it can be imported into the graphical interface.

If a 3D model of the structure is available, then it can be used as a starting point to build the geometry.

  • MICRO-SAS format: If the original data is in MICRO-SAS format, translate the input file into a BEASY format file (*.off file) using the Offshore tools. To see how to do this follow the link: Translate a Micro-SAS file into a BEASY offshore file

  • ALTERNATIVE format: If the original data is in a format that can be easily translated into a BEASY format file (off format) by editing it, then edit your input data to the required format (off file format). The off file can be imported directly into the graphical interface.

  • IGES format: If the original data is in IGES format it can be directly imported into the user interface

Importing the geometry

According to the format of the input, proceed as follows:

  1. Starting with an off file

  2. Starting from scratch or with an IGES file.

Up to this point you will have a model of intersecting lines with properties assigned.

Follow tutorial showing how to proceed: Jacket Structure.

Anode creation

If you are using GiD, follow the link showing how to create anodes

Trimming

If you are using GiD, follow tutorial on : Jacket Structure showing how to automatically trim all members

Alternatively, you can also use the Offshore tools to trim the structure using the off file.

More on trimming tools

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Additional tools for trimming

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\moretrimmingtools\moretrimmingtools.htm

Additional tools for trimming

This document shows how to customise the options for trimming a tubular structure

Introduction

Default trimming

Criteria used in the default trimming

Checking the model after the default trimming

Modifications to the default trimming.

Short members

Check the geometry

Trim isolated members

Introduction

After having the jacket structure correctly oriented according to BEASY conventions, it is necessary to trim members at the joints in order to avoid intersections between them.

The main objectives of the trimming procedure are:

  • To avoid any overlapping members.

  • To cut the structure at the seabed.

Default trimming

As an example, we will use a model of a jacket structure as shown in Figure 1.

Figure 1: The untrimmed structure jacket1.off used as example in this document

You can perform the "Default Trimming" in the GiD User Interface environment.

You can also, do the trimming through the "Offshore Tools" wizard. In this wizard, the trimming can be customised, if necessary.

Start by selecting the "Offshore Tools" in the BEASY CP Desktop. The window shown in Figure 2 pops up.

Figure 2: Offshore Tools

Select the process ‘Trim members’. The ‘Trim members’ panel is displayed as shown in Figure 3.

Figure 3: Trim members

The starting point of the trimming tool is a file containing the information of the jacket structure in an .off format.

If you generated the geometry using the GiD interface, export the tubular members using "Files > Export > BEASY_off".

If the tubular members are defined through a MICRO-SAT format, you can use the "translator" in the "Offshore Tools" to convert it into an .off file.

After, clicking on ‘Load *.off file’ select the .off file representing the untrimmed structure.

Once the file is loaded, enter the seabed z coordinate if you want to cut the structure at seabed and the short member threshold length. This parameter sets a threshold for the member length. The default value is 0.1, which is an appropriate in most cases when the length units are in m.

If the length of a trimmed member is smaller than the threshold, then it will be recorded and the user may choose to delete this ‘short’ member in a further trimming. A suitable value for the threshold (if the model is in metres) is 0.1m.

Figure 4: ‘Perform default trimming’.

Set the z coordinate for the seabed if necessary and a threshold for the length of the members and press ‘Perform default trimming’ as shown in Figure 4. If the trimming is successful, the window shown in Figure 5 pops up.

Figure 5: Information window

Figure 6 shows the list of files created after the trimming is performed. Table 1 describes the content and use of each file.

Figure 6: List of files after trimming

Input file name | Content description
Jacket1.off | Untrimmed structured, orientated in z direction, z positive pointing towards seabed
Output files | Content description
Jacket1_t.off | Trimmed structure in .off format, IMS and GID format respectively
Jacket1_t.bch
Jacket1_t.out
Jacket1_t.sta | Template to use when defining anodes (relevant only for IMS users)
Jacket1.short_members.txt | Information about short members. This file is not used by the user
Jacket1.trim.log | Log file. Information about the trimming
Jacket1.trim_report | Report file. Detailed information about the trimming

Table 1: Files created by the trimming tool

After the trimming is performed the ‘Trim members’ panel changes to the view shown in Figure 7.

If you are happy with the first trimming (default trimming) then, you can continue to the next step.

Otherwise, if you want to make adjustments to the trimming, then a second trimming applying advanced options can be used (Figure 7). Data in panel ‘Do not trim following members’ can be modified and then ‘Advanced Trimming’ can be imposed. Note that in this simple example, there are no members shown in the right hand side of the panel. (no short members )

Figure 7: Trim members. View after the first trimming has been performed

Criteria used in the default trimming

The first trimming, (the ‘default trimming’), is performed following these criteria,

  • The thickest of all the concurrent members to a joint is called the ‘main member’. The main member will not be trimmed. An example of a joint sharing two members is shown in Figure 8. The red member will be selected as the main member by the ‘default trimming’, whereas the blue one is going to be trimmed.

Figure 8: Concurrent members. The red member is the ‘main member’

  • The concurrent members to a joint are trimmed to the circumference of the main member and then by a distance proportional to the angle between the main member (the thickest) and the member to be trimmed. (Figure 9)

Figure 9: Default trimming. The concurrent members are trimmed to the circumference of the main member up to point B. Then by a distance which depends on the angle α.

  • If at a joint there is more than one member with bigger diameter, the longest (between those with bigger and equal diameter) is selected as main member.

  • If at a particular joint, a member is collinear to the main member and has the same diameter, then it will not be trimmed.

If after taking a look at the trimmed structure you decide that at a particular joint the default criteria to select the main member does not give satisfactory results, then the main member can be set by introducing its id into the left hand side panel of Figure 7.

Regarding short members the criteria are as follows:

  • All actions taken with short members in the ‘default trimming’ are written in the file *.short_members.txt and displayed in the right hand side panel in Figure 7.

  • If the members are very short after the default trimming, they are trimmed and listed (Figure 7).

  • If members have negative length after the ‘default trimming’, they are deleted.

  • The user can choose to delete the members identified as very short members in a further trimming by changing the radio button in Figure 7 to ‘Delete’.

Checking the model after the default trimming

After the default trimming is performed it is convenient to check the model to decide if it looks appropriate or if you want to make modifications to the trimming options. The followings steps can be followed:

  1. Visualise the trimmed structure with solid members.

  2. Introduce any changes to the trimming if necessary.

  3. Perform a new trimming.

  4. Visualise again the trimmed structure with solid members.

  5. If you are happy with the general look of the structure, then add a boundary box and launch a run. The test run can be used to estimate the wetted and buried steel area and to corroborate results are consistent.

A view of the trimmed structure with elements is shown in Figure 10.

Figure 10: View of the trimmed structure (default trimming)

We are going to make the following visual checks

  1. First, check the members’ look to decide if we need to change the default criteria at a particular joint.

  2. If that is the case, then identify the member ids that will need ‘Advanced Trimming’ and list them in the panel of ‘members not to be trimmed’.

  3. After finishing adding members not to be trimmed, check the short members, to decide if we can delete them in a further trim.

First, we are going to check the general look of the members by zooming into the different regions on the structure. In general, we do not want to cut the legs, or the external frames.

Figure 11 illustrates an example of members that may need special trimming options. There, the ‘default trimming criterion’ is applied to the joint shared by members 69, 6 77, 210 and 76. All of them have the same diameter, so the longest will be chosen as the main member, which is member 77 in this case. The right hand side of Figure 11 shows how the result can be changed if we choose to trim with ‘advanced trimming’ using the ‘Do not trim the following members’ panel. If members ‘69 6’ are listed in the panel, then the main member will be 69 on the joint shared by 6, so they will not be trimmed.

Figure 11: Showing the result of the ‘default trimming’ and the ‘advanced trimming’ for members 69 and 6.

To find out which members will require special options, it is easier to analyse the joints at the different elevations. We need to look the trimmed structure to decide which joints require any change. But also, in order to identify the ids of the members to whom we want to define special options for trimming, we need to open the original untrimmed structure.

Modifications to the default trimming.

Members not to be trimmed

When all the pairs of members have been identified, you can paste the list of them into the left hand side of the panel as shown in Figure 12.

Figure 12: Members not to be trimmed defined by the user.

Do not forget to click into ‘Do not trim following members’ to enforce the option. Then press ‘Perform advanced trimming’ as shown in Figure 12.

The list of members introduced by the user is saved in the file *.user_options.txt after performing the trimming.

Short members

Now that we are happy about the appearance of the structure we can take a look at the short members’ panel.

  • If there are members listed on the panel, then it is convenient to have a closer look and decide if it is worth keeping those members or not.

Note that any member with negative length after trimming is automatically deleted.

Figure 13 shows a closer view of the some of the short members that appear in a jacket structure. It can be seen that the identified members are very short and their contribution to the total steel area is negligible, so they can be deleted.

Figure 13: Close view to short members

Therefore, in the next step, we set all these members to be deleted by clicking in the corresponding radio button as shown in Figure 14.

Do not forget to click on to ‘Trim the following short members’ to enforce this option.

Finally, press ‘Perform advanced trimming’.

Figure 14: ‘Trim members’ panel. Advanced trimming settings

In general, at this stage, the resulting structure looks appropriate, so this should be the end of the trimming procedure.

It is advisable, however, to perform a check run of the model at this stage, so the wetted and buried steel area can be evaluated. If we are happy with these figures and with the results then we can confidently go to the next stage and start adding anodes.

Check the geometry

The main objective of performing a check run of the model at this stage is to evaluate the wetted and buried steel area and at the same time to confirm our trimming has been correctly done when looking at the results.

However, the run we are doing at this stage does not need to be rigorous and does not need to reflect the real physical properties of our problem. To perform a run check you may follow the following procedure:

  • Import the _t.off file in the user interface into a new project, generate the groups as usual, introduce a distant anode and a boundary box, then create the dat file and perform a run for the 1 zone model.

  • Use any material file with linear polarisation curves if possible to minimise the time for this run.

Figure 15: BEASY Solver wizard. Anode and Cathode Properties panel.

Note that the BEASY Solver wizard has calculated the steel areas which are visible in Figure 16.

Figure 16: BEASY Solver wizard. Steel areas for wetted and buried steel ( 3263m2 and 1283m2)

Then, proceed as usual and launch the run.

Once the run is finished, open the user interface in post-process mode and show results for Protection Potential.

If the case is that results are significantly more positive than expected, then we need to find the source of this error. If that is the case, this should be caused by some overlapping members. To identify the problem we will change the minimum in the scale to -400mV for example as shown in Figure 17.

Figure 17: Set the minimum value to -400mV

Then, only members with potential more positive than -400mV are visible, and any problem can be identified. If there are overlapping members that are isolated, as shown in Figure 18, there is a way to overcome this problem by using the tool ‘Trim isolated members’.

Figure 18: Showing overlapping members 786 and 802

Trim isolated members

This tool is used to perform the trimming of a member having an isolated node that remains inside another member.

Start by selecting ‘Trim isolated members’ on the Offshore Tool.

The panel will show as in Figure 19. Load the .off file representing the trimmed structure jacket1_t.off.

Figure 19: ‘Trim isolated members’ panel

Then tick the box ‘Trim isolated members’ and input the id of the member to which members with a ‘free end’ should be trimmed. The trimming is performed if the ‘free end’ is inside the member to be trimmed to.

Figure 20: Trim isolated members ( trim all the members with free ends that are overlapping member 786)

After the trimming is performed check the structure again using the generated jacket1_t_t.out file. Resulting members are shown in Figure 21.

Figure 21: Members after ‘Trim’ using ‘Trim isolated members’

In the same way we did in the previous section 5, we have to perform a check for this new model.

If results for potential look reasonable, we can say we are happy with the trimming and we can move on to the next stage

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Starting with IGES file

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\startingwithiges\startingwithiges.htm

Starting from IGES or from scratch

This document is relevant for the modelling of jacket structures. It shows how to start the modelling from IGES file

If the file describing the structure is in IGES format, then it can be directly imported into the user interface.

However, it is convenient to consider the following rules when producing the IGES file or when creating the geometry from scratch in the 3D user interface:

  • The IGES file should contain axial lines of all structural members in the jacket

Also note that:

  • The axial lines should meet at points

  • No line should cross another line

Thus separate lines A and B shown in Figure 14 are required because another line meets the horizontal member at the junction between lines A and B

Figure 1: Lines should meet at points

Once the geometry is defined as previously described, then the IGES file can be imported into the user interface.

If you are a GiD user follow the link to tutorials.

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Starting with OFF file

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\jacketstructures\startingwithoff\startingwithoff.htm

Starting with a BEASY offshore format file

This document is relevant for the modelling of jacket structures. It shows how to start the modelling from an off file

If the input data is a BEASY offshore file (off file) then you can import it directly into the user interface.

For GiD users, having the latest BEASY GiD problem type loaded, go to "CP Modelling > Jacket_Structures> >Import .off file" to import the *.off file.

Follow a tutorial on how to proceed.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Contents

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\meshingguidelines\meshingguidelines.htm

Guidelines on Meshing

This document contains a set of basic guidelines for mesh definition.

CONTENTS

Elements

Element Shape for a 3D model

Elements order on the geometry (Quadratic)

Elements order on the solution. Constant, linear and Quadratic elements

Guidelines for mesh definition

Aspect ratio

Element size

Shape of elements

Element Order in the geometry

Element Order in the solution

Elements close together

Grading

How many elements should I use?

Special Elements

Tube elements

Dual Elements

Internal Points. Result Elements

Elements

All the surfaces representing the external boundaries in a 3D model (or lines in a 2D model) need to be divided and covered with elements, as well as any interface surfaces (or lines in a 2D model) between sub-regions of the model.

From now on we will always refer to a 3D model, but similar concepts are applied to a 2D model.

Element Shape for a 3D model

The process of dividing or covering the surfaces enclosing the electrolyte with elements is called "meshing". For a 3D model elements are usually either triangular or quadrilateral shapes as shown in Figure 1.

Figure 1: Meshing

In general, the geometry is defined by points, lines and surfaces and the mesh by elements and points, as shown in Figure 2.

Figure 2: Geometry and Mesh

Elements order on the geometry (Quadratic)

When the 3D graphical interface generates the mesh each element is defined by points. The interface refers to the points as "nodes". But in BEASY CP, these points are referred as "mesh points".

Elements of quadrilateral shape are defined by 9 "mesh points" and elements of triangular shape by 6 "mesh points". This representation is "quadratic" in order. In this way, the position and curvature of the element is well represented. Quadratic elements and associated mesh points are shown in Figure 3.

Figure 3: Elements and mesh points

Elements order on the solution. Constant, linear and Quadratic elements

Each element is used to represent the potential and current density (i.e. the variables of the problem) of a small section of the surface area. The positions where the variables are calculated are called "nodes".

Elements can represent variables using constant, linear or quadratic functions.

Constant elements have only one node per element, linear elements have 3 nodes for triangular shape elements and 5 nodes for quadrilateral shape elements, and quadratic elements have 6 nodes for triangular shape elements and 9 nodes for quadrangular shape elements, as shown in Figure 4.

Figure 4: Elements Order on the solution

The user can choose "the order" of the element used in the calculation. This can be set in the "Solver" tab (Settings) in the CP Model Editor.

The choice of element order has a major impact on the size of the model and hence the number of nodes. The number of nodes directly relates to the number of equations to be solved, i.e. to the number of degrees of freedom

Note that:

  • Constant elements are fastest but least accurate

  • Quadratic elements are slowest but more accurate

For Corrosion simulations constant elements give very satisfactory results and these are the default value for the element order.

Guidelines for mesh definition

Criteria for a good model and aspects to avoid are given in this section.

Aspect ratio

Boundary elements can become inefficient and inaccurate when they have extreme aspect ratios. In general, you should keep all elements within the advised limit on aspect ratio of 5:1.

Element size

In general allocate more elements in regions where the solution is expected to change rapidly. In these regions, smaller elements are required to capture the variations of the solution. Elements may then be graded away to larger sizes in parts of the model over which the behaviour is more stead. Therefore, concentrate elements where the geometry or the boundary conditions change abruptly.

Figure 5 shows concentration of elements in regions where the geometry changes or where the materials change. Away from these areas the mesh is coarser.

.

Figure 5: Element size

Shape of elements

Distorted elements may cause inaccuracies. Avoid distorted elements. The log file reports a list of distorted elements. Check the log searching for distorted elements and correct the mesh.

Element Order in the geometry

The geometry needs elements that are quadratic in order.

Element Order in the solution

Constant elements give generally good results for CP simulations.

Elements close together

Elements too close together may cause inaccurate results, slow convergence and high error in flux balance. Check in the log file for report on "closeness of nodes". If nodes are too close together, try to enlarge the number of elements on the localised region. If this is not possible consider alternative ways of modelling such as dividing the problem in two different zones, using of dual elements, etc.

As a rule, the distance between nodes on two different elements "d" should be greater than a tenth of the characteristic distance "s" shown in Figure 6 measured in an element.

Figure 6: Distance between elements

Grading

While it is often desirable to have small and large elements in the same model, take care that adjacent elements do not have very different sizes. This will involve grading of element sizes from small to large in a more gradual way.

Avoid very extreme changes in mesh size as shown in the left in Figure 7. Allow the mesh to transition smoothly.

Figure 7: Mesh grading

How many elements should I use?

The answer to this question clearly depends on the problem you are analysing. However, you can start by using the correct number of elements to satisfy the criteria listed above to mesh the sensitive areas. The rest of the model can be meshed from there by satisfying the mesh grading criteria when creating larger elements. This should leave you with a boundary element model with significantly fewer elements. It is best to focus on local refinement of elements around key areas of the model in which you are interested in.

Special Elements

Tube elements

A tube element represents a thin cylindrical cavity in the electrolyte. It is important to note that the solution is constant around the circumference, though it may change in the axial direction.

It has three major uses:

  • To model members of offshore platforms.

  • To model cylindrical anodes

  • To model pipelines

Figure 8: Tube element

Use of tube elements for problems like these significantly reduces the problem size.

Dual Elements

"Dual elements" are triangular or quadrilateral elements which allow different potential (V) and normal current density (q) solutions on opposite sides (Figure 9)

Figure 9: Dual Elements

Dual elements can be used for modelling thin surfaces (e.g. thin plates) submerged in the electrolyte. The thickness of the plate must be negligible compared to the other dimensions as illustrated in Figure 10 .

Figure 10: Thin surfaces fully immersed in the electrolyte

In some situations, it is possible to avoid using dual elements by either representing the full 3D equivalent plate, or by dividing the model into zones.

Internal Points. Result Elements

Internal points are points which lie inside the electrolyte, at which the BEASY solver finds the potential and current density results at the end of the analysis run.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Modelling Steps

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\modellingsteps\modellingsteps.htm

Modelling steps

The following list outline the general modelling steps:

  1. Geometry and Mesh:

    • First create/import the geometry using the 3D graphical interface equipped with the corresponding BEASY plugin.

    • Export the mesh of your model or several meshes of the different parts of your model

  2. Model Data:

    Using the CP Model Editor:

    • "Import mesh" or meshes for all the parts of your model

    • Import a polarisation file (*.mat_cp file) using the "Imported polarisation" tool.

    • On the "Groups Definitions" tab, for each group of mesh elements: Define zone id, boundary conditions, element type, and other pertinent data.

    • On the "Zones" tab define zone conductivities and relevant parameters.

    • If you want to simulate anode decay and calculate consumption of sacrificial anodes, on the "Sacrificial Anodes" tab define sacrificial anode data.

    • If you need to calculate the solution within the electrolyte or at reference electrode locations, or want to evaluate the solution at survey points, define internal points on the "Internal Points" tab. (Alternatively, you can create result elements at the pre-processing stage using the 3D graphical interface).

    • If connection resistances between components are significant or if a Transformer Rectifier Unit (TRU) is defined, define a non-default return path circuit using the "Return Path Circuit" tab. In these cases, voltage losses will be calculated.

    • When all data is defined, save the hmd file using "File > Save" or "Files > Save As" .

  3. Model creation and Solve:

    • Then go to the "Solve" tab where you can edit settings for the solver, create the model.

    • Check the "Model Creation Report" for possible errors

    • Launch the Solver pressing "Solve Model".

    • After the solver finishes, check the Solver log file for possible errors during the simulation.

  4. Results

  • A summary of results is shown in the "Report" tab. Press "Create Report.

  • You can now visualise 3D results using the GiD graphical interface or/and analyse numerical results using Process Results from GDF file or any of the additional tools for post-processing.

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Multi-layered zone

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\multi_layer\multi_layer.htm

Multi-layer

This document provides a short introduction to the multi-layered zone approach for solving models where the conductivity values change over one or more parallel layers in the electrolyte.

CONTENTS

Introduction

Setting up a multi-layered zone

Advanced user information

The multi-layer algorithm

Fine tuning

Limitations

Introduction

In some particular cases the electrolyte can be considered as stratified into one or more parallel layers, where each layer is characterised by a given thickness and electrical conductivity. Common examples could include soil composed of different formations, or seabed – sea interfaces including different layers of mud.

Figure 1 illustrates a model consisting of a metallic pipeline buried in a complex soil consisting of several layers

Figure 1: Illustrative example of a multi-layered region consisting of a pipeline in a soil of 4 formations (layers)

The multi-zone approach has been traditionally the method of choice for solving this type of scenarios. In a multi-zone approach each layer consists of a "Zone", which is essentially a region of the integration domain (a volume in the case of a 3D problem) totally surrounded by bounding surfaces, as illustrated in Figure 2.

Figure 2: Example of mesh discretisation for multi-zone approach

When using the multi-zone approach for solving layered media , the interfaces between layers need to be included into the model, as shown in Figure 2.

On the other hand, the so called "Multi-Layer" method, contemplates the stratified nature of the electrolyte as a set of parameters consisting basically of:

  • Thickness and conductivity of each layer

  • Layering direction

  • Boundary conditions on the top and bottom surfaces of the model.

In other words, in a multi-layered zone all the information included in Figure 2 is parametrised and processed with a dedicated solving algorithm rather than being geometrically described and discretised.

DEFINITION: The "layering direction" is defined by a unitary vector parallel to the normal vector to the planes representing the interfaces (surfaces between layers) which points from the "Top" to the "Bottom" surfaces. As indicated in Figure 2.

A multi-zone approach could be too difficult to implement, especially when the thickness of each layer is too small in comparison with other dimensions of the model.

This could lead to an extremely high number of degrees of freedom. During the model preparation which involves geometry modelling as well as group and zone definitions, a multi-zone approach would require the user to consider the details of the geometrical interference between the different layers of the electrolyte and the structures embedded in it, which are most of the times the main focus of the model rather than the electrolyte itself.

Therefore, for this type of problems it may result more convenient to switch to a "multi-layer" calculation approach.

Setting up a multi-layered zone

Multi-layered zones are defined using the CP Model editor - Zones tab.

Parameters to define a multi-layer zone:

TOP_LAYER_LOCATION: Refers to the position (in the corresponding length units of the model) of the top surface of the zone.

ZONE_TYPE: Could be either BOUNDED or INFINITE. The zone type MUST be defined as BOUNDED if the multi-layer zone is enclosed between lateral surfaces which are included in the model and prescribed with admissible boundary conditions (such as interfaces with other zones, polarisation conditions, potential or normal current density). If the zone does not contemplate lateral surfaces, then it means that it could extend to infinity in all directions except in the layering direction. In this case the zone type MUST be defined as "INFINITE"

CONDUCTIVITY THICKNESS: Allows defining the layers of conductivity and their thickness

BOUNDARY_COND_TOP and BOUNDARY_COND_BOTTOM: These fields allow defining the type of boundary condition associated to the top (Layer 1 in Figure 3) and bottom (Layer N in Figure 3) surface. The options are:

  • "INSULATED": Zero normal current density

  • "INFINITE": The first layer extends indefinitely in the direction opposite to the layering direction

  • POT_ZERO": Simulates the case in which the potential on the electrolyte in contact with the top surface is zero.

Any other type of boundary condition is not allowed in this type of calculation.

DIRLAYER: is used to select the layering direction.

Figure 3: Parameters involved in the definition of a multi-layer zone

Advanced user information

In the BEASY input data file (.dat file) multi-layer zones information can be found between the keywords:

"START PRIVATE DATA FOR MULTILAYER" and "END PRIVATE DATA FOR MULTILAYER" as shown in Figure 4. Once this file is created the information stored there can be modified with the GUI or with a text editor such as notepad.

START PRIVATE DATA FOR MULTILAYER

DEBUG_CP_MLAYER .FALSE.

ENABLE_MULTI_LAYER .TRUE.

NUMBER_OF_MULTILAYER_MATERIALS 1

TOP_LAYER_LOCATION 0

ZONE_ID 1

MATERIAL_NAME Mediterranean-soil

ZONE_TYPE INFINITE

NUMBER_OF_LAYERS 7

CONDUCTIVITY THICKNESS

0.1 300

0.5 500

1.0 100

0.5 400

0.67 200

0.0010 100

0.02 900

BOUNDARY_COND_TOP INSULATED

BOUNDARY_COND_BOTTOM INFINITE

DIRLAYER Z

N_EXP_APPROX 12

N_SAMPLE_POINTS 0

GAMMA_MAX_APPROX 0.0

GAMMA_MIN_APPROX 0.0

END PRIVATE DATA FOR MULTILAYER

Figure 4. Region of the .dat file containing the information related to a multi-layer zone

Figure 6 shows basic and advanced information, in blue and red fonts respectively. Advanced user information is not accessible from the GUI, and written to the file with default values. The list of basic information is as follows:

NUMBER_OF_MULTILAYER_MATERIALS followed by an integer number which indicates the number of multi-layer material definitions defined in the file (this is equal to 1 for single zone multi-layer calculations).

TOP_LAYER_LOCATION followed by a real decimal number indicating the coordinate of the top surface

ZONE_ID followed by an integer number that identifies the zone

MATERIAL_NAME followed by one or more string of characters used to identify the ZONE name

ZONE_TYPE followed by either the keyword "INFINITE" or "BOUNDED" depending on the zone type.

NUMBER_OF_LAYERS followed by an integer denoting the number of layers involved in this zone (7 layers in this example)

"CONDUCTIVITY THICKNESS" two keywords which should be kept as they are indicating that the following lines contain values of conductivity and thickness for each one of the layers specified in NUMBER_OF_LAYERS

A list of NUMBER_OF_LAYERS pairs of real decimal numbers indicating the conductivity and thickness values of each layer

BOUNDARY_COND_TOP followed by either "INSULATED", "INFINITE" or "POT_ZERO" depending on the type of boundary condition assigned to the top layer

BOUNDARY_COND_BOTTOM INFINITE followed by either "INSULATED", "INFINITE" or "POT_ZERO" depending on the type of boundary condition assigned to the bottom layer

DIRLAYER followed by the character "X", "Y" or "Z" indicating the layering direction.

The advanced user input information takes the form of a keyword followed by its value. The table below indicates the purpose of each keyword

KEYWORD

Description

Default value

DEBUG_CP_MLAYER

Follow by either ".TRUE." or ".FALSE."

If ".TRUE." then debug information that allows to measure the quality of the multi-layer approximation will be produced. This information is written in series of ASCII files named: mlayer_debug_MM_NN.log

Where MM and NN are the indices of the layers containing the source and observation points respectively. By default, no debug information is produced

.FALSE.

ENABLE_MULTI_LAYER

Followed by either ".TRUE." or ".FALSE."

To enable or disable the multilayer zone without deleting the information entered. When disabled, the corresponding zone transforms directly into a "normal" zone with constant homogeneous conductivity.

.TRUE

N_EXP_APPROX

Followed by an integer number between 4 and 20 indicating the number of terms used to approximate the multi-layer kernel.

12

N_SAMPLE_POINTS

A number used to sample the kernel of the multi-layer problem. Its default value is 0, meaning that the code will internally select the best choice. Usually it might be a number between 100 and 400.

0

GAMMA_MAX_APPROX

A real number identifying the maximum gamma value for the multi-layer kernel sampling. A value lower or equal than zero will force the solver to select the optimal value automatically

0.0

GAMMA_MIN_APPROX

A real number identifying the minimum gamma value for the multi-layer kernel sampling. A value lower or equal than zero will force the solver to select the optimal value automatically.

0.0

The multi-layer algorithm

The idea behind the solving algorithm associated with a multi-layer zone is that the stratified nature of the electrolyte is packaged into the corresponding Green’s function of the problem. The Boundary Element Method is applied in the same way as in the case of the homogeneous electrolyte, except that the Green’s function for the homogeneous Laplace equation is replaced by a more complex multi-layer Green’s function given by:

where x denotes the 3D coordinates, the sub-indices i and j stand for the source and field point, respectively; m and n indicate the layer of the source and field points, respectively; ck is a weight coefficient and [image] denotes a displacement. The Green’s function written in this way can be regarded as the one produced by a weighted method of images.

The implications from a practical point of view are:

  • There is no need to model explicitly interfaces between layers

  • The user does not need to consider the interference between the model and the multi-layer media

Because the discretisation of the intermediate surfaces between layers is totally avoided, very thin layers in large models can be more efficiently solved without increasing the computational burden.

In addition, the medium is parameterised as mentioned above, thus simplifying the pre-processing work required from the user.

The multi-layer approach offers also a good advantage even in the case of a single thin layer with either insulating or infinite boundary conditions, since the top and bottom surfaces of the model do not need to be modelled.

Fine tuning

Note that the multi-layer mode introduces a convenient numerical approximation to the real problem. The approximation approach is aided by the following parameters:

N_EXP_APPROX, N_SAMPLE_POINTS, GAMMA_MAX_APPROX, GAMMA_MIN_APPROX.

Under most common scenarios these parameters are set automatically by BEASY in an optimal way. However, in particularly difficult cases the automatic mode may not be the optimal solution and more involvement of the user with the calculation is required. This could be the case with multi-layer models presenting very dissimilar materials whose conductivities or thickness layer differ in orders of magnitude.

By setting DEBUG_CP_MLAYER to true, a series of .log files will be created which give more information about the quality of the approximation, and allow the user to manually impose the parameters: N_EXP_APPROX, N_SAMPLE_POINTS, GAMMA_MAX_APPROX, GAMMA_MIN_APPROX.

As mentioned above, the DEBUG_CP_MLAYER will produce a series of files named: mlayer_debug_MM_NN.log, where MM and NN are the indices of the layers containing the source and observation points respectively. Each one of these files contains a series of blocks of data showing the quality of the approximation involved in the multi-layer kernel G(xi, xj, m,n)

A 6-line top header with the legend:

Line 1: Contains the title:

# EXTENDED DEBUG INFORMATION FOR MULTILAYER

Line 2: indicates the value of m and n representative of this file, where m is the layer that contains the source point, and n the field (observation) point, for example:

# m =  1 n =  1

Line 3 to 6 indicate the maximum and minimum values of gamma suggested automatically by the solver:

# gmin_auto(:,1) =  8.0000E-08  8.0000E-08  8.0000E-08  8.0000E-08

# gmin_auto(:,2) =  8.0000E-08  8.0000E-08  8.0000E-08  8.0000E-08

# gmax_auto(:,1) =  6.2800E-03  6.2800E-03  7.0000E-03  7.0000E-03

# gmax_auto(:,2) =  6.2800E-03  7.0000E-03  6.2800E-03  7.0000E-03

After this top header, 8 blocks of data will appear showing a comparison between the exact kernel and the approximated kernel in Fourier (gamma) space. Each block of data is preceded by a 7-line header containing the following information:

Line 1 indicates the values of gamma_min and gamma_max effectively used in the calculation. By default, these values are coincident with the ones suggested by BEASY. However, if the user manually overrides the variables GAMMA_MAX_APPROX and GAMMA_MIN_APPROX with valid numbers, these valid numbers will be used. In this example, the default values were selected:

# gamma_min, gamma_max =  8.0000E-08  3.2000E-03

Line 2 indicates the number of exponential terms used in the approximation (in this case 18). This value is normally selected by BEASY, however, it can be overridden with N_EXP_APPROX

# Number of exponentials: Nc =   18

Line 3 indicates the number of sampling points used for the approximation. The accuracy of the kernel approximation increases with the number of sampling points, however this will introduce higher computational cost. The maximum level advisable is 400, and the minimum is 100. By default BEASY selects 400 points, but this value can be overridden with N_SAMPLE_POINTS.

# Number of Green sample points: Np =  400

Line 4 shows the values of m and n corresponding to this block.

# m,n =   1   1

Line 4 indicates the parameter nu and dg representative of this block. Nu indicates the relative location between the source and field point.

nu=1 is for the case when the observation point is above the source point (following the layering direction), while nu =2 is for the case when the observation point is below the source point (following the layering direction).

Dg is the sampling step used to sample the exact kernel in Fourier space. This sampling step is given by (gamma_max – gamma_min) / Np

# nu =   1 k =   1 dg =  8.0198E-06

Line 5 indicates the displacement [image] coefficients (from Green function equation above resulting from the approximation with Np sampling points, for example:

# lambda(1:Nc) = -3.1753407E+05 -2.1634832E+05 ……

These should be the best Nc coefficients that reproduce the exact kernel in Fourier space, where N is the number of exponential terms selected in N_EXP_APPROX.

Line 6 indicates the weight coefficients (ck from Green function equation above resulting from the approximation with Np sampling points, for example:

# Cmn(1:Nc)    = -3.3811123E-03  2.9919493E-02 …..

These should be the best Nc coefficients that reproduce the exact kernel in Fourier space, , where N is the number of exponential terms selected in N_EXP_APPROX.

Line 7 contains the comparison between the exact Green function and the numerical approximation for each sampling point in Fourier space. There should be one comparison for each sampling point (therefore Np lines). The quality of the multi-layer approximation depends on how close the numbers in the fourth column (G_approx) are to the numbers in the third column (G_exact). Usually, the first few sampling points present large errors, but this error should substantially decrease with increasing ID numbers (increasing gamma). This behaviour is absolutely normal and to be expected. Low ID numbers are identified with sampling points with very small gamma (in Fourier space), which corresponds to distant points in real space.

The multi-layer kernel (G_exact) representing the embedding media is computed exactly (without approximations) in Fourier (frequency, or gamma) space, then in order to transform to real space the following approximation needs to be made:

where [image] is the gamma value of the sampling point. The approximation of G_exact by G_approx is done between a range of frequencies gamma defined between gamma_max and gamma_min. The first column is an ID for the sampling point (there are Np sampling points), the second column indicates the gamma value (frequency in Fourier space), the third column is the exact multi-layer Green function in Fourier space, while the fourth column is the approximated Green function in Fourier space.

An example of this block is as follows:

 #ID              X        G_exact       G_approx

   1  8.0000000E-08  2.6600602E+00  2.6534938E+00

   2  8.0998496E-06  2.1391758E+00  2.1350863E+00

   3  1.6119699E-05  1.7999977E+00  1.7972088E+00

   4  2.4139549E-05  1.5614681E+00  1.5594447E+00

  …… … … … … …

 399  3.1919802E-03  5.6564993E-02  5.6563545E-02

 400  3.2000000E-03  5.6319287E-02  5.6317880E-02

At the end of the comparison between G_exact and G_approx for Np sampling points, there is a line showing overall error estimation for the number of Nc approximating exponentials.

 # ERROR = Sum( Kapprox - K) / Npoints =   7.377632097864959E-005 N_Exp = 18

The quality of the approximation can be controlled by manually changing the following parameters in the .dat file

N_EXP_APPROX, (number Nc of exponential terms)

N_SAMPLE_POINTS (Np, number of sampling points)

GAMMA_MAX_APPROX ( gamma_max = maximum gamma coordinate in Fourier space considered for the approximation)

GAMMA_MIN_APPROX (gamma_min = minimum gamma coordinate in Fourier space considered for the approximation)

Limitations

  • Symmetry planes MUST NOT EXIST along the layering direction

  • Version BEASY 10 Release 19 of the solver does not support the definition of dual elements in multi-layer problems

  • The Multi-layer zone supports constant flat elements only. Curved elements will be flattened and a warning message will appear in the .log file. While linear and higher order interpolation schemes are forbidden and will cause the solver to stop with a fatal error

  • The multi-layer mode introduces an automatic mesh division algorithm which relieves the user from creating a mesh consistent with the surrounding media. In other words, the interference between the physical model and the interface planes between layers is already accounted for within the solver on behalf of the user. For this feature to perform efficiently, severely distorted elements should be avoided as much as possible

  • Tube elements which are partially embedded in two or more adjacent layers are automatically cut at an angle of 90 degrees ONLY with respect to the axial direction at the intersection point with the interface (plane between layers). This could introduce inaccuracies if the cut is expected to be at any other angle rather than 90 degrees. The figure below illustrates this situation. Note that the inaccuracy (represented as yellow coloured areas) introduced by the automatic cutting increases as the angle [image] decreases. Note that triangular or quadrilateral elements do not suffer from this type of inaccuracies, which affect only tube elements at oblique angles immersed in two or more layers.

NOTE:

If the multi-layer zone is included into a normal zone fully enclosed by surfaces, define the multi-layer zone as "FULLY_BOUNDED".

=============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Sigmoidal Curve Method

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\modellingaspects\sigmoidal_curve_method\sigmoidal_curve_method.htm

Sigmoidal curve method for CP simulation of offshore structures

This document provides an overview of the fundamentals underpinning the method of the sigmoidal curve for CP simulation of offshore structures.

CONTENTS

Introduction

Various published sigmoidal curves

Application of the sigmoidal long-term curve method for no-flow waters

Application of the sigmoidal curve method for tidal waters

Selecting data

References

Introduction

A "sigmoidal curve" shows the long-term relationship between current density and potential on wetted steel surfaces on which calcareous deposits may form. Each point on the curve shows the current density which would eventually be reached if a sample of the metal was held at a particular potential for a long period of time, during which calcareous deposits would form.

The term "sigmoidal" is used in a paper published by Hartt [1], which showed a curve shape as Figure 1, which was for water at 23 to 25 Celsius.

The same type of sigmoidal curve was noted by Fischer et al [2] in their study in northern waters, but their paper did not include numerical values for the curve.

Data published by Roe Strommen [5] for North Sea waters shows the same sigmoidal shape, but shows upper and lower limits experimentally observed on offshore structures.

It seems appropriate to use the data by Strommen for CP simulation of North Sea structures, and the data by Hartt for simulation of structures in warmer waters.

Details of the sigmoidal curves are shown in the following section.

Various published sigmoidal curves

  1. Hartt[1]

    Hartt data, shown in Figure 1 and Table 1, is for zero water flow rate in sea water at 23 to 25 Celsius.

    Figure 1: Long term relationship between current density and potential, after Hartt [1]

    Current density

    [mA/m**2]

    Voltage

    [mV]

    1.06

    -612.81

    8.39

    -621.7

    18.09

    -631.75

    23.33

    -639.46

    31.19

    -651.02

    38

    -662.67

    45.34

    -679.7

    52.15

    -702.22

    56.62

    -726.29

    57.94

    -758.78

    56.12

    -784.75

    52.99

    -809.46

    46.73

    -841.24

    40.72

    -868.91

    33.4

    -899.41

    27.14

    -928.47

    23.48

    -950.51

    21.4

    -964.28

    19.57

    -982.09

    19.06

    -995.72

    19.06

    -1012.02

    20.91

    -1030.88

    24.32

    -1052.32

    28.25

    -1065.57

    31.92

    -1074.77

    37.16

    -1087.91

    45.29

    -1103.53

    Table 1: Long term relationship between current density and potential, after Hartt [1]

  2. Strommen [5]

    Strommen published a paper [5] from which Figure 2 has been duplicated. The extremes of the band in Figure 2 have been extracted and are shown in Figure 3 and Table 2.

    At present we have limited information about the paper (which we are in process of sourcing), but our understanding is as follows…

    The data is for North Sea waters, and was obtained from experimental measurements on a large number of structures. The curve A (in Figure 3) represents low water flow rate conditions, and curve B represents high water flow rate conditions.

    Figure 2: Chart from paper by Strommen [5]

    Figure 3: Extremes of long term relationship between current density and potential, after Strommen[5]

    Curve A

    Curve B

    j(mA/m**2)

    Pot (mV Ag/AgCl/seawater)

    j(mA/m**2)

    Pot (mV Ag/AgCl/seawater)

    37.14

    -672.54

    75.71

    -661.79

    39.52

    -680.90

    77.62

    -667.76

    42.14

    -695.22

    79.05

    -673.73

    43.33

    -710.75

    80.71

    -685.67

    44.76

    -731.04

    82.86

    -702.39

    44.29

    -756.12

    83.57

    -719.10

    42.14

    -790.75

    83.81

    -732.24

    39.76

    -814.63

    83.57

    -747.76

    37.86

    -837.31

    83.10

    -764.48

    36.43

    -857.61

    81.90

    -782.39

    35.48

    -880.30

    79.52

    -800.30

    35.00

    -901.79

    77.38

    -824.18

    34.76

    -919.70

    75.95

    -839.70

    34.76

    -942.39

    74.29

    -867.16

    35.24

    -960.30

    73.33

    -893.43

    36.19

    -974.63

    73.10

    -919.70

    37.38

    -992.54

    73.10

    -938.81

    37.86

    -1000.90

    74.05

    -961.49

    39.29

    -1014.03

    75.24

    -980.60

    41.43

    -1027.16

    76.67

    -996.12

    44.29

    -1043.88

    78.33

    -1006.87

    46.43

    -1055.82

    80.71

    -1021.19

    48.81

    -1066.57

    83.33

    -1034.33

    50.95

    -1076.12

    85.95

    -1043.88

    53.57

    -1086.87

    89.05

    -1053.43

    56.19

    -1096.42

    92.14

    -1062.98

    58.81

    -1103.58

    94.76

    -1071.34

    98.81

    -1080.90

    Table 2: Extremes of long term relationship between current density and potential, after Strommen[5]

    Application of the sigmoidal long-term curve method for no-flow waters

  3. Bare steel surfaces

    The approach is to use a selected "long-term sigmoidal curve" in combination with a pair of matching dynamic polarisation curves to iteratively determine the position on the long-term curve of each part of the structure.

    One of the dynamic polarisation curves represents behaviour with no calcareous deposits, and the other represents behaviour with good calcareous deposits.

    The "no calcareous deposits" dynamic polarisation curve is ideally based on an experimentally measured curve, with potentials adjusted if needed to match the open circuit potential implied by the selected long-term curve.

    To obtain the "good calcareous deposits" dynamic polarisation curve, the current densities of the "no calcareous deposits" dynamic polarisation curve are scaled until the resulting curve passes through the long-term curve at the position of the minimum of current density.

    If there are no calcareous deposits initially, the simulation first uses the "no calcareous deposits" dynamic polarisation curve to determine potential and current density on all parts of the structure.

    The resulting potential at any position on the structure gives an initial indication of the potential and current density which would eventually be reached if calcareous deposits form , and this ‘indication’ is provided by looking for the point on the long-term curve which has the same potential. To reach this point on the long-term curve, the software therefore increases the "amount" of calcareous deposit recorded for the position on the structure (and does this for the entire structure), and then obtains another solution.

    The simulation process is therefore iterative, and mimics the effects of the build-up of calcareous deposits, in the sense that calcareous deposits form first close to the anodes, and the deposits gradually "spread" further from the anodes, but only if the anodes are capable of providing enough current to get past the peak of current density which occurs at about -750 mV.

    If the CP system is well designed, so that the anodes are able to provide enough current, and distance of anodes from the polarising surfaces is suitable, the structure will polarise (ie develop calcareous deposits) so that most of the structure will be at potentials around -950 to -1000mV. Since this corresponds to the minimum of current density on the long-term curve, the "maintenance current" required if the anodes are to maintain the deposits can be small.

    If the anodes are not able to supply enough current the structure (or parts of it) may remain at the maximum of current density on the long-term curve at around -750mV. In this case the anode life may be reduced.

    When the simulation starts from some previously calculated calcareous deposits, the simulation process can mimic the effects of loss of calcareous deposits which may occur as the anodes reduce in size, or as the breakdown factor increases on any coated part of the structure.

    At present the methods used to predict loss of calcareous deposits are rather conservative in the sense that they assume the solution will drift back to the sigmoidal curve whenever the potential changes. In practice it is likely that other conditions are required for loss of calcareous deposits, such as reduction of current density below some critical level, or change of potential to more positive than some critical level.

    By using the "end-of-life" state of the anodes and coating breakdown factor but assuming no initial calcareous deposits, it is possible to determine whether or not the remains of the anodes are able to repolarise a structure in the event that calcareous deposits have been lost (for example as a consequence of a storm).

  4. Coated steel

    If the coating breakdown factor is regarded as a percentage bare area of steel, then the same basic methods can be used for coated surfaces, with the difference that the current densities of the various curves are scaled to take account of the coating breakdown factor.

    This approach seems to be entirely logical for high breakdown factors where presumably significant areas of coating have been completely lost. It also seems a reasonable approach for lower breakdown factors.

    Application of the sigmoidal curve method for tidal waters

    In any tidal area the water flow rate varies continuously throughout each day, and there is generally great geographical and monthly variation in the way flow rate varies with time.

    Consequently it is necessary to adapt the simulation methods so as to achieve:

    • Representative predictions of accumulation of calcareous deposits

    • Representative anode consumption rates and predictions of anode life

    • Representative predictions of the most positive potentials on the structure

    This section describes how these aims are achieved.

  5. Method to determine the build-up of calcareous deposits

    Because of the time-variation of flow rate during the monthly and daily tidal cycle, there are significant periods when the water flow rate will be low, and we make the assumptions that:

    • calcareous deposits will form during these periods of slack water

    • the calcareous deposits will not be removed during the subsequent higher-flow periods

    This allows us to use the methodology described in section 3 to determine the build-up of calcareous deposits on the structure. Presumably the build-up of calcareous deposits on the structure will take longer than for a structure in non-tidal waters, but the simulation simply determines the long-term condition.

    The simulation at zero water flow rate also provides the "best case" potentials on the structure. These potentials occur only at certain times during the tidal cycle.

  6. Method to determine anode life

    It would not be appropriate to use the zero-flow-rate results to predict anode mass loss rate and anode life, because doing so would over estimate anode life.

    Neither would it be appropriate to use the maximum water flow rate, because doing so would under estimate anode life.

    The point is that to achieve some particular potential on a metal requires current density which increases as the water flow rate increases.

    With this in mind, it is clear that anode life should be estimated using polarisation curves which correspond to the average water flow rate, and the water flow rate averaging should be done over at least a full month of tidal cycle.

    In an ideal world we would have experimental dynamic polarisation curves for surfaces with every "amount" of calcareous deposits which occurs on the structure, and at all water flow rates experienced by the structure, but this data is not available.

    The approach taken for a point on the structure is therefore to take the dynamic polarisation curve which corresponds to the "amount" of calcareous deposit (at the point on the structure) at zero water flow rate, and to increase the current densities to allow for non-zero water flow rate.

    Data published by Hack and Guanti [4] provides a scale factor for any selected flow rate, and current densities for the entire dynamic polarisation curve are scaled by the factor.

    Different factors are applied to steel with no calcareous deposits and steel with "good" calcareous deposits. For example the factor at flow-rate 1.2 m/sec is 2.11 with no calcareous deposits and 1.84 with calcareous deposits. Polarisation curves at intermediate flow rates or states of calcareous deposits are interpolated linearly.

    The flow-rate can be defined as a function of depth, so if a flow-rate versus depth profile is available it can be used.

    The simulation at time-averaged water flow rate provides the "time-averaged" potentials on the structure. These potentials occur only at certain times during the tidal cycle.

  7. Method to determine most positive potentials

It would not be appropriate to use the zero-flow-rate results or the "time averaged" results to determine the most positive potentials on the structure, because doing so would suggest that potentials are more negative than they should be.

If we wish to know the most positive potentials on the structure, then we need to use the dynamic polarisation curves which correspond to the highest water flow rates.

The required dynamic polarisation curves are obtained in the same way as described in section 4.2, but obviously using the "time-maximum" water flow rates.

The simulation at time-maximum water flow rate provides the most positive potentials on the structure, and these potentials occur only at certain times during the tidal cycle.

Selecting data

Although the flow-rates corresponding to curve A in Figure 3 is not known, it seems reasonable to use curve A as the long-term "zero flow rate" curve for N. Sea simulation work.

Hack [3] has obtained a dynamic polarisation curve for bare steel with no calcareous deposits under no-flow conditions in warm water. If no better data is available, this source can be used as the "no calcareous deposits" curve mentioned in section 3.

If "time-averaged" water flow rate or a "time maximum" flow rate are not available, it seems reasonable to use mean high water spring flow rates for simulation work.

References

[1] Hartt W.H. and Chen S. "Galvanic anode cathodic polarisation of steel in seawater: Part 3 – Retrofit Cathodic Protection of Offshore Structures". Corrosion June 1999.

[2] Fischer K.P., Sydberger T. and Lye R. „Field testing of deep water cathodic protection on the Norwegian continental shelf". Corrosion March 1987.

[3] Hack H.P. "Atlas of polarisation diagrams for naval materials in seawater". Carderock Division, Naval Surface Warfare Centre, CARDIVNSWC-TR-61-94/44 April 1995.

[4] Hack H.P. and Guanti R.J. "Effect of high flow on calcareous deposits and cathodic protection current density". David Taylor Research Center. DTRC/SME-87/82 April 1988.

[5] Strommen R. "Review of Offshore CP Design Criteria based on In-situ current density measurements". Pages 195-211, Proceedings of the UK Corrosion 1985 Conference, Harrogate, 4-6 November 1985.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Adjust settings while running

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\adjustswhilerunning\adjustswhilerunning.htm

Adjustments that can be performed while running

This feature applies to BEASY CP release dat 04 November 2019 and later

Overview

Keywords which can be placed in the "rootname.cp_wizard_data" file

STOP

APPLY_MAXIMUM_HISTORY_CHANGE: delta_history

ARCHIVE SOLUTION FILES

STOP ARCHIVE SOLUTION FILES

CP CURRENT DENSITY TOLERANCE tolerance1 tolerance 2

TRACK_NODAL_RESULTS element_1 element_2 element_3 … (this line can be repeated multiple times)

Overview

During a very long CP simulation run, it may be the case that you would like to modify settings, for example to change a convergence tolerance, or to turn on or turn off archiving of solution files.

You can achieve this by:

  • creating a file called "rootname.cp_wizard_data"

  • inserting appropriate keywords and data

  • and then copying it to the folder in which the simulation is taking place. It is best NOT to create or edit the file in the folder in which the simulation is taking place, in case the solver attempts to open the file while you are editing it!

The solver will periodically read the file and take appropriate action.

The next section lists the available keywords (and associated required data).

Keywords which can be placed in the "rootname.cp_wizard_data" file

The following are keywords which can be used:

  • STOP

  • APPLY_MAXIMUM_HISTORY_CHANGE: delta_history

  • ARCHIVE SOLUTION FILES

  • STOP ARCHIVE SOLUTION FILES

  • CP CURRENT DENSITY TOLERANCE tolerance1 tolerance2

  • TRACK_NODAL_RESULTS element 1 element 2 element 3 … (this line can be repeated multiple times)

STOP

The effect of this keyword is to make the simulation immediately stop in an orderly way, creating results files as normal. No further attempt is made to achieve convergence, so be aware that results are likely to not be on the polarisation curves, and that if the solution involves calculation of metal voltage, that the metal voltage calculation may not have converged.

This action is useful if convergence is not being achieved, and it is desired to view results so that judgement can be made as to whether poor solution in part of the mesh might be adversely affecting convergence.

APPLY_MAXIMUM_HISTORY_CHANGE: delta_history

This keyword is only relevant if the solution uses one or more long-term curves defined in a file "rootname.longterm.cols.txt". (Use of such a longterm curve requires simultaneous use of a matched pair of potentiodynamic curves).

Since the solution involves interpolation between "history" values 0 and 1 (to represent effects of calcareous deposits), the value of "delta_history" that you define is likely to be a number much smaller than 1. This keyword is useful when convergence of the "history parameter" is poor, or is oscillating back and fore between two values. Too small a value of "delta_history" would have the effect of greatly slowing convergence. The value to be can be judged from the changes of history reported in the log file (look for "calcareous" in the log file to locate reports on convergence of the history parameter).

ARCHIVE SOLUTION FILES

This keyword turns on creation of a set of results files following every solution obtained during the iterative simulation process. This is useful if convergence is poor, and it is desired to view successive results in an attempt to identify which part of the model might be causing the poor convergence.

STOP ARCHIVE SOLUTION FILES

This keyword turns off creation of archived results files.

CP CURRENT DENSITY TOLERANCE tolerance1 tolerance 2

The effect of this keyword is to make the solver change the convergence tolerance (used to assess convergence onto the polarisation curves) to the value of parameter "tolerance1" for non-sigmoidal curves and to the value of parameter "tolerance2" for sigmoidal curves. The fact that a change has been made is reported to the log file using text as follows:

***The CP Wizard data file has defined a tolerance for current density,

   of value= tolerance1 for non-sigmoidal curves present in the .mat_cp file, and

   of value= tolerance2 for sigmoidal curves present in the .mat_cp file

TRACK_NODAL_RESULTS element_1 element_2 element_3 … (this line can be repeated multiple times)

This keyword is used to track behaviour at nodes of selected elements.

The tracking is only performed for models which use a rootname.longterm.cols.txt file.

The keyword can be repeated as many times as required.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Available Results

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\availableresults\availableresults.htm

Available results

Once a model is solved, the results can be visualised/accessed in various ways. The available results are:

Current density

The Current density result is a scalar quantity evaluated at mesh points that refers to the corrosion current density exchanged between the electrode and the electrolyte (i.e. current flowing in the normal direction of the surface exposed to the electrolyte).

Potential

The potential is a scalar magnitude evaluated at mesh points that refers to the polarisation potential distribution on the surfaces exposed to the electrolyte.

Metal Voltage

Metal voltage result gives results different than zero in any of the following cases:

  • If an internal resistance is defined for long and thin cylindrical structures then the IR drop through the conductor is calculated.

  • If the electrical connection between structures is defined with a resistance value different than zero, then the IR drop through the resistance conductor is an output of the CP simulation.

Corrosion Rates and anode expected life

It is possible to obtain results of corrosion rates and mass loss rates of anodic surfaces if the anodes have "sacrificial anode properties" defined.

Results are provided in a tabulated form for each sacrificial anode, reporting:

  • Current

  • Mass consumption rate

  • Remaining life

  • Utilisation Factor, Consumption Factor, Original mass , Condition (i.e. Active/not Active)

This file can be easily imported into Excel

Additional results for models with non-default return path circuit defined

If the model has a non-default return path circuit defined the ditional result files are created by the solver: *.pipelines and *.MVResults.

Results along pipelines

  • *.pipelines gives numeric results for potential, metal voltage and current flowing along a pipeline length.

Results along pipelines

  • *.MVResults gives numeric results for potential in junction boxes, potential at both ends of a resistor and current along resistors.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


GDF File

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\gdf_file\gdf_file.htm

Results in gdf file

Once a model is solved, a file with extension *.gdf is produced which contains detailed results in plain text format; as well as a text based report file (with extension .report) which provides a summary of results per each group involved in the model.

.gdf result file

The .gdf file is a text based file (i.e. can be opened with a text editor or a section can imported into a spread sheet).

Tools to process and extract data from the gdf

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\index\index.htm

BEASY CP Results

Once a model is solved, the results can be visualised directly in GiD (in post-processing mode). In addition, a file with extension. gdf (GDF file) is produced. The GDF file contains detailed results in plain text format organised in blocks of data.

  • Available results

  • Displaying results in 3D interface

  • GDF file

  • Tools to extract and process results from the GDF file

  • Checks to perform after doing a run

  • Modify settings while running

  • Aspects to consider to ensure accurate results

  • CP Solver output files

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Model Checking

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\model_checking\model_checking.htm

Important checks to perform after a run

Check that a solution has been created

Check convergence

If your model has not converged

Warning messages in the log file

Identify locations that may need refinement

Checks on the report file

Current Balance

Results lie on the polarisation curves

Checks on the input data

The checks described in this section are needed to guarantee the accuracy of the solution. Having completed the checks, the results can be assessed from a physical point of view.

Check that a solution has been created

When your solution has completed, you should review the ".log" file that is created by the BEASY CP solver. The log file is located together with the solution files and has the same root file name as the dat file.

You can check the log file using the vertical tabs in the "Solve" tab with CP Model Editor.

If a solution was created you will see the following message in the log file.

Check convergence

Check that your solution has converged. You can do this check by looking at the log file. You can check the log file using the vertical tabs in in the "Solve" tab with CP Model Editor.

If your model has not converged

If your model has not converged, it may be that you need to re-consider aspects on your mesh definition (aspect ratio, distorted elements, elements too close together) or/and refine your mesh in some areas. This is particularly likely in regions close to junctions between different material types.

Warning messages in the log file

You should also check for "Warning" messages in the log file to discard inaccuracies due to distorted elements for example.

You can use the "Search" button shown below to look for warning messages.

Identify locations that may need refinement

If you the checks are not satisfactory, you may be able to identify locations which may need refinement by inspection of the .log file. For each iteration, the log file reports the ID of the mesh point at which current density error is greatest.

If you are using the GiD interface, you can locate a mesh point ID by using the model mesh in the GiD pre-process mode and the command "Signal > Node".

Checks on the report file

Current Balance

After an analysis is finished, you can create a report using "Create Report" in the "Results" tag with the CP Model Editor.

You should check the "Model Current Balance" section. This should be in equilibrium. A small error of a few percent is acceptable.

If there are significant errors in the equilibrium it is highly unlikely that the results are correct.

The difference between the "Current into the model" and "Current out of the model" needs to be small. If this is not the case, you may need to refine the mesh in the model in a particular area.

Also in the "*.log" file there is a section, at the end of the simulation reporting the summation of the current in the system.

Results lie on the polarisation curves

An additional standard check is to confirm that the results (i.e. Normal Current Density and Potential) conform to the polarisation curve specified.

The tool "CP_ResPolCurve" can be used for this check.

Checks on the input data

You can check that zones are complete and normal directions to surfaces are correct using the tool "Model Checking" in the CP Desktop.

You can visit a tutorial showing an example on how to do this.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Tools to process numeric results

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\processnumres\processnumres.htm

Processing Numeric Results

Tools to process and extract data from the GDF file

The GDF file is a text based file containing the numeric results. There are a set of tools provided to extract data from the GDF file.

Tool

Description

CP Create report (Process results from a BEASY GDF file)

This tool is useful for creating automatic and customizable reports on the results obtained by the BEASY-CP solver

CP_CreateReport reads model results and generates a summary of the results in different formats (html, tabulated text and GiD postprocessing results)

This tool is launched by the CP Model Editor (without any argument) to produce the html report summary. Optional arguments allow using the tool to produce results grouping groups and generating different outputs.

CP Report Current

This tool is useful for filtering results from a GDF file and creating custom reports. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

CPReportCurrent reads solution for selected elements from a GDF file and writes them to a plain text file.

Results on Polarisation Curves

This tool is used to filter results based on polarisation curve labels.

CPResPolCurve reads results at mesh elements from a .gdf file and creates one separate report file (in plain text) per each polarisation curve label used in the model

Report Internal Points

This tool is useful for having a quick analysis of the internal points in different zones of the model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

Report_Internal_Points reads all results at internal points from a GDF file and for each zone with internal points, it reports average and extremes of electrolyte potential

Filter Internal Points

This tool is useful for having a quick analysis of preselected internal points in your model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

Filter_Internal_Points extracts results at individually selected internal points from a GDF file and prints them to STD OUT (standard output)

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Visualisation in 3D interface

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\results\result_display\result_display.htm

Visualising Results

To visualise results in GiD you need to open the GiD interface and switch to post-process mode. This is done by selecting "View > Mode > Postprocess":

Then, you must load the results into the GiD environment.

Solution files for GiD are located in your run folder and have extension:

  • *.post.res

  • *.post.msh

To load results, select "Files > Open" and then browse the file with extension .post.res and name same as your model.

  • GiD post-processing mode

  • How to open result files

  • How are layers shown in post-process mode

  • Results in GiD

  • How to change the location of the colour bar

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Theoretical Aspects

BEASY version 21 - CP

Filename: installdir\docs\cp\cp_solver\theoreticalaspects\theoreticalaspects.htm

Theoretical aspects

Cathodic Protection systems

Mathematical Background

Designing a CP system

The driving force of galvanic corrosion in offshore, onshore and marine structures are differences in electrochemical properties of the materials involved. An electric current is induced and the material which acts as the anode is subject to corrosion.

Two common methods used to protect systems from corrosion are galvanic protection and impressed current protection.

Galvanic protection occurs when different metals are introduced into the structure to setup an electric field which will reduce and delay the corrosion of the structure. Impressed current protection occurs when an external power supply is introduced so that anodes positioned close to the structure are supplying a known and controllable current into the system. Like the galvanic system this sets up an electrostatic field which prevents the structure from corrosion.

Both galvanic and impressed current protection systems involve making the structure behave as a cathode and for this reason the process is known as cathodic protection.

Cathodic Protection systems

A cathodic protection system consists of three parts: the structure to be protected (cathode), the anode which provides the protection, and the electrolyte (e.g. sea water). Classically, there are two general types of anodes in normal use: Sacrificial and Impressed Current anodes. The former are usually made of zinc, aluminium alloys or similar materials which are more active in the galvanic series than iron or steel (i.e. the material requiring protection). The sacrificial anode therefore, corrodes in place of the protected structure, Figure 1.

Figure 1: Showing an example of a structure protected with a sacrificial anode

Impressed current anodes apply a potential difference by means of an external power supply, Figure 2.

Figure 2: Showing an example of a structure protected with an ICCP anode

During the electrochemical corrosion process, several anodic (oxidation) and

cathodic (reduction) reactions occur. For example, in an offshore structure, the principle anodic reaction in the corrosion process is:

, (1)

and the principle cathodic reaction is

. (2)

When the structure is placed under the control of a suitable cathodic protection system, the anodic (corrosion) reactions are transferred from the structure to the sacrificial or impressed current anodes. The flow of current is reversed by this electrochemical process and the structure surface becomes the cathode upon which reaction (2) occurs. In the case of sacrificial anodes, the anode metal simply dissolves due to the inherent potential difference between the anodes and the structure.

However, using "inert", impressed current anodes, causes a gas evolution reaction (i.e. hydrogen) to occur on the anode (without loss of material) and the familiar protective, cathodic reaction occurs on the structure. A further important concept in cathodic protection is that there is a minimum potential (thermodynamically reversible potential) which must be exceeded before any reaction occurs (and consequently before any current can flow). To describe a cathodic protection system mathematically, not only must the equations which represent the flow of current through the medium (e.g. sea water) be developed but also the equations which represent the electrode reactions.

Mathematical Background

For a uniform, isotropic medium, the flow of current can be shown to obey the Laplace equation, which imposes electro-neutrality in the bulk of the electrolyte:

in W, (3)

where u = potential and k = conductivity , together with

, (4)

where j = current density.

The volume containing the bulk of the electrolyte is considered to be the integration domain (W), and its boundary G is given by the set of all surfaces surrounding it. Depending on the nature of these surfaces different boundary conditions are introduced. For example, active electrodes (e.g. with anodic or cathodic behaviour) in contact with the electrolyte introduce "polarising boundary conditions" of the form:

in G, (5)

where jn is the current density component normal to the surface and f(u) is a function of the potential u on the surface of the electrode representing its polarisation curve.

This function is known for a given material in certain environmental conditions, and can be obtained for example from potentiodynamic tests.

A fixed potential condition yields:

in G, (6)

where U is a known function on the surface G representing its potential.

Surfaces with fixed known normal current density introduce the constraint:

in G, (7)

where J is a known function on the surface G, representing the normal current density. In particular, insulating surfaces introduce the condition expressed in eq. (7) with J = 0.

Finally, modelling a CP system consists essentially of solving equations (3) to (7) simultaneously, in order to find u and j in the regions of interest for a particular model.

In general, for an arbitrary geometry, the solution to this problem cannot be expressed as a closed simple mathematical expression. Only special cases with particular symmetry properties can, but these cases do not usually appear in industrial applications. Far from it, for almost any practical application, solving these equations requires robust numerical methods and computer power.

The main focus of the BEASY software for CP modelling is solving these equations for arbitrary geometries in three or two dimensional space by means of the Boundary Element Method (BEM).

Designing a CP system

When designing a cathodic protection system the engineer must calculate for the galvanic system the size and position of different material parts so as to achieve the desired voltage and current distribution and similarly for impressed current applications the positions and current supplied by the introduced anodes. The ideal is to have the whole structure cathodic and within a known range of voltages which for some marine applications is around -0.8V to -1.0V.

===============================End of document=========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Installation and SetUp

BEASY version 21 - CP

Filename: installdir\docs\cp\gettingstarted\cp_installation\cp_installation.htm

BEASY CP installation guide

Welcome to BEASY CP.

Please read these instructions carefully before starting the installation process.

Introduction

This document firstly identifies the system resources required to install and use BEASY products.

Secondly there is a section which shows you how to install the BEASY CP

Next there are sections showing you how to provide us with the information which we need in order to provide you with appropriate licence files.

Next there is a section which shows you how to test that your installation is working correctly.

Finally, there is a section that shows how to access the supporting documentation which is installed at the same time as the software.

In addition, there is an appendix with background information providing additional details about how the BEASY Licence Manager works.

Notice

CM BEASY has prepared this document for use by licensees and customers. The information contained herein is the property of CM BEASY and shall neither be reproduced in whole or in part without prior written approval from CM BEASY. CM BEASY reserves the right to make changes without notice in the specifications and materials contained herein and shall not be responsible for any damages (including consequential) caused by reliance on the materials represented, included but not limited to typographical, arithmetic or listing errors.

© CM BEASY (2020)

Ashurst Lodge

Ashurst

Southampton

Hampshire

SO40 7AA

England

Tel. Southampton: +44 (0)2380 293223

Fax: Southampton:+44 (0)2380 292853

25 Bridge Street

Billerica MA 01821

USA

Tel: Billerica: (1) 978 667 5841

Fax: Billerica: (1) 978 667 7582

Email: info@beasy.com

All rights reserved

If this software is furnished to a Department of Defence Agency, the following applies:

Restricted Rights Legend

Use, duplication or disclosure by the Government is subject to restrictions as set forth in sub-division (b)(3)(ii) of the Rights in Technical Data and Computer Software Clause at 52.227-7013, Computational Mechanics Inc, 25 Bridge Street, Billerica, MA 01821, USA.

If this software is furnished to the National Aeronautics and Space Administration the following applies:-

Restricted Rights Notice

This computer software is submitted with restricted rights. Use, duplication or disclosure is subjected to restriction as set forth in NASA FAR SUP 18-52.227-79 (April 1985). If the contract contains the clause at 8-52.227-74 "Rights in Data - General" then the "Alternate III" clause applies.

Contents

Introduction

Resources required to install and use BEASY

Hardware

Operating System

Other software

Installation instructions

Starting installation

Installing the License Manager Software

Installing JAVA

Installing the BEASY Product

License set up

How to provide us with information which we need in order to provide you with appropriate license files

Node-locked license for a BEASY product

Floating license for a BEASY product

Dongle-locked license for a BEASY product

How to Use your licenses

Node-locked licence for a BEASY product

Prepare the licence file

Set up the licence service

Floating licence for a BEASY product

How to set up the licence service on the BEASY licence server computer

Prepare the licence file

Set up the licence manager service

On the client machine

Dongle-locked licence for a BEASY product

Installing the dongle-driver software

Insert the dongle, and check that the licensing software recognises it

Set up a licence service on the computer

Licence service troubleshooting

How to interpret error messages from the licence manager

What to do if you cannot start or stop the licence service

What processes should there be running when the licence service is operating?

Test the installation

BEASY CP Help

Appendix: Background information

How the FLEXlm-based licensing works

Resources required to install and use BEASY

This section identifies the hardware and software which is required to install and use BEASY and its associated software.

Hardware

Your computer must have an Ethernet card, because it is used for most types of licensing of BEASY products.

Your machine must have a 64 bit operating system.

The pre and postprocessors use openGL to display models, so the graphics card in your computer should support openGL.

The disk space required to install BEASY may be as much as 650 Mbytes, and the installation is usually made to the "Program Files".

The disk space required while you are using BEASY depends considerably on the type and size of the models which you create, but as a general guide we suggest that you have available at least 100 Gigabytes of disk space.

The memory suggested for satisfactory use of BEASY products is at least 8 gigabytes

Operating System

The operating system must be Windows 7 or more recent. This applies to a computer on which you wish to use BEASY and for a computer which you wish to use as a license server.

Other software

BEASY CP documentation has been constructed using html, and so a browser must be installed. The documentation has been tested using Microsoft Internet Explorer, Google Chrome and Microsoft Edge.

Installation instructions

This section contains instructions for the installation of BEASY products on your computer. You should have already read the previous section giving the requirements for installing and using BEASY and you should have ensured that your computer facilities are adequate.

Starting installation

BEASY software is usually supplied by ftp download. This document assumes you have already downloaded and extracted the zip file.

After extraction, there should be a folder with a name similar to "BEASY21.03.001_CP". Before proceeding, make sure this folder is located in the "C" drive of the machine on which you wish to install BEASY CP.

If the folder is not on the C: drive, the installation may fail with a message such as "Error 1305. Error reading from file".

To install BEASY CP, navigate to the folder which contains the installation data (as identified above) and:

  • Start the installation process by running file "bMenu.exe"

  • Note that this installation process requires administrator privileges.

  • You may be able to right-click on the file and select "Run as Administrator", or you may need to log in as Administrator.

The "BEASY install window" will appear on your screen similar to Figure 1.

Select "Install License Manager" only when installing the first BEASY version 21 product and if the license manager is required on this machine. For example:

  • If you have already installed another BEASY version 21 product and at that time installed the License Manager you don't need to select "Install License Manager"

  • If you ordered a floating license you don't necessarily need to install the License Manager on the machine where you are installing the BEASY version 21 software.

Figure 1 BEASY CP Installation window. The "Help" button brings up this document

When you press the "Install" button on the dialog, the checked components are installed. During each installation, you will need to make selections, for example destination folder (note it is generally best to use the default), and confirm acceptance of license agreements.

Installing the License Manager Software

If you haven't already installed it while installing other BEASY version 21 product, you need to install the License Manager.

  1. Node-locked license: If you have ordered a node-locked license for a BEASY product, you need to choose the single computer on which you wish to use BEASY and install the License Manager in that computer.

  2. Floating license: If you have ordered a floating license for a BEASY product, you will need to choose a single computer which will act as a license server to all other machines on which BEASY will be used

    You only need to install the BEASY license manager on this license server machine.

  3. License locked to a dongle: If you have ordered a license which is locked to a dongle, you will need to install the BEASY product and the License Manager on the machine you have selected.

When installing any BEASY product, you will need to accept the License agreement (as shown in figure 2), otherwise installation cannot continue.

Figure 2 License Agreement

The destination folder for the installation is generally "C:\Program Files\beasy" and the license manager software will be installed inside this in a subfolder such as "beasy21 beasy21\license", which is automatically created.

Figure 3 Destination Folder

If the BEASY License Manager is already installed, you will not be able to install it a second time

Installing JAVA

If you are installing JAVA first accept the licence agreement " and press "Install" as shown in Figure 4.

Figure 4 Java installation

Installing the BEASY Product

When installing any BEASY product, you will need to accept the License agreement, otherwise installation cannot continue.

Figure 5 License agreement

The destination folder for the installation is generally "C:\Program Files\beasy" (see Figure 5) and the software will be installed inside this in a subfolder such as "beasy21", which is automatically created.

You should install all BEASY21 software to the same location, and we recommend that this should be the default location "C:\Program Files\beasy\beasy21".

Figure 6 Destination Folder

License set up

This section shows how to set up the license for the BEASY product you ordered.

How to provide us with information which we need in order to provide you with appropriate license files

This section shows you how to find the information which we need so that we can create and send you a license file.

The information depends on the type of licenses you have ordered, so before proceeding, make sure you know what you have ordered!

You should follow the instructions and then send the required data by email to info@beasy.com.

Node-locked license for a BEASY product

If you have ordered a node-locked license for a BEASY product, you need to choose the single computer on which you wish to use BEASY.

This "node-locked computer" will act as its own license server.

To collect the required data about the "node-locked computer" please do both of the following (as this allows us to correctly select the appropriate hostid):

  1. Firstly:

    • Create a command shell

    • In the command shell type the command:

    ipconfig/all > nodelockedcomputer.txt

    • Send the "nodelockedcomputer.txt" file created to us by email.

  2. Secondly:

  • Navigate to the folder "C:\Program Files\beasy\beasy21\license

  • Run file "lmtools.exe"

  • Go to the "System Settings" tab

  • Press the button "Save HOSTID Info to a File"

  • Enter file name "nodelockedhostid.txt"

  • Send the file "nodelockedhostid.txt" file created to us by email.

Floating license for a BEASY product

If you have ordered a floating license for a BEASY product, you will need to choose a single computer which will act as a license server to all other machines on which BEASY will be used.

This means that the license server will run a service, waiting for other machines to request a license to use a BEASY product.

Since the requests are made through your local intranet, it is essential that the license server computer is accessible to all computers on which BEASY will be used. Licensing cannot work if the license server is on a completely different network!

To collect the required data about the license server please do both of the following (as this allows us to correctly select the appropriate hostid):

  1. Firstly:

    • Create a command shell

    • In the command shell type the command:

    ipconfig/all > licenseservercomputer.txt

    • Send the "licenseservercomputer.txt" file created to us by email.

  2. Secondly:

  • Navigate to the folder "C:\Program Files\beasy\beasy21\license

  • Run file "lmtools.exe"

  • Go to the "System Settings" tab

  • Press the button "Save HOSTID Info to a File"

  • Enter file name "licenseserverhostid.txt"

  • Send the file "licenseserverhostid.txt" file created to us by email.

Dongle-locked license for a BEASY product

If you have ordered a dongle-locked license for a BEASY product, you can use BEASY on any computer into which you can plug the USB dongle. Note that only dongles provided by BEASY can be used.

The computer will act as its own license server.

You don't need to send us any information about the computer.

How to Use your licenses

This section shows you how to use the licence files which you receive from info@beasy.com.

The procedures depend on the type of licences you have ordered, so make sure you choose the procedure which corresponds to each licence file!

It is very important that the tasks described here are performed either by a user with "administrator" privileges or by the "administrator" user. The licensing system may not work if you do not follow this rule!

In cases where a licence is obtained by communications involving an Ethernet card, it is essential that you modify any firewall to allow the necessary communications to take place. Cases where this is required include GiD floating licences, BEASY node-locked licences, BEASY floating licences and BEASY licences locked to a dongle.

It is important that for a BEASY node-locked licence the Ethernet card is not turned off, for example by power-saving settings.

In the following text, when discussing locations of installed BEASY products and where to put files, reference will be made to folder "C:\Program Files\beasy\beasy21". You should interpret this to be the folder into which you have installed BEASY on your computer.

Node-locked licence for a BEASY product

To use the BEASY node-locked licence (which is Flexlm-based), you must:

  • Prepare the licence file.

  • Set up a licence service on the single computer on which you wish to use BEASY (the licence file you have been sent will not work on any other computer). Details on how to do this are shown in the following section "Set up the licence service"

All of the following instructions should be performed on the single computer on which you wish to use BEASY. You should already have installed BEASY on this computer.

You should perform these steps in the order shown.

Prepare the licence file

  1. Copy the licence file to the folder "C:\Program Files\beasy\beasy21\license".

    The licence file has extension ".lic" – it is important that you do not change this!

  2. Edit the licence file to identify the location of the "beasyd.exe" executable.

To do this, first locate the line which begins with the word "VENDOR". This line will take the form shown below (note the version number of BEASY and the installation folder may be different):

VENDOR beasyd "C:\Program Files\beasy\beasy21\license\beasyd.exe"

If the path shown on this line in your licence file does not correspond to the installed location of the "beasyd.exe" file on your BEASY licence server, (ie "C:\Program Files\beasy\beasy21\license\beasyd.exe") you must edit the file to insert the correct path.

Note that most lines in the licence file must not be changed at all - if you change such a line, the licensing system will refuse to issue a licence to you!

Set up the licence service

To set up and start the service, perform the following tasks (when logged-in with Administrator privileges):

  1. Run lmtools.exe (located in folder "C:\Program Files\beasy\beasy21\license")

  2. Go to the "Service/License file" tab as shown below. Select the radio button labelled "Configuration using Services"

  3. Now go to the "Config Services" tab, which initially appears as follows:

    • Enter "BEASY license service" in the "Service Name" edit field (the exact form of this name is not critical)

    • Define the "Path to the lmgrd.exe file". You can do this most easily by using the "Browse" button. The "lmgrd.exe" file supplied with BEASY is in the folder "C:\Program Files\ beasy\beasy21\license".

    • Define the "Path to the license file". You can do this most easily by using the "Browse" button. The licence file is usually stored in the folder "C:\Program Files\ beasy\beasy21\license".

    • Define the "Path to the debug log file". You can do this most easily by using the "Browse" button. The debug log file can be stored anywhere you like. For example you can choose to store it in the folder "C:\Program Files\ beasy\beasy21\license". As the licence server debug log file does not yet exist, navigate to the folder you require, and then enter the filename you want to use, for example "flex.log". Note that you may need to allow "write permission" to this folder. Alternatively, you could locate the flex.log file in a folder such as "C:\Program Data\BEASY"

    • Select the "Use Services" check box

    • If you wish the service to start automatically at power-up, select the "Start Server at Power Up" check box. Note this is the recommended setting.

    • At the completion of the above steps, the "Config Services" tab might appear as shown below.

    • Press the "Save Service" button to save details of the service you have defined. If you do not have "administrator" privileges you will not be able to save the service!

  4. Go to the "Start/Stop/Reread" tab.

    • If more than one service is listed in the "Flexlm license Services installed on this computer" listbox, select the "BEASY license service" which you earlier defined.

  5. Press the "Start Server" button. This should result in appearance of text "Server Start Successful" in the report field on this tab (circled in red in the image below).

    The service has now been defined and started.

  6. After starting the server it is useful to check the service is running correctly, and identify any problems, as follows:

  • Go to the "Config Services" tab

  • Select the "BEASY license Service" in the "Service Name" list (use the button to access the drop down list if necessary)

  • Press the "View Log" button

  • Scroll down the file viewer to see the actions performed. It is here that you will be able to identify expired licences, corrupted licence files, and any other problems.

  • When you have finished viewing the log file, press the "Close Log" button

  • This procedure can be used at any time to help diagnose problems which may be occurring.

Floating licence for a BEASY product

To use the BEASY floating licence (which is Flexlm-based), you must:

  • Set up a licence service on the computer on which you have selected to act as a BEASY licence server. Details on how to do this are shown in the next section.

  • Then for each computer on which you wish to use BEASY, you must identify how the computer should contact the licence server. Details on how to do this are shown in the following section "On the client machine"

How to set up the licence service on the BEASY licence server computer

You should first install the BEASY licence server on the computer which you have selected to act as the BEASY licence server. Installation is described in an earlier section.

Next, you should perform the following steps, in the order shown. The following instructions should be performed on the computer which you have selected to act as the BEASY licence server.

Prepare the licence file

  1. Copy the licence file to the folder "C:\Program Files\beasy\beasy21\license".

    The licence file has extension ".lic" – it is important that you do not change this!

  2. Edit the licence file to identify the location of the "beasyd.exe" executable.

To do this, first locate the line which begins with the word "VENDOR". This line will take the form shown below (note the version number of BEASY and the installation folder may be different):

VENDOR beasyd "C:\Program Files\beasy\beasy21\license\beasyd.exe"

If the path shown on this line in your licence file does not correspond to the installed location of the "beasyd.exe" file on your BEASY licence server, (ie " C:\Program Files\ beasy\beasy21\license\beasyd.exe") you must edit the file to insert the correct path.

Note that most lines in the licence file must not be changed at all - if you change such a line, the licensing system will refuse to issue a licence to you!

Set up the licence manager service

To set up and start the service, perform the following tasks (when logged-in with Administrator privileges):

  1. Run lmtools.exe (located in folder "C:\Program Files\beasy\beasy21\license ")

  2. Go to the "Service/License file" tab as shown below. Select the radio button labelled "Configuration using Services"

  3. Now go to the "Config Services" tab, which initially appears as follows:

    • Enter "BEASY license service" in the "Service Name" edit field (the exact form of this name is not critical)

    • Define the "Path to the lmgrd.exe file". You can do this most easily by using the "Browse" button. The "lmgrd.exe" file supplied with BEASY is in the folder "C:\Program Files\beasy\beasy21\license".

    • Define the "Path to the license file". You can do this most easily by using the "Browse" button. The licence file is usually stored in the folder "C:\Program Files\beasy\beasy21\license".

    • Define the "Path to the debug log file". You can do this most easily by using the "Browse" button. The debug log file can be stored anywhere you like. For example you can choose to store it in the folder "C:\Program Files\beasy\beasy21\license ". As the licence server debug log file does not yet exist, navigate to the folder you require, and then enter the filename you want to use, for example "flex.log". Note that you may need to allow "write permissions" to this folder. Alternatively, you could locate the "flex.log" file a folder such as "C:\ProgramData\BEASY"

    • Select the "Use Services" check box

    • If you wish the service to start automatically at power-up, select the "Start Server at Power Up" check box. Note this is the recommended setting.

    • At the completion of the above steps, the "Config Services" tab might appear as shown below.

    • Press the "Save Service" button to save details of the service you have defined. If you do not have "administrator" privileges you will not be able to save the service!

  4. Go to the "Start/Stop/Reread" tab.

    • If more than one service is listed in the "Flexlm license Services installed on this computer" listbox, select the "BEASY license service" which you earlier defined.

  5. Press the "Start Server" button. This should result in appearance of text "Server Start Successful" in the report field on this tab (shown circled in red in the image below).

    The service has now been defined and started.

  6. After starting the server it is useful to check the service is running correctly, and identify any problems, as follows:

  • Go to the "Config Services" tab

  • Select the "BEASY license Service" in the "Service Name" list (use the button to access the drop down list if necessary)

  • Press the "View Log" button

  • Scroll down the file viewer to see the actions performed. It is here that you will be able to identify expired licences, corrupted licence files, and any other problems.

  • When you have finished viewing the log file, press the "Close Log" button

  • This procedure can be used at any time to help diagnose problems which may be occurring.

On the client machine

For each computer on which you wish to use BEASY, you must identify how the computer should contact the licence server.

You should first install BEASY on the computer on which you wish to use BEASY. Installation is described in an earlier section.

Then copy the licence file to the folder "C:\Program Files\beasy\beasy21\bin".

Now when you run a BEASY product, the product will read the licence file. The first line of a floating licence file takes the form:

SERVER mycomputer myhostid

The first line identifies the BEASY licence server computer using the name by which it is known on your network ("mycomputer" in this case). If required you can edit your licence file to replace the name of your licence server with its IP number.

Do not delete or modify the remainder of the first line.

The second line of a floating licence file takes the form:

USE_SERVER

This line indicates to the BEASY application that it should contact the licence server to obtain a licence.

Provided the BEASY licence server is already running the BEASY licence service, you should now be able to use the BEASY products which you have licensed.

Dongle-locked licence for a BEASY product

To use the BEASY dongle-locked licence (which is Flexlm-based) you must, on the selected machine, perform the following steps in the order shown:

  • Install the BEASY licence manager software (you may have done this at the same time as installing the BEASY product)

  • Install the dongle-driver software

  • Restart the computer

  • Insert the dongle, which was supplied by BEASY, into a USB slot on the machine

  • Set up a licence service on the computer

Installing the BEASY licence manager software was described in an earlier section.

The other tasks are described in the following sections:

Installing the dongle-driver software

  • Navigate to the installation folder "C:\Program Files\beasy\beasy21\license\dongle", where you will see a number of files.

  • Select, and run (as administrator) the file "Setup64.exe". Note that:

  • The drivers are installed in "C:\Program Files (x86)"

  • You should use defaults on all panels which appears during installation

  • Now restart the computer

Warnings:

  • Do not plug the BEASY-supplied dongle into the machine before installing the dongle-driver software. The reason for this is that if you do, Windows may automatically install inappropriate drivers, and this may prevent correct functioning of the dongle.

  • Do not forget to restart the machine, as not restarting may prevent correct functioning of the following steps.

Insert the dongle, and check that the licensing software recognises it

Now insert the BEASY-supplied dongle into one of the USB slots on the computer.

Windows should react and display (briefly) a window similar to that shown below.

To check that the dongle is recognised by the BEASY licensing software on the machine:

  • Navigate to folder "C:\Program Files\beasy\beasy21\license"

  • Select, and run (as administrator) the file "lmtools.exe"

  • If the dongle is recognised by the licensing software, you should see a text string (which corresponds to the ID printed on the dongle) similar to that shown circled in red in the figure below. If you do not see this text string, then you may need to uninstall the dongle drivers and repeat the process.

Set up a licence service on the computer

To set up and start the service, perform the following tasks (when logged-in with Administrator privileges):

  1. Run lmtools.exe (located in folder "C:\Program Files\beasy\beasy21\license")

  2. Go to the "Service/License file" tab as shown below. Select the radio button labelled "Configuration using Services"

  3. Now go to the "Config Services" tab, which initially appears as follows:

    • Enter "BEASY license service" in the "Service Name" edit field (the exact form of this name is not critical)

    • Define the "Path to the lmgrd.exe file". You can do this most easily by using the "Browse" button. The "lmgrd.exe" file supplied with BEASY is in the folder "C:\Program Files\beasy\beasy21\license".

    • Define the "Path to the license file". You can do this most easily by using the "Browse" button. The licence file is usually stored in the folder "C:\Program Files\beasy\beasy21\license".

    Define the "Path to the debug log file". You can do this most easily by using the "Browse" button. The debug log file can be stored anywhere you like. For example you can choose to store it in the folder "C:\Program Files\beasy\beasy21\license". As the licence server debug log file does not yet exist, navigate to the folder you require, and then enter the filename you want to use, for example "flex.log". Note that if you use this location, you may need to allow "write permissions" to this folder. Alternatively you could locate the flex.log file in a folder such as "C:\ProgramData\BEASY".

    • Select the "Use Services" check box

    • If you wish the service to start automatically at power-up, select the "Start Server at Power Up" tick box. Note this is the recommended setting.

    • At the completion of the above steps, the "Config Services" tab might appear as shown below.

    • Press the "Save Service" button to save details of the service you have defined. If you do not have "administrator" privileges you will not be able to save the service!

  4. Go to the "Start/Stop/Reread" tab.

    • If more than one service is listed in the "Flexlm license Services installed on this computer" listbox, select the "BEASY license service" which you earlier defined

  5. Press the "Start Server" button. This should result in appearance of text "Server Start Successful" in the report field on this tab (circled in red in the image below)..

    The service has now been defined and started.

  6. After starting the server it is useful to check that the service is running correctly, and to identify any problems, using techniques as follows:

  • Go to the "Config Services" tab

  • Select the "BEASY license Service" in the "Service Name" list (use the button to access the drop down list if necessary)

  • Press the "View Log" button

  • Scroll down the file viewer to see the actions performed. It is here that you will be able to identify expired licences, corrupted licence files, and any other problems.

  • When you have finished viewing the log file, press the "Close Log" button

  • This procedure can be used at any time to help diagnose problems which may be occurring

Licence service troubleshooting

How to interpret error messages from the licence manager

In the event that you cannot obtain a licence when running BEASY software, explanatory messages are passed to a file, which is called for example:

  • "%USERPROFILE%/PolCurveX.log" for PolCurveX

  • "%USERPROFILE%/BEASY_GiD.log" for the GiD problem type

where "%USERPROFILE%" is the user space C:/users/username

  • "rootname.log" for the CP solver

  • "rootname_CPBuilder.log" for the CP Builder

Where "rootname" is the model name given by the user

If in such a file you see the message:

***Error: Cannot issue a licence. Diagnostic information follows...

No such feature exists.

the problem could be simply that you have not put a licence file in one of the required folders which include:

  • C:\Program Files\beasy\beasy21\license

  • C:\Program Files\beasy\beasy21\bin

What to do if you cannot start or stop the licence service

In the event that:

  • You are unable to start the licence service (and get a message like "VD is starting, please check vendor daemon's status in debug log")

  • You are unable to stop the licence service, (as shown in the image below)

  • You get a message like "FlexNet Licensing error:-15,10. System Error: 10061 "WinSock: Connection refused""

there are a number of things you can do to get over the problem, as shown below.

Firstly, go to the Service/License File tab in lmtools.exe, and make sure that "LMTOOLS ignores licence file path environment variables" is checked.

Secondly, make sure that the BEASY licence service is configured as a Local System account.

To do this on Windows 7 follows steps as shown in the series of images below.

Having completed the steps below, you should be able to start and stop the service using lmtools.exe.

Figure 7: Select "Administrative tools"

Figure 8: Select "Services"

Figure 9: Select the BEASY V 21 licence service which you have set up

Figure 10: Go to "Properties"

Figure 11: Select "Local System account", and then press "Apply", then press "OK" and close the services dialog

What processes should there be running when the licence service is operating?

As shown in the image below, when the BEASY 21 licence service is running you should be able to see processes "beasyd.exe" and "lmgrd.exe" in the "Processes" tab of "Windows Task Manager" (but make sure you have checked "Show processes from all users").

Test the installation

After installing the BEASY CP product an icon will appear in your Windows desktop as shown below.

By double clicking on the icon, the BEASY CP Desktop will open:

The BEASY CP Desktop gives you access to the different tools required for modelling.

If the licence is set up, you are ready to start using BEASY CP. Double click on any of the icons to launch BEASY CP applications.

BEASY CP Help

The BEASY CP documentation is located in folder:

C:\Program Files\beasy\beasy21\docs\CP

The documentation can be accessed either:

  • by directly using a browser to open the file:

C:\Program Files\beasy\beasy21\docs\CP\beasycp.main.htm

  • or by using the icon "CP Help" from the BEASY CP desktop.

Appendix: Background information

This section contains background information.

How the FLEXlm-based licensing works

When a BEASY application is running, it looks for licence file data in the folder that contains the executable file.

For a network licence, the licence file identifies the machine that is acting as the licence server. The application issues a request to the licence server machine, and if the licence daemon is running on the licence server, it eventually issues a licence.

Note however that the licence daemon will only issue a licence (or "check-out" a licence) if the count of "simultaneously in-use" licences for the product is less than the total number of licences available in the licence data.

The licence daemon will only issue a licence if the requested product and version is present in the licence data on the server.

The licence daemon will only issue a licence if the licence for the requested product and version in the licence data on the server has not expired. All requests made to the licence daemon on the licence server are recorded in the licence server log file.

When a BEASY application terminates, it notifies the licence server, and the licence becomes available to other users.

Throughout use the BEASY application maintains contact with the licence server. If contact is lost and cannot be regained, the application will terminate.

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Help and Support

BEASY version 21 - CP

Filename: installdir\docs\cp\gettingstarted\help_support\help_support.htm

BEASY CP

Documentation

Documentation is installed with the software locally in the folder:

"C:\Program Files\beasy\beasy21\docs\CP"

The documentation can be accessed either by directly using a browser to open the file:

C:\Program Files\beasy\beasy21\docs\CP\beasycp.main.htm

or by using the icon "CP Help" from the BEASY CP desktop.

Help and support

For further information please contact us on info@beasy.com

Ashurst Lodge, Ashurst,

Southampton, SO40 7AA, UK

Tel: 44 (0) 2380 293223 Fax: 44 (0) 2380 292853

25 Bridge Street,Billerica MA 01821, USA

Tel: 978 667 5841 Fax: 978 667 7582

BEASY (TM) www.beasy.com

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Release Notes

BEASY version 21 - CP

Filename: installdir\docs\cp\gettingstarted\releasenotes\releasenotes.htm

BEASY CP

Release Notes (BEASY_21.03.002_CP)

This section provides a summary of improvements to the BEASY CP Software compared to the previous release (BEASY_21.03.001_CP).

  • Correction of bug related to internal point calculation in a zone containing tube elements.

  • Updated reporting tool "CP_CreateReport". The new version gives more detailed results for models with dual elements.

Release Notes (BEASY_21.03.001_CP)

This release introduces a completely new and improved way of defining data which is applied to geometric features in the model. This release of BEASY CP coincides with release of a new BEASY_GiD "problem type" which is greatly simplified and supports GiD14. This problem type exports a mesh file which can be imported into the CP Model Editor.

A set of new interfaces have been included:

  • CP Model Editor,

  • Model Checking Tools,

  • Process Results form a GDF File

  • IP Editor

Several new tools for manipulation of results and polarisation data are provided.

New features have been added to the "MatViewer" interface.

In addition, it introduces new features and a set of improvements to the CP Solver

New Features

"CP Model Editor" interface:

The CP Model Editor is an interface that provides a canvas for model creation, and management, introducing the possibility to aggregate different meshes and defining/editing model data and model parameters independently. In this way,

  • model geometry can be changed/updated independently from the physical parameters applied to it

  • the model geometry can be created in different sub-models, allowing users to integrate or take away part of it without having to regenerate the full set of pre-processing data or revise an existing sub-model again.

  • New model parts can be integrated with an existing model without needing to regenerate previously defined modelling information such as polarisation properties or networks of electrical connections.

  • One instance of model geometry can be created and the associated mesh can be used applying geometrical transformations to generate several instances of that geometry at different locations/orientations without a need to re-create the geometry.

The CP Model Editor provides:

  • Imported meshes tool: to import/remove/edit meshes and apply mesh transformations

  • Imported polarisation data tool: to import a mat_cp file with polarisation data

  • Units used in the simulation: A tool to define model units.

  • A section for modelling notes

  • A window showing a summary of the defined zones indexes and names.

  • A series of tabs to define/edit model properties, such as polarisation data, sacrificial anode properties and definition of a non-return path circuit.

  • A tab to define groups of internal points of single points, lines or surfaces.

  • A tab to create the BEASY model in which the CP Builder is launched and model creation reports are visible with search options to check for warnings or model errors.

  • A tab to launch the CP Solver and run an analysis

  • Tabs to inspect the CP Solver log files

  • A tab to create and visualise a report of results

Additional features of the CP Model Editor include:

  • Once the model properties are defined, and "Create model" is selected, a series of checks are performed on the model

  • A number of model parameters (for example conductivity/resistivity or sacrificial anode capacity) can be entered in a set of different units. They will be internally converted at the moment of writing the model files to the "units used in the simulation".

  • Units in the loaded mat_cp file will be automatically converted to the "units used in the simulation".

"Model Checking tools" interface

The Model Checking tools is an interface that facilitates model checking. In particular, it allows you to inspect completeness of zones and normal orientations defined in a dat file.

"IP Editor" interface

The IP Editor is used to find solutions at additional internal points for a BEASY model that has already been solved. It allows for the addition of internal points and the creation of groups of points, lines and surfaces.

"Process Results from a BEASY GDF file" interface

This is an interface dedicated to results reporting for BEASY-CP which reads model results (primarily from the .gdf file generated by the BEASY-CP solver "beasyand.exe") and generates a summary of the results in different formats (html, tabulated text and GiD post-processing results).

"CP Create report" tool

This tool is useful for creating automatic and customisable reports of the results obtained by the BEASY-CP solver. Many of its outputs can be generated using the interface "Process Results from a BEASY GDF file". Additional functionality can be obtained by invoking the tool CP_CreateReport. For html, tabulated text and/or GiD post-processing results format, it can be used with special options to generate reports for sub-sets of groups, merged groups, etc.

"Report Current" tool

This tool is useful for filtering results from a GDF file and creating custom reports. Analysis can also be performed in a systematic way for several models. CPReportCurrent reads solutions for selected elements from a GDF file and writes them to a plain text file.

"Results on Polarisation Curves" tool

This tool is used to filter results based on polarisation curve labels. CPResPolCurve reads results at mesh elements from a .gdf file and creates one separate report file (in plain text) for each polarisation curve label used in the model

"Report Internal Points" tool

This tool is useful for providing a quick analysis of the internal points in different zones of the model. Users can also run analysis of several models in a systematic way by placing the instruction in a Windows batch file.

Report_Internal_Points reads all results at internal points from a GDF file and for each zone with internal points, it reports average and extremes of electrolyte potential

"Filter Internal Points" tool

This tool is useful for providing a quick analysis of preselected internal points in a model. Analysis can also be performed of several models in a systematic way. Filter_Internal_Points extracts results at individually selected internal points from a GDF file and prints them to STD OUT (standard output)

"MatCP2Pol" tool

This tool is useful in order to extract the polarisation data in a matfile (*.mat_cp). MatCP2Pol reads a *.mat_cp file and outputs an ASCII file listing current density and potential for the list of the polarisation curves in the matfile.

"Pol2MatCP" tool

This tool is useful in order to create a matfile (*.mat_cp) from potential and current density pairs. Pol2MatCP reads a *.pol ASCII file and outputs a matfile.

"ListGroups" tool

This tool reads a BEASY-CP .dat file and reports the list of groups appearing in the "PRIVATE DATA FOR GROUPS TOOL" section, together with the properties associated to it, to a text file. ListGroups is useful for interpreting the data stored in a .dat file.

New features added to the "MatViewer" interface

  • New button to launch the plotting function "Plot Polarisation Curve"

  • A new worksheet called "About" has release version information

  • Multiple selected polarisation curves (or all curves in the mat_cp file) can be selected at once.

"CP Builder" tool

This release introduces a completely new and improved way of defining data which is applied to geometric features in the model. The new "CP Builder" tool is invoked when using the "CP Model Editor" interface. It takes mesh data from one or more mesh files, and takes "properties" (needed to create the BEASY .dat file) which are defined in a text file. This text file can have any name and extension, but is generally given the extension ".hmd" and is referred to as "the hmd file".

The "CP Model Editor" interface allows defining properties and data and saves them into the hmd file. However, data in the "hmd" file can be completed/edited using a text editor or a spreadsheet.

General features of the CP Builder include:

  • The same definition of properties can be used when a mesh is refined in BEASY_GiD and re-exported, saving the need to re-apply properties (as was required in the old CP Wizard). This change greatly simplifies creation of a .dat file, and makes it very easy to check the definition of "properties" in a model.

Features related to mesh import

  • One or more mesh files are read into the CP Builder, allowing pre-processing using multiple "models". This can be helpful in cases where the model is large, or complex, as each BEASY_GiD model can be kept to a manageable size. The CP Builder automatically takes care of element and node ID numbers.

  • A mesh file can be transformed as it is read, by operations such as translate, rotate

  • Because transformations can be used, the same mesh file can be used more than once in the CP builder. This allows a mesh of a component to be used more than once (eg when the component occurs at multiple positions on a vessel hull)

Features related to group definition

  • The CP Builder uses "non-overlapping groups" to define properties such as:

  • Master zone ID

  • Slave zone ID

  • Whether the elements are tube elements

  • Whether/not the elements in the group are dual elements

  • Diameter of tube elements

  • Resistance/m along the length of tube elements

  • Boundary conditions

  • Anode type

  • The "area factor" to apply to the elements in the group

  • Expanded definition of groups able to hold cloud of points (i.e. support of groups containing mesh-points)

Features related to tube elements

  • Methods to define Tube elements with open or closed criteria for tube ends (Note that this is not supported by the CP Model Editor)

Features related to Boundary conditions

  • Added PIECEWISE_BCONDS_FUNCTION region to define POTENTIAL or NORMALFLUX boundary conditions using LINEAR piecewise functions of the element coordinate (Note that this is not supported by the CP Model Editor)

  • Methods to capture errors in the data have been introduced, for example:

  • Adds ".hmd" extension automatically when launched and the given filename has no extensions.

  • Submits fatal error if MESH_FILE_FORMAT is missing and MESH_FILENAME has no extension.

  • CREATE_INTERFACE_GROUPS is set to TRUE if the keyword is missing or commented out

  • CREATE_INTERNAL_POINT_GROUPS is set to TRUE if the keyword is totally missing or commented out

  • Method to allow addition of modelling notes

Features related to internal points

  • Methods to use internal points which are defined in named groups

  • Added capability to create groups of internal points parametrically

  • Added capability to read layers (groups) from *.bzmsh mesh files containing clouds of disconnected mesh-points.

Features related to sacrificial anodes

  • Control of the way ID numbers are assigned to Galvanic anodes

  • Ability to interpret SHAPELESS SAC anode type for anodes whose shape don't change with time

Features related to the definition of a non-default return path circuit

  • Methods to combine groups to create an electrical "component", including automatic electrical connection along the length of a pipeline (for example)

  • Methods to electrically connect different components together, including use of a "junction box" component.

  • Junction boxes can be identified using names (text strings)

  • Methods to define power supplies

  • Methods to define a different boundary condition on the two sides of dual elements

  • Methods to use a single surface to define two sides of a metal plate which divides a region of electrolyte into two zones, and to apply a polarisation curve to the two sides of the plate

  • Methods for checking the definition of electrical components

Features related to Solver settings

  • Options to define solver settings such as the maximum number of iterations to be performed.

New features and Improvements to the CP Solver

The new features and improvements to the CP Solver include:

New sacrificial anode types

  • An extended range of sacrificial anode types is available which change size as anode mass is lost during time-stepping

  • Change of anode size with mass loss follows DNV recommended practices

New methodology for metal voltage calculation (IR drop)

  • There is new functionality, to calculate metal voltage drop inside the solver. This greatly improves convergence and speed of solutions where IR drop is calculated.

  • The solver provides improved reporting of metal voltage results, by placing details of metal voltages at electrical connections in file "rootname.MVResults"

  • The solver provides enhanced results for pipelines (or other long thin structures) which have non-zero resistance along the structure length in file "rootname.pipelines" which, for each group of tube elements representing a pipeline section (with non-zero internal resistance) contains the following results:

  • Name of the group representing the pipeline section

  • Meshpoint id and coordinates of the starting endpoint of the pipeline section

  • Meshpoint id and coordinates of the ending endpoint of the pipeline section

  • Number of elements along the pipeline section

  • Length of the pipeline section

  • Metal voltage at each endpoint

  • Current flowing out of the section through each endpoint

In addition, for each tube element involved in the pipeline section, the following results are placed in the file:

  • Element id

  • x, y, z, coordinates of the element centroid

  • Coordinate along the pipeline to the element centroid

  • Length of the tube element

  • Electrolyte potential at the centroid of the element

  • Metal voltage at the centroid of the element

  • Current flowing along the tube element (i.e. through the metal)

New features related to polarisation data

  • A "long-term curve" can be used with paired potentio-dynamic curves

  • During an analysis where a long-term curve is used, checks are performed to guarantee that the long-term curve is between the pair of potentio-dynamic curves

  • Long-term curves can be defined in the .mat_cp file

  • If all polarisation curves are single straight lines and if there is no need to perform metal voltage calculation, the solver no longer needs to solve equations more than 1 time. For appropriate models this reduces solution time significantly, because previously two solutions were required.

New tools to control simulations during runtime

  • There are new keywords which can be put in the "rootname.cp_wizard_data" file to modify settings during a run. This file is accessed periodically during solution. Settings which can be modified include for example convergence parameters, and archiving of solution files

  • Keyword "STOP" in a cp_wizard_data file can interrupt a run with flow profile rate variation with depth and calcareous deposits

Other new features and improvements

  • The solver allows creation of "fluxlines" extending from internal points defined in the .dat file

  • The solver allows application of a polarising boundary condition to a "zone interface". This allows easier model building in some circumstances, and allows representation of both sides of a metal plate using a single surface.

  • Correction of bug regarding dual elements and result elements

  • Updated license manager

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Graphical Intefaces Index

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\graphical_intefaces_index.htm

Graphical interfaces

Third party 3D graphical interfaces are used to import/create/export the model geometry and mesh. They are also used to display results.

The graphical interfaces are equipped with a BEASY plugin that allows exporting the mesh file ( *.bzmsh)

BEASY GiD

Use the link to access documentation on BEASY GiD: BEASY GiD interface

SOLIDWORKS

Use the link to access documentation on BEASY SOLIDWORKS: Not available in this release

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


GiD Plugin Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gid_plugin_introduction.htm

BEASY GiD

The 3D User Interface has powerful geometry building capabilities, including solid geometry and Boolean operations. In addition, there are multiple ways to read geometry from CAD.

The BEASY GiD problem type (BEASY GiD Plug-in) is provided as part of this product, which specialises GID for BEASY modelling.

  • Main window in the pre-processing session Main features of the 3D User Interface on pre-processing mode

  • GiD Use and Help: Access to GiD documentation

  • The BEASY GiD problem type: How to load, unload and configure problem type

  • Pre-processing: Common tools used when creating the model geometry

  • Post-processing: Visualising results in 3D

  • BEASY GiD Tutorials: Tutorials illustrating the use of BEASY GiD to create a model for BEASY CP

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\introduction\introduction.htm

The BEASY GiD problem type

The BEASY GiD problem type is a plugin for GiD. The modules of software are added to GiD when the problem type is loaded, equipping GiD with additional functionality.

Starting with BEASY GiD

After installing all products, it is advisable you copy the BEASY GiD problem type into the corresponding GiD folder.

Loading the BEASY GiD problem type

When creating a new model it is convenient to start the model build environment and load the BEASY problem type.

  • How to load the problem type

  • How to know if the problem type is loaded

  • What happens if the problem type is not loaded

The BEASY GiD problem type can be found at:

  • Problem type location

You can deprive GiD from the BEASY plug-in by:

  • Unloading the problem type

Note: The problem type has been tested with GiD 9 and GiD 14.

BEASY GiD

The BEASY GiD problem type:

  • provides tools useful for creating the geometry and other tasks required during the pre-processing stage.

  • allows exporting a BEASY mesh file (.bzmsh)

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Add BEASY labels

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\beasylabels\beasylabels.htm

BEASY GiD. Add labels to points in your model

When the BEASY GiD problem type is loaded, it is possible to view defined labels.

Beasy_Labels allows attaching a label to a coordinate in your model. The labels need to be defined in a text file (*.txt).

Format: The format of the file containing labels should be as follows:

string xcoord ycoord zcoord

For example, create a file "My_labels.txt" with the following content

origin 0 0 0

kp250 250 0 0

When loading the file using "Beasy_Labels>Load", the label "origin" and "kp250" will be created.

Use "Unload" to stop seeing the labels.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Anodes

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\anodes\anodes.htm

BEASY GiD. Anodes

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models.

Under the menu "Anodes" the following tools are available.

Figure 1: Anodes menu

Tutorials showing how to use these tools:

  • How to create sacrificial anodes

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP Modelling Menu

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\cpmodelling\cpmodelling.htm

BEASY GiD. BEASY CP Modelling tools

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models. This section is relevant only for BEASY CP users. The additional functionality is aimed at facilitating the modelling for ship building, jacket structures and pipelines, for creating anodes and survey points.

The CP Modelling tools can be accessed through the GiD standard menu bar:

  • Tools for ship building

  • Tools for jacket structures

  • Tools for pipelines

  • Tools for anode creation and positioning

  • Tools for creating survey points

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Jacket Structures

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\jacketstructures\jacketstructures.htm

BEASY GiD. Jacket Structures

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models. Under the menu "Jacket_Structures" the following tools are available.

Figure 1: Jacket structures menu

Visit the Tutorial "OffshoreJacket_gidplugin" to see how to prepare a model for a jacket structure.

Note that there are submenus that are useful in any model containing tube elements, such as pipelines for example, or cylindrical anodes. The menus that may be useful in these situations are:

  • Member Properties: If member properties are defined you easily organise the lines with different diameters into different layers.

Define member properties by assigning a diameter to each line in the "Member Properties" panel

If you imported an off file member properties are automatically defined.

  • Generate Solid Member (for a volumetric view of tubes)

  • Organise member into layers ( to define layers according to member names or diameter)

  • Trim whole structure (to avoid intersecting pipes and preserve the steel area)

The menus related to anodes are described in the Anodes menu.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Pipelines

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\pipelines\pipelines.htm

BEASY GiD. Pipelines

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models.

Under the menu "Pipelines" menu the following tools are available.

Figure 1: Pipelines menu

Follow a tutorial showing how to use this tool: " How to insert bracelet anodes"

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Ship Building

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\shipbuilding\shipbuilding.htm

BEASY GiD. Ship Building

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models.

Introduction

Overlay shape on hull

Position anode near Hull

Introduction

The "Ship Building" menu provides the following tools:

  • Overlay Shape on Hull

  • Position Anode near Hull

  • Align Custom anode to surface

The use of some of these tools is illustrated in the tutorial "Ship Building". Below, there is a brief description of the tools.

Overlay shape on hull

The first menu is used to inscribe a predefined two-dimensional shape at one or many locations on one surface. This is particularly useful in the case of ship models to insert ICCP anodes or dielectric shields on the hull surface.

However, when using the tool, it is necessary to orientate the surfaces in a particular way.

Figure 6 shows example of a surface in green at the left. It is necessary to define an insertion point (i.e. the location where the shape will be inscribed) and the 2D shape defined at the origin. At the right hand side of Figure 1, the resulting surfaces after inscribing two different shapes are shown.

Figure 1: Overlay Shape in hull

Position anode near Hull

The second menu is used when a three dimensional object (such as an anode) needs to be positioned at one or many locations near a surface and separated from the surface at a given offset distance.

In this case it is necessary to define the surface (or hull surface) and insertion points, the offset distance (distance to the insertion point) and a separate 3D model containing the geometry of the anode.

Figure 2: Position anode near hull

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Survey Points

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\cp_modelling\surveypoints\surveypoints.htm

BEASY GiD. Survey Points

The BEASY GiD problem type provides a selection of useful functions for pre-processing CP models.

Under the menu "Survey_Points" the following tools are available.

Figure 1: Survey menu

The Survey menu allows defining internal points near a line and surface at a defined offset.

Points Near Tube

Press "Point_Near_Tube". The Survey Point definition tool window pops up.

You can select a line with member properties defined and choose a Radial Distance Factor and a select or define a Target Layer for the internal points. You can use the settings in Reference plane , such as axial position and angular position to adjust the location of the point.

Points on surface

Press "Point_on_Surface". The Survey Point definition tool window pops up.

You can select a surface. Then, select a point on the surface and an offset.

To select the point on the surface you can click on the surface using the "Pick" button or enter the coordinates manually.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Export hmd template

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\export_hmd\export_hmd.htm

BEASY GiD. Export BEASY hmd file

When the BEASY GiD problem type for BEASY CP users is loaded, it is possible to export the mesh (.bzmsh). While exporting the mesh, you can choose to export an hmd file.

When invoking "Export > Mesh_with_Layers" a window pops up allowing to export a template for the CP Builder (hmd file):

Tick on "Export CPBuilder template file"

You can choose to export

  • a "complete template": the hmd file with all the fields to introduce properties

  • a "partial" template" containing only the section of "NON_OVERLAPPING_GROUPS"

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Export BEASY mesh

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\exportmesh\exportmesh.htm

BEASY GiD. Export BEASY mesh

When the BEASY GiD problem type is loaded, it is possible to export the mesh (.bzmsh). This file is an input to BEASY CM solver or the BEASY CP Builder.

The export function exports all the mesh for all layers in your model.

When invoking "Export > Mesh_with_Layers" a window pops up:

Press the "Export" button.

If you want to export only a set of layers, then turn off the unwanted layers and tick on "Export only visible layers".

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Problem type functions

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\functions\functions.htm

Functions provided by the BEASY GiD problem type

The BEASY GiD problem type consists of modules of software that equip GiD with additional functionalities. When the "BEASY" problem type is loaded, these functions are available.

Functions provided by the problem type for BEASY CM and BEASY CP are:

  • Geometric Functions

  • Export mesh

  • Add BEASY labels

  • Layer tools

  • Report entities ids

  • Line operations

  • Surface Area Calculation

  • Help and problem type version in use

  • Import multiple GiD meshes

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Geometric Tools

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\geometricfunctions\geometricfunctions.htm

BEASY GiD. BEASY Geometric tools

The BEASY GiD problem type provides a selection of useful functions for pre-processing CM models. The additional functionality is aimed at facilitating the creation of geometrical entities.

Toolbar with geometric functions

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Help and problem type version number

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\help\help.htm

BEASY GiD. Help and Problem type version

When the BEASY GiD problem type is loaded, the Corrosion Manager documentation is available through the Help menu on the GiD standard menu bar.

Problem type version in use

When the problem type is loaded the "Help" menu in the GiD standard menu bar display the following options

By selecting "About BEASY_GiD" button you can check the problem type version number in use.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Import.off file

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\import_off\import_off.htm

BEASY GiD. Import off file

When the BEASY GiD problem type for BEASY CP users is loaded, it is possible to import a BEASY off file with information of structural members and diameters

This tool is useful for modelling of jacket structures

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Import Multiple GiD Meshes

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\importmulgidmesh\importmulgidmesh.htm

BEASY GiD. Import multiple mesh

When the BEASY GiD problem type is loaded, it is possible to import multiple meshes in one action

Note for CP users:

This tool is useful when importing multiple zone mesh files generated by the "CheckDat" tool.

In this way, it is possible to visualise a complex model divided into zones with Layers created by the "CheckDat" tool structured in the following way:

Zone id, Master/Slave, group name

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Layer Tools

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\layertools\layertools.htm

BEASY GiD. Layer tools

When the BEASY GiD problem type is loaded, it is possible to export the layer names to an ASCII file.

Export_Layers_Names: Creates a text file listing the layers in the model.

ReSend_Surfaces: It sends lower entities to the layers of the corresponding surfaces for all surfaces in the model. For example, this can be useful when un-collapsed surfaces are in one layer and their lower entities (lines/points) do not belong to the same layer.

.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Line Operations

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\lineoperations\lineoperations.htm

BEASY GiD. Line Operations

When the BEASY GiD problem type is loaded, there are some functions available for line operations:

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Report Entities IDs

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\reportentitiesid\reportentitiesid.htm

BEASY GiD. Report Entities IDs

When the BEASY GiD problem type is loaded, it is possible to list ids of selected entities.

Select the entity type:

Press "list Ids" and click on the entities you want to list:

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Surface Area Calculation

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypefunctions\surfaceareacalculation\surfaceareacalculation.htm

BEASY GiD. Surface Area Calculation

When the BEASY GiD problem type is loaded, it is possible to calculate the surface areas of a group of surfaces by using the menu "Utilities>Surface Area". Select the surfaces of interest and press "Escape".

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to know if the problem type is loaded

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypecheckload\ptypecheckload.htm

BEASY GiD. How to know the problem type is loaded

When the problem type is correctly loaded additional features are present, like the additional geometric tool bar.

You can also check the problem type version in use through the "Help" command on the GiD standard menu bar:

A window will pop up with the list of BEASY GiD plugins in use and corresponding release dates.

If these menus don't appear you need to load the problem type.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Getting started with BEASY GiD

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypeinstall\ptypeinstall.htm

BEASY GiD. Getting started with BEASY GiD

To start working with BEASY GiD, it is recommended that you first copy the folder "BEASY_ddmmmyyyy" with all its contents to the GiD\problemtypes folder. (ddMMMyyyy is for example 18Jun2020)

Note that the problem type name reflects the release date of the problem type and will change in the future.

The folder to copy ("BEASY_ddmmmyyyy") is located at: C:\Program Files\beasy\beasy21\plugins\GidProblemType\

The destination folder into which you should copy the folder "BEASY_18Jun2020" is:

C:\Program Files\GiD\GiD 14.0.2\problemtypes\

After the copying is done, you can use GiD to load the problem type using the "Data>Problem type" menu.

For example, from GiD select "Data>Problem type>BEASY_18Jun2020>BEASY" to load the problem type with added BEASY functions.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Load BEASY GiD problem type

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypeload\ptypeload.htm

BEASY GiD. Loading the problem type

The BEASY GiD problem type can be loaded using the menu: "Data > Problem type".

From the GiD standard menu bar select "Data > Problem type > BEASY_ddmmmyyyy>BEASY"

where ddmmmyyyy is the release date of the problem type; for example 18Jun2020. Note that the problem type name reflects the release date of the problem type and will change in the future.

You can then check that the problem type is loaded .

If the problem type is not available under "Data > Problem type" you need to copy the problem type in the corresponding GiD folder.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Location of the problem type

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypelocation\ptypelocation.htm

BEASY GiD. Location of the problem type

The BEASY GiD problem type BEASY_18Jun2020, is located inside the folder installation_path\plugins\ GidProblemType

installation path is for example: installation_path = C:\Program Files\beasy\beasy21\

The release date of the BEASY GiD problem type is identified on the name as follows: BEASY_ddmmmyyyy

where

  • dd refers the release day

  • mmm refers to the release month

  • yyyy refers to the release year

Note that the problem type name reflects the release date of the problem type and will change in the future.

To start working with BEASY GiD, it is recommended that you first copy the BEASY GiD problem type to the GiD problem types folder, so you can load it with GiD using Data>Problem type menu in GiD.

========================End of document======================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


What happens if the problem type is not loaded

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypenotpresent\ptypenotpresent.htm

BEASY GiD. Problem type not loaded

If the problem type is not loaded, you won’t be able:

  • to export a BEASY mesh (.bzmsh) needed as an input for the other BEASY products.

  • To access any of the additional tools developed for BEASY modelling, for example, the "Geometric tools" bar won't be displayed.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Unload BEASY GiD problem type

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\beasygid_problem_type\problemtypeload\ptypeunload\ptypeunload.htm

BEASY GiD. Unload problem type

Command to unload the BEASY GiD problem type is as follows: "Data > Problem Type > Unload"

To delete all the problem type data after unload close GiD and then open a new instance of GiD.

==============================End of document=============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


GiD Use and Help

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gid_use_help\gid_use_help.htm

BEASY GiD. GiD Use and Help

Aspects of geometry creation, meshing and post-process in GiD applied to a BEASY product are discussed throughout the tutorials included in the documentation system of the corresponding BEASY product.

Tools that are normally needed for creating geometry and interpreting results obtained with the any BEASY product are covered in sections that are accesible through the introduction to this topic.

Despite of that, please familiarise yourself with geometry modelling and result visualisation using GiD by following the instructions and tutorials under "Help à Help GiD" from the main menu at the top. You can also access the GiD help system by pressing F1.

Access to GiD documentation through the icon at the right of the main horizontal bar.

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Bi-Metallic Cell - Gid plugin

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\bimetalliccell_gidplugin\bimetalliccell_gidplugin.htm

BEASY GiD. Bi-Metallic Corrosion cell

This tutorial shows how to prepare the geometry and layers for a later use with the CP Model Editor.

CONTENTS

1 Introduction

2 Geometry building

3 Mesh generation

4 Export mesh

5 Comments

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    Two plates of dissimilar materials are immersed in a tank filled with electrolyte of conductivity 4 S/m as shown in Figure 1. The plates are interconnected through a conductor.

    Figure 1: Schematic of the bi-metallic galvanic corrosion cell. The dimensions of the tank are: Width = Height = 2m (the circumscribed circle has a radius of 1.41421), Length = 5m.

    The objectives of this tutorial are:

    • To introduce to the GiD interface and BEASY modelling with a simple comprehensive model

    • To learn the most basic approach for creating the geometry of a model

  2. Geometry building

    STEP 1: Open an empty GiD project and load the BEASY problem type problem type through the menu: "Data>Problem type >BEASY_12May2020>BEASY". Note the date corresponds to the problem type release date, and it will change.

    If you can't find the latest problem type in the menu "Data>Problem Type" you need to configure the problem type.

    If the problem type is correctly set then the interface window should appear as in Figure 2.

    Figure 2: BEASY GiD User Interface

    STEP 2: Save the project with name "BiMetallicCell" for example, in your hard disk by selecting "Files -> Save As"

    STEP 3: Create the 8 points that define the tank by selecting: "Geometry->Create->Point"from the standard menu at the top (see Figure 3, step 1 in Figure 4)

    The point coordinates are as follows:

    Point

    X

    Y

    Z

    1

    0

    0

    0

    2

    0

    2

    0

    3

    2

    2

    0

    4

    2

    0

    0

    5

    0

    0

    5

    6

    0

    2

    5

    7

    2

    2

    5

    8

    2

    0

    5

    Figure 3: Showing the standard menu bar in GiD and how to add new points

    STEP 4: Connect the points created in 3- with lines by selecting "Geometry->Create->Straight line"

    Then right click with the mouse and select contextual->JoinCA or equivalently press Ctrl + A to snap the selection with the mouse pointer to existing points, i.e. the points created in the previous step. See Figure 4, step 2.

    You will end up creating 12 lines in this model

    STEP 5: Create surfaces by selecting: Geometry->Create->NURBS Surface->By contour; and left click with the mouse on each line considered to be the border of a surface. You will end up creating 6 surfaces in this model. The final outcome is shown in Figure 4.

    Figure 4: Illustrating the creation of a box (representing the tank) in GiD in 4 steps.

    STEP 6: Make sure that all surface normal directions point outwards as shown in step 4 in Figure 4, by selecting View->Normal->Surfaces->Normal from the standard menu bar.

    If a surface is not oriented as shown in the figure, swap it by right clicking the mouse and selecting: Contextual->Swap some from the floating menu.

    STEP 7: Arrange the model into layers as shown in Figure 5. This will allow you to switch on and off the visualisation of different parts of the model.

    Note that the particular layer organisation we choose not only affects the way in which we can visualise and explore our model during its pre-processing but also has an impact on the modelling results. When organising your model into layers first consider which boundary conditions you need to apply.

    Figure 5: Showing the GiD layers defined in the model

  3. Mesh generation

    STEP 8: Define properties (Type of mesh and number of elements in each surface) for the 6 surfaces appearing in the model. We will use a structured mesh with 6, 6 and 12 quadrilateral elements along the x, y and z directions of the surfaces. Hence, click on Mesh->Structured->Surfaces->Assign number of cells from the main standard menu as shown in Figure 6 and select all the surfaces with the mouse.

    Figure 6: Showing how to define a structured mesh in surfaces

    STEP 9: Press the mesh generation button from the BEASY-GiD toolbar. As a result you will have created the discretisation mesh for this model as in Figure 7. Note that different visualisation styles (i.e. solid, wireframe, etc) can be set by selecting:

    View -> Render -> (Normal, Flat or Smooth)

    Figure 7: Showing the discretisation mesh associated to the model

  4. Export mesh

    STEP 10: Finally export the mesh o to: File -> Export -> Mesh_with_Layers by selecting File->Export->Mesh_with_Layers.

    The "Export Mesh with Layers" window pops up (Figure 8).

    Figure 8: Export mesh with layers

    You can avoid exporting all layers by turning off the unwanted layers and checking "Export only visible layers"

    In this example, we don't want to export the layer "Dimensions" so we check "Export only visible layers":

    Figure 9: Export mesh with layers

    Press "Export" and enter an appropriate name for the mesh (for example BiMetallicCell").

    The information window pops up as shown in Figure 10.

    Figure 10: Export mesh. Information window

    Save and Close your model.

  5. Comments

  • There are several different ways to create or modify geometry

  • The generic bottom-top approach consists of first creating points, second joining them with lines and third creating surfaces on closed loops of lines.

  • With the bottom-top approach any arbitrary type of geometry can be created, however there are always other methods available which can be simpler and faster depending on the particular case.

  • Surfaces in a CP model are usually organised into "groups", which allow applying conditions (e.g. material properties, boundary conditions) on them. Layers defined in GiD will be associated with "groups" when defining the CP model.

  • A "zone" represents the volume occupied by the electrolyte in the region of interest. Any CP model requires having at least one zone defined by the "groups" (i.e. layers) enclosing it.

  • All boundary surfaces defining a zone must be oriented such that their normal directions point outwards from the electrolyte point of view, as illustrated in Figure 11.

Figure 11: Showing the correct orientation of the normal vector for boundary surfaces in a zone of a BEASY-CP 3D model

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Flowline - Gid plugin

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\flowline_gidplugin\flowline_gidplugin.htm

BEASY GiD. Flowline

This tutorial shows how to export the mesh for later use with the CP Model Editor for a model of a flowline with internal resistance partially buried.

CONTENTS

1 Introduction

2 Geometry using BEASY GiD problem type

2.1 Open the GiD project

2.2 GiD layers

2.3 Export mesh

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    This example consists of a flowline in seawater and anodes. A section of the flowline is buried. The geometry and mesh are already defined.

  2. Geometry using BEASY GiD problem type

  1. Open the GiD project

    In an empty GiD project open the provided model "Flowline.gid".

    The model has the geometry and mesh defined. There is no additional data stored in the GiD model. You need to load the problem type to export the mesh.

    Load the problem type problem type through the menu: "Data>Problem type>BEASY>BEASY_12May2020" for example. The date is the problem type release date, so it will change. You can then check that the problem type is loaded.

    A view of the model is shown in Figure 1.

    Figure 1: Overview of the geometry and layers

  2. GiD layers

    When defining the model you need to keep in mind that the GiD layers will be associated to BEASY groups. Therefore, we need to separate the model into different layers with the purpose of assigning conditions later on while using the CP Model Editor.

    We use different layers to differentiate between different materials or coatings.

    We will define a circuit to represent the internal resistance of the flowline. The new methods in BEASY version 21 allow you to define only one group for all the sections of the flowline and one group for all its anodes.

    The defined layers "Anodes" and "Pipeline" are shown in Figure 1.

  3. Export mesh

Go to: File -> Export -> Mesh_with_Layers

The "Export Mesh with Layers" window pops up (Figure 2).

Figure 2: Export mesh with layers

Press "Export" and enter an appropriate name for the mesh (Figure 3)

Figure 3 Export mesh file

Save and Close your model.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Create the anodes geometry

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_create_anodes\how_to_create_anodes.htm

BEASY GiD. How to create the anodes geomtry

This tutorial shows tools to create the anodes geometry for use in CP models.

The tools for creating anodes are under the CP Modelling menu:

Start by defining the anodes using "Define Anodes". Once the anodes are defined, you can then position them using the insertion tools.

1 Define Anodes

1.1 Brick

1.2 Tubular

1.3 Custom

2 Position Anodes

2.1 Insert Anodes on Tube Members

2.2 Insert Anodes on Surf Centres

2.3 Align custom Anode to Surface

2.4 Insert bracelet anode on a tubular member

  1. Define Anodes

    Use this tool to define shape, dimensions, number of elements, offset distance and names of the layers for your anodes.

    Go to "CP Modelling > Anodes > Define Anodes". The "Definition of Sacrificial Anodes" window pops up:

    Press "Add" and define anodes types using the buttons under "Definition of Sacrificial Anodes".

    1. Brick

      Use "Brick" to create anodes with cuboid shape.

      Define anode dimensions, stand off distance and number of elements. Define a name for the anode type and press "Done".

      Create a different anode type for changes in any of the parameters.

      This geometry is appropriate to define sacrificial anode properties with the CP Model Editor for BRICK, STAND_OFF AND BRICK_FLUSH_MOUNTED type anodes

    2. Tubular

      Use "Tubular" to create anodes with cylindrical shape.

      Define anode dimensions, stand off distance and number of elements. Define a name for the anode type and press "Done".

      Create a different anode type for changes in any of the parameters.

      This geometry is appropriate to define sacrificial anode properties with the CP Builder for CYLINDER and BRACELET type anodes

    3. Custom

    Use "Custom" to create anodes with customised shape.

    You need to have the anode geometry in a separate GiD model. Browse to the corresponding file to copy the anode geometry into your model at the origin. When creating the anode geometry, follow the convention on the "Definition of Sacrificial Anodes" window to orient the anode.

    Define a name for the anode type and press "Done".

  2. Position Anodes

There are tools available to position anodes at desired locations:

  • Insert Anodes on Tube Members: To insert brick anodes at an offset distance to a tubular member.

  • Insert Anodes on Surf Centres: To insert brick anodes at an offset distance to a surface centre.

  • Align Custom Anode to Surface: To insert custom anodes at an offset distance to a position on a surface.

  • Insert bracelet anodes: To insert tubular anodes aligned on the centre of tubular member

  1. Insert Anodes on Tube Members

    Go to "CP Modelling > Anodes > Insert Anodes on Tube Members". The "Positioning Tool for Sacrificial Anodes on Tube Members" window pops up. Click on "Select" to select the anode type.

    The window expands. Select one anode type from the list. The anode properties of the selected anode type are visible (dimensions, stand-off distance and elements) on the right side of the window.

    Click Select. The selected anode type, length and stand-off distance are shown:

    Continue completing the fields:

    Target layer: define a layer name or press Auto

    Member Id: Select the member by clicking on a line with member properties already defined.

    Member length: Once the member length is selected, its length is displayed

    Use the Reference plane, Axial position and Angular position to orient the anode.

  2. Insert Anodes on Surf Centres

    Go to "CP Modelling > Anodes > Insert Anodes on Surf Centres". The "Positioning Tool for Sacrificial Anodes on Surfaces" window pops up. Click on "Select" to select the anode type.

    The window expands. Click on one anode type from the list. The anode properties of the selected anode type become visible (dimensions, stand-off distance and elements).

    Click Select.

    Continue completing the fields:

    Target layer: define a layer name or press Auto

    Offset: Add the offset distance between anode and surface

    Tick "Anode on Surface Normal Direction" to attach the anode on the outer direction.

    Tick "Back face on different layer" if you need two layers for the CP Model Editor Sacrificial Anodes tab (this is needed for BRICK and BRICK_FLUSH_MOUNTED types) STAND_OFF can be modelled using only one layer for the 6 surfaces.

    Press "Insert" and select the surface to add the anode:

    Refresh the layers window to see the new created layers:

  3. Align custom Anode to Surface

    Go to "CP Modelling > Anodes > Align custom Anode to Surface".

    The "Anode Positioning Tool" window pops up.

    Click on "Load" to load an existing model of the anode geometry and mesh.

    When creating the geometry and mesh of the anode in a separate model, consider that:

    • The Z direction on the anode model will be aligned with the local normal of the surface.

    • The centre of surface of the anode show in green (back surface) needs to be at the origin.

    1-Load Anode Model: Press "load anode model" and browse to the location of the anode model. The anode shape is imported at the origin.

    2-Anode Insertion Point: Select or input an insertion point for the anode.

    If you choose to select the point by clicking in the blue dot, then you can select the point on your model or right click to open the Contextual Menu and use any of the available options to select point

    3-Surface Selection: Select the surface to which the anode will be attached.

    4-Offset distance: Input the offset distance

    5- Anode Orientation: Define the anode orientation. If the Auto Box was ticked when inserting the previous parameters, then the anode orientation is automatically calculated.

    If you want to correct the automatic selection untick the box, press into the line icon and select a line in the model on the direction of the desired orientation. You can also introduce the coordinates of a vector pointing in the desired direction by typing them into the corresponding boxes.

    6-Insert: Press Insert

    Once finish adding anodes of the loaded shape you can press "Unload Anode Model" and the anode at the origin will be deleted.

  4. Insert bracelet anode on a tubular member

These anodes are inserted without the need of defining an anode type. The tubular member is cut and at the anode length.

If you need to define bracelet anodes along a pipe you can use the tool for Pipelines (CP Modelling> Pipelines>Insert Bracelet Anodes)

Go to " CP Modelling> Pipelines>Insert Bracelet Anodes ". The "Insert Bracelet Anodes" window pops up. Click on "Select" to select the tubular member (i.e. line with member properties defined).

Click on the line with member properties defined in which you want to insert the anode.

The fileds:

Pipleline: Show the line Id

Pipeline length: Show the line length

You can adjust the number of anodes to attach. In this example:

And press "Accept"

The line gets divided.

Go to "Definition of Sacrificial Anodes" and select the anode geometry and parameters.

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Define Member Properties

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_define_member_props\how_to_define_member_props.htm

BEASY GiD. How to define member properties

In a CP model, a thin cylindrical cavity in the electrolyte can be represented by lines (i.e. tube elements). Member Properties are a set of data defined in the GiD model: line and diameter value.

Member properties in GiD can be used for two purposes:

  • visualisation of the lines as cylinders in the GiD project

  • trimming intersecting lines to avoid overlapping

This tutorial shows how to define member properties.

Load the BEASY problem type problem type through the menu:

"Data>Problem type>BEASY>BEASY"

To define member properties:

  • use the CP Modelling menu (CP Modelling> Jacket Structures > Member Properties).

  • The "Structural Member Properties" window pops up.

  • Define diameter, Name field is optional

  • Press "Assign" and click on the corresponding line or group of lines.

In the "Structural Member Properties" window, you can also press "Draw" to display the lines diameters already assigned.

Member properties are also created when importing an off file. Automatically the diameter associated with a line is retained in the model.

Once member properties are assigned you can use other tools under the CP Modelling menu:

  • Organise members into layers

  • Trim members

  • Visualise the lines as a 3D cylinder

  • Insert cuboid anodes to tubular members

  • Insert tubular anodes to surfaces

  • Insert bracelet anodes on tubular members

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to load BEASY tools

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_loadproblemtype\how_to_loadproblemtype.htm

BEASY GiD. How to load BEASY tools into GiD interface

To make available tools used in geometry creation of a model for BEASY CP and to be able to export a mesh, you need to have loaded the BEASY problem type into GiD first. This tutorial shows how to do load the problem type into the GiD environment.

1 Load problem type

2 How would you know the problem type is loaded

  1. Load problem type

    Before starting creating a new model load theBEASY problem type:

    From the GiD standard menu bar select "Data > Problem type > BEASY>BEASY".

    NOTE: For the BEASY problem type to appear under "Data > Problem type" list, you should configure the problem type first. You should do this only once after installation.

  2. How would you know the problem type is loaded

You can then check that the problem type is loaded

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Modelling intersecting pipes

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_model_intersecting_pipes\how_to_model_intersecting_pipes.htm

BEASY GiD. How to model intersecting pipes

This tutorial shows how to resolve problems of intersecting pipes. You can also visit the tutorial for Jacket Structures.

To avoid overlapping between pipes when they intersect each other and to preserve the exposed steel area we trim a section of the pipes at the junctions.

If you have a number of intersecting pipes proceed as follows:

1 Define member properties

2 Use the trimming tool

3 Jackets. Conventions for the jacket orientation

First, load the BEASY problem type problem type through the menu:

"Data>Problem type>BEASY>BEASY"

  1. Define member properties

    Define Member Properties using "CP Modelling > Jacket Structures > Define Member Properties". The "Member Properties" panel pops up.

    Enter the diameter value, press assign and click on the intersecting lines.

    Once the members are defined, you can proceed using the trimming tools

    This tool removes the original members and trims all the members with properties defined so it is advisable to save the model before doing the trimming.

    Note that the trimmed members (and all other tube elements with Member Properties defined) are going to be moved to the active layer.

  2. Use the trimming tool

    When ready, proceed with the trimming by pressing the "Trim" button as shown in Figure 1.

    Do not tick the boxes, as they are options from trimming jackets.

    Figure 1 Press the "Trim" button. When the trim is done, you can press "Done" to close the window

    Figure 2 shows how the intersecting lines look after being trimmed.

    Figure 2 Intersecting pipes should be trimmed at the joints

    Before proceeding further be sure you have checked that there are not intersecting members.

    Checking the model after the trimming

    After the trimming is performed it is convenient to check the model to decide whether it looks appropriate or if there are any members still intersecting each other. The followings steps can be followed:

    • If you are happy with the general look of the structure, then add a large and distant anode and launch a run for the model of the trimmed jacket and only one anode. You can use this test run to estimate the wetted steel area in the model and to corroborate that results are consistent. If there are intersecting members you will notice them by looking at the results. Local regions with potentials much more positive than the rest of the structure will indicate members are still intersecting in those areas. In this case, members will need further trimming.

    • If you noticed there is a member requiring additional trimming use the tool show in Figure 3 to trim the individual member; or use the offshore tool ‘Trim isolated members’.

    Figure 3: You can use ‘Extend lines’ and enter a negative multiplier to trim an individual member

  3. Jackets. Conventions for the jacket orientation

Before trimming we need to have the structure orientated according to the following convention:

  • Orientate the main axis of jacket structure parallel to the z coordinate.

  • Define the z origin coincident with the sea surface.

  • Orientate the z coordinate pointing towards the seabed, i.e. all the points having positive z coordinates.

After having a look at the imported structure we need to identify if geometric transformations are required. If the original structure is orientated along y axis for example, we may need to:

a) Rotate the structure so it is oriented according to BEASY convention (Origin at sea surface, with z coordinate pointing to seabed)

b) Translate it if the sea level is not located at z=0.

We also may need to cut off the structure at sea level and delete all members above sea level, but this can be performed later when trimming.

Figure 4: Convention for the orientation of the jacket structure

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Organise members into layers

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_organise_members_into_layers\how_to_organise_members_into_layers.htm

BEASY GiD. How to organise members into layers

This tutorial shows how to organise members into layers by Diameter

Load the BEASY problem type problem type through the menu:

"Data>Problem type>BEASY>BEASY"

If you have lines with member properties assigned (for instance, if you imported a .off file) then you can arrange the layers to reflect the diameters by selecting "CP Modelling>Jacket Structures> Organise members into Layers > by Diameter":

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Visualise tube elements in 3D

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\how_to_visualise_tube_elements_in3d\how_to_visualise_tube_elements_in3d.htm

BEASY GiD. How to visualise tube elements

This tutorial shows how to generate a 3D visualisation of tube elements (i.e. lines that will have an associated diameter in the CP model)

First, load the BEASY problem type problem type through the menu:

"Data>Problem type>BEASY>BEASY"

If you want to visualise tube elements in a 3D view you can use the menu Generate Solid Members (CP Modelling >Jacket Structures>Generate Solid Members) as shown in Figure 1.

Figure 1: Generate Solid Members

The lines need to have "Member Properties" defined (how to define member properties) .

Once the properties are defined, you can use "Generate Solid Members". An example is shown in Figure 2

Figure 2: Three pipes with different diameters. "Generate Solid Members" tool

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Jacket Structure - GiD plugin

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\jacket_gidplugin\jacket_gidplugin.htm

BEASY GiD. Offshore jacket structure

This tutorial illustrates how to import an off file for modelling of jacket structures, how to proceed with tube elements and how to create suitable layers for use with the CP Model Editor. It shows steps to construct the geometry using functions in the BEASY GiD problem type dedicated to jacket structures and attach anodes creation on jacket members.

CONTENTS

1 Introduction

2 Geometry using BEASY GiD problem type

2.1 STEP 0: Load BEASY problem type

2.2 STEP 1: Import OFF file geometry

2.3 STEP 2. Define sacrificial anode dimensions

2.4 STEP 3. Insert SAC anodes

2.5 STEP 4: Trim the structural members

2.6 STEP 5: Organising layers for export

2.7 STEP 6: Define a suitable mesh for the jacket members

2.8 STEP 8: Export the mesh file

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    A view of the structure is shown in Figure 1. Figure 2 shows the anode dimensions.

    Figure 1: Jacket structure

    Figure 2: Showing the anode geometry

  2. Geometry using BEASY GiD problem type

  1. STEP 0: Load BEASY problem type

    Open an empty GiD project and load the BEASY problem type.

  2. STEP 1: Import OFF file geometry

    Import the off file "FrameStructure.off" ( Files>Import > BEASY off) . This should result in the geometry shown in Figure 3.

    Figure 3 Import BEASY off

    Save the GiD model with an adequate name.

  3. STEP 2. Define anode dimensions

    To create a new anode type go to "CP Modelling > Anodes > Define SAC Anodes", this will open the "Definition of sacrificial anodes".

    Click the "Add" button to add a new anode type. Create a brick anode called "AType1" for example, with parameters as shown in Figure 4.

    Figure 4: Define sacrificial anode type

    Press "Done" button to confirm the selection and close the window.

  4. STEP 3. Insert SAC anodes

    Now, we will position SAC anodes on all the horizontal members, as indicated in Figure 5.

    Figure 5: Anode locations

    Using "CP Modelling > Anodes > Insert SAC Anodes" the "Anode Positioning tool for jacket structures" windows pops up:

    Click on "Select". The existing anode types are displayed. Select the anode geometry we have just created "AType1"

    Press "Select" again.

    Define a "Target Layer" name: BrickAnode for example

    Press "Select" in "Member Id" and then pick the line of the member where the anode will be inserted. Once a member is selected, the fields "Member Id" and "Member length" get populated and the member gets painted in green.

    Tick on "Relative" for all coordinates and input x=0, y=0, z=-1 to position the anode above the member.

    Enter 0.5 in "Axial position" to position the anode in the middle of the member and input 0 in "Angular position"

    Finally press "Accept". The anode is created at the offset position and with dimensions as defined in the "Anode Type" used.

    If you refresh the layers window you will see the two new layers created:

    Proceed in the same way adding anodes on all the horizontal members. You can use "Geometry> Delete > Volumes" and select all the anodes to delete all volumes.

    Optionally, for "visualisation only" you can generate "solid members" using "CP Modelling > Jacket Structures > Generate Solid Members":

    The model with inserted anodes is shown in Figure 6.

    Figure 6: Showing the model equipped with SAC anodes. On the left hand side, the structural members are represented with lines, on the right hand side the structural members are visualised as solid.

  5. STEP 4: Trim the structural members

    This is to avoid geometrical interference at the intersections between members connected to the same node. Save your model if you haven't done that before. Use the tool: "CP_ModellingàJacket StructuresàTrim Whole Structure" and press the button "Trim" and "Done" after a successful run of the trimming tool. NOTE you may need to refresh the GUI by pressing redraw once trimming is complete.

    Figure 7: Redraw

  6. STEP 5: Organising layers for export

    BEASY groups are defined from the GiD layers. We need each of the different member diameters to be in a separate GiD layer. To do this we can select:

    "CP Modelling -> Jacket_Structures -> Organise Members into Layers -> by Diameter"

    This will automatically create a GiD layer for each of the different diameters.

    We can now tidy up our GiD layers to delete any empty layers. We should be left with the following layers:

    • SolidMembers (frozen)

    • BrickAnode_TOP

    • BrickAnode_BOTTOM

    • MEMBERS_Diam_2.000000

    • MEMBERS_Diam_1.000000

    • MEMBERS_Diam_0.500000

  7. STEP 6: Define a suitable mesh for the jacket members

    Define an unstructured size of 1.5 for all jacket members.

    "MeshàUnstructuredàAssign sizes on Lines" and put the corresponding value in the pop up box

    **** do not select the anodes!!! ****

    Once complete generate the mesh.

  8. STEP 8: Export the mesh file

Turn on all GiD layers except for SolidMembers.

Go to: File -> Export -> Mesh_with_Layer

The "Export Mesh with Layers" window pops up (Figure 8).

Figure 8: Export mesh with layers

Check "Export only visible Layers". Press "Export" and enter an appropriate name for the mesh

The information window pops up:

Save and close your model.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Meshing

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\meshing\meshing.htm

BEASY GiD. Meshing

This tutorial introduces to the commands and menus in the BEASY GiD inteface used to define and generate a mesh.

Follow the link " Guidelines on Meshing " for basic information on the mesh definition on a boundary elements model.

CONTENTS

1 Procedure

1.1 Mesh definition

1.2 Element order

1.3 Mesh generation

2 Discontinuous and Meshes

3 Appendix

3.1 Structured mesh

3.2 Element concentration

3.3 Unstructured Mesh

  1. Procedure

    The first step consists on defining the mesh properties for individual components of geometry.

    Note that

    • The mesh definition is saved with the model and kept if the model is exported.

    • if the entity is copied, the mesh definition is also inherited by the copied entities.

    1. Mesh definition

      This involves declaring the type of mesh and number of elements or size to apply to entities. To do so, consider the following:

      • Identify if a structured mesh is required on surfaces. In many cases structured meshes, leading to quadrilateral elements, are preferred. Then declare the number of elements on lines.

      • If a unstructured mesh is required, then declare sizes for surfaces.

      • Concentrate elements in regions where the geometry or the conditions vary rapidly.

      • Prefer elements with good aspect ratio (i.e. avoid long and thin elements for example)

      • Avoid distorted elements with big curvatures.

      • Preserve a smooth grading factor

    2. Element order

      BEASY CP requires that the mesh elements are of quadratic order.

      You need to change the settings in GiD. Select "Mesh > Quatric type > Quadratic9".

    3. Mesh generation

    Then you can generate the mesh using the "Mesh>Generate".

  2. Discontinuous and Meshes

    The normal meshing generates a continuous mesh, in which element edges match up on adjacent surfaces and share mesh points.

    You can however create a discontinuous mesh by using the "Geometry>Edit>Uncollapse>Surfaces" command. Any surfaces processed like this can be meshed independently of adjacent surfaces.

    Figure 2 shows an example of un-collapsed surfaces with different number of elements applied to them generating a non-conforming or un-matching mesh; this can be useful when applying grading.

    Figure 2: Un-matching meshes

    Figure 3 shows and example of discontinuous mesh. When modelling two different materials that are in contact un-collapse surfaces to create a discontinuous mesh. If the materials are not sharing nodes, then the displayed Averaged Solution will show the abrupt change on the solution from one side to the other. However, if the nodes are shared, the solution will be averaged showing a smooth transition which is unreal.

    Figure 3: Discontinuous mesh

  3. Appendix

  1. Structured mesh

    Menu: Mesh->Structured

    A structured mesh is a mesh where all the nodes have the same number of elements around them.

    The mesh is by the number of elements that are required on every line.

    This number must be the same for all lines that are opposite each other on each surface.

    To create a structured mesh, choose Structured -> Surfaces/Lines.

    After selecting escape, you can set the number of elements per line is, or the line size.

    The default number of elements for surfaces or lines defined as "Structured" 2.

    In the case of surfaces, structured meshes can be four-sided, three-sided or centred structured.

    By default, the generated elements in four-sided structured meshes are quadrilaterals. (Figure 2)

    Figure 4: Structured Mesh

  2. Element concentration

    Menu: Mesh->Structured->Lines

    By default, all partitions in one structured line have the same approximate length. This command lets you select one line, which will be shown in the graphical window with an arrow indicating its direction. You then have to enter a positive or negative weight. If the weight is positive the elements will be concentrated towards the extremities of the line; if negative, the elements will be repelled.

    Figure 5: Concentrate elements

  3. Unstructured Mesh

Menu: Mesh->Unstructured

By default all the surfaces or lines will be treated as unstructured unless they are defined otherwise and meshed with a default size.

It is possible to assign different sizes to different entities of the mesh. To do so, declare the mesh as unstructured and apply a size.

All the entities that do not have an assigned size when meshing take the default one.

Assigning the size 0.0 to an entity is the same as setting the default size.

The transition between different sizes is controlled by a parameter in preferences.

==========End of document======================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Modelling Steps

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\modellingstepsingid\modellingstepsingid.htm

BEASY GiD. Modelling steps for creating a mesh for CP

This tutorial illustrates the steps needed in GiD to prepare the geometry and layers for a later use with the CP Model Editor.

CONTENTS

Load BEASY GiD problem type

Create or import geometry using BEASY GiD problem type

Define the mesh

Export mesh file and template for CP Model Editor

Load BEASY GiD problem type

You can start loaoading the problem type so you have the additional BEASY tools accessible.

Create or import geometry using BEASY GiD problem type

  • Create or import the geometry of the model using the GiD commands and/or BEASY geometric tools on the vertical bar.

You can create different parts of the model in different GiD models if this is more convenient.

  • Create one separate layer for each component with different properties (for example, separate layers for anodes, metals, boundary or insulating surfaces, and interfaces)

Considerations at the moment of creating the geometry:

  • There are several different ways to create or modify geometry

  • Surfaces in a CP model are usually organised into "groups", which allow applying conditions (e.g. material properties, boundary conditions) on them. Layers defined in GiD will be associated with "groups" when defining the CP model.

  • A "zone" represents the volume occupied by the electrolyte in the region of interest.

  • All boundary surfaces defining a zone must be oriented such that their normal directions point outwards from the electrolyte point of view.

Define the mesh

  • Assign appropriate mesh dimensions.

Export mesh file

  • Export the mesh

Go to: File -> Export -> Mesh_with_Layers

Press "Export" and enter an appropriate name for the mesh

Options

  • Export only visible layers : Use this option to export the "ON" layers only. Not visible layers (OFF layers) will not be present in the mesh file. This is useful to avoid exporting auxiliary layers for example.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Monopile - Gid plugin

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\monopile_gidplugin\monopile_gidplugin.htm

BEASY GiD. Monopile

This tutorial shows how to prepare the geometry and layers for a later use with the CP Model Editor. The steps to construct the geometry are briefly discussed.

CONTENTS

1 Introduction

2 Geometry using BEASY GiD problem type

2.1 Anode geometry

2.2 Monopile geometry

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with:

  • Creating geometry and meshes for BEASY CP.

  • BEASY zone modelling concepts.

  1. Introduction

    A view of the structure is shown in Figure 1. The example consists of a monopile immersed in seawater. Sacrificial aluminium anodes are arranged around the pile. The initial model to be analysed consist of 12 anodes, however, results for different numbers and configuration of anodes will be assessed.

    The anode dimensions are 0.2 x 0.2 x 2.0 m.

    Figure 1: Monopile structure

  2. Geometry using BEASY GiD problem type

The geometry will be created using two GiD models:

  1. Anode geometry: This will consist of 6 anodes arranged circumferentially at a radius of 3 m. i.e. the offset distance between anodes and monopole is 1m.

  2. Monopile geometry: This model will consist of the monopile and zone boundaries/interfaces.

  1. Anode geometry

    Open an empty GiD project and load the BEASY problem type problem type through the menu: "Data>Problem type>BEASY_>BEASY_13Mar2020" for example. The date is the problem type release date, so it will change.

    Create a cuboid from the following points:

    x

    y

    z

    3.0

    0.1

    1.0

    3.0

    -0.1

    1.0

    3.2

    0.1

    1.0

    3.2

    -0.1

    1.0

    3.0

    0.1

    -1.0

    3.0

    -0.1

    -1.0

    3.2

    0.1

    -1.0

    3.2

    -0.1

    -1.0

    Table 1: anode x, y, z co-ordinates

    Orientate the normal directions so that they point towards the centre of the cuboid as shown in Figure 2.

    Figure 2 Anode normal vectors directions

    Organise the surfaces into layers so that the rectangular surface nearest the origin is in a layer called "Anode_Back" and all other surfaces are in a layer called "Anode_TopSides" as shown in Figure 3.

    Figure 3: Anode layers

    Assign a structured mesh to the surfaces so that the anode has 1 element along its width/height and 4 elements along its length.

    Use the Utilities->Copy tool to replicate the anode so that there are 6 anodes equally spaced around a 6 m diameter circumference, centred at the origin. The settings for the copy are shown in Figure 4.

    Figure 4: Copy tool to position the anodes

    Generate the mesh. The modelling is now complete and should look as shown in Figure 5.

    Figure 5: Anode geometry

    Go to: File -> Export -> Mesh_with_Layers

    The "Export Mesh with Layers" window pops up (Figure 6).

    Figure 6: Export mesh with layers

    Press "Export" and enter an appropriate name for the mesh.

    Save and Close your model.

  2. Monopile geometry

Open an empty GiD project and load the BEASY problem type problem type.

  1. Create the geometry of the monopole with dimensions as shown in Figure 1.

  2. Create an appropriate bounding box for the seawater/seabed zones and an interface between these zones.

The following should be considered for modelling:

  • The monopile should be orientated such that:

  • Its axis is located on the origin and the Z axis aligns with this axis.

  • The sea surface is at z = 0 and the z axis points towards the seabed.

  • The "bounding box" which has been used in the files provided is a cylinder of diameter 512 m. The user can use an alternative boundary shape/size, however, should be aware that if the boundary is placed too close to the monopile then it will influence the flow of current through the electrolyte and affect the results.

  • Normal directions should point away from the electrolyte.

  • On interfaces normal directions should point from the lower ID zone into the higher ID zone.

  • The geometry should be split into GiD layers with view to continue the modelling using the CP Model Editor, for example, the following layers:

  • tp: Coated section of the monopile (transition piece)

  • bare: Bare wetted section of the monopile

  • buried: Buried section of the monopile

  • z1b:Zone 1 bounding box

  • z2b:Zone2 bounding box

  • z12:Interface between zone 1 and zone 2

Assign an appropriate mesh dimensions, mesh and export "Monopile.bzmsh". As done with the anode geometry.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


ShipHull - Gid plugin

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\shiphull_gidplugin\shiphull_gidplugin.htm

BEASY GiD. Ship hull

This tutorial shows how to define layers and export the mesh for later use with the CP Model Editor.

CONTENTS

1 Introduction

2 Open GiD, open the model, load problem type

3 GiD layers and BEASY groups

4 Export mesh

5 Comments

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    This example consists of a ship hull in seawater with propellers and shaft rods. There is an area of damage on the propellers. ICCP anodes are arranged along the hull.

  2. Open GiD, open the model, load problem type

    On the GiD interface opent the model "ShipHull.gid" provided with this tutorial.

    Load the BEASY problem type using the menu "Data>Problem type>BEASY_ddMMYYYY>BEASY". (where ddMMYY refers to the release date)

    You can check that the problem type is loaded .

    The geometry and the mesh are already defined in the provided model "ShipHull.gid". An overview of the model is shown in Figure 1. Details are shown in Figure 2 and Figure 3.

    Figure 1: Overview of the geometry and layers

    Figure 2: Showing the area of damage

    Figure 3: Showing the trim tab and the anode geometry

  3. GiD layers and BEASY groups

    The GiD layers are associated to BEASY groups. Therefore, with the purpose of assigning properties later on while using the CP Model Editor, separate the model into different layers.

    We will define layers to differentiate materials and coatings. Layers used in this example are shown in Figure 4.

    Figure 4 Showing the layer window in GiD

  4. Export mesh

    Turn off the layer "Result_Surface". This layer is used to calculate results at internal points. But we will not be using it for this example.

    Go to: File -> Export -> Mesh_with_Layers. The "Export Mesh with Layers" window pops up (Figure 5).

    Figure 5: Export mesh with layers (Only visible layers)

    Check "Export only visible layers" and press "Export". Then enter an appropriate name for the mesh (Figure 6).

    Figure 6: Export mesh file

    Save and Close your model.

  5. Comments

  • There are several different ways to create or modify geometry

  • Surfaces in a CP model are usually organised into "groups", which allow applying conditions (e.g. material properties, boundary conditions, electrical connections, etc) on them. Layers defined in GiD will be associated with "groups" when defining the CP model.

  • A "zone" represents the volume occupied by the electrolyte in the region of interest. Any CP model requires having at least one zone defined by the "groups" (i.e. layers) enclosing it.

  • All boundary surfaces defining a zone must be oriented such that their normal directions point outwards from the electrolyte point of view, as illustrated in Figure 7.

Figure 7: Showing the correct orientation of the normal vector for boundary surfaces in a zone of a BEASY-CP 3D model

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Contents

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\gidplugin_tutorials\cp\tutorials_index\tutorials_index.htm

BEASY CP Tutorials for BEASY GiD

This set of tutorials is meant to introduce the user of BEASY GiD on the steps and tools available to create a mesh suitable for BEASY CP simulations. You will find instructions showing how to create/import the geometry for a CP model and how to create and export the "*.bzmsh" mesh file.

Aspects of modelling and tools

Examples

Aspects of modelling and tools

This set of tutorials cover general aspects of modelling

Modelling steps in GiD | This tutorial summarise the steps needed to prepare the geometry and layers for a later use with the CP builder.
Load BEASY added functions into GiD | This tutorial shows how to load the BEASY functions into the GiD environment. You will need the BEASY functions (BEASY problem type) to export the mesh of the model.

Meshing | This document introduces to the commands and menus in the GiD User Interface used to define and generate a mesh.
How to create anodes | This tutorial shows tools to create anodes for use in CP models.
How to define member properties | This tutorial shows how to define Member Properties Member Properties are a set of data attached to lines which will represent tube elements.
How to insert bracelet anodes | This tutorial shows how to insert bracelet anodes in a pipeline modelled using tube elements
How to organise members into layers | This tutorial shows how to generate layers and place entities into them with "member properties" defined that have the same diameter (or Name)
How to visualise tube elements in 3D | This tutorial shows how to generate a 3D visualisation of tube elements
How to model intersecting pipes | This tutorial model intersecting pipes represented by tube elements

Examples

This set of tutorials focus on models for specific examples.

Bi-Metallic Corrosion Cell | This tutorial shows in detail how to create the geometry and layers for a later use with the CP Model Editor.
Monopile | This tutorial shows how to prepare the geometry and layers for a later use with the CP Model Editor. The steps to construct the geometry are briefly discussed.
Flowline | This tutorial shows how to export the mesh and hmd template for later use with the CP Model Editor for a model of flowline (partially buried) with internal resistance.
Offshore jacket structure | This tutorial illustrates how to import an off file for modelling of jacket structures, how to proceed with tube elements and how to create suitable layers for the CP Model Editor.
Ship hull | Using an existing geometry and mesh, this tutorial shows how to export the geometry mesh and hmd file for later use with BEASY CP Model Editor.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Main Window

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\mainwindowinpre\mainwindowinpre.htm

BEASY GID. Main window in the pre-processing session

Main features of the 3D User Interface on pre-processing mode

The "GiD standard menu bar" across the top contains the commands to display various menus and a workspace switcher.

Various icons appear on the left (GiD toolbar).

The "Layers" window is accessible through the standard menu bar "Utilities > Layers"

The "status bar" shows a history of the commands introduced.

The "command line" allows introducing commands by text.

If the BEASY problem type is loaded, the BEASY geometric toolbar appears on the vertical panel.

To load the "BEASY problem type", on the GiD standard menu bar, go to "Data>Problem type> BEASY> BEASY"

Note that, in order to see the BEASY problem type under "Data>Problem Type" menu, you should first copy the BEASY the problem type to the correspondig folder.

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Location of the colour bar

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\colourbarlocation\colourbarlocation.htm

BEASY GID. How to change the location of the result colour bar

Move the legend

You can move the bar by using: "Utilities> Tools> Move screen objects"

To move the contour bar, axes or other objects in the main working GiD environment, go to the standard menu bar on the top and select "Utilities->Tools->Move screen objects", then select the object to move. Click again to confirm the new position and press "Escape" to finish.

This location is saved in your user preferences file so next time you open GiD legends or other objects will appear in the previously selected position.

View the legend in a new window

You could use "Options>Legends" and tick "Outside" to visualise the contour bar in a separate window:

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Displaying Results BEASY CP

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\displayresults_cp\displayresults_cp.htm

BEASY GID. Displaying CP Results

View Results

Contour fill

View Results Window

Display of results on tube elements

Display of results on dual elements

View Results

To load results first switch to post-processing mode.

You can visualise results in a wide variety of ways. Through the command "View Results" different ways of visualising results can be accessed. The main categories that are commonly use and shown in the BEASY tutorials are:

Scalar results

  • Show Minimum & Maximum

  • Contour Fill

Vector results:

  • Display Vectors

Graphs lines:

  • xy plots

Contour fill

For example, to visualise contour fills of protection potential, select "View Results >Contour Fill > Averaged protection potential".

Figure 1. View Results. Contour Fill

Figure 2 shows results on metallic surfaces. The view is obtained by:

  • turning off the layers containing anodes surfaces

  • turning off the layer "No BC" (the external boundary box)

  • changing "Set contour limits" to "Visible sets for this step" in the "Preferences Window", "Contour fill and lines" section.

Figure 2. View Results. Contour Fill. Protection potential

Preferences Window accessed through "Utilities > Preferences" is shown in Figure 3.

Figure 3. Preferences

View Results Window

An alternative way to access different results available is by using the "View Results" window. Select "Window" from the main standard bar and then "View Results". The "View Results" window pops up:

Figure 4. View Results window

Scroll in View to select the result type to display:

Figure 5. View Results window

Display Contour Fill

Figure 6. Select what to view

Tube elements

Results in tube elements are shown in two different displays. The layers with names containing "TUBEs" have results displayed on a line and the layers with names containing "Resels on tubes" have results displayed on the corresponding cylindrical surface.

Figure 7. Layers in post-process

Figure 8 shows the post-process view when "No results" are selected. On the top, only the "TUBEs" layers are on. Below, the layers "Resels on tubes" only are "on".

Figure 8: Showing "No Results". line display (TUBEs layers) and cylindrical display (Resels on Tubes layers)

Figure 9 and Figure 10 show results using the two displays.

Figure 9: Showing results using the TUBEs layers

Figure 10: Showing results using "Resels on Tubes" layers

Dual elements

Results on dual elements are displayed in two surfaces. The separation is controlled by the offset distance introduced at the pre-processing stage. Figure 11 shows results on the dual elements. In this case the offset distance value was 0.02.

Figure 11: Showing Protection Potential on the two beams and a closer view showing both sides of one beam

Figure 12 shows a view of the results when the offset distance is 0.0002 . Results look superimposed and the separation resulted too small.

Figure 12: Showing Protection Potential on the two beams. Separation is too small.

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Result Visualisation

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\index_cp\index_cp.htm

BEASY GiD. Visualising Results

To visualise results in GiD you need to open the GiD interface and switch to post-process mode.

  • How to switch to post-process stage

  • How to open result files

Visualising results

  • Visualising Results on BEASY CP

Layers in Post-process

  • How are layers shown in post-process mode for BEASY CP models

  • How to change the location of the colour bar

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP - Layers in post-process mode

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\layers_cp\layers_cp.htm

BEASY GiD. Layers in post-process mode for BEASY CP

You can choose to view any layer of the mesh by clicking on "Window>View Style" to make the "View style" window appear as shown in the right hand side of Figure 1.

Figure 1: Post- processing showing View Style window with layers on the right hand side

Note that the name of each layer corresponds to the name of the groups defined in the model. After the group name appears in brackets the label of the polarisation (Boundary Condition) applied to the group, as shown in Figure 2.

The groups with insulating boundary conditions appear in one layer called "S No BC"

Figure 2: Labels names

For example, while viewing results some layers are hidden, then the range of the contours is adjusted (Figure 3) to show results on the "on" layers only.

Figure 3: Showing results over STEEL only (materials with label STEL)

Layers for tube elements

If the model has tube elements, the original layer name ("gname", for example) is subdivided and shows two layers in post-processing mode ("Resels on tubes", "TUBEs").

The TUBEs layers show the results on a line.

The Resels on tubes layers show the results on a cylindrical surface with the diameter assigned to the tube element.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Open Result File

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\openresultfiles\openresultfiles.htm

BEASY GiD. Open Result Files

Once in post-process mode, go to "Files > Open" to open the post-processing files (*.pos.res).

Browse to the location of the result file. You can select either:*.post.res, or *.post.msh to open a result file.

Open multiple files

To open multiple files, go to "Files > Open multiple" and browse to the post-processing files.

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Post-processing mode

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\post-process\postprocessmode\postprocessmode.htm

BEASY GiD. Post-process mode

When GiD is launched, it starts in pre-process mode. To switch to post-process mode you can use the icon at the top right hand side:

Once the User Interface is opened the post-processing mode is accessed by clicking on the icon that toggles between pre and post-process modes

For more information about post-processing and 3D visualisation with GiD, press the function key F1, or go to "Help>Help GiD" from the standard toolbar.

The status bar shows the text:

You can now procced to open a result file

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Check For Coincident Lines

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\checkcoincidentlines\checkcoincidentlines.htm

BEASY GiD. How to check for coincident lines

The command "View>Higher Entities>Lines" is used to check for coincident lines

With this option, it is possible to colour-code lines according to the number of surfaces that a given line belongs to.

In the example below, surface 1 and 2 are contiguous. If they share the common line at the boundary, the number of higher entities for the line should be 2.

The images below show the result of the command in the case the surfaces don't share any line and the case where the centre line is shared.

There are 2 coincident lines at the boundary between S1 and S2: Each line has 1 higher entity, i.e. one line is associated with S1 and the other with S2.

There is only 1 line at the boundary between S1 and S2. There are 2 higher entities associated with the line at the boundary, i.e. the line is shared by the contiguous surfaces

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Collapse Lines

To make lines to be shared by contiguous surfaces, use "Collapse" lines. Follow instructions below

To verify there are no more coincident lines go to "View>Higher Entities> Lines"

If lines are still not collapsed

Sometimes trying to collapse all lines will not immediately correct the problem at all locations If after using "Geometry > Edit > Collapse >Lines", there are still coincident lines, you can check the following:

  • Check the collapsing settings in preferences (if lines are in different layers these could be the cause). Change the preferences if needed.

  • Check that the coincident lines don't have mesh defined sizes. If mesh size if different for both lines they won't be collapsed.

Alternatively, using "Utilities > Repair Model", may allow collapse all lines to work more effectively.

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to define a mesh for CP modelling

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\definemeshcp\definemeshcp.htm

BEASY GiD. How to define a mesh for CP modelling

The first step consists on defining the mesh properties for individual components of geometry.

Note that

  • The mesh definition is saved with the model and kept if the model is exported.

  • If an entity is copied, the mesh definition is also inherited by the copied entities.

  • The mesh for CP models needs to be quadratic type (Quadratic9)

Mesh definition for BEASY CP model

This involves declaring the type of mesh and number of elements or size to apply to entities. To do so, consider the following:

  • Identify if a structured mesh is required on surfaces. In many cases structured meshes, leading to quadrilateral elements, are preferred. Then declare the number of elements on lines.

  • If an unstructured mesh is required, then define sizes for surfaces.

  • Concentrate elements in regions where the geometry or the conditions vary rapidly.

  • Prefer elements with good aspect ratio (i.e. avoid long and thin elements for example)

  • Avoid distorted elements with big curvatures.

  • Preserve a smooth grading factor

  • When generating the mesh for CP models, remember to set up quadratic type (Mesh > Quadratic > Quadratic9)

Structured mesh

Menu: Mesh >Structured

A structured mesh is a mesh where all the nodes have the same number of elements around them.

To create a structured mesh, choose Structured -> Surfaces/Lines.

In GiD 9 after selecting escape, the number of elements per line is given.

The default number of elements for surfaces or lines defined as "Structured" 2.

By default, the generated elements in four-sided structured meshes are quadrilaterals.

In GiD 14 you can select the number of divisions on lines or the size of the elements on directions on lines.

Figure 1: Structured Mesh

Element concentration

Menu: Mesh >Structured >Lines > Concentrate elements

By default, all partitions in one structured line have the same approximate length. This command lets you select one line, which will be shown in the graphical window with an arrow indicating its direction. You then have to enter a positive or negative weight. If the weight is positive the elements will be concentrated towards the extremities of the line; if negative, the elements will be repelled.

Figure 5: Concentrate elements

Unstructured Mesh

Menu: Mesh > Unstructured

By default all the surfaces or lines will be treated as unstructured unless they are defined otherwise and meshed with a default size.

It is possible to assign different sizes to different entities of the mesh. To do so, declare the mesh as unstructured and apply a size.

All the entities that do not have an assigned size when meshing take the default one.

Assigning the size 0.0 to an entity is the same as setting the default size.

The transition between different sizes is controlled by a parameter in preferences.

Discontinuous Meshes for BEASY CP modelling

When lines between 2 different surfaces are shared the resulting mesh is continuous, in which element edges match up on adjacent surfaces and share mesh points.

You can however create a discontinuous mesh by using the "Geometry>Edit>Uncollapse>Surfaces" command. Any surfaces processed like this can be meshed independently of adjacent surfaces.

Figure 1 shows an example of un-collapsed surfaces with different number of elements applied to them generating a non-conforming or un-matching mesh; this can be useful when applying grading.

Figure 1: Un-matching meshes

Figure 2 shows and example of discontinuous mesh. When modelling two different materials that are in contact un-collapse surfaces to create a discontinuous mesh. If the materials are not sharing nodes, then the displayed Averaged Solution will show the abrupt change on the solution from one side to the other. However, if the nodes are shared, the solution will be averaged showing a smooth transition which is unreal.

Figure 2: Discontinuous mesh

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


View Surface Normals

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\identifysurfacenormals\identifysurfacenormals.htm

BEASY GiD. How to check normals orientation

The command "View>Normal>Surfaces" draws the normal vectors of the selected surfaces.

To check consistency of directions it is handy to select "View>Normal>Surfaces>Colored". This command draws the back face of the surface in colour yellow (the front of the surface is drawn in the same colour as the colour of the corresponding layer).

Other way to view normals is by using the command "View>Normal>Surfaces>Normal".

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Move Entities To Layer

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\moveentitiestolayer\moveentitiestolayer.htm

BEASY GiD. How to send entities to layer

In the "Layers" window, "Sent To" button: Moves entities from one layer to another. No new entities are created.

For example, if in geometry mode you select "Send to > Surfaces" and then click on some surfaces, then those surfaces will be sent from the original layer to the selected/highlighted layer (layer 2 in the picture below)

If the option "Also lower entities" is ticked then the selected surface, together with its lines and points will be moved to the highlighted layer

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Pre-processing mode

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\preprossesingmodecp\preprossesingmodecp.htm

BEASY GiD. Pre-processing mode

The BEASY GiD 3D User Interface has powerful geometry building capabilities, including solid geometry and Boolean operations. In addition, there are multiple ways to read geometry from CAD.

For creating geometry, the most important difference with other CAD systems is that the geometry is constructed in a hierarchical mode. This means that an entity of higher level (dimension) is constructed over entities of lower level.

The BEASY GiD Problem Type is provided as part of this product, which specialises GID for BEASY modelling.

When GiD is launched, it starts in pre-processing mode.

In pre-process mode you can visualise the geometry and the mesh. To toggle between geometry and mesh view you can use the icon in the vertical toolbar:

Tools commonly used at pre-processing stage:

  • Move entities to a different layer

  • Collapse lines

  • Un-collapse surfaces and lines

  • Identify surface normals

  • Swap surface normals

How to define a mesh suitable for CP models:

  • Define mesh size for CP models

Additional tools provided by the problem type can be found at:

  • Geometric Functions: Additional functionality aimed at facilitating the creation of geometrical entities

  • Surface area calculation : Calculate the surface areas of a group of surfaces

  • Beasy Labels: To define Labels attached to a position

  • Line operations : Offers a set of operations for geometrical handling of lines

  • Report entities ID: This tool allows listing ids for any number of selected entities

  • CP Modelling: A set of tools to aid the building of geometry for CP models (anode creation, tools for pipelines, ship builiding and jacket structures, tool for creating survey points )

Import functions provided by the BEASY problem type:

  • Import off file : Import a BEASY off file with information of structural members and diameters.

  • Import multiple GiD mesh: Use to import multiple mesh files. This tool is useful when importing multiple zone mesh files generated by the "CheckDat" tool in GiD 14

Export functions provided by the BEASY problem type:

  • Layer tools: Export model layer names (or a subset of layers names) to an ASCII file.

  • Export mesh : Export the mesh files "*.bzmsh".

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Swap Surface Normals

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\swapsurfacenormals\swapsurfacenormals.htm

BEASY GiD. How to swap surface normals

The command "Utilities->Swap normals> Surfaces>Select" inverts the direction of the normals of the selected surface(s).

Alternatively, if you are already visualising normals, you can right-click the mouse to display the Contextual menu. Then, select "Swap Some"

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Un-Collapse

BEASY version 21 - CP

Filename: installdir\docs\cp\graphical_interfaces\gid_plugin\pre-process\uncollapse\uncollapse.htm

BEASY GiD. How to create independent surfaces

Un-collapse surfaces

To make a surface independent from contiguous surfaces select Geometry > Edit > Uncollapse > Surfaces"

To verify there are no more coincident lines go to "View>Higher Entities>Surfaces"

Un-collapse lines

To make a line, boundary to a surface, to be not shared by a contiguous surface, select "Geometry > Edit > Uncollapse lines

To verify there are no more coincident lines go to "View>Higher Entities> Lines"

==============================End of document=================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Bi-Metallic Cell

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\bimetalliccell\bimetalliccell.htm

Bi-Metallic Galvanic Corrosion Cell

This tutorial explains how to build a bi-metallic corrosion cell composed of zinc and steel, solve it, and obtain results such as total current flowing between the electrodes and electrode potentials.

In the GiD plugin tutorials, you can find the steps to construct the geometry.

CONTENTS

1 Introduction

2 Geometry and mesh

3 Polarisation data

4 Model Definition

4.1 Open the CP Model Editor

4.2 Import mesh

4.3 Import polarisation curves

4.4 Group Definitions

4.5 Zones

4.6 Save the hmd file

4.7 Solve

4.8 Results

5 Post-process

5.1 Protection Potential

Files used in this tutorial are zipped and you can save them by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    Two plates of dissimilar materials are immersed in a tank filled with electrolyte of conductivity 4 S/m as shown in Figure 1. The plates are interconnected through a conductor.

    Figure 1: Schematic of the bi-metallic galvanic corrosion cell. The dimensions of the tank are: Width = Height = 2m (the circumscribed circle has a radius of 1.41421), Length = 5m.

    The problem has been broken down into the following key stages:

    • Creating geometry and mesh

    • Creating model and running analysis in order to find the total current flowing from one plate to the other and the potential on each plate

    • Post-process

    The files used in this example are provided in multiple folders as shown in Figure 2. The mesh files are in the folder "Mesh" and the model and result files are in the folder "Model Files"

    Figure 2 Files location

    The objectives of this tutorial are:

    • To introduce to BEASY modelling with a simple comprehensive model

    • To learn the most basic approach for creating the geometry of a model

    • To understand the complete simulation process

    • To introduce the concept of groups and zones

  2. Geometry and mesh

    The geometry for this example was created using the GiD graphical interface equipped with the BEASY problem type. Follow this link to learn how to create the geometry.

    The resulting mesh has groups named as follows:

    • Anode: surface in contact with Zinc

    • Cathode: surface in contact with Steel

    • Insulating_Walls: surfaces of the cell with insulating conditions

    Important notes to consider when creating geometry and mesh:

    • Surfaces in a CP model are usually organised into "groups", which allow applying conditions (e.g. material properties, boundary conditions) on them.

    • A "zone" represents the volume occupied by the electrolyte in the region of interest. Any CP model requires having at least one zone defined which is done by listing the "groups" enclosing it.

    • All boundary surfaces defining a zone must be oriented such that their normal directions point outwards from the electrolyte point of view, as illustrated in Figure 3.

    Figure 3: Showing the correct orientation of the normal vector for boundary surfaces in a zone of a BEASY-CP 3D model

  3. Polarisation data

    The material file provided has a sample polarisation curves with labels:

    • STEL: non-linear polarisation curve for steel in contact with seawater

    • ZNLI: linear polarisation curve

  4. Model Definition

    To begin this section you should have already created the mesh (*.bzmsh) for the model and have the material file (*.mat_cp) available.

    1. Open the CP Model Editor

      Start by opening the CP Model Editor.

      Figure 4: CP Model Editor

    2. Import mesh

      Import the mesh using the "Imported meshes" tool. To add a mesh press the "+" button at the bottom of the tool or right click inside the panel area and select the option "Add Mesh".

      When the "Import mesh file" window pops up browse to "BiMetallicCell.bzmsh".

      Note that the field "Mesh Name" is automatically generated. You can change the proposed name. In this example our model is defined by only one mesh, so the "Mesh Name" is not relevant.

      Figure 5: CP Model Editor. Import mesh file

      It is possible to add geometrical transformations to the mesh but we don't need to do that in this example, so we continue and press "Accept".

      After importing the mesh all the groups defined in the mesh file are also loaded with default parameters in the "Group Definitions" tab. The CP Model Editor looks as shown in Figure 6.

      Figure 6: CP Model Editor. Mesh imported

    3. Import polarisation curves

      We need to import the polarisation file containing all the polarisation curves we will be using in this example. Using the "Imported polarisation curves" tool, press on the "+" button at the bottom of the tool and browse to the corresponding mat_cp file (ModelFiles/BiMetallicCell.mat_cp). The available polarisation curves are identified by labels as shown in the tool in Figure 7.

      Figure 7: Imported polarisation curves tool

      Note the information bar at the bottom of the CP Model Editor reports on the actions performed and possible errors.

    4. Group Definitions

      The "Group Definitions" tab is used to define the role of each group in the assembled model.

      Note that after importing the meshes, the "Group Definitions" tab is populated with the groups corresponding to each of the imported meshes. Values assigned to the different columns are default parameters. (Figure 8).

      Figure 8: Group definitions tab. Default values

      The values shown in red represent errors or missing data that needs to be defined. For example, values in Figure 8 for "Master zone ID" are shown in red because we haven't entered any parameter to define the zone yet.

      1. Mesh and Group

        The first two column properties (Mesh and Group) are already defined:

        Mesh:This column has the name of the mesh to which the group belongs.

        Group: Indicates the name of the groups present in the imported mesh file.

      2. Master and Slave zone IDs

        We now need to define values for the other column properties. We can start defining "Master zone ID" and "Slave zone ID" for example. Note model data can be enter in any order.

        Each group needs to have a Zone ID defined.

        Master zone ID: This is a positive integer. The IDs are defined progressively for different zones with increasing number starting from 1. This model is a single zone (all the groups of surfaces are enclosing the electrolyte in zone 1)

        You can edit the zone ID by clicking on it and entering a value, or using the spin box arrows.

        Figure 9: Group definitions tab. Master and Slave zone ID properties

        Note that by clicking on a column title, the data is sorted according to values on that column.

        Values are shown in red because zones are not defined yet. We can go to the "Zones" tab and define them at any time.

      3. Group type property

        Group type defines the role of the group in the simulation. The available options are shown in Figure 10. A full description of all the options can be found in the "Group Definitions" tab section.

        Figure 10: Defining "Group type" property

        For this example select:

        • ANODE for the group "Anode". This is generally used for groups that need to be specially considered as anode or need to be assigned sacrificial anode properties.

        Note: The CP Solver will calculate the performance despite of this assignment. For example, depending on the particular conditions of the problem results could show that a group defined as "ANODE" has cathodic behaviour.

        • METAL for the other groups. This is generally used for groups of the structure with polarising, insulated, fixed current density or potential boundary conditions (or for boundary surfaces which confine the shape electrolyte).

        Double click on "METAL" and select the corresponding group type for each group using the down arrow.

        You can also click on "METAL" and type the first letter of the available keywords.

        After selections are made for all the groups the "Group type" property looks as shown in Figure 11.

        Figure 11: "Group type" property defined

      4. Boundary type and Boundary value properties

      We can proceed to define "Boundary type" and "Boundary value" properties. First, for "Boundary type", select "POLARISATION" for the groups "Anode" and "Cathode" and "INSULATED" for the group "Insulating_Walls" as shown in Figure 12.

      Figure 12: "Boundary type" properties defined

      Values in "Boundary value" property turned red meaning we need to define them, i.e. specify the label that identifies the corresponding polarisation curve.

      You can type labels manually, or copy them through the column. To avoid misspelling a label, we recommend selecting the labels from the ones defined in the material file.

      One way of assigning a polarisation curve is by double clicking on "UNKNOWN" and scrolling to select among the available labels. Alternatively, you can start by typing the initial letter of the label.

      Another way of doing this is using the "Imported polarisation curves" tool. Select a row in the "Boundary value" column and in the "Imported polarisation curves" tool, select the label you want to apply and press the double arrow.

      After assigning all labels the "Group Definition" tab looks as shown in Figure 13.

      Figure 13: "Boundary value" property. Scroll to assign polarisation curve

    5. Zones

      We can now start defining the zone properties. The "Zones" tab is used to define the zone properties such us conductivity/resistivity of the electrolytes. This example consists of a single zone with:

      • Electrolyte conductivity 4 S/m

      Go to the "Zones" tab.The tool is shown in Figure 14. Zone ID 1 is already defined and highlighted in red. It appeared defined because we already used zone ID 1 in the "Group Definitions" tab. It is shown in red because we haven't defined any parameter for the zone yet. (Figure 14)

      Figure 14: "Zone" tab

      Click on zone 1 to start defining the zone parameters. In this example, we define conductivity value as shown in Figure 15.

      Figure 15: "Zone" tab. Zone 1 parameters

      Note you can select the units of your choice to enter zone conductivity (or resistivity). Units will be converted to match the model units shown at the top of the window "Units to use during the simulation".

    6. Save the hmd file

      We have defined all the data needed for this example. We need to save the hmd file and then go to the "Solve" tab.

      To save the file go "File > Save as". We save it as "BiMetallicCell.hmd". The name of the file is at the top of the window and the "Work directory" is now showing the path to the hmd file. (Figure 16)

      Figure 16: Saved hmd file

    7. Solve

      We can now go to the "Solve" tab. We will leave default settings for this example. So we go directly to press "Create Model".

      1. Create Model

        The "Create Model" button performs the following actions:

        1. Creates a mat_cp file using the materials defined in the imported mat_cp file. The file is created with the same root name as the hmd file. If necessary, units are converted to match the model units defined in the top of CP Model Editor window ("Units used in simulation")

        2. Saves the hmd file with the current name. If the hmd has never been saved before, then you will be asked to provide a name.

        3. Performs a series of sanity checks

        4. Runs the CP Builder to create a dat file.

        5. It also creates a batch file to launch the CP Solver from command line

        After pressing "Create Model" the CP Model Editor looks as shown in Figure 17.

        Figure 17: After "Create Model"

        At the right of the window, vertical tabs give access to different reports. The model creation report is shown in Figure 18.

        Always check for errors or warnings on the Model Creation Report. You can use the search button at the bottom of the window.

        Figure 18: "Model Creation Report"

      2. Solve Model

      Now we are ready to start to run an analysis Press "Solve Model" to launch the BEASY CP Solver. The "Solver runtime report" shows the messages from the Solver while the analysis is in progress. You can also check the "Status" at the bottom of the window.

      Once the analysis is finished, the "Solver runtime report" will appear as shown in Figure 19.

      Figure 19: "Solve Model". Analysis finished

      You can now check the "Solver Log File" for any warning or error

    8. Results

    Go to the "Results" tab and press "Create Report". The Summary Report is created as shown in Figure 20.

    Figure 20: "Summary Report"

    First, we check that the error in current balance is negligible. Go to the section "Model Current Balance"(Figure 21). It reports the summation of the current in the system. This should be in equilibrium. A small error of a few percent is acceptable, i.e. below 3% for example. Larger errors could mean that some errors were introduced during the preparation of the model and it is highly unlikely that the results are correct.

    Figure 21: "Summary Report". Model current balance

    Then, we can look at the "Group results". For each group, we can identify values of the most positive protection potential, or ranges of protection potential. For each group, the total anodic and cathodic currents are also reported.

  5. Post-process

Once the simulation has completed you can visualise contour plots of results in GiD. Open GiD, switch to "Post-process mode" and open the GiD result files (one of post.res/post.msh files). This is done by selecting View -> Mode -> PostProcess from the standard menu bar at the top.

Contour plots can be viewed by going to "View results > Contour Fill".

  1. Protection Potential

Select "View Results->Contour Fill->Protection Potential > Averaged Protection Potential" to see the potential distribution on the active electrodes shown in Figure 22

Figure 22: Showing the potential distribution on the active electrodes of the model

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to check zones are correctly defined

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\checkzonedefinition\checkzonedefinition.htm

How to check that geometry of zones are correctly defined

This tutorial shows how to check that zones are correctly defined in a dat file and illustrates the use of the " Model checking tool " .It shows how to visualise the resulting meshes in GiD 9 and GiD 14.

CONTENTS

1 Introduction

2 Model description

3 Model checking tool

4 Viewing the zone checking .msh files

4.1 Using GiD9 to view zone checking data

4.2 Using GiD14 to view zone checking data

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with:

  • Creating geometry and meshes using GiD.

  • BEASY multi-zone modelling concepts .

  1. Introduction

    In a boundary element model it is important that:

    • The normal direction of all surfaces is correctly defined

    • The zone boundary is complete

    • Any internal points are inside the zone boundary

    In a multi-zone model these aspects can be difficult to check.

    This example shows how to use the available tools to check that zones are geometrically correctly defined.

    The input file to the tool is a dat file and the output files are a number of GiD mesh files (one for each zone in the model) containing all the mesh elements that enclose each zone.

    The files used in this example are provided in multiple folders:

    • Geometry: Containing the geometry files in GiD and

    • Mesh: Containing the mesh file

    • ModelFiles: Containing the hmd file, mat_cp file and the created dat file.

    • Checks: Containing the dat file and the mesh files created with "Checking Model tool".

  2. Model description

    The model consists of a three zones including internal points. Zones are shown in Figure 1.

    Figure 1. Three zone model

    All the layers defined in the GiD model are shown in Figure 2

    Figure 2. Layers in the GiD model

    There are four surfaces on which elements will be used to define internal points in the model. These surfaces are in groups such as "internal_points_in_zone_1". The groups of internal points are shown in Figure 3.

    Figure 3. Groups of internal points

    All the groups enclosing zone 1 are shown in Figure 4.

    The interface between zones 1 and 2 has been divided into a "grillage" pattern, and:

    • part of the grillage (in group "zone_1_to_2_steel_interface") is intended to represent both sides of a metal plate

    • the remainder of the interface (in group "zone_1_to_2_interface") represents the boundary between the zone through which currents can flow

    Figure 4. Groups enclosing zone 1

    Master groups to zone 2 are shown in Figure 5.

    Figure 5. Master groups to zone 2

    At the position where zone 2 and zone 3 meet, a different strategy has been used to represent the two sides of the metal grillage:

    • group "zone_2_cathode" includes geometry which is on the grillage surface in zone 2

    • group "zone_3_cathode2" includes geometry which is on the grillage surface in zone 3

    Because the thickness of the plate was not taken into account in this example, this means that the geometry in the above two groups is in exactly the same position. This is a perfectly valid technique, but makes it difficult to check the zone geometry without using the techniques demonstrated in this example.

    Master groups in zone 3 are shown in Figure 6.

    Figure 6. Master groups to zone 2

  3. Model checking tool

    The .dat file provided is checked with the "Model Checking tool".

    Select the the "Model Checking tool" in the CP Desktop to access the panel shown in Figure 7.

    Figure 7 Model Build Tools. Create GiD files for zone checking

    The third radio button was selected, to create layer names which most easily identify the zone and function of the layers in the model.

    Press "Select dat file and create .msh files" and browse to the .dat file "threeZones_with_InternalPoints.dat". The three mesh files created are shown in Figure 8.

    Figure 8. Created mesh files

  4. Viewing the zone checking .msh files

    Each of the files created for zone-checking contains only geometry which is part of a single zone.

    By reading a single such file into GiD, it is possible:

    • to identify the element normals

    • to visually check that the zone does not contain geometry which it should not, and does not have holes

    Reading a single .msh file into GiD can be done using either GiD9 or GiD14. However, with GiD14, when the BEASY problem type is loaded a function to read the 3 meshes together is available.

    1. Using GiD9 to view zone checking data

      An example of doing this using GiD9 is shown in Figure 9 to Figure 12.

      First import a mesh using "Files > Import > GiD mesh " as shown in Figure 9. Select one of the mesh files, for example "threeZones_with_InternalPoints_Zone1.msh" to start checking zone 1.

      Figure 9 Import GiD mesh

      You can change the visualisation using "View > Render> Flat".

      As can be seen in Figure 10, the layer names available in GiD9 all start with the word "Mat" followed by a number. The correlation of these layer names with the GiD layer names in the model is written in the Check.log file

      In this way, it is possible to check that the zone boundary is complete, is oriented correctly, and that all internal points are inside the zone.

      Figure 10. Showing layers and mesh for zone 1using render flat

      Figure 11 and Figure 12 show how to turn on display in which the "inside" side of a surface is drawn in colour yellow and the outside in the colour assigned by GiD to the layer. It is clearly better to make sure that the colours assigned to each layer do not include colour yellow!

      Figure 11. Command to visualise normals such that the side of the surface that is facing the electrolyte(back of the surface) is shown in yellow

      Figure 12. Showing normals with colours (the side facing the electrolyte is shown in yellow)

    2. Using GiD14 to view zone checking data

    1. One .msh file at a time

      Performing the same operations (as described in the previous section) but using GiD14 is demonstrated in Figure 15 to Figure 17.

      Note that in GiD14:

      • the layer names are displayed as a tree structure

      • the layer called "All_InternalPoints" was created by the Checkdat operation (i.e. it is not a group which was present in the dat file) and contains all internal points in the corresponding zone

      • the layer called "internal_points_in_zone_1" (which was present in the .dat file) now contains only the result elements which were used to create the internal points

      Figure 15. Showing layers and mesh in zone 1 using render flat

      Figure 17. Showing side exposed to the electrolyte in yellow

    2. Multiple .msh files at the same time

    In GiD14, if the BEASY_GiD problem type is loaded, the command "Multiple GiD Mesh" provides a way to import multiple .msh files at the same time.

    It is important to note that during this operation, GiD avoids having more than 1 element or mesh point with the same ID by renumbering. This means that displayed ID number will not in general correspond to those in the .dat file when you have read multiple msh files.

    To use this facility, first load the problem type ("Data > Problem Type> BEASY_21May2020 > BEASY") and then use the command shown in Figure 19.

    Figure 19. Import Multiple GiD mesh

    This brings up the panel shown in Figure 20.

    Figure 20. Select all mesh files

    Select all the .msh files and press "Open", which after file import will display a panel as shown in Figure 21.

    Figure 21. Information window

    You can check completeness of each zone separately by turning off/on different layers.

    Once the location of the internal points is checked, layers of internal points can be turned off as shown in Figure 22.

    Figure 22. The three zones with internal points layers turned off

    Now using "coloured elements" (described earlier) to display element normals, and using clip planes to view the "inside" of the model gives a view as shown in Figure 23.

    Figure 23. Showing sides facing the electrolyte in yellow

    Note the arrowed "speckled" section of the image in Figure 23, which normally indicates two surfaces on top of each other. In this case there should be two surfaces on top of each other (as noted in section ‎3) on parts of the grillage between zones 2 and 3.

    Figure 25 shows the display when both zones 1 and 2 are turned off.

    Figure 25. Showing zone 3 only

    Points to note are:

    • The red-arrowed elements are in layer "Z3//MASTER//zone_3_cathode2"

    • The blue-arrowed elements are in layer "Z3//SLAVE//NoBC"

    As element in layer "Z3//SLAVE//NoBC" should be outward pointing to zone 2, this means they should be inward pointing to zone 3, so this is all correct.

    Similar checks can be done for zone 2 and zone 3.

  5. Type of errors and how to correct them

After performing the checks, you could find different type of errors: For example:

  • A group was found in an incorrect zone: To correct these open the CP Model Editor and load the hmd file. Correct the assignment of zones on the corresponding groups and re-create the dat file

  • A normal was found with wrong direction: To correct this you can go back to GiD, revert the normal and export the mesh with the same name and in the same location as you did when creating the original hmd file. Then in the CP Model Editor open the corresponding hmd file and re-create the dat file.

Alternatively, you can load the hmd file in the model editor without changing the mesh and activate "Swap Normal" in the "Group Definitions" tab for that particular group. Then re-create the daf file.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Create Model from existing HMD

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\createmodelfromhmd\createmodelfromhmd.htm

Steps to create a model from an existing HMD file

One of the main uses of the CP Model editor is to create or edit existing model files. This tutorial shows steps to follow to create a model using an existing HMD file.

CONTENTS

Creating a model from an existing HMD file

What happens if the mesh import goes wrong

What happens if the material file import goes wrong

Files used in this tutorial are zipped and you can save them by right clicking in the following link: Right click here to save files.zip

Creating a model from an existing HMD file

You can edit aspects of your model by loading an existing *.hmd file. Steps to follow:

  1. Load the existing hmd file in the CP Model editor ( model0.hmd for example)

  2. The "Imported Meshes" tool will be populated with the names of the meshes defined in the existing hmd file.

    Note the existing hmd file contains the path/names of the mesh files.

    You can add more or remove meshes at this stage. You can also edit a mesh by adding geometrical transformations to the mesh

  3. Load a mat_cp using the "Imported Polarisation Curves" tool. Note you need to have all the labels already defined in the existing hmd file (model0.hmd) defined in the imported mat_cp file.

  4. Edit model properties using the different tabs. According to the particularities of the model, define/edit additional properties using the pertinent tabs

    You can choose to omit groups from the list, or if the mesh was recreated with additional add properties for the new groups, etc.

  5. Go to "File > Save as" and save the hmd file with a new name

  6. Once the new hmd file is saved you can go to the "Solve" tab.

  7. If needed, adjust the settings in "Settings". Then you can press the button "Create model".

What happens if the mesh import goes wrong

If after loading the HMD file the error message shown in Figure 1 pops up that means the mesh was not found in the path defined in the HMD file.

Figure 1 Error importing mesh when opening the HMD file.

You can press "Export" to export the error message to a txt file. In the example shown above, the error message is as follows:

Error reading MESH_IMPORT_PARAMETERS from file "ResultElements.hmd"

Mesh Error "threeZones_001"

Line: 113 Mesh file :"../Mesh/threeZones_with_InternalPoints.bzmsh" does not exist

Error reading group definitions from file "ResultElements.hmd"

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

Mesh "threeZones_001" is not part of the model

The mesh file was not found in the described location.

To overcome this you can proceed doing one of the following options:

  • OPTION 1: Make sure the mesh files are in the defined paths, i.e. copy/create directories as written in the HMD file

  • OPTION 2: Close the CP Model Editor and manually edit the path in the hmd file before loading the hmd file into the CP Model Editor. Edit line 113 with the correct location of the mesh file.

  • OPTION 3: Or you can simply import the mesh again browsing to the correct location. Press the "+" button in the "Imported meshes" tool and browse to the corresponding meshes as shown in Figure 2.

Figure 2 Importing mesh

What happens if the material file import goes wrong

If after loading the HMD file the labels defined in the "Group Definitions" tab appear in red and the error message in the in the status bar at the bottom of the CP Model editor says "Matching mat_cp file could not be found" (Figure 1) that means you should incluede a mat_cp file with the same root name as the HMD file in the same folder as the loaded HMD file.

Figure 3 Error importing mat_cp file when opening the HMD file. Matching mat_cp not found

To overcome this you can proceed doing one of the following options:

  • OPTION 1: Close the CP Model Editor, place an adequate mat_cp file with the same root name as the HMD file in the same location where the HMD file is.

  • OPTION 2: Or you can simply import a mat_cp file browsing to the correct location. Press the "+" button in the "Imported polarisation curves" tool and browse to the corresponding mat_cp file. Note in this case the file can have any name.

=============================End of document==============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Flowline with internal resistance

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowline\flowline.htm

Flowline with internal resistance

This tutorial illustrates the use of the CP Model editor. It shows how to model a flowline in seawater with internal resistance, how to define sacrificial anode data and how to model tube elements and a multi-layered zone with the CP Model editor.

CONTENTS

1 Introduction

2 Geometry and mesh

3 Polarisation data

4 Model definition

4.1 Open the CP Model Editor

4.2 Import mesh

4.3 Import polarisation curves

4.4 Group Definitions

4.5 Zones

4.6 Sacrificial anodes

4.7 Return Path Circuit

4.8 Save the hmd file

4.9 Solve

4.10 Results

5 Post-process

5.1 Protection Potential

5.2 IR drop

5.3 Numeric results

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example uses the existing geometry of a flowline and anodes as a starting point. It assumes that the user is familiar with:

  • Creating geometry and meshes using GiD.

  • BEASY zones and modelling concepts

  • Definition of return path circuit

  1. Introduction

    This example aims to assess the performance of a CP system based on sacrificial anodes on a flowline. A view of the model is shown in Figure 1.

    The example consists of a flowline in seawater that has a buried section on the seabed.

    Figure 1: Model overview

    The problem has been broken down into the following key stages:

    • Creating geometry and mesh

    • Creating model data

    • Running analysis

    • Post-process

    The files used in this example are provided in multiple folders as shown in Figure 2. The mesh files are in the folder "Mesh" and the model and result files are in the folder "Model Files"

    Figure 2 Files location

    We will define this model as a single zone multi-layered model. You can follow the links to access documentation related to zone definition and multi-layer approach.

  2. Geometry and mesh

    The geometry for this example was created using the GiD graphical interface and the BEASY problem type for GiD. Follow this link to learn how to export the mesh and define layers for this example.

    In the resulting mesh for the flowline and anodes, the layers (i.e. groups) are named as follows:

    • Anodes: for the anodes

    • Pipeline: For all the sections of the pipeline

    Note that in this example, for simplicity, the buried sections of the flowlines will be applied the same polarisation curves than the wetted parts, so there is no need to define a different group for the buried sections.

    In addition, this example will be modelled using the multi-layer approach with only one zone, so we don't need groups of surfaces enclosing the zone.

  3. Polarisation data

    The material file provided to use in this tutorial has three polarisation curves with labels:

    • ST00 corresponding to bare steel

    • ST03 corresponding to coated steel, will be applied to the flowline

    • ZINC will be applied to the anodes

    NOTE: In this example, for simplicity, we will using the same polarisation curve for the wetted and buried sections of the flowline.

  4. Model definition

    To begin this section you should have already created the mesh (*.bzmsh) for the model of the flowline and anodes and have the material file (*.mat_cp) available.

    1. Open the CP Model Editor

      Start by opening the CP Model Editor through the CP Desktop.

      Figure 3: CP Model Editor

    2. Import mesh

      Import the mesh using the "Imported meshes" tool. To add a mesh press the "+" button at the bottom of the tool or right click inside the tool area and select the option "Add Mesh".

      When the "Import mesh file" window pops up browse to "flowline.bzmsh". (Figure 4). Note that the field "Mesh Name" is automatically generated. You can change the proposed name.

      Figure 4: CP Model Editor. Import mesh file

      Then and press "Accept".

      After importing the mesh all the groups defined in the mesh file are also loaded with default parameters. The "Group Definitions" tab looks as shown in Figure 5.

      Figure 5: CP Model Editor. Group Definitions tab

    3. Import polarisation curves

      We need to import the polarisation file containing all the polarisation curves we will be using in this example. Using the "Import polarisation curves" tool, press on the "+" button at the bottom of the tool and browse to the corresponding mat_cp file (Flowline.mat_cp). The available polarisation curves are identified by labels as shown in the tool in Figure 6.

      Figure 6: Imported polarisation curves tool

    4. Group Definitions

      The "Group Definitions" tab is used to define the role of each group in the assembled model.

      Note that after importing the meshes, the "Group Definitions" tab is populated with the groups corresponding to each of the imported meshes. Values assigned to the different columns are default parameters.

      Figure 7: Group definitions tab. Default values

      The values in red represent errors or missing data that needs to be defined. For example, values in "Master zone ID" property are shown in red because zones are not defined yet. (Figure 7)

      1. Mesh and Group properties

        The first two property columns (Mesh and Group) are already defined:

        Mesh:This is the name of the mesh to which the group belongs.

        Group: Indicates the name of the group in the mesh file

      2. Master and Slave zone IDs properties

        We now need to define values for the other column properties. We can start defining "Master zone ID" and "Slave zone ID" properties for example. Note model data can be enter in any order.

        Master zone ID: This is a positive integer ( Zone ). The IDs are defined progressively with increasing number starting from 1.

        You can edit this value by clicking on it and entering a value, or using the spin box controls.

        Figure 8: Group definitions tab. Master and Slave zone ID property

        Note that by clicking on a column title, the data is sorted according to values on that column.

      3. Group type property

        Group type property defines the role of the group in the simulation. The available options are shown in Figure 9. A full description of all the options can be found in the "Group Definitions" tab section.

        Figure 9: Defining "Group type" property

        For this example select:

        • ANODE for the anode group.

        • METAL for the flowline. Double click on "METAL" and select the corresponding group type for each group using the down arrow.

        The "Group type" property looks as shown in Figure 10.

        Figure 10: "Group type" properties defined

      4. Boundary type and Boundary value properties

        We can proceed to define "Boundary type" and "Boundary value" properties. First, for "Boundary type", select "POLARISATION" as shown in Figure 11.

        Figure 11: "Boundary type" property defined

        Values in "Boundary value" property turned red: we need to specify the label that identifies the corresponding polarisation curve.

        You can type labels manually, but to avoid misspelling a label, we recommend selecting the labels from the ones defined in the material file.

        One way of assigning a polarisation curve is by double clicking on "UNKNOWN" and scrolling to select among the available labels. Alternatively, you can start by typing the initial letter of the label.

        Another way of doing this is using the "Imported polarisation curves" tool. Select a row in the "Boundary value" property column and in the "Imported polarisation curves" tool, select the label you want to apply and press the double arrow.

        After assigning all labels the "Group Definition" tab looks as shown in Figure 12.

        Figure 12: "Boundary value" property. Scroll to assign polarisation curve

      5. Is Tube element, Diameter, Resistance length

        The flowline and flowline anodes are modelled with tube elements, so we need to assign tube elements to these groups and define diameters for the flowline and anodes (0.3m).

        To define properties for tube elements change the radio button in Visualisation from "Basic" to "Intermediate"(Figure 13). More column properties appear visible.

        Figure 13: "Visualisation"

        Is tube element: By default this parameter is set to "false". Change to "true" if this group is intended to represent tube elements. Select "true"

        Diameter:If "Is tube Element" is true, then the field is used to enter the diameter for the tube element. Assign the diameter to flowline and anodes.

        In addition, in this example we will take into consideration the drop of voltage due to the internal resistance of the flowline, so we will input a value for the resistance per unit length and we will need to define a non-default return path circuit.

        Resistance length: If "Is tube Element" is true, then you can use this field to define the resistance per unit length of the tube element. This must be a real number of value zero or greater used to define the resistance per unit length of all tube elements in this group.

        NOTE: This property is ignored (set internally to zero) if "Activate non-default return path circuit" in the "Options" window in the "Return Path Circuit" Tab is not selected.

        If a non-zero value is defined a return path metal voltage calculation will be performed provided you set to "Activate non-default return path circuit". In addition all groups must be given a "Component" name. All electrical components must be defined in the "Electrical components" tab, and electrical connections may be defined in the "Electrical connections" tab.

      6. Sacrificial anodes property

        In this example, we want to define sacrificial anode data, so we can analyse the anode decay. To define sacrificial anode data change the radio button in Visualisation from "Basic" to "Intermediate" (Figure 13). More columns appear visible.

        SAC geometry: This is used to declare sacrificial anodes. The default value is "NO_SAC". You can press the down arrow to access the possible values: "TOP", "BOTTOM" or "NO_SAC".

        • NO_SAC: Use if you don't intend to model sacrificial anode data

        • TOP: Use for any anode type except for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

        • BOTTOM: Use for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

        SAC name: This is used to define a name for the sacrificial anode. Properties such as mass, anode capacity, etc. will be assigned to this anode name later on the "Sacrificial Anodes" tab.

      7. Component property

      Since we already define internal resistances in tubular members we will need to define a non-default return path circuit .

      A circuit is made up by declaring electrical connections between electrical components. So we will start by defining the electrical components here.

      Component: This is used to define the name of the electrical component this group belongs to. Many groups may be part of the same electrical component. Groups belonging to the same component are electrically connected. The connection mechanism is set up later in the "Return Path Circuit" tab

      After filling in all the previous data the fields look as shown in Figure 14,

      Figure 14: Group Definitions. All parameters defined.

      Note that you can hide from the view columns by right-clicking on the column title and selecting "Hide selected columns"

    5. Zones

      We can now start defining the zone properties. The "Zones" tab is used to define the zone properties such us conductivity/resistivity of the electrolytes. This example consists of a single multi-layer zone with:

      • Seawater conductivity 3.5 S/m ( from z=0 to seabed depth at z=75 m)

      • Soil conductivity 0.7 S/m

      Go to the "Zones" tab. Click on "Zond ID" 1 and change the Zone type to "Layered" (Figure 15).

      Figure 15: Zones. Zone type: Layered.

      Parameters used in the multi-layer zone are described in Figure 16.

      Figure 16: Parameters involved in the definition of a multi-layer zone

      We start defining the different properties:

      Zone Name: This is optional. It can be used as a reference and it could be useful when the model has a many zones. We can use "MyZone" or leave it undefined.

      Layering direction: Is the direction perpendicular to the planes that divide layers.

      Top layer location: Refers to the position of the top surface of the zone.

      Press the "+" button to add a new layer and define values for each layer:

      • Conductivity or Resistivity. You can define either of those

      • Thickness: Define the thickness of the layer

      • Top location: Define the coordinate at the top of this layer (in the layering direction)

      • Bottom location: This is displayed for information, and automatically filled once the thickness is defined

      Zone boundaries: Options are "INFINITE" or "BOUNDED". Select "BOUNDED" in a problem where lateral surfaces are constraining the zone. We leave the default ("INFINITE") since the model has no lateral boundaries.

      Top layer boundary condition, Bottom layer boundary condition: These fields allow defining the type of boundary condition associated to the top and bottom surfaces as referred in Figure 16 (TOP and BOTTOM). Options are:

      • "INSULATED": It imposes zero normal current density

      • "INFINITE": The first layer extends indefinitely in the direction Options are

      Select "INSULATED" for the top and "INFINITE" for the bottom.

      After all parameters are defined, the Zones tab looks as shown in Figure 17.

      Figure 17: Zones tab. Multi-layer zone parameters

    6. Sacrificial anodes

      Use the "Sacrificial Anodes" tab to fill in the anode data. Initially, the tab shows the names previously defined in the "Group Definitions" tab as shown in Figure 18.

      Figure 18: Sacrificial anodes tab.

      Enter sacrificial anode data on the corresponding SAC name:

      • Type. Use the drop down menu to select the anode type

      • Utilisation Factor

      • Consumption Factor

      • Mass

      • Capacity

      Data is shown in Figure 19

      Figure 19: Sacrificial anodes data

      NOTE: the "Diameter" and "Density" fields are ignored if set to zero. These parameters are optional for "STAND_OFF" and "BRICK_FLUSH_MOUNTED" anode types.

    7. Return Path Circuit

      Since the internal resistance of the flowline is non-negligible, we need to define a non-default return path circuit. The Return Path Circuit tab is shown in Figure 20.

      Figure 20: Return Path Circuit tab. Options toolbox

      1. Options

        The circuit will only be created if the option "Activate no-default return path circuit" is checked. This option is found in the "Options" toolbox shown in Figure 20.

        Tick on "Activate no-default return path circuit".

        We also want to set the location for the zero value of metal voltage. Un-check "Automatic location of Reference Metal Voltage (Vm=0)".

        When you do that the parameters to define the reference metal voltage become available as shown in Figure 21.

        Figure 21: Options. Uncheck Automatic location of Reference Metal Voltage (Vm=0)

        Identify the name of the mesh and group and the reference coordinates. We select the location of the reference at the top of the flowline (0, 0, 0)

        Figure 22: Options. Location of Reference Metal Voltage (Vm=0)

        Now go to "Electrical Components" toolbox.

      2. Electrical components

      The components that were previously defined using the "Group Definitions" tab appear listed in the "Electrical Components" toolbox. In this example, only one component is defined. (Figure 23)

      Figure 23: Return Path Circuit tab. Electrical Components toolbox

      Start by selecting the inter-connection method using the drop down menu. These are the ways offered to connect groups in the same electrical component.

      For this example, select FLOWLINE. The relevant groups are automatically broken into two-ended pipes and then reconnected by physical proximity The FLOWLINE inter-connection method is illustrated in Figure 24

      Figure 24: Schematic representation of the FLOWLINE inter-connection method

      Then define the inter-connection resistance (we consider it negligible) and the tolerance.

      The tolerance parameter defines the maximum distance allowed for establishing an automatic electrical connection between connection points on the different groups involved in a component.

      Parameters defined for this example are shown in Figure 25

      Figure 25: Return Path Circuit tab. Electrical Components toolbox

    8. Save the hmd file

      We save the model parameters to "Flowline.hmd".

    9. Solve

      We can now go to the "Solve" tab. Leave the default settings and go directly to "Create Model".

      1. Create Model

        The "Create Model" button performs the following actions:

        1. Creates a mat_cp file using the materials defined in the imported mat_cp file. The file is created with the same root name as the hmd file. If necessary, units are converted to match the model units defined in the top of CP Model Editor window ("Units used in simulation")

        2. Saves the hmd file with the current name. If the hmd has never been saved before, then you will be asked to provide a name.

        3. Performs sanity checks on the model.

        4. Runs the CP Builder to create a dat file.

        5. It also creates a batch file to launch the CP Solver from command line

        After pressing "Create Model" the CP Model Editor looks as shown in Figure 26.

        Figure 26: Create Model

        At the right of the window, vertical tabs give access to different reports. The model creation report is shown in Figure 27.

        Always check for errors or warnings on the Model Creation Report. You can use the search button at the bottom of the window.

        Figure 27: Model Creation Report

        Browse the Model Creation report to read information on the different sections. The section for sacrificial anode data reports the creation of 6 SAC anodes. You can continue to see details on the created circuit.

        Figure 28:Section reporting SAC anode data.

        Figure 29: Report on automatic connections.

        An additional report file that is worth checking if sacrificial anode data is defined is the CPBuilder_SAC_Anodes_Report.txt. This file lists the data associated to each individual anode.

      2. Solve Model

      Now we are ready to press "Solve Model". After pressing "Solve Model" the BEASY CP Solver is launched. The "Solver runtime report" shows the messages from the Solver while the analysis is in progress. You can also check the "Status" at the bottom of the window.

      Figure 30: Solve Model. Analysis is running.

      Once the analysis is finished, the "Solver runtime report" will appear as shown in Figure 31.

      Figure 31: Solve Model. Analysis is finished.

      You can now check the "Solver Log File" for any warning or errors. Go to vertical tab "Solver Log file" and search for warnings or errors.

      Figure 32: Solver Log file

      There could be warnings of "very distorted elements", for example. In those cases, it could be necessary to re-define the mesh on a particular area.

      In this case the only warning does not represent any problem and can be disregarded.

      Figure 33: Solver Log file. Warning

    10. Results

    On the "Results" tab press "Create Report". The Summary Report is created as shown in Figure 34.

    Figure 34: "Summary Report"

    First, we check that the error in current balance is negligible. Go to the section "Model Current Balance". Then, we can look at the "Group results".

  5. Post-process

Once the simulation has completed the post.res/post.msh results can be read into GiD. Contour plots can be viewed by going to "View results>Contour Fill".

  1. Protection Potential

    To visualise protection potential along the flowline, first turn the layers with "Resels on tubes" off.

    To improve the visualisation of results, it could be useful to adjust the size of the lines. Go to "Utilities > Preferences". Adjust the line parameters on the Preferences window:

    Select "View Results > Contour Fill > Protection Potential > Average protection potential. Figure 35 shows protection potential along the flowline.

    Figure 35 Protection potential in mV along the flowline

  2. IR drop

    The IR drop (mV) along the length of the pipe is shown is shown in Figure 36

    Figure 36 IR drop

  3. Numeric results

There are different ways of extracting results for analysis. IR drop and sacrificial anode results can be extracted using the additional files as described below.

  1. IR drop

    The file *.pipelines contains tabulated results for each section of the flowlines.

    If sections are imported into Excel you can plot IR drop versus depth for instance.

  2. Sacrificial anodes

Tabulated results for sacrificial anodes can be found in the *.cp_anode_decay file (flowline.cp_anode_decay). If the file is imported into Excel, for example, you can plot total current, or remaining life versus anode ID.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to prepare a dynamic polarisation curve

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowprofile\curves_flowprofile\curves_flowprofile.htm

How to prepare dynamic polarisation curves which take into account water flow rate and calcareous deposits

This tutorial shows how to produce the family of dynamic polarisation curves and the flow rate profile file which must be used to simulate tidal waters.

It is worth stressing that if the file containing the flow-rate profile is not used, then "depth" will be used to interpolate into the family of curves, and the generated solution will not correspond to the intended scenario.

TABLE OF CONTENTS

1 Introduction

2 The flow profile file

3 Dynamic polarisation curves

4 Long-term curves

5 References

Example files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save flow-environment.zip

  1. Introduction

    In order to run a model simulating a flow rate profile we need

    • the file containing the flow rate profile

    • a pair of matching dynamic polarisation curves.

    • the file containing the sigmoidal curve (long term file)

    The file containing the flow rate profile has extension *.flowprofile.cols.txt.

    The set of dynamic polarisation curves is stored in the mat file.

    The file containing the sigmoidal curve has extension *.longter.cols.txt

    It is important to stress that the flow profile file has to have the same rootname as the model name. Also note that if a run is launched without the flow profile file, then "depth" will be used to interpolate into the family, with undesired consequences.

  2. The flow profile file

    The data contained in the flow rate profile file is basically the flow rate at different depths.

    The format of the long-term file is shown in Table 1

    flowrate_depth_profile:

    data_points(depth,flowrate):

    0.000 0.826

    12.150 0.826

    13.365 0.814

    .

    .

    .

    21.870 0.656

    23.085 0.594

    24.300 0.000

    /data_points(depth,flowrate)

    Table 1 Flow profile file example (*.flowprofile.cols.txt) at time of average flow rate

    You can simulate different flow rate scenarios, for example at zero, average and maximum flow rate. You could only simulate zero and average speed for example.

    If 3 rates are needed, you need 3 files with different names to store the flow rates at different times. Remember you need to assign the same rootname used for the model to each flow profile file.

    If there are different materials affected then the format may be as shown in Table 2.

    potential_name: mV

    current_name: mA

    distance_name: m

    time_name: hours

    material_affected: STMN

    material_affected: ST00

    flowrate_depth_profile:

    data_points(depth,flowrate):

    0.000 0.8

    14.0 0.8

    17.0 0.7

    23.0 0.6

    25.0 0.0

    /data_points(depth,flowrate)

    Table 2 Flow profile file example (*.flowprofile.cols.txt)

  3. Dynamic polarisation curves

    The material file needs two dynamic polarisation curves representing behaviour between no flow rate and a particular flow rate value.

    These curves shown in Figure 1 are based on Hack and Guanti’s paper [1].

    Figure 1 Example of dynamic polarisation curves at depths 0 and 2 m.

    NOTE: When defining the potentio-dianamic curves and the long-term curve note that the long term curve must be “between�? the pairs of potentio-dynamic curves at all potentials. If this is not the case the CP solver r19 will stop with a FATAL ERROR Message.

    To create a material file containing both curves, first you need to define the material with the polarisation database. For the software purposes the different flow rates will be regarded as "Depth".

    First introduce the curve for "zero flow rate" regarded as "Depth 0", and then the curve for the other flow rate or "New Depth".

    The following figures will guide you on the procedure.

    Having defined the data at zero flow rate and at a non zero flow rate using suitable multipliers, go to the polarisation data base and create a new material. (Figure 2)

    Figure 2 Create new material

    Then, introduce the data for the curve representing "zero depth" (i.e. zero flow rate) as shown in Figure 3.

    Figure 3 Introduce data corresponding to the curve with zero flow rate

    Now, go to "Introduce new material data" again and select "New Season or New Depth for a material already in the database" (Figure 4)

    Figure 4 Define new depth data

    Select the material just created "bare_flow_env bare_flow" and press OK (Figure 5).

    Figure 5 Select the material created to add new depth data

    The window in Figure 6 pops up. Input a "2" in the box "Depth" to define the new depth data at flow rate 2m/s.

    Figure 6 Input "2" to define the new depth data at flow rate 2m/s.

    Then, add the data corresponding to flow rate 2m/s as shown in Figure 7.

    Figure 7 Input data for the curve with flow rate 2m/s

    Now the definition of the material is complete and you can write a mat file for this material. Using the polarisation database software select "Export Import files" and then "Create Mat file". The window in Figure 8 pops up. Select the material we have just created.

    Figure 8 Select material to include in matfile

    Proceed selecting "Cathodic" (Figure 9) and then fill in the boxes as in Figure 10.

    starting with -14, indicates the flow values 0 and 1.2 m/s.

    Figure 9 Select "Cathodic material"

    Figure 10 Fill in label and other fields

    Finally, Figure 11 shows an example material file varying between 0 and 1.2m/s. Note that the line

    Figure 11 Example Material file flow 0 to 1.2.

  4. Long-term curves

    Follow the link to learn how to prepare a long-term file.

  5. References

[1] Hack H.P. and Guanti R.J. "Effect of high flow on calcareous deposits and cathodic protection current density". David Taylor Research Center. DTRC/SME-87/82 April 1988.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Files Format

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowprofile\files_format\files_format.htm

Simulation of Calcareous Deposits and Flow rate profiles.

Files format.

This document lists the different file formats that the user needs to build to model calcareous deposits growth and flow rate profiles.

TABLE OF CONTENTS

1. Calcareous deposits. Long-term curve files.

2. Starting from calcareous deposits previously developed

3. Do not allow calcareous deposits previously developed to change

4. Flow rate profile file format

5. Simulating different flow rate profiles

Example files can be saved to your local working space by right clicking into the following links:

  • Longterm files, mat files and flow profile files to use in a flow environment. Right click here to save files.zip

NOTE: You may need to adjust the files provided so that the long-term curves are "between" the pairs of potentio-dynamic curves at all potentials. If this is not the case the CP solver r19 will stop with a FATAL ERROR Message

1. Calcareous deposits. Long-term curve files.

The file that contains the information of the long-term curve is the file “rootname.longterm.cols.txt�?. The standard file format is shown in Table 1.

In this example, there are two long-term curves in the file, one for bare steel and another for some coated material.

Using the format shown in Table 1 , the software will calculate the calcareous deposits developed in both materials starting from a state without calcareous deposits.

LONGTERM_CURVE: 1

MATERIAL_AFFECTED: BARE

UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

TOLERANCE_FOR_J: 0.1

DATA_POINTS(J,V):

1.06 -612.81

……….

……….

……….

45.29 -1103.53

/DATA_POINTS(J,V)

LONGTERM_CURVE: 2

MATERIAL_AFFECTED: TP00

UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

TOLERANCE_FOR_J: 0.1

DATA_POINTS(J,V):

0.0212 -612.81

……….

……….

……….

0.9058 -1103.53

/DATA_POINTS(J,V)

Table 1 Long-term curve ( rootname.long-term.cols.txt)

2. Starting from calcareous deposits previously developed

If the simulation needs to start from calcareous deposits previously developed, then an additional line needs to be added at the end of the file, as shown in Table 2.

LONGTERM_CURVE: 1

MATERIAL_AFFECTED: BARE

UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

TOLERANCE_FOR_J: 0.1

DATA_POINTS(J,V):

1.06 -612.81

……….

……….

……….

45.29 -1103.53

/DATA_POINTS(J,V)

READ_INITIAL_HISTORY_FROM_FILE rootame.initial.history.txt

Table 2 Long-term curve ( rootname_inihis.long-term.cols.txt)

If you are launching a time step run in which some of the steps will use calcareous deposits previously calculated and some won’t, then use two files, for example:

  • rootname.longterm.cols.txt

  • rootname_inihis.longterm.cols.txt

where the file rootname.longterm.cols.txt has the format as shown in Table 1 and the file rootname_inihis.longterm.cols.txt has the format as shown in Table 2. The software will use the proper file in the corresponding run.

3. Do not allow calcareous deposits previously developed to change

If you want to make a simulation starting from previously developed deposits, but not allowing them to grow or be lost, then you can add an extra line to the file in Table 2 to end up with the format shown in Table 3.

LONGTERM_CURVE: 1

MATERIAL_AFFECTED: BARE

UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

TOLERANCE_FOR_J: 0.1

DATA_POINTS(J,V):

1.06 -612.81

……….

……….

……….

45.29 -1103.53

/DATA_POINTS(J,V)

READ_INITIAL_HISTORY_FROM_FILE rootame.initial.history.txt

DO_NOT_CHANGE_HISTORY

Table 3 Long-term curve ( rootname_inihisfixed.long-term.cols.txt)

4. Flow rate profile file format

If you are simulating a problem with flow rate profile, then the file “rootname.flowprofile.cols.txt�? containing the flow rate at different depths is needed.

The format of the long-term file is shown in Table 4

flowrate_depth_profile:

data_points(depth,flowrate):

0.000 0.826

……..

……...

24.300 0.000

/data_points(depth,flowrate)

Table 4 Flow profile file example (rootname.flowprofile.cols.txt)

If there are different materials affected then include them in the file with format as shown in Table 5.

potential_name: mV

current_name: mA

distance_name: m

time_name: hours

material_affected: STMN

material_affected: ST00

flowrate_depth_profile:

data_points(depth,flowrate):

0.000 0.8

……...

……...

25.0 0.0

/data_points(depth,flowrate)

Table 5 Flow profile file example (rootname.flowprofile.cols.txt)

5. Simulating different flow rate profiles

If different flow rate scenarios need to be model, use separate files for each flow rate profile needed.

For example, if data for times at zero, average and maximum flow rate are modellend, generate 3 files with different names to store the flow rates at different times:

  • zeroflow.flowprofile.cols.txt

  • averflow.flowprofile.cols.txt

  • maxflow.flowprofile.cols.txt

If the options for each run are specified through the Offshore Tools GUI then, the software will use the appropriate file as specified.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Water flow rate and calcarous deposits

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowprofile\fp_method\fp_method.htm

CP simulation of offshore structures accounting for water flow rate variation with depth and allowing formation of calcareous deposits

To include the effects of water flow rate variation with depth allowing the formation of calcareous deposits a set of additional input files need to be created. This tutorial introduces the modelling procedures and additional files needed to set up these runs.

CONTENTS

1 Introduction

2 Flow profile files

3 Long-term curve file

4 mat_cp file

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    The input files needed to prepare a run accounting for flow rate variation with depth and the formation of calcareous deposits are:

    • Model *.dat file

    • Flow profile file *.flowprofile.cols.txt

    • Long-term curve files

    • Material file *.mat_cp.

  2. Flow profile files

    The flow profile needs to be included in a separate file, the "flow profile" file with extension *.flowprofile.cols.txt

    The technique involves carrying out two sets of simulations:

    • The first one with flow profile zero: this run allows for the formation of calcareous deposits

    • The second run uses the non-zero flow profile.

  3. Long-term curve file

    To describe the sigmoidal curve an additional file is created: the long-term file, with extension *longeterm.txt

  4. mat_cp file

The mat_cp file needs to include a polarisation curve for the material exposed to the formation of calcareous deposits.

The polarisation curve applied to surfaces exposed to the formation of calcareous deposits is defined with two formations (one representing the polarisation curve with no calcareous deposits and the other representing the polarisation curve with good calcareous deposits) at two different water profile rates: zero water profile rate and maximum water profile rate

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Flow Profile and Calcareous deposits tutorial

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowprofile\fp_monopile\fp_monopile.htm

Calcareous deposits on tidal waters

This tutorial illustrates how to perform a time-stepping run for an offshore monopile that contemplates the formation of calcareous deposits and water flow rate variation with depth.

CONTENTS

1 Introduction

2 Model description

3 Coating degradation

4 Flow profile files

5 Long-term curve file

6 Material file ( mat_cp)

7 Anode data

8 Procedure

9 Launch run_timestep.bat

10 Results

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with modelling techniques introduced in earlier tutorials

This example aims to illustrate how to conduct a time stepping run allowing formation of calcareous deposits and considering water flow rates variation with depth. Refer to the section on tidal waters in the document describing the sigmoidal curve method.

  1. Introduction

    We will predict the end of life condition using a time stepping simulation starting from the year of installation and progressing every 5 years up to end of design life ( 25 years).

    In each time step, the condition of the coatings and the anode consumption will be updated.

    In any tidal area the water flow rate varies continuously throughout each day, and there is generally great geographical and monthly variation in the way flow rate varies with time.

    Consequently it is necessary to adapt the simulation methods so as to achieve for each time step:

    • Representative predictions of accumulation of calcareous deposits

    • Representative anode consumption rates and predictions of anode life

    • Representative predictions of the most positive potentials on the structure

    The files used in this example are provided in multiple folders as shown in Figure 1.

    Figure 1: File structure

    The mesh files are in the folder "Mesh", the hmd and dat file for this example are in the folder "Model". Mat file and additional long term and flow profile files needed for this tutorial are in folder "Tidal_Waters_Files". The folder "StartFilesTimeStepping" contains the files needed to start the time stepping analysis. The folder "TimeStepping" contains the solution files.

  2. Model description

    A view of the structure, anodes and bounding boxes used in this example is shown in Figure 2. The example consists of a monopile immersed in seawater and partially buried. Sacrificial anodes are arranged around the pile.

    Figure 2: Zone bounding boxes (on the right) and Monopile (on the left)

    The transition piece is coated and the rest of the monopile is bare.

    The mesh files used in this example are provided in the folder "Meshes". "The layers defined named as follows:

    • tp: Coated section of the monopile (transition piece)

    • bare: Bare section of the monopile

    • buried: Buried section of the monopile

    • Anode_Back: sacrificial anodes

    • Anode_TopSides:sacrificial anodes

    • z1b: Zone 1 bounding box (seawater)

    • z2b:Zone 2 bounding box (mud)

    • z1z2: Zone1, zone 2 interface

    In folder model the hmd has all the properties already defined and has been used to create the dat file (36Anodes_TidalWaters_CalcDep.dat)

  3. Coating degradation

    This tutorial illustrates how to perform a time stepping that accounts for coating degradation through time. Coating breakdown factors and labels applied to the different simulation steps are shown in Table 1.

    Year

    Breakdown factor

    LABEL in the mat file

    0

    2%

    ST00

    5

    7%

    ST05

    10

    12%

    ST10

    15

    17%

    ST15

    20

    22%

    ST20

    25

    27%

    ST25

    Table 1. Label and breakdown factors to apply to the different years.

  4. Flow profile files

    The flow profile needs to be included in a file with extension *.flowprofile.cols.txt.

    The technique involves carrying out at least two sets of simulations:

    • The first one is the water flow rate profile at which calcareous deposits are formed ( i.e. slack waters or zero-flow-rate)

    • The second run is used to determine anode life, and uses an average water flow rate

    Additional simulations could be carried out at different flow rates, for example, to determine the most positive potentials on the structure we need to use the highest water flow rate.

    The content of the first file with zero flow rate ( flow1.flowprofile.cols.tx) is as follows:

    potential_name: mV

    current_name: mA

    distance_name: m

    time_name: hours

    material_affected: BARE

    material_affected: ST00

    material_affected: ST05

    material_affected: ST10

    material_affected: ST15

    material_affected: ST20

    material_affected: ST25

    flowrate_depth_profile:

    data_points(depth,flowrate):

    0.0 0.0

    1.59 0.0

    4.24 0.0

    6.88 0.0

    9.53 0.0

    12.18 0.0

    14.82 0.0

    16.94 0.0

    18.9 0.0

    /data_points(depth,flowrate)

    The content of the second file used to update anode decay at average flow rate (flow2.flowprofile.cols.tx) is as follows:

    potential_name: mV

    current_name: mA

    distance_name: m

    time_name: hours

    material_affected: STMN

    material_affected: ST00

    material_affected: ST05

    material_affected: ST10

    material_affected: ST15

    material_affected: ST20

    material_affected: ST25

    flowrate_depth_profile:

    data_points(depth,flowrate):

    0 0.62

    3.9 0.6

    4.9 0.59

    5.9 0.59

    6.9 0.58

    7.9 0.57

    8.9 0.57

    9.9 0.56

    10.9 0.55

    11.9 0.54

    12.9 0.53

    13.9 0.51

    14.9 0.5

    15.9 0.48

    16.9 0.45

    17.9 0.41

    18.9 0

    /data_points(depth,flowrate)

    The content of the third file used to calculate the most positive potentials at maximum flow rate (flow3.flowprofile.cols.tx) is as follows:

    potential_name: mV

    current_name: mA

    distance_name: m

    time_name: hours

    material_affected: BARE

    material_affected: ST00

    material_affected: ST05

    material_affected: ST10

    material_affected: ST15

    material_affected: ST20

    material_affected: ST25

    flowrate_depth_profile:

    data_points(depth,flowrate):

    0 1.24

    3.9 1.2

    4.9 1.18

    5.9 1.18

    6.9 1.16

    7.9 1.14

    8.9 1.14

    9.9 1.12

    10.9 1.1

    11.9 1.08

    12.9 1.06

    13.9 1.02

    14.9 1

    15.9 0.96

    16.9 0.9

    17.9 0.82

    18.9 0

    /data_points(depth,flowrate)

    NOTE: All the labels affected need to be included in the flow profile file!!

  5. Long-term curve file

    When modelling flow profiles the sigmoidal curve is included in an additional file: the long-term file, with extension *longterm.txt

    The long-term file has as many long-term curve as needed for the simulation. For the BARE material the long-term file is as follows:

    LONGTERM_CURVE: 1

    MATERIAL_AFFECTED: BARE

    UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

    TOLERANCE_FOR_J: 0.1

    DATA_POINTS(J,V):

    0 -611.53

    8.39 -621.70

    18.09 -631.75

    23.33 -639.46

    31.19 -651.02

    38.00 -662.67

    45.34 -679.70

    52.15 -702.22

    56.62 -726.29

    57.94 -758.78

    56.12 -784.75

    52.99 -809.46

    46.73 -841.24

    40.72 -868.91

    33.40 -899.41

    27.14 -928.47

    23.48 -950.51

    21.40 -964.28

    19.57 -982.09

    19.06 -995.72

    19.06 -1012.02

    20.91 -1030.88

    24.32 -1052.32

    28.25 -1065.57

    31.92 -1074.77

    37.16 -1087.91

    45.29 -1103.53

    /DATA_POINTS(J,V)

    NOTE: The long-term file needs to have one curve for each label used!!

    For example, one curve for bare steel with label BARE, one curve for coated steel label ST00 with 2% breakdown factor, etc.

  6. Material file ( mat_cp)

    The mat_cp file contains polarisation curves with labels as follows:

    • BARE for bare steel on the monopile.

    • ST00 for the coated steel on the transition piece at initial time

    • ST05, ST10, ST15, ST20 and ST25 will be used for coated steel at the different time steps (Table 1).

    • SHBS for the buried steel

    • ALUM for the anodes

  7. Anode data

    The anodes are stand-off anodes with an initial mass of 36 Kg, utilisation factor 0.9 and anode capacity 2500 A h/kg.

  8. Procedure

    Files needed to start this simulation are in the folder "TimeStepping_StartingFiles".

    Open the "Offshore Tools" from the CP Desktop and select "Perform forward time stepping" and press "Start". The Forward Time Stepping tool is opened.

    Start by loading the dat file. Then complete fields as shown in Figure 3

    Figure 3: Forward Time Stepping. Define parameters for time stepping, choose effects and press "Next"

    Now, we will create a set of labels to represent the changing breakdown factor the coated steel. Press "Create new set" and choose "ST00" (Figure 4).

    Figure 4: Forward Time Stepping. Set of labels for coated steel. Initial label

    Assign the corresponding labels for each time step using the double chevron as shown in Figure 5 and press "Next".

    Figure 5: Forward Time Stepping. Set of labels for coated steel. Initial label

    Select the long-term file (Figure 6)

    Figure 6: Forward Time Stepping. Select long-term curve

    Then select water flow rate profiles as shown in Figure 7

    Figure 7: Forward Time Stepping. Select water flow rate profiles

    Finally, you can tick on "Create folder for post-process, "Run in background" and select Option 1 to generate a batch file "run_timestep.bat" to launch the runs (Figure 8).

    Figure 8: Forward Time Stepping. Solve

    You will see that many long-term and flow-profile files were created. Those will be used during the different steps (Figure 9 ).

    Figure 9: Showing some of the created files

  9. Launch run_timestep.bat

    When launching "run_timestep.bat" the time stepping runs start. All the files needed to re-launch the run are copied into a folder "my_backup". Subsequently the analysis for the initial time with zero water flow rate is launched, followed by the average and the maximum water flow rate at initial time. Then the dat file is updated with the labels for the following step and the calculated anode consumption factors at the following time step. The procedure proceeds in similar way for all the time steps.

    Solution files for each time step are in separate folders.

  10. Results

When the complete analysis is finished the results for the different runs can be found in different folders as shown in Figure 10.

Figure 10: Result folder structure

The remaining life of the anodes at the end of life under conditions of maximum flow is shown in Figure 11.

Figure 11 Showing wetted monopole surfaces in grey and contour plot of anodes remaining life in years at the end of life under conditions of maximum flow

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to prepare a long-term file

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\flowprofile\longtermfile\longtermfile.htm

How to prepare a long-term file

This tutorial shows how to produce the long term file (sigmoidal curve)

TABLE OF CONTENTS

1 Introduction

2 The long-term curve

Example files are zipped and you can save them into your working area by right clicking in the following links:

Right click here to save flow_environment.zip

  1. Introduction

    In order to run a model simulating the accumulation of calcareous deposits with flow rate we need

    • the sigmoidal curve or long-term curve file

    • the flow profile curve

    • a pair of matching dynamic polarisation curves for each flow extreme in the mat file

    The sigmoidal curve is stored in the file with extension *.longterm.cols.txt.

    The set of dynamic polarisation curves is stored in the mat file.

    The flowprofile file has extension *.flowprofile.

    It is important to stress that the long-term and flow profile file have to have the same rootname as the model name. Also note that if a run is launched without the long-term file the results will not represent the accumulation/loss of calcareous deposits.

    After a simulation considering deposition of calcareous deposits ends, a new result file is created named *.0.history.txt, where 0 is the default value of the initial year of the simulation. This file has information of the built of calcareous deposits.

    The default value for the initial year can be changed and set by the user before the run. This can be done launching the process via the BEASY Offshore Tools anode decay solver or editing the line in the datfile " CP TIME STATION 1 0.0" to "CP TIME STATION 1 2010.0", for example. If this is the case, the history file will be *.2010.history.txt.

  2. The long-term curve

As described in the polarisation data section it seems appropriate to use the data by Strommen for CP simulation of North Sea structures, and the data by Hartt for simulation of structures in warmer waters.

NOTE: The long-term curve must be "between" the pairs of potentio-dynamic curves at all potentials. If this is not the case the CP solver r19 will stop with a FATAL ERROR Message

The format of the long-term file is shown in Table 1

LONGTERM_CURVE: 1

MATERIAL_AFFECTED: BARE

UNITS: j(ma/m**2) V(mV Ag/AgCl/seawater)

TOLERANCE_FOR_J: 0.1

DATA_POINTS(J,V):

1.06 -612.81

……….

……….

……….

45.29 -1103.53

/DATA_POINTS(J,V)

Table 1 Long-term curve file *.longterm.cols.txt

The tolerance for current density is the maximum value accepted for the difference between the results for current density and the current density on the sigmoidal curve.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Flux Lines

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\fluxlines\fluxlines.htm

Flux lines

This tutorial illustrates how to visualise the direction of the current flow through the electrolyte using flux-lines.

CONTENTS

1 Introduction

2 Overview

3 Keywords in the .dat file

4 Resulting flux-lines

5 Keywords which may be used, in the solution control section of the .dat file

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with CP modelling and creation of internal points. It shows how to edit the *.dat file to create flux lines

  1. Introduction

    Flux-lines show the direction of current flow through the electrolyte. For an internal point, flux-lines can be determined at positions in the zone in which the internal point is present.

    The example is of a single anode near a tank with polarising conditions. The anode has fixed electrolyte potential (but could have other conditions).

  2. Overview

    The starting point of this tutorial is a *.dat file with the model of the tank and anode and internal points.

    Protection potential on the tank is shown in Figure 1.

    Figure 1: Protection potential on the tank

    Internal points have been created at about mid-height of the anode, off the anode surface and around the circumference of the anode, as shown in Figure 2 and Figure 3.

    Figure 2 Internal points positioned at about mid-height of the anode

    Figure 3 Plan view showing internal points positioned near the anode

  3. Keywords in the .dat file

    Calculation and display of the flux-lines along which current flows, starting from the internal points shown in Figure 2, is turned on by inserting into the data file (using a text editor) a selection of the keywords as shown in Figure 4.

    Figure 4 Keywords used to turn on calculation of flux-lines

    The location in the data file and the keywords used in this example are shown in Figure 4.

    The keywords and parameters used in this example have the following actions:

    1. MOVE_INTERNAL_POINTS 2000 .1: turn on calculation of flux-lines and indicate that up to 2000 positions on each flux-line should be determined, at positions 0.1 (distance units) apart.

    2. ANGLE_CHANGE_LIMIT_FOR_MOVES 90.0: turn on use of the "angle-change" stopping criterion and defines the corresponding angle change to be 90 degrees..

    3. DO_NOT_USE_FLUX_DENSITY_LIMIT_FOR_MOVES: turns off use of the "flux-density" stopping criterion.

    4. SEPARATE_MESH_EACH_TRACK: turns on creation of a separate layer for each flux-line track when the GiD *.post.msh file is created

    Note that a flux line is calculated for every internal point in the model, so be careful not to turn on calculation of flux-lines if you have a lot of internal points!

    Calculation of new positions along a flux-line stops for an internal point, when either:

    • The number of positions along the flux-line reaches the selected number (2000 in this example)

    • Or when the angle change from one position to the next is greater than the selected angle (90 degrees in this case)

    • Or when the flux-density drops below the selected value (this keyword has not been used in this example)

  4. Resulting flux-lines

    The resulting flux-lines are shown in Figure 5.

    Figure 5 Resulting flux-lines

  5. Keywords which may be used, in the solution control section of the .dat file

MOVE_INTERNAL_POINTS   numberOfMoves    distanceToMove

DO_NOT_USE_FLUX_DENSITY_LIMIT_FOR_MOVES

FLUX_DENSITY_LIMIT_FOR_MOVES    fluxDensityLimit

DO_NOT_USE_ANGLE_CHANGE_LIMIT

ANGLE_CHANGE_LIMIT_FOR_MOVES     angleChangeLimit (in degrees)

SEPARATE_MESH_EACH_TRACK

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to use the geometry from an old dat file

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\howto_importmeshfromdat\howto_importmeshfromdat.htm

How To Import Mesh from an old dat file

This tutorial shows how to the use the mesh defined in an old dat file (CP version 10.0r15) to define a new model with the CP Builder.

CONTENTS

1 Introduction

2 CP Builder

2.1 Template for the CP Builder

2.2 Section MESH_IMPORT_PARAMETERS

2.3 Section NON_OVERLAPPING_GROUPS_DATA

2.4 Proceed editing sections

  1. Introduction

    The aim is to use the mesh coming from an old dat file (CP version 10.0r15 or older) to define different properties and re-run the model, or/and to add new geometry to an old geometry. You can do this as long the groups defined in the old model are non-overlapping.

  2. CP Builder

The CP Builder will be used to create a new dat file.

To begin this section you should have a

  • CP Builder template (.hmd file)

  1. Template for the CP Builder

    You can generate a template from a command shell window by introducing "CPBuilder.exe". This generates a template file "MyModel.hmd" in the current directory.

    Open the template for the CP Builder ("MyModel.hmd file") with a text editor (e.g. notepad).

    It is important to note that anything written after a "#" is a comment.

  2. Section MESH_IMPORT_PARAMETERS

    Go to the section "MESH_IMPORT_PARAMETERS". And edit

    • the MESH_FILENAME field with the name of the dat file you want to use

    • the MESH_FILE_FORMAT" field with BEASY_DAT.

    BEGIN MESH_IMPORT_PARAMETERS

    BEGIN MESH

    MESH_NAME Mesh1

    MESH_FILENAME Monopile_01.dat # Name of file from where to import

    elements, meshpoints and groups.

    MESH_FILE_FORMAT BEASY_DAT

    END MESH

    END MESH_IMPORT_PARAMETERS

    You can add other meshes in the "MESH_IMPORT_PARAMETERS" section if you need to.

  3. Section NON_OVERLAPPING_GROUPS_DATA

    NOTES:

    You can use only a set of groups from your old .dat file.

    The groups need to be non-overlapping.

    To generate a list of the groups existing in your old dat file you can use the tool "ListGroups".

    How to run ListGroups tool:

    Copy your old dat file into a new folder and open a command shell window.

    Run the following script:

    "%BEASY_CP_21%\bin\cp\ListGroups.exe" MyOldDAT.dat

    You can use the text file created with the list of groups in the old dat file to start editing the hmd section "NON_OVERLAPPING_GROUPS_DATA"

    Continue defining adequate properties on each row.

  4. Proceed editing sections

You need to proceed editing the relevant sections in the hmd file.

Proceed filling the sections:

  • ZONES_DEFINITIONS

Depending on your model you could finish the edition at this stage.

If sacrificial anode data is needed, fill the corresponding section

If a non-default circuit needs to be implemented, proceed editing the relevant sections.

Save and close the "MyModel.hmd" file.

Now you can launch the CP Builder. Open a command shell window.

Run the following script:

"%BEASY_CP_21%\bin\cp\CPBuilder.exe" MyModel.hmd

Check the CPBuilder.log file for warnings or errors.

If the build was successful then a .dat file will be created with the same name as the hmd file, i.e. "MyModel.dat"

You can now proceed to solve. Place the .dat file and the .mat_cp file in one folder and launch the solver using the "Launch Solver" in the CP Desktop.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How Add Sacrificial Anode Data

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\howtoaddsacdata\howtoaddsacdata.htm

How to add sacrificial anode data

This tutorial shows how to define sacrificial anode data to simulate anode decay.

CONTENTS

1 Introduction

2 Procedure

3 Solve. Create Model

4 Results

  1. Introduction

    Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

    This example assumes that the user is familiar with using the CP Model Editor and knows about the different sacrificial anode types.

    If you need to calculate anode mass loss and/or consumption rates of sacrificial anodes at initial life or if you are planning to perform step forward simulations, you have to introduce some additional data such as anode mass, initial consumption, utilisation factor, anode capacity, etc. This set of data is called sacrificial anode data.

  2. Procedure

    1. Start by opening the CP Model Editor

    2. Open the file "6_Anodes_Monopile.hmd". We will be adding sacrificial anode data to the existing anodes. The anodes are cuboids and will be modelled as "BRICKS".

    3. Save the hmd file with a different name, for example "6Anodes_Monopile_SAC".

    4. In the " Group Definitions" tab use the radio button in the "Intermediate Visualisation". Additional column properties appear. You can hide unwanted columns by right clicking on the column property and selecting "Hide Selected Columns".

    5. We need to define entries for "SAC geometry" and "SAC name". Double click on NO_SAC and select "BOTTOM" for the group "Anodes_Back:

    6. Do the same for the group "Anode_TopSides" and select "TOP".

    7. Then you can define a name for the anode type, for example Anode_Type1:

    8. Then we can go to the "Sacrificial Anode" tab . The anode type is already there to fill in the anode data. The default anode "Type" is "SHAPELESS". We change it to "BRICK"

    9. And fill in the anode data:

    Anode Utilisation Factor = 0.9

    Anode consumption factor =0.0

    Anode Mass = 200Kg

    Anode Capacity 200A h/Kg

    NOTE: the "Diameter" and "Density" fields are ignored if set to zero. These parameters are optional for "STAND_OFF" and "BRICK_FLUSH_MOUNTED" anode types.

  3. Solve. Create Model

    1. Now go to the " Solve" tab and press "Create Model" . And fill in the anode data:

    2. Check the "Model Creation Report". There is a section related to sacrificial anodes.

    3. You can now proceed to run an analysis. Press "Solve Model"

    4. After the analysis ends, you check the log file for errors or warnings.

  4. Results

  1. You can go to the folder where your result files are and check there is file : 6Anodes_Monopile_SAC.cp_anode.decay

  2. This file contains consumption data for each individual anode

  3. You can also look at contour plots of using the 3D graphical interface. You can view contour plots showing anode remaining life. In this simple example all the anodes are consumed at similar rate and have almost the same remaining life in years.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to create a model from mesh

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\howtocreatemodel\howtocreatemodel.htm

How to create a model and run analysis

This tutorial describes general steps to follow when creating a BEASY model and how to run an analysis using the CP Model Editor.

CONTENTS

1 Introduction

2 Procedure

  1. Introduction

    Files needed to start working with this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

    In this example we show how to create a multi-zone model consisting of a structure and a set of anodes.

    The starting point is the meshes:

    • A mesh file containing the structure

    • A mesh file containing 6 anodes

  2. Procedure

Start by opening the CP Model Editor . You should then:

  1. Import the meshes: Follow the animation showing:

    • Browse to the mesh files.

    • Introduce geometrical transformation to copy the mesh of the anodes at different locations

    Figure 1 How to import meshes. Animation

  2. Define properties for groups: Follow the animation showing how to define group properties and load a material file

    Figure 2 How to define properties in the "Group Definitions" tab. Animation

  3. Define zones: Go the Zone tab and define 2 zones with homogeneous conductivity.

    Figure 3 How to define properties in the "Group Definitions" tab. Animation

  4. Create the model and Solve:

    • Save the hmd file and go to the "Solve" tab.

    • Create the model.

    • Check for warnings or errors in the model.

    • Solve.

    • Check for warnings and error in the CP Solver Log file

    Figure 4 Create the model and Solve. Animation

  5. Create report

Figure 5 Create report. Animation

You can visualise results in the 3D graphics interface

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to remove a mesh

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\howtoremoveamesh\howtoremoveamesh.htm

How to remove a mesh

This tutorial shows how to remove a mesh and all its associated groups from an existing hmd file.

CONTENTS

1 Introduction

2 Procedure

  1. Introduction

    Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

    This example assumes that the user is familiar with using the CP Model Editor.

  2. Procedure

  1. Start by opening the CP Model Editor

  2. Open the file "12_Anodes.hmd"

  3. In the "Imported meshes" tool, right click on "Ring_002" and select "Remove"

  4. The warning message pops-up:

  5. Select "yes" to remove the mesh and associated groups.

  6. Save the model as "6_Andoes.hmd"

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to use old geometry

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\howtouseoldgeo\howtouseoldgeo.htm

How to use geometry from a GiD model constructed with problem type for r15

This tutorial shows guidance on how to proceed to use the geometry of a model built with BEASY GiD version 10.0r15.

CONTENTS

1 Introduction

2 Procedure

  1. Introduction

    The steps needed to reuse the geometry of a model built with BEASY GiD version 10.0r15 are very simple and small work is involved. However, if you have a model with tube elements you need to follow a different strategy to avoid losing information of the tube elements diameters.

  2. Procedure

STEP 1: Open the model in GiD

STEP 2: In version 21, the layers defined in GiD become BEASY groups when the mesh is imported into the CP Model Editor. Having this in mind, you may need to change the definition of layers in the model, create new layers, or move entities to different layers to be able to apply conditions to the layers/groups later on with the CP Model Editor.

STEP 3: Unload the problem type using "Data > Problem type > Unload"

You will lose the defined model data. Press accept.

STEP 4: Load the latest problem type "BEASY_21May_2020" or later.

STEP 5: Re-mesh and export the mesh using "File > Export Mesh"

STEP 6: Proceed importing the mesh into the CP Model Editor and defining model data.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Internal Points - CP Model Editor

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\internalpoints_cpme\internalpoints_cpme.htm

Internal points created with the CP Model Editor

This tutorial illustrates how to add internal points to an existing model with the CP Model Editor using a predefined HMD file. The results are then processed using GiD 14.

CONTENTS

1 Introduction

2 Load HMD File

3 Internal Points

3.1 Points along lines

3.2 Points on flat grids

3.3 Solve and Results

4 Post-process

4.1 Contour plots on internal points

4.2 Numeric results on internal points

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example uses the existing geometry of a ship hull, propellers and anodes as a starting point. It assumes that the user is familiar with the steps involved in BEASY CP model creation.

  1. Introduction

    This example consists of a ship hull and ICCP anodes. Model parameters are defined in the hmd file already created in the tutorial "ShipHull". The hmd file created in the tutorial "ShipHull" will be used as a starting point to add internal points.

    Internal points are points which lie inside the electrolyte. The CP Solver finds the potential and current density results at these mesh points at the end of the analysis run.

    In this tutorial, internal points will be created along a line parallel to the centre line of the ship hull at depth 10m and a grid of points on a horizontal plane at 15m depth. Figure 1 shows a view of the ship and internal points that will be defined in this tutorial.

    Figure 1 Internal points along a line and grid of internal points

    The files used in this example are provided in multiple folders as shown in Figure 2. The input files that are needed to start working on this tutorial are in the folders "Mesh" and "ModelFiles". There contain the mesh file, the hmd file and mat_cp. The result files with added internal points are in the folder "Solution Files".

    Figure 2 Files location

  2. Load HMD File

    A previously defined HMD file can be loaded into the CP Model Editor by pressing the open button in the top left of the screen, as shown below.

    Pick the file "ShipHull_01.hmd" provided in this tutorial.

    When the HMD file is loaded, the following sections should be already be defined:

    • Imported meshes tool

    • Imported polarisation curves tool

    • Defined zones tool

    • Group Definitions tab

    • Zones tab

    This is shown Figure 3.

    Figure 3: Predefined HMD file

    Note: if either the mesh or the mat_cp don't load it means the CP Model editor couldn't find them. To overcome this, quickly import the mesh or mat_cp file.

  3. Internal Points

    To add internal points navigate to the "Internal Points" tab (Figure 4).

    Figure 4: Internal Points tab

    There are 3 options for creating points:

    • Scattered points

    • Points along lines

    • Points on flat grids

    This tutorial shows how to create internal points using the methods "Points along lines" and "Points on flat grids".

    1. Points along lines

      To create points along a line click on the "Points along lines" option shown in Figure 5.

      Figure 5: Selecting the "Points along lines" method

      The "+" button can now be pressed to add a new line of points (Figure 6).

      Figure 6: Adding a line of internal points

      Assign:

      • 1 to "Zone ID"

      • (0 0 10) and (56 0 10) for x1,y1,z1 and x2,y2,z2

      • And 20 number of points

      Leave the "Group name" and "Start ID" as default.

      The suggested group name can be changed, but we will leave the default.

      These settings are shown in Figure 7.

      Figure 7: Coordinates of the line defining the series of points

    2. Points on flat grids

      To create a grid of points click on the "Points on flat grids" tab highlighted in Figure 8.

      Figure 8: Selecting the "Points on flat grids" method

      Now click on the middle button at the bottom of the screen highlighted in Figure 9.

      Figure 9: Opening the flat grids creation menu

      This opens the tool to create internal points on flat grids.

      Define a plane at constant Z.

      Define the zone ID using the drop down menu at the top right of the window (Zone ID)

      To create a grid of points parallel to Z plane centred in (28, 0, 15) input parameters as shown in Figure 10.

      The plane will be centred at the "Centre point coordinates". The extent of the plane and the number of points are controlled by defining:

      • "Size" "(size 60 along x direction and size 20 along y direction)

      • "Number of points" (20 points along x direction and 20 points along y direction).

      Define a name for the group of points.

      Finally press "Accept".

      Figure 10: Creating a flat grid of points

      This results on the screen as shown in Figure 11.

      Figure 11: Coordinates of points defining the surface which represents the flat grid of points

    3. Solve and Results

    Now navigate to the "Solve" tab to create and solve the model using the on screen buttons. If the model runs successfully, the following message will be displayed in the ".runlog" file (Figure 12).

    Figure 12: Runlog successful completion message

    To create a report navigate to the "Results" tab and press the "Create Report" button. Scroll down through the report to the section that shows internal points results (Figure 13 ).

    Figure 13: Summary of internal point results

  4. Post-process

Once the simulation has completed the post.res/post.msh results can be read into GiD.

  1. Contour plots on internal points

    Contour plots can be viewed by going to "View results>Contour Fill".

    To view results on the internal points, it's a good idea to hide all other layers as shown in Figure 14 below.

    Figure 14: "On layers"

    The "To back" tool can also be used to view the line of internal points and the grid of internal points independently of one another as they are in the same layer. The "To back" tool is shown below in Figure 15.

    Figure 15: "To back" tool at the bottom of the layers menu

    NOTE: Alternatively, you can use "Send to" shown in Figure 15, followed by "New set", so you can create a separate set by selection of points.

    Figure 16 below shows the electric field on the line of internal points situated 10 m below the sea surface.

    Figure 16: Electric field in mV/m on line of internal points situated 10 m below the sea surface

    Figure 17 below shows the electric field on the grid of internal points situated 15 m below the sea surface.

    Figure 17: Electric field in mV/m on grid of internal points situated 15 m below the sea surface

  2. Numeric results on internal points

After the run is finished you can use the tool “Process Results from a GDF file�? to create a separate report file with results on the internal points only. Launch “Process Results from a GDF file�? from the desktop and select the "Analysis output option" as shown in Figure 18.

Figure 18: Process Results for internal points

A text file (*_report_IntPoints.txt) with internal point results is created. Figure 19 shows the contents of "ShipHull_02_report_IntPoints.txt"

Figure 19: Numeric results at internal points

In addition, if you select "Post-processing results" the GiD post files created will present the internal points in different layers according to the defined groups.

The created files are "ShipHull_02_report_custom.post.msh" and "ShipHull_02_report_custom.post.res". Figure 20 shows the created layers.

Figure 20: Layers for internal points in *_report_custom.post.res

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Internal Points. Results Elements

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\internalpoints_geometry\internalpoints_geometry.htm

How to model result elements

This example shows how to model result elements (internal points created as geometry, how to visualise results in GiD with separate layers for the different internal points groups and how to get results on internal points into a Excel spreadsheet .

CONTENTS

1 Introduction

2 Geometry and mesh

3 Model definition

4 Post-process

4.1 Contour plots of potential on the electrolyte

4.2 Import internal point results into Excel

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with:

  • Creating geometry and meshes using GiD.

  • BEASY Zone modelling concepts.

  1. Introduction

    This example consists of of 3 zones, and several planes on which elements have been created, intended for internal point solution.

    Internal points are points which lie inside the electrolyte. If the solution is required along lines or surfaces within the electrolyte, you can create lines or surfaces in the 3D interface and export the mesh with layers/groups.

    Then define the group type "INTERNAL_POINT" with the CP Model Editor.

  2. Geometry and mesh

    The geometry for this example was created using the GiD graphical interface equipped with the BEASY problem type.

    The mesh contains a series of planes created for internal point solution

    Figure 1 shows the mesh and the layers used in the model.

    Figure 1: Mesh and layers for creating groups

  3. Model definition

    To begin this section you should have already created the mesh (*.bzmsh) for the model and have the material file (*.mat_cp) available.

    STEP 1: Start by opening the CP Model Editor. Import the mesh "ResultElements.bzmsh" using the "Imported meshes" tool.

    After importing the mesh all the groups defined in the mesh file are also loaded with default parameters in the "Group Definitions" tab. The CP Model Editor looks as shown in Figure 2.

    Figure 2: CP Model Editor. Mesh imported

    STEP2: Import the polarisation file (ModelFiles/ResultElemnts.mat_cp). containing all the polarisation curves we will be using in this example. The available polarisation curves are identified by labels STEL and ZINC as shown in the "Imported polarisation curves" tool in Figure 3.

    Figure 3: Imported polarisation curves tool

    STEP 3: Define group properties.

    Use the "Group Definitions" tab to define group properties.

    There are four surfaces on which elements will be used to define internal points. These surfaces are in groups such as "internal_points_in_zone_1". The groups of internal points are shown in Figure 4.

    Figure 4. Groups of internal points

    All the groups enclosing zone 1 are shown in Figure 5.

    The interface between zones 1 and 2 has been divided into a "grillage" pattern, and:

    • part of the grillage (in group "zone_1_to_2_steel_interface") is intended to represent both sides of a metal plate

    • the remainder of the interface (in group "zone_1_to_2_interface") represents the boundary between the zone through which currents can flow

    Figure 5. Groups enclosing zone 1

    Master groups to zone 2 are shown in Figure 6.

    Figure 6. Master groups to zone 2

    At the position where zone 2 and zone 3 meet, a different strategy has been used to represent the two sides of the metal grillage:

    • group "zone_2_cathode" includes geometry which is on the grillage surface in zone 2

    • group "zone_3_cathode2" includes geometry which is on the grillage surface in zone 3

    Because the thickness of the plate was not taken into account in this example, this means that the geometry in the above two groups is in exactly the same position. This is a perfectly valid technique, but makes it difficult to check the zone geometry without using the techniques demonstrated in this example.

    Master groups in zone 3 are shown in Figure 7.

    Figure 7. Master groups to zone 3

    STEP 4: Define zone properties

    Define zone properties using the "Zones" tab. A summary of the input data for zones can be seen in Figure 8 to Figure 10.

    Figure 8. Zone1 definition

    Figure 9. Zone3 definition

    Figure 10. Zone3 definition

    STEP 5:: Create and solve model

    Go to the "Solve" tab and press "Create Model". Once the model is created press the "Solve" button.

    Once the run is completed go to the Results tab and press "Create Report".

    There is a section showing results on internal points at the end of the report as shown in Figure 11.

    Figure 11. Internal point results

  4. Post-process

Use the tool "Process Results from a BEASY GDF file" to produce:

  • GiD post-process files with the same post layers for internal points as internal point groups defined

  • An asci file with numeric results on internal points.

Start the tool from the CP Desktop as shown in Figure 12.

Figure 12. "Process Results from a BEASY GDF file"

Load the GDF file and select options as shown in Figure 13 and press "Create output".

Figure 13. Select the GDF File

  1. Contour plots of potential on the electrolyte

    You can now open GiD in post-process mode and load the files "ResultElements_report_custom.post.res"

    When the layers are turned off/on as shown in Figure 14, electrolyte potential on the result elements is displayed as shown in Figure 15

    Figure 14 Post process layers

    Figure 15 Electrolyte potential on result elements

  2. Import internal point results into Excel

The created file "Result_Elements_report_IntPoints.txt" can be imported into Excel.

After some manipulation of formatting, and creation of filters, the data available in the file is as shown in Figure 16.

Figure 16 Excel

Note that the data is divided into groups of internal points (shown in Figure 1) are present in the spreadsheet (Figure 16), allowing simple processing using Excel.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Internal Points. IP Editor

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\internalpoints_ipeditor\internalpoints_ipeditor.htm

Internal points created with the IP Editor

This tutorial illustrates the use of the IP (Internal Point) Editor. It shows how to edit or add internal points to an existing model which has already been solved. The results are then processed using GiD 14.

CONTENTS

1 Introduction

2 Internal Point Editor

2.1 Loading the Model

2.2 Points along Lines

2.3 Grid of Points

2.4 Solve Model

3 Results

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example uses the existing solution of a model of a ship hull, propellers and anodes as a starting point. It assumes that the user is familiar with the steps involved in BEASY CP model creation.

  1. Introduction

    The example consists of a ship hull and ICCP anodes. The model has been previously solved in the tutorial "ShipHull". The solution files will be used as a starting point for this tutorial. The objective is to calculate the solution on internal points without having to re-run the model again.

    Internal points are points which lie inside the electrolyte.

    In this tutorial, internal points will be created along a line parallel to the centre line of the ship hull at depth 10m and a grid of points on a horizontal plane at 15m depth. Figure 1 shows a view of the ship and internal points that will be defined in this tutorial.

    Figure 1. Internal points along a line and grid of internal points

    The files used in this example are provided in multiple folders as shown in Figure 2 . The files to start working on the tutorial are in the folder "ModelFiles_noIPs". These folders contain the mesh and hmd the solution first obtained without internal points. The folder "SolutionFiles_IPs" contains the result files with added internal points are in folder.

    Figure 2: Files location

  2. Internal Point Editor

    The IP Editor can be used to add or edit internal points to an existing model which has already been solved. It can be opened from the CP Desktop.

    The IP Editor is shown in Figure 3.

    Figure 3: The CP Internal Point Editor

    1. Loading the Model

      A previously solved model can be opened by pressing the "Load Model" button in the top left corner of the screen, as shown in Figure 4. The following files must be present in the same folder as the .dat file selected:

      • .lo2

      • .sf1

      • .sf2

      • .mat_cp

      Copy the files in the folder "Input_files" into a separate folder and load the dat file.

      Figure 4: Loading a previously defined model

    2. Points along Lines

      Press the button highlighted in Figure 5 to create a line of internal points.

      Figure 5: Selecting the points along lines option for creating internal points

      This will open the menu shown in Figure 6, fill the in the menu as shown below.

      • Start point coordinates: (0, 0, 10)

      • End point coordinates: (56, 0, 10)

      • Number of points: 20

      • Start point id: Auto

      • Zone ID: 1

      • Group Name: Internal_Points

      Figure 6: Add points along a line menu

    3. Grid of Points

      To create a grid of points on a surface click on the button highlighted below in Figure 7.

      Figure 7: Selecting the flat grid of points option for creating internal points

      This will open the menu shown in Figure 8, fill the in the menu as shown below.

      • Plane at constant: Z

      • Zone ID: 1

      • Center point coordinates: (28, 0, 15)

      • Total Length

      • X: 60

      • Y: 20

      • Number of points

      • X: 60

      • Y: 20

      • Start point id: Auto

      • Group Name: Grid_of_Points

      Figure 8: Add grid of points menu

    4. Solve Model

    The model can now be saved by pressing the "Save" button as shown in Figure 9 below.

    Figure 9: Save the edited model with the inclusion of internal points

    The "Solve" button now becomes active to indicate the model has been saved successfully and can now be solved by pressing the "Solve" button. This is highlighted below in Figure 10, as well as the message displayed upon the completion of a successful simulation.

    Figure 10: Solve button and message indicating a successful simulation

  3. Results

Results on internal points can be visualised/analysed using different methods:

  • Contour plots: the post.res/post.msh results can be read into GiD

  • Numeric results can be extracted from the GDF using “Process Results from a GDF file "

Tutorial "Internal Points created with the CP Model Editor" shows how to visualise/analyse results.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Minimise SolutionTime whehn changing material LABEL

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\minsoltime_changelabel\minsoltime_changelabel.htm

Changing material label and adding internal points. How to minimise solution time

This tutorial illustrates how to minimise solution time when it is required to change a polarisation curve boundary condition ("MATERIAL LABEL" ) applied to elements, by re-using influence matrices obtained in a previous solution. It also shows how to get solution at internal points when the model has already run without having to re-solve.

CONTENTS

1 Introduction

2 The process to change a material label

3 The process to add an internal point

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    This tutorial is shows how to minimise solution time when it is required to change a polarisation curve boundary condition ("MATERIAL LABEL" ) applied to elements, by re-using influence matrices determined in a previous solution.

    This procedure is useful if the elements to which the boundary conditions is going to change remains the same. If the list of elements changes, it is not possible to follow this procedure.

    Note: If the list of elements to which the boundary condition is applied changes it is always necessary to perform all solution steps, including calculation of influence matrices.

    In this example the .dat file has been edited using notepad, but of course in a real model it is more likely that:

    • the .dat file will have a POTENTIAL BC changed by use of the CP Builder

    • the .dat file will have internal points inserted by use of the CP Builder

    The files used in this example are provided in multiple numbered folders:

    1. ..\solve_1_WithLabel_ZINC_NoIPs\before_solve

    2. ..\solve_1_WithLabel_ZINC_NoIPs\after_solve

    3. ..\solve_2_WithLabel_STEL_NoIPs\beforeSolve

    4. ..\solve_2_WithLabel_STEL_NoIPs\afterSolve

    5. ..\solve_3_WithLabel_STEL_AndAnIPAdded\beforeSolve

    6. ...\solve_3_WithLabel_STEL_AndAnIPAdded\afterSolve

  2. The process to change a material label

    Folder 1 contains the .mat_cp file and the .dat file in which;

    • The BC label "ZINC" has been applied to elements 1 to 25

    • There are no internal points

    The solution control section of the .dat file includes keyword "ALL ALL", so that all solution steps are performed.

    Folder 2 contains all files after solution of the data file in folder 1.

    Folder 3 contains all files from folder 2, but with the .dat file modified as follows:

    • The BC label "ZINC" has been replaced with BC label "STEL"

    • The keyword "ALL ALL" has been replaced with keywords as follows:

    *** CREATE INF ALL

    CREATE SYS ALL

    SOLVE SYS ALL

    SOLVE ZONE ALL

    *** SOLVE INT PNTS ALL

    Note that the keyword "CREATE INF ALL" has been "commented out" by putting an asterisk at the start of the line.

    Similarly "SOLVE INT PNTS ALL" has been "commented out", but since there are no internal points in the .dat file in this folder, internal point results would not have been determined anyway.

    The remaining keywords cause the solver to reuse the influence matrices to produce a revised boundary solution, and to place results in the results files.

    Folder 4 contains all files after solution of the data file in folder 3.

  3. The process to add an internal point

Folder 5 contains all files from folder 4, but with the .dat file modified as follows:

  • An internal point has been added to the model by inserting the following lines just before the line "LOADING DATA":

ZONE INTERNAL POINTS

1000 0.0 0.0 2.0

  • The keyword "*** SOLVE INT PNTS ALL" has been uncommented by removing the asterisks and leading spaces from the line

Folder 6 contains all files after solution of the data file in folder 5.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Minimise SolutionTime whehn changing POT BC

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\minsoltime_changepotbc\minsoltime_changepotbc.htm

Changing electrolyte potential. How to minimise solution time

This tutorial is illustrates how to minimise solution time when it is required to change a "POTENTIAL" boundary condition applied to elements, by re-using influence matrices determined in a previous solution. It also shows how to get solutions at internal points without re-solving

CONTENTS

1 Introduction

2 The process to change a POTENTIAL BC

3 The process to add an internal point

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    This tutorial shows how to minimise solution time when it is required to change a "POTENTIAL" boundary condition applied to elements, by re-using influence matrices determined in a previous solution.

    This procedure is useful if the elements to which the boundary conditions is going to change remains the same. If the list of elements changes, it is not possible to follow this procedure.

    Note: If the list of elements to which the boundary condition is applied changes it is always necessary to perform all solution steps, including calculation of influence matrices.

    In this example the .dat file has been edited using notepad, but of course in a real model it is more likely that:

    • the .dat file will have a POTENTIAL BC changed by use of the CP Builder

    • the .dat file will have internal points inserted by use of the CP Builder

    The files used in this example are provided in multiple numbered folders:

    1. ..\solve_1_WithPotential_400_NoIPs\before_solve

    2. …\solve_1_WithPotential_400_NoIPs\after_solve

    3. …\solve_2_WithPotential_500_NoIPs\before_solve

    4. …\solve_2_WithPotential_500_NoIPs\after_solve

    5. …\solve_3_WithPotential_500_andIPAdded\before_solve

    6. … \solve_3_WithPotential_500_andIPAdded\after_solve

  2. The process to change a POTENTIAL BC

    Folder 1 contains the .dat file in which;

    • The potential "4.0000000e+002" has been applied to elements 1 to 25

    • There are no internal points

    Folder 1 also contains the "dummy" .mat_cp file, which must be there but is not really required since the model does not include any BC labels.

    The solution control section of the .dat file includes keyword "ALL ALL", so that all solution steps are performed.

    Folder 2 contains all files after solution of the data file in folder 1.

    Folder 3 contains all files from folder 2, but with the .dat file modified as follows:

    • The value of the POTENTIAL BC has been changed from "4.0000000e+002" to "5.0000000e+002"

    • The keyword "ALL ALL" has been replaced with keywords as follows:

    *** CREATE INF ALL

    CREATE SYS ALL

    SOLVE SYS ALL

    SOLVE ZONE ALL

    *** SOLVE INT PNTS ALL

    Note that the keyword "CREATE INF ALL" has been "commented out" by putting an asterisk at the start of the line.

    Similarly "SOLVE INT PNTS ALL" has been "commented out", but since there are no internal points in the .dat file in this folder, internal point results would not have been determined anyway.

    The remaining keywords cause the solver to reuse the influence matrices to produce a revised boundary solution, and to place results in the results files.

    Folder 4 contains all files after solution of the data file in folder 3.

  3. The process to add an internal point

Folder 5 contains all files from folder 4, but with the .dat file modified as follows:

  • An internal point has been added to the model by inserting the following lines just before the line "LOADING DATA":

ZONE INTERNAL POINTS

1000 0.0 0.0 2.0

  • The keyword "*** SOLVE INT PNTS ALL" has been uncommented by removing the asterisks and leading spaces from the line

Folder 6 contains all files after solution of the data file in folder 5.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Monopile

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\monopile\monopile.htm

Monopile

This tutorial illustrates the use of the CP Model Editor. It shows how to create different anode configurations from the same mesh file using the CP Model Editor. It shows how to define a multi-zones model. It also exposes a new methodology to deal with sigmoidal curves.

CONTENTS

1. Introduction

2. Geometry and mesh

3. Polarisation data

4. Model definition. The 12 anodes model

Open the CP Model Editor

Import meshes

Import polarisation curves

Group Definitions

Zones

Save the hmd file

Solve

Results

5. Modifying the anode configuration

6. The 24 anodes model

Imported meshes tool

Group Definitions tab

Save the hmd file

Solve tab

Results

7. Tips for creating the 36 anodes models

36 anodes model

Transformations needed for the 36 anodes model

Define and Solve the 36 anodes model

8. Post-process

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with:

  • Creating geometry and meshes.

  • BEASY zones and modelling concepts

  1. Introduction

    This example aims to assess the performance of a CP system based on sacrificial (SAC) anodes on a monopile structure. A view of the structure is shown in Figure 1. The example consists of a monopile immersed in seawater. Sacrificial aluminium anodes are arranged around the pile. The initial model to be analysed consist of 12 anodes, however, results for different numbers and configuration of anodes will be assessed.

    The anode dimensions are 0.2 x 0.2 x 2.0 m.

    Figure 1: Monopile structure

    The problem has been broken down into the following key stages:

    • Creating geometry and mesh

    • Creating model an running analysis

    • Post-process

    The files used in this example are provided in multiple folders as shown in Figure 2. The mesh files are in the folder "Meshes" and the model and result files for each case are located indicating in the folders "12_anodes", "24_anodes", "36_anodes; indicating the number of anodes in the model.

    Figure 2 Files location

  2. Geometry and mesh

    The geometry for this example was created using the GiD graphical interface and the BEASY problem type for GiD. Follow this link to learn how to create the geometry and the anodes.

    Please look at documentation related to definition of zones and normal directions to surfaces if you are not familiar with the multi-zone approach.

    The resulting mesh for the monopile structure and bounding boxes has layers (i.e. groups) named as follows:

    • tp: Coated section of the monopile (transition piece)

    • bare: Bare wetted section of the monopile

    • buried: Buried section of the monopile

    • z1b: Zone 1 bounding box

    • z2b: Zone2 bounding box

    • z12: Interface between zone 1 and zone 2

    In the resulting mesh for the anodes the layers (i.e. groups) are named as follows:

    • Anode_Back: Anode surfaces facing the monopile

    • Anode_TopSides: Other anode surfaces

  3. Polarisation data

    The material label "BARE", which will be applied to the wetted surfaces of the monopile, is a sigmoidal polarisation curve. This is a technique that can be used to account for the reduction in maintenance currents due to the formation of calcareous deposits. BEASY CP version 21 allows defining the sigmoidal curve in the mat_cp file. Note that version 10r15 and previous versions of the CP solver were not able to solve sigmoidal polarisation curves inside the material file.

    The material file provided in this tutorial includes the curve shown in Figure 3.

    NOTE: Do not include additional files for long-term curves.

    The procedure to define a mat_cp file with a sigmoidal curve is exactly the same as with any other not-sigmoidal polarisation curve. You create the material file using the polarisation database tool. Alternatively, you can create a material file using Pol2MatCP tool.

    Figure 3 BARE steel sigmoidal

  4. Model definition. The 12 anodes model

    To begin this section you should have already created:

    • a mesh (bzmsh) for the monopile and boundaries

    • a mesh (bzmsh) for 6 anodes

    You also need to have the material file (*.mat_cp) available

    Open the CP Model Editor

    Start by opening the CP Model Editor.

    Figure 4: CP Model Editor

    Import meshes

    We will first start by creating the 12 anodes model. For the 12 anodes model we need to import:

    • the anode mesh centred at z=5

    • the anode mesh centred at z = 10

    • the monopile mesh

    The "Imported meshes" tool is at the top on the right hand side.

    To add a mesh press the "+" button located at the bottom of the tool or right click inside the panel area and select the option "Add Mesh".

    The "Import mesh file" window pops up. Browse to the mesh file Ring_of_6_anodes.bzmsh. (Figure 5)

    Figure 5: Import mesh file

    Note that the field "Mesh Name" is automatically generated. If you want you can change the proposed name.

    We need to apply a geometrical transformation to the mesh. Press the "+" button at the bottom of the "Order transformations" panel and select "Translation" as shown in Figure 6. Then press "Accept"

    Figure 6: Import mesh file. Translation in z direction

    Repeat the procedure for the second row of anodes, but this time use translation vector (0, 0, 10).

    Figure 7: Import mesh file. Translation in z direction

    After pressing accept the CP Model Editor looks as shown in Figure 8

    Figure 8: CP Model Editor after importing meshes

    If you prefer, you can also change the mesh name by right clicking on the corresponding mesh on the "Imported meshes" tool and selecting "Edit Mesh".

    You can also use "Edit Mesh" to add a geometrical transformation after the mesh was imported.

    Now we need to import the mesh corresponding to the monopole structure. Press the "+" button again and browse to the mesh file "Monopile.bzmsh" (Figure 9).

    Figure 9: Import monopile mesh

    After pressing accept the CP Model Editor looks as shown in Figure 10.

    Figure 10: CP Model Editor after importing all meshes

    Import polarisation curves

    We need to import the polarisation file containing all the polarisation curves we will be using in this example. Using the "Import polarisation curves" tool, press on the "+" button at the bottom of the tool and browse to the corresponding mat_cp file (Monopile.mat_cp). The available polarisation curves are identified by labels as shown in the tool in Figure 11.

    Figure 11: Imported polarisation curves tool

    Group Definitions

    The "Group Definitions" tab is used to define the role of each group in the assembled model.

    Note that after importing the meshes, the "Group Definitions" tab is populated with the groups corresponding to each of the imported meshes. Values assigned to the different columns are default parameters.

    Figure 12: Group definitions tab. Default property values

    The values in red represent errors or missing data that needs to be defined. For example, values in "Master zone ID" property are shown in red because zones are not defined yet. (Figure 12)

    Mesh and Group

    The first two property columns (Mesh and Group) are already defined:

    Mesh:This column has the name of the mesh to which the group belongs.

    Group: Indicates the name of the group in the mesh file

    Master and Slave zone IDs

    We now need to define values for the other columns. We can start defining "Master zone ID" property and "Slave zone ID" property for example. Note model data can be enter in any order.

    Master zone ID: This is a positive integer ( Zone ). The IDs are defined progressively with increasing number starting from 1.

    You can edit this value by clicking on it and entering a value, or using the spin box arrows. It is possible to highlight a number of values in a column and copy them below.

    Figure 13: Group definitions tab. Master and Slave zone ID properties

    Note that by clicking on a column title, the data is sorted according to values on that column.

    Group type

    Group type property defines the role of the group in the simulation. The available options are shown in Figure 14. A full description of all the options can be found in the "Group Definitions" tab section.

    Figure 14: Defining "Group type" property

    For this example select:

    • ANODE for the anode groups. This is generally used for groups that need to be specially considered as anode or need to be assigned sacrificial anode properties.

    Note: The CP Solver will calculate the performance despite of this assignment. For example, depending on the particular conditions of the problem results could show that a group defined as "ANODE" has cathodic behaviour.

    • METAL for the monopile. This is generally used for groups of the structure with polarising, insulated, fixed current density or potential boundary conditions (or for boundary surfaces which confine the shape electrolyte).

    • BOUNDING_BOX for the surfaces on z1b and z2b. This is generally used for insulated surfaces which confine the electrolyte

    • INTERFACE for surfaces on z12. This is generally used for groups containing non-material surfaces representing an interface between two zones which are connected by the electrolyte. An interface allows continuity of electrolyte potential and continuity of current normal current density between its two adjacent zones, and it cannot be assigned any type of boundary condition apart from NO_BC. Interfaces require a Master Zone ID number greater than 1.

    To define the "Group type" property column, double click on "METAL" and select the corresponding group type for each group from the list using the down arrow.

    You can also click on "METAL" and type the first letter of the available keywords.

    After selections are made for all the groups the "Group type" looks as shown in Figure 15

    Figure 15: "Group type" property defined

    Boundary type and Boundary value

    We can proceed to define "Boundary type" property and "Boundary value" property. First define the values for "Boundary type" as shown in Figure 16.

    Figure 16: "Boundary type" property defined

    Values in "Boundary value" property turned red meaning we need to define them. In this case, we need to specify the label that identifies the corresponding polarisation curve.

    You can type labels manually, or copy them through the column. To avoid misspelling a label, we recommend selecting the labels from the ones defined in the material file.

    One way of doing this is using the "Imported polarisation curves" tool. Select a row in the "Boundary value" column and in the "Imported polarisation curves" tool, select the label you want to apply and press the double arrow.

    Figure 17: "Boundary value" property. Assign polarisation curve from the "Imported polarisation curves" tool

    Another way of assigning a polarisation curve is by double clicking on "UNKNOWN" and scrolling to select among the available labels. Alternatively, you can start by typing the initial letter of the label.

    Figure 18: "Boundary value" property. Scroll to assign polarisation curve

    After assigning all labels the "Group Definition" tab looks as shown in Figure 19.

    Figure 19: "Boundary value" property. Scroll to assign polarisation curve

    Zones

    We can now start defining the zone properties. The "Zones" tab is used to define the zone properties such us conductivity/resistivity of the electrolytes.

    This example consists of two homogeneous zones:

    • Zone 1 (seawater) has conductivity 1.0 S/m and a symmetry plane at z=0.

    • Zone 2 (seabed) has conductivity 0.2 S/m and no symmetry planes.

    Go to "Zones" tab. The tool is shown in Figure 20. The zones 1 and 2 are already defined. This is because we already used those IDs in the "Group Definitions" tab. They are highlighted in red because we haven't defined any parameter for the zones yet.

    Figure 20: "Zone" tab

    Start selecting zone 1:

    Figure 21: "Zone" tab, Zone 1 selected

    You can select the type of zone on the "Zone type" field:

    • Homogeneous: For a zone with homogeneous conductivity value

    • Layered: For a stratified zone with layered conductivity values

    We are modelling homogeneous zones so we start filling in the information for zone1.

    Figure 22: "Zone" tab. Zone 1 parameters

    Note you can select the units of your choice to enter conductivity (or resistivity). Units will be converted to match the model units shown at the top of the window "Units to use during the simulation".

    Proceed in the same way to enter parameters for zone 2.

    Figure 23: "Zone" tab. Zone 2 parameters

    Save the hmd file

    We have defined all the data needed for this example. We need to save the hmd file and then go to the "Solve" tab.

    To save the file go "File > Save as". We save it as "12_Anode_Monopile". Note the name of the file is at the top of the window and the "Work directory" shows the path to the hmd file. (Figure 24)

    Figure 24: Saved hmd file

    Solve

    We can now go to the "Solve" tab. We will leave default settings for this example. So we go directly to press "Create Model".

    Create Model

    The "Create Model" button performs the following actions:

    1. Creates a mat_cp file using the materials defined in the imported mat_cp file. The file is created with the same root name as the hmd file. If necessary, units are converted to match the model units defined in the top of CP Model Editor window ("Units used in simulation")

    2. Saves the hmd file with the current name. If the hmd has never been saved before, then you will be asked to provide a name.

    3. Performs a series of sanity checks

    4. Runs the CP Builder to create a dat file.

    5. It also creates a batch file to launch the CP Solver from command line

    After pressing "Create Model" the CP Model Editor looks as shown in Figure 25.

    Figure 25: After "Create Model"

    At the right of the window, vertical tabs give access to different reports. The model creation report is shown in Figure 26.

    Always check for errors or warnings on the Model Creation Report. You can use the search button at the bottom of the window.

    Figure 26: "Model Creation Report"

    Solve Model

    Now we are ready to press "Solve Model". After pressing "Solve Model" the BEASY CP Solver is launched. The "Solver runtime report" shows the messages from the Solver while the analysis is in progress. (Figure 27)

    You can also check the "Status" at the bottom of the window.

    Figure 27: "Solve Model". Analysis in progress

    Once the analysis is finished, the "Solver runtime report" will appear as shown in Figure 28.

    Figure 28: "Solve Model". Analysis finished

    You can now check the "Solver Log File" for any warning or errors.

    Results

    On the "Results" tab press "Create Report". The Summary Report is created as shown in Figure 29.

    Figure 29: "Summary Report"

    First, we check that the error in current balance is negligible. Go to the section "Model Current Balance".

    Then, we can look at the "Group results". We can identify that the most positive protection potential on the wetted steel is about -676mV (Figure 30). This means the anodes are not providing protection to all surfaces on the monopile. We will modify the model to include more anodes.

    Figure 30: "Summary Report". Group results

  5. Modifying the anode configuration

    We will model 3 additional anode configurations with 24 and 36 as shown in Figure 31.

    Figure 31: Anode configurations

    The following step by step process will show how to set-up the models for the 24 anodes model.

  6. The 24 anodes model

    For the 24 anodes you will need to apply a rotation to the anode ring mesh when importing the mesh.

    We can continue on the same session of the CP Model Editor and start by saving the hmd with another name, for example "24_Anode_Monopile.hmd".

    Imported meshes tool

    Open the "Imported meshes" tool. To the existing meshes we need to add:

    • the anode mesh centred at z=5, rotated by 30o

    • the anode mesh centred at z=10, rotated by 30o

    Press the "+" button at the bottom of the tool, or click inside the panel area to add a mesh. The "Import mesh file" window pops up.

    Browse to the corresponding mesh file Ring_of_6_anodes.bzmsh and apply the transformations "MESH_TRANSLATE" with vector ( 0,0,5) and then "MESH_ROTATE" as shown in Figure 32.

    Figure 32: Mesh Transformations. Adding 6 anodes at z=5, rotated 30o

    Press Accept. The "Group Definitions" tab will now show the new groups for mesh "Ring_003"

    Do the same for the anodes at z=10, apply translation and rotation and press "Accept".

    The "Imported meshes" tool shows the following meshes:

    Figure 33: Imported meshes

    Group Definitions tab

    After adding the meshes to generate 12 more anodes, the "Group Definitions" tab looks as shown in Figure 34.

    Figure 34: Group definitions tab. New meshes added.

    Proceed to define fields for meshes "Ring_003" and "Ring_004". After fields are defined the "Group Definitions" tab should look as shown in Figure 35.

    Figure 35: Group definitions tab. Properties defined

    Save the hmd file

    We don't need to make any other changes to the model definition. Save the "24_Anode_Monopile.hmd" file using "File>Save As" and go "to the "Solve" tab

    Solve tab

    We can now go to the "Solve" tab.

    Settings

    If you are not interested in visualising numerous results together in GiD, leave default settings and go directly to press "Create Model".

    If you would like to take advantage of visualising numerous results in one GiD instance, change the "Post-processing step number" from 1 to 2 for example as shown in Figure 36.

    Figure 36: Model Settings

    For creating pictures or animation of results it may be handy to open the results for the different models (12 anodes, 24 anodes, etc.) altogether in GiD. To open multiple results, each set of results must have a different step number.

    For example, you can set the step number to: 2 for 24 anodes and 3 for 36 anodes. Then if you import multiple results and cycle through the results GiD will display the 12 anodes followed by 24 anodes followed by 36 anodes.

    Create Model

    Press "Create Model" and check for warnings and errors in the Model Creation Report.

    Solve Model

    Now you can press "Solve". After the analysis is finished, you can now check the "Solver Log File" for any warning or errors.

    Results

    We can now go the "Results" tab and press "Create Report". The Summary Report is created

    First, we check that the error in current balance is negligible. Go to the section "Model Current Balance".

    Then, we can look at the "Group Results". We can identify that now the most positive protection potential on the wetted steel is about -726mV ().

    Figure 37: Report

  7. Tips for creating the 36 anodes models

    You need to apply more mesh transformations for the 36 anodes model.

    36 anodes model

    You can start by opening the CP Model Editor. Go to "File>Open" and select the hmd file corresponding to the 24 anodes model "24_anodes_Monopile.hmd". Save it with a different name, for example"36_anodes_Monopile.hmd" then import the additional meshes and apply the corresponding transformations.

    Transformations needed for the 36 anodes model

    For the 36 anodes model we need to import the following additional meshes:

    • the anode mesh centred at z=15

    • the anode mesh centred at z=15 rotated by 30o

    Define and Solve the 36 anodes model

    Define fields on the "Group Definitions" tab for the new groups and save the hmd file. Note that you can select rows (Figure 38), copy and paste into the new anodes.

    Figure 38: Select and copy properties and paste them onto the new anodes

    You can proceed and run the analysis for the 36 anodes model.

  8. Post-process

Once the simulation has completed the post.res and post.msh result files can be read into GiD and the results can be plotted as shown in Figure 39.

Figure 39 Protection potential on the monopile surfaces

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Off Potentials

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\offpotential\offpotential.htm

Off potentials

This tutorial illustrates the use of the Off Potential Wizard and how to compare ON and OFF results at a line of result elements defined at ground level.

CONTENTS

1. Introduction

2. Model description

3. Procedure

4. Off Potential Wizard

5. Process Results

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with:

  • Creating geometry and meshes.

  • BEASY zones and modelling concepts

  1. Introduction

    For the pipeline industry accurate survey measurement of the ‘OFF’ potential is of paramount importance, because this value can be used to estimate the protection potential on a nearby pipeline.

    BEASY CP software can be used to simulate the usual ICCP system in its "ON" state. This simulation produces the "ON" potential field throughout the electrolyte, and comparison with survey measurements of ground level "ON" potentials can be used to verify the simulation assumptions regarding coating damage, so increasing confidence in the simulation results for protection potentials at the pipe surface.

    In cases where it is nevertheless required to calculate the "OFF" potential field, the BEASY "OFF Potential" Wizard can be used.

    The tool takes as input the "*.dat" and "*.mat_cp" files which was used to calculate the "ON" potentials, plus the "*.gdf" results file from that simulation. For any selected polarising surface the tool determines the protection potential (which is the difference between the potential in the electrolyte and the potential in the nearby metal) and applies it to the surface, at the same time removing the "polarising" boundary condition. In addition, any rectifier is removed from the model.

    The resulting data file can be solved to determine the "OFF" potential field.

    The files used in this example are provided in multiple folders as shown in Figure 1. The mesh file is in the folder "Mesh" and the model and result files for the "ON" simulation are in in folder "ModelFiles". The files needed to perform the "OFF" simulation and the corresponding results are in the folder "OFFPotentials".

    Figure 1 Files location

  2. Model description

    The example in this tutorial consists of a pipeline and an ICCP anode. The pipeline and anode are modelled using tube elements. A polarisation curve is applied to the pipeline and the ICCP anode output is defined by imposing a fixed normal current density. The bounding box and result elements are also included and illustrated in Figure 2.

    Figure 2: Geometry

    A line of result elements is created to evaluate the ON and OFF potentials at ground level.

  3. Procedure

    This tutorial starts with the solution files obtained when solving the "ON" case. The hmd file with model properties, the mesh file containing the geometry of a pipeline, anode, bounding box and line of results elements together with solution files are also provided as a reference.

    It is assumed the model was created and a run with the specified conditions was performed using the CP Model Editor. These represents the ON solution.

    The starting point for this tutorial are the *dat, *mat_cp and *.gdf file obtained when running the ON solution. Then, the calculation of the OFF potential results can proceed.

  4. Off Potential Wizard

    To calculate OFF potentials, start by selecting the BEASY Off Potential Wizard icon in the CP Desktop.

    The OFF potential calculator window will pop up:

    Figure 3: OFF potential calculator

    Load "Pipeline.dat" and "Pipeline.gdf" corresponding to the ON conditions run. Note that "Pipeline.mat_cp" file needs to be present as well, in the same folder as the gdf and dat files.

    Then press "Prepare data file".

    Figure 4: OFF potential calculator

    A window pops up so you can select the required groups.

    Figure 5: OFF potential calculator. Groups selection

    Select the groups containing polarising surfaces from the list on the left and then click the ">>" button to transfer it to the list on the right. The groups you selected will be used to calculate Off-potentials (Figure 6). Press "OK".

    Figure 6: Select the groups with surfaces that have been polarised

    Then press "Run". The run will start and result files for this run will have extension *_off_potential.*

  5. Process Results

You can then use "Process Results from a BEASY GDF file" from the CP Desktop.

In this way, results are written into an ascii file. You can then import them into Microsoft Excel for example, to plot results at ground level or on the pipeline with ON and OFF potentials

Select Pipeline.gdf as shown in Figure 7. Check "Internal points results" to see results at ground level. Then press "Create Output"

Figure 7: Process ON results for Pipeline.gdf

Similarly, select "Pipeline_off_potential.gdf" as shown in Figure 8

Figure 8: Process OFF results for Pipeline_off_potential.gdf

Use the created files:

  • Pipeline__report_IntPoints.txt

  • Pipeline_off_potential_report_IntPoints.txt

to plot results as shown in Figure 9

Figure 9: ON and OFF potentials at ground level

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Offshore Jacket Structure

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\offshorejacket\offshorejacket.htm

Offshore jacket structure

This tutorial illustrates the use of the CP Builder, shows how to define tube elements, sacrificial anode properties and multilayer zones using the CP Model Editor.

In the GiD plugin tutorials , you can found the steps to construct the geometry and functions in the BEASY GiD problem type dedicated to jacket structures and anode creation on jacket structures.

CONTENTS

1 Introduction

2 Geometry

3 Model Definition

3.1 Open the CP Model Editor

3.2 Import mesh

3.3 Import polarisation curves

3.4 Group Definitions

3.5 Zones

3.6 Sacrificial anodes

3.7 Save the hmd file

3.8 Solve

3.9 Results

4 Post-process

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    This example aims to assess the performance of a CP system based on sacrificial (SAC) anodes on an offshore jacket structure. A view of the structure is shown in Figure 1. Figure 2 shows the anode dimensions.

    Figure 1: Jacket structure

    Figure 2: Showing the anode geometry

    The problem has been broken down into the following key stages:

    • Geometry using GiD interface

    • CP Builder

    • Solve and post-process

    The files used in this example are provided in multiple folders as shown in according to the key stages listed above.

    The files used in this example are provided in multiple folders as shown in Figure 3. The mesh files are in the folder "Mesh" and the model and result files are in the folder "Model Files".

    Figure 3 Files location

  2. Geometry

    The geometry for this example was created using the GiD graphical interface and the BEASY problem type for GiD. Follow this link to learn how to export the mesh and define layers for this example.

  3. Model Definition

    To begin this section you should have already created the mesh (*.bzmsh) for the model and have the material file (*.mat_cp) available.

    1. Open the CP Model Editor

      Start by opening the CP Model Editor.

    2. Import mesh

      Import the mesh using the "Imported meshes" tool. To add a mesh press the "+" button at the bottom of the tool or right click inside the panel area and select the option "Add Mesh".

      When the "Import mesh file" window pops up browse to "Jacket.bzmsh".

      After importing the mesh all the groups defined in the mesh file are also loaded with default parameters in the "Group Definitions" tab. The CP Model Editor looks as shown in Figure 5.

      Figure 5: CP Model Editor. Mesh imported

    3. Import polarisation curves

      We need to import the polarisation file containing all the polarisation curves we will be using in this example. Using the "Import polarisation curves" tool, press on the "+" button at the bottom of the panel and browse to the corresponding mat_cp file (ModelFiles/Jacket.mat_cp). The available polarisation curves are identified by labels as shown in the panel in Figure 6.

      Figure 5: Imported polarisation curves tool

    4. Group Definitions

      The "Group Definitions" tab is used to define the role of each group in the assembled model.

      We can model the seawater and mud either using a single zone multi-layer approach or a multi-zone with 2 zones. We already defined the geometry with no boundaries with the intention of using multi-layer approach.

      Define the entries for each group as shown in Figure 6.

      Figure 6: Group definitions. Properties on the "Basic" visualisation

      1. Tube elements

        To define diameters for the jacket members check the radio button for "Intermediate" Visualisation and set "Is tube element" property to true. Then enter values for the diameters as shown in Figure 6.

        Figure 7: Group definitions. Intermediate visualisation. Is tube element property

      2. Sacrificial anode data

      In this example, we want to define sacrificial anode data, so we can analyse the anode decay. To define sacrificial anode data change the radio button in Visualisation from "Basic" to "Intermediate". Then, define SAC geometry and SAC name properties as shown in Figure 8.

      Figure 8: Group definitions. Intermediate visualisation. Sacrificial anode data

      Note that you can hide from the view columns by right-clicking on the column title and selecting "Hide selected columns"

    5. Zones

      We can now start defining the zone properties. The "Zones" tab is used to define the zone properties such us conductivity/resistivity of the electrolytes. This example consists of a single multi-layer zone with:

      • Seawater conductivity 5 S/m ( from z=0 to seabed depth at z=41 m)

      • Soil conductivity 1.5 S/m

      Go to the "Zones" tab. Click on "Zond ID" 1. Change the Zone type to "Layered".

      Parameters used in the multi-layer zone are described in Figure 9.

      Figure 9: Parameters involved in the definition of a multi-layer zone

      Enter the parameters as shown in Figure 10 .

      Figure 10: Zones tab

    6. Sacrificial anodes

      Use the "Sacrificial Anodes" tab to fill in the anode data. Initially, the tab shows the names previously defined in the "Group Definitions" tab.

      Enter sacrificial anode data on the corresponding SAC name:

      • Type. Use the drop down menu to select the anode type

      • Utilisation Factor

      • Consumption Factor

      • Mass

      • Capacity

      Data is shown in Figure 11

      Figure 11: Sacrificial anodes data

      NOTE: the "Diameter" and "Density" fields are ignored if set to zero. These parameters are optional for "STAND_OFF" and "BRICK_FLUSH_MOUNTED" anode types.

    7. Save the hmd file

      We save the model parameters to "Jacket.hmd".

    8. Solve

      We can now go to the "Solve" tab. Leave the default settings and go to "Create Model".

      1. Create Model

        Press "Create Model". ( Figure 12)

        Figure 12: Create Model

        At the right of the window, vertical tabs give access to different reports. Always check for errors or warnings on the Model Creation Report. You can use the search button at the bottom of the window.

        An additional report file that is worth checking if sacrificial anode data is defined is the CPBuilder_SAC_Anodes_Report.txt. This file lists the data associated to each individual anode.

      2. Solve Model

      Now we are ready to press "Solve Model". After pressing "Solve Model" the BEASY CP Solver is launched. The "Solver runtime report" shows the messages from the Solver while the analysis is in progress. You can also check the "Status" at the bottom of the window.

      After the analysis is finished you can check the "Solver Log File" for any warning or errors. Go to vertical tab "Solver Log file" and search for warnings or errors.

    9. Results

    On the "Results" tab press "Create Report". The Summary Report is created as shown in Figure 13.

    Figure 13: "Summary Report"

    First, we check that the error in current balance is negligible. Go to the section "Model Current Balance". Then, we can look at the "Group results".

  4. Post-process

Once the simulation has completed the post.res/post.msh results can be read into GiD and the results can be plotted as shown in Figure 14.

Figure 14 Protection potential on jacket members

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Polarasing Condition on Interface

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\polarisingcondoninterface\polarisingcondoninterface.htm

Applying a polarising boundary condition to a zone interface

This tutorial shows how to proceed if you want to apply a polarising boundary condition to a zone interface.

CONTENTS

1 Introduction

2 Geometry and Mesh

3 Model definition

3.1 Open the CP Model Editor

3.2 Group definitions tab

3.3 Zone tab

3.4 Solve tab

3.5 Results tab

4 Post-process

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example assumes that the user is familiar with CP modelling and creation of internal points. It shows how to edit the *.dat file to create flux lines

  1. Introduction

    Normally a zone interface is a surface at which there is physical continuity from one side of the interface to the other, which means that:

    • electrolyte potential has the same value on both sides of the interface

    • normal current density has the same magnitude on both sides of the interface, but flows out of one zone and into the other zone

    It can greatly simplify modelling of certain structures (for example, a metal grill which separates electrolyte inside a sea-chest from the seawater outside) if a zone interface can be used to define the metal of the grill as well as the gaps between the grill surfaces, and if appropriate polarisation data can then be applied to the surfaces which represent both sides of the metal grill.

    This example shows how to construct such a model, using the "DIVIDER" property in the CP Model Editor.

    Note that it is not possible to perform metal voltage calculation if you use a "DIVIDER".

    The problem has been broken down into the following key stages:

    • Creating geometry and mesh

    • Creating model and running analysis

    • Post-process

    The files used in this example are provided in multiple folders as shown in Figure 1. The mesh files are in the folder "Mesh" and the model and result files are in the folder "Model Files"

    Figure 1 Files location

  2. Geometry and Mesh

    The model used for this example is very simple, and include two cuboid regions of electrolyte separate by a zone interface. The zone interface is split into:

    • parts where physical continuity is required

    • other parts where it is intended to apply a "cathode" polarisation curve

    Appropriate "anode" properties are applied to another surface in one of the zones, and "cathode" properties to another surface in the other zone.

    Figure 2 to Figure 4 show the geometry of the model in this example. The anode surface is shown in colour magenta, the cathode surface on the zone interface shown coloured yellow, and the other cathode on the left side shown coloured dark blue.

    Figure 2 Geometry view 1. Zone 1 and Zone 2 sides are shown in dark and bright green

    Figure 3 Geometry view 2. Zone 1 and Zone sides are shown in transparent

    Figure 4 Geometry view 3. Zone 1 and Zone 2 sides are turned off

    In Figure 3 the sides are shown partially transparent. In Figure 4 the "sides" of the two zones are hidden.

    Note that each of the pale blue and the yellow surfaces shown in Figure 4 is a single surface.

    The GiD geometry file and the mesh file is provided with this tutorial.

  3. Model definition

    To begin this section you should have already created the mesh (*.bzmsh) for the model as described in the previous section and have the material file (*.mat_cp) available.

    1. Open the CP Model Editor

      Open the CP Model Editor and import the corresponding mesh file and mat_cp file provided with this tutorial.

    2. Group definitions tab

      Assign properties for the groups in the Group Definitions tab as shown in Figure 5.

      Figure 5 Group Definitions tab.

      In particular note the "DIVIDER" used for group "zone_1_to_2_steel_interface"

    3. Zone tab

      Then, go to the "Zones" tab to identify two homogeneous zones with conductivity 1.0 S/m and no symmetry planes as shown in Figure 6 and Figure 7.

      Figure 6 Zones tab. Zone 1 definition

      Figure 7 Zones tab. Zone 2 definition

    4. Solve tab

      You can now go to the Solve "tab" and press "Create Model". The outcome is shown in Figure 8.

      Figure 8 Solve tab. Create Model

      You are now ready to press the "Solve Model" button.

      Figure 9 Solve tab. Run finished

    5. Results tab

    When the run is finish go to the Results tab and create a Results Summary report. (Figure 10)

    Figure 10 Results tab. Results summary

  4. Post-process

Having read the results files into BEASY_GiD, the command shown in Figure 11 was used to plot averaged protection potential, and this produced the image shown in Figure 12.

Figure 12 shows the two sides of the grill slightly apart, but because of the contour scale used, in this figure it is not easy to see any difference between the grill surfaces in zone 1 and those in zone 2.

Figure 13 has the "Zone 1 anode" and the "zone 2 cathode" surfaces turned off, and clearly shows the change of protection potential between the side of the grill which is in zone 1 and the side in zone 2.

Figure 11 Plotting averaged protection potential

Figure 12 Contours of protection potential are drawn only on surfaces where polarising boundary conditions have been applied

Figure 13 Protection potential on the grill

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Polarisation DataBase Create Mat

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\poldatbase_creatematfile\poldatbase_creatematfile.htm

How to create a mat file with a new material using the Polarisation Database

This tutorial shows steps to create a material in the polarisation database and then create a mat_cp file containing the new material. This methodology can be applied to any linear or non-linear polarisation curve, in particular to a sigmoidal curve used to represent the formation of calcareous deposits in offshore structures.

Follow the steps described in this tutorial to add a new material to the database and then create the mat file. In this example we are using a polarisation sigmoidal curve.

1 Open polarisation database and introduce new material in the database

2 Create a mat file with the new material

2.1 Select materials to go in your matfile

2.2 Define label, proportional factor and comment line

2.3 Press "Write" to keep adding other breakdown factors for this material

2.4 Press "Write and go the next material"

2.5 Mat file

  1. Open polarisation database and introduce new material in the database

    First introduce a new material into the database. Follow this link if you want to learn how to add a new material in the database.

    When prompted input the sigmoidal curve data in the sheet show in Figure 1:

    Figure 1: Sheet to enter the data

    Add potential and current density values, for example:

    Potential (mV Ag/AgCl seawater)

    Current Density (mA/m2)

    -612.81

    1.06

    -621.7

    8.39

    -631.75

    18.09

    -639.46

    23.33

    -651.02

    31.19

    -662.67

    38

    -679.7

    45.34

    -702.22

    52.15

    -726.29

    56.62

    -758.78

    57.94

    -784.75

    56.12

    -809.46

    52.99

    -841.24

    46.73

    -868.91

    40.72

    -899.41

    33.4

    -928.47

    27.14

    -950.51

    23.48

    -964.28

    21.4

    -982.09

    19.57

    -995.72

    19.06

    -1012.02

    19.06

    -1030.88

    20.91

    -1052.32

    24.32

    -1065.57

    28.25

    -1074.77

    31.92

    -1087.91

    37.16

    -1103.53

    45.29

    Then press the End Input data button

    Figure 2: Press Input data

    Now you can check the data by viewing its plot. Press the Plot curves button

    To see a graph of the data, press the Experimental curve button

    Figure 3: Experimental curve

    Next time, when you have to write a material file, you will be able to select the new material you have defined.

  2. Create a mat file with the new material

From the polarisation database main sheet press "Export, Import Files" and select "Create Mat File".

Figure 4: Create Mat file

  1. Select materials to go in your matfile

    Browse to your working folder and add a name to the material file.

    Select the material created in the previous section (add more materials if you need more materials in your file):

    Figure 5: Press OK.

    Select cathodic material and press OK

    Figure 6: Select cathodic material and press OK.

  2. Define label, proportional factor and comment line

    Add a label WBST (Wetted Bare Steel for example). You can also add a comment line:

    Figure 7: Mat file data

    You can press "Write" to keep adding more proportional values of this material or "Write and go to next material" to start with other materials from the list on the first step

  3. Press "Write" to keep adding other breakdown factors for this material

    Press "Write". Enter OK to accept the Select material

    Figure 8: Press OK

    Add a new label and a proportional value, for e.g. 0.02 ( i.e. 2% bf at initial life)

    Figure 9: Mat file data

    Proceed the same to add other breakdown factors.

  4. Press "Write and go the next material"

    Press "Write and go the next material" to finish creating the material file.

  5. Mat file

Figure 10: Mat file

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Ship Hull - Damaged blade

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\shiphull\shiphull.htm

Ship Hull

This tutorial illustrates the use of the CP Model Editor. It shows how to model a ship hull with a damaged propeller coating, how to set up a model with dual elements and how to apply different polarisation properties to each side of the plates. The results are then processed using GiD 14.

CONTENTS

1 Introduction

2 Mesh

3 Model definition

3.1 Start the CP Model Editor

3.2 Importing a Mesh File

3.3 Adding Material File

3.4 Group Definitions

3.5 Zone Definitions

3.6 Save the hmd file

3.7 Solve tab. Create model

3.8 Solve tab. Run the analysis

3.9 Results tab

4 Post-process

4.1 Protection Potential

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

This example uses the existing geometry of a ship hull, propellers and anodes as a starting point. It assumes that the user is familiar with:

  • Creating geometry and meshes

  • BEASY zones and modelling concepts

  1. Introduction

    This example aims to assess the performance of a CP system based on ICCP anodes on a ship hull. A view of the model is shown in Figure 1.

    The example consists of a ship hull in seawater with propellers and shaft rods. There is an area of damage on the propellers. ICCP anodes are arranged along the hull.

    Figure 1: Model overview

    Figure 2: Showing the area of damage

    Figure 3: Showing the trim tab and anode geometry

    The problem has been broken down into the following key stages:

    • Mesh generation through a third party interface equipped with a BEASY plug in.

    • Creating model data

    • Running analysis

    • Post-process

    The files used in this example are provided in multiple folders as shown in Figure 4 according to the key stages listed above. The mesh files are in the folder "Mesh" and the model and result files are in the folder "Model Files

    Figure 4: Files location

  2. Mesh

    Mesh files are provided in the "Mesh" folder.

    Follow this link to learn how to export the mesh and hmd file using BEASY problem type for GiD.

  3. Model definition

    To begin this section you should have the mesh for the complete model of the ship hull, anodes and boundaries ("ShipHull.bzmsh" ) and have the material file (*.mat_cp) available.

    1. Start the CP Model Editor

      Start by opening the CP Model Editor trhough the CP Desktop.

    2. Importing a Mesh File

      A mesh file can imported into the model by pressing the "+" button highlighted in the "Imported meshes" tool.

      Figure 5: Imported meshes tool

      This opens the following menu, now press the "Browse" button highlighted in Figure 6 to select a BEASY mesh file.

      Figure 6: Import mesh file window

      Now select the required mesh file titled "ShipHull.bzmsh".

      Press the "Accept" button highlighted below to confirm the mesh selection.

      Figure 7: Confirming the mesh selection

      After confirming the mesh, groups defined in the mesh should appear in the "Group Definitions" tab, as highlighted below.

      Figure 8: Resulting screen from importing a mesh

    3. Adding Material File

      A material file needs to be loaded. It has to contain all the polarisation curves that will be used in the simulation. Press the "+" button in the "Import polarisation curves" tool as shown in Figure 9.

      Figure 9: Imported polarisation curves toolbar

      Now select the material file included in this tutorial. This should load the following materials into the "Imported polarisation curves" tool ( Figure 10).

      Figure 10: Polarisation curves in the imported material file

    4. Group Definitions

      First assign all the groups with a zone ID of "1", these will stay red for now as the zones properties haven't been defined yet.

      Figure 11: Filling in the "Master zone ID" property in the group definitions tab

      There is only 1 zone in this model, so the "Slave zone ID" property column can be left as default. For the "Group type" property, the groups "Anodes_Active_Surfaces" and "Anodes_Insulated_Surfaces" should be assigned "ANODE"; additionally the group "Z1" should be assigned "BOUNDINGBOX". These settings are shown in Figure 12.

      Figure 12: Filling in the "Group type" property in the group definitions tab

      Now for the "Boundary type" property:

      • Select "POLARISATION" for all the "METAL" groups.

      • Select "NORMAL_CURRENT_DENSITY". For the group "Anodes_Active_Surface"

      • Leave the group "Anodes_Insulated_Surface" as "INSULATED".

      • Finally select "NO_BC". For group "Z1"

      These settings are shown in Figure 13.

      Figure 13: Filling in the "Boundary type" property in the group definitions tab

      For all the groups assigned "POLARISATION" the "Boundary value" property entry will automatically change to "UNKNOWN" and be highlighted in red to indicate that a value needs to be assigned. For the groups assigned "NO_BC" and "INSULATED", these entries will change to "NA" to indicate they don't need to be changed. For the group assigned "NORMAL_CURRENT_DENSITY" the entry will change to "0" to indicate a numerical value should be entered.

      The "Boundary value" properties can be entered by starting typing the first label letter or using the "Imported polarisation curves" tool by selecting one of the curves and one or more groups and pressing the ">>" button shown below.

      Figure 14: Imported polarisation curves toolbar assign button

      • Assign "ST00" to the groups "Hull_01", "Hull_02", "Hull_03", "PropHub", "ShaftRod" and "Trimtab".

      • Assign "NA00 to the group "Blades".

      • Assign "NA03" to the group "Blade_Damage".

      • Assign "500" or "-500" to the group "Anodes_Active_Surfaces", this will automatically be set to a negative value, if the group type column is set to "ANODE".

      • Leave the groups "Z1" and "Anodes_Insulated_Surface" as "NA".

      These settings are shown in Figure 15.

      Figure 15: Filling in the "Boundary value" column in the group definitions tab

      For this model, dual elements also need to be defined, in order to do this we need to adjust the "Visualisation" section at the top left of the "Group Definitions" tab; change the radio option to "Advanced". In this way the property to define dual elements becomes visible and the properties to define different polarising conditions on both sides of the dual elements becomes available.

      Figure 16: Group definitions tab visualisation options

      Now assign the groups "Blade_Damage" and "Blades" the value "true", as in Figure 17.

      Figure 17: Filling in the "Is dual" property in the group definitions tab

      Now scroll horizontally till you find the "Boundary value side2" column and change the group "Blade_Damage" to "NA00", as shown in Figure 18.

      Figure 18: Filling in the "Boundary value side2" column in the group definitions tab

      The group definitions are now fully defined for this model.

    5. Zone Definitions

      This example consists of a single homogeneous zone with seawater conductivity 4 S/m and a symmetry plane on the Z=0 plane. Assign these properties in the "Zones" tab, as shown in Figure 19.

      Figure 19: Defining a homogeneous zone using the zone tab

    6. Save the hmd file

      Save the model definitions to "Flowline.hmd".

    7. Solve tab. Create model

      Navigate to the "Solve" tab to create the model. Click on the "Create Model" button to create the input files for the CP Solver. This should result in the following text appearing in the "Model Creation" log tab.

      Figure 22: Model creation tab and log file

    8. Solve tab. Run the analysis

      The model can be solved by pressing the "Solve Model" button, which will switch the log tab to "Solver runtime report". If the model completes successfully the message in Figure 23 should be shown.

      Figure 23: CP Solver runtime log file

      The full log file can also be viewed by clicking on the "Solver Log file" log tab. If the model completes successfully the message in Figure 24 should be shown.

      Figure 24: Full solver log file

    9. Results tab

    A report of the results can be produced by navigating to the "Results" tab and pressing the "Create Report" button, this is highlighted in Figure 25.

    Figure 25: Report of results creation

    The details of the results can be viewed by scrolling down to the "Results" section (Figure 26). This includes:

    • A summary of the current balance in the overall model and individual zones. (This model only has 1 zone) This can be useful in determining the accuracy of the simulation.

    • A series of results and information about individual groups in the model. This can be useful for reviewing the results in critical areas of the model or to measure the current drain from specific structures.

    Figure 26: Summary of results available in the created report

  4. Post-process

Once the simulation has completed the post.res/post.msh results can be read into GiD.

Contour plots can be viewed by going to "View results>Contour Fill". Before viewing results it may be easier to hide post layer "No BC".

  1. Protection Potential

To visualise protection potential on the hull surfaces turn off the layers containing the ICCP anodes, blades, internal points and the result surface:

Figure 27: "On" layers

Figure 28 shows protection potential on the hull surfaces.

Figure 28: Protection potential in mV on the hull surfaces

Now turn off all the layers containing the hull surfaces as well, as shown in Figure 29 below.

Figure 29: "On" layers

Figure 30 shows protection potential on the damaged blade

Figure 30: Protection potential in mV on the both side of the blade with damage

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Contents

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\tutorials_index\tutorials_index.htm

BEASY CP Tutorials

Model Build Tutorials

Polarisation Data

Internal Points

Checking tool

Modelling calcareous deposits in offshore structures

OFF Potential

Miscellaneous

Using old model data

Modelling water flow rate variation with depth and formation of calcareous deposits in offshore structures

Click on the following links to access:

  • Introductory material on "approach to modelling".

  • A list of steps to follow to create and solve a BEASY CP model.

  • Meshing guidelines.

Model Build Tutorials

This set of tutorials is meant to introduce the user to the CP modelling methodologies.You will find detailed instructions showing how to build a CP model, and prepare the data illustrated through different examples.

In the BEASY GiD tutorials section you will find tips on how to construct the geometry or how to make up groups (layers) for the examples in these tutorials.

Bi-Metallic Corrosion

Cell

This tutorial explains how to build a bi-metallic corrosion cell composed of zinc and steel, solve it, and obtain results.

How to create a CP model and run analysis

Watch movie showing steps to create a BEASY CP model and run an analysis using the CP Model Editor.

How to add sacrificial anode (SAC) data

This tutorial shows how to define sacrificial anode data to simulate anode decay using the CP Model Editor.

How to remove a mesh

This tutorial shows how to remove a mesh and all its associated groups from an existing hmd file using the CP Model Editor.

Steps to create a BEASY model from an HMD file

One of the main uses of the CP Model editor is to create or edit existing model files. This tutorial shows steps to follow to create a model using an existing HMD file

Monopile

This tutorial shows how to create different anode configurations from the same mesh file and how to define a multi zones model.

It also exposes the new methodology to deal with sigmoidal curves.

Offshore jacket structure

This tutorial shows how to create a model of a jacket structure: how to define tube elements, sacrificial anode properties and a single multi-layered zone.

In the GiD plugin tutorials , you can found the steps to construct the geometry and functions in the BEASY GiD problem type dedicated to jacket structures and anode creation on jacket structures.

Flowline

This tutorial illustrates the use of the CP Model Editor. It shows how to model a flowline in seawater with internal resistance and a buried section, how to model tube elements and a multi-layered zone and how to define sacrificial anode data.

Ship hull with damaged blade

This tutorial shows how to model a ship hull with hull with a damaged propeller coating, how to set up a model with dual elements and how to apply different polarisation properties to each side of the plates..

Polarisation Data

How to create a mat file using the Polarisation database

This tutorial shows steps to create a material in the polarisation database and then create a mat_cp file containing the new material. This methodology can be applied to any linear or non-linear polarisation curve, in particular to a sigmoidal curve used to represent the formation of calcareous deposits in offshore structures.

How to create a mat file using the Pol2Mat tool

This tutorial shows how to create a material file from a series of sets of polarisation data (i.e. pairs potential and, current density).

This methodology can be applied to any linear, non-linear polarisation curve, in particular to a sigmoidal curve used to represent the formation of calcareous deposits in offshore structures.

Internal Points

Internal Points defined with CP Model Editor | This tutorial illustrates how to create a line and a grid of internal points with the CP Model Editor. The results are then processed using GiD 14. It also shows how to get a file of numeric results for internal points.
Result Elements | This example shows how to create groups of result elements (internal points created as geometry), how to declare the group type "INTERNAL_POINT" using the CP Model Editor and how to visualise results in GiD with separate layers for the different internal points groups. It also shows how to get results on internal points into a Excel spreadsheet
Internal Points defined with the IP Editor | This tutorial illustrates the use of the IP Editor showing how to calculate results on internal points using results previously calculated.

Checking tool

How to check that zones are correctly defined

This tutorial shows how to check that zones are correctly defined and illustrates the use of the "Create GiD files for zone checking" .It shows how to visualise the resulting meshes in GiD 9 and GiD 14.

Modelling calcareous deposits in offshore structures

Modelling of offshore structures accounting for the formation of calcareous deposits has been greatly simplified in this release and steps and procedures are not different to the common procedures described in the previous sections.

The only difference, from the modelling point of view, is that the polarisation curve used is a sigmoidal curve.

You can visit documentation introducing the sigmoidal polarisation curve method.

The sigmoidal curve is included in the material file (*.mat_cp) in the same way as any other linear or non-linear curve.

The previous tutorial " Monopile "includes the use of a sigmoidal curve to account for the formation of calcareous deposits.

The material file using a sigmoidal curve can be created from the pairs potential /current density, using the same techniques used for any other polarisation curve, as described in the previous section Polarisation Data

  • How to create a mat file using Polarisation Database

  • How to create a mat file using the Pol2Mat tool

OFF Potential

How to calculate Off potentials

This tutorial illustrates the use of the Off Potential Wizard and how to compare ON and OFF results at a line of result elements defined at ground level.

Miscellaneous

How to create flux lines | This tutorial illustrates how to visualise the direction of the current flow through the electrolyte using flux-lines
Changing potential boundary condition. How to minimise solution time | This tutorial illustrates how to minimise solution time when it is required to change a "POTENTIAL" boundary condition, by re-using influence matrices determined in a previous solution. It also shows how to get solution at internal points without re-solving
Changing material label. How to minimise solution time | This tutorial illustrates how to minimise solution time when it is required to change a boundary condition defined by a material LABEL, by re-using influence matrices determined in a previous solution. It also shows how to get solutions at internal points without re-solving
Applying polarising conditions to a zone interface | This tutorial shows how to proceed if you want to apply a polarising boundary condition to a zone interface.

Using old model data

How to use an old GiD model | This tutorial shows how to the use the geometry files from an old GiD model
How to use the mesh from an existing dat file | This tutorial shows how to the use the mesh defined in an old model to define a new model with the CP Builder.
How to use an old dat file with the CP Builder | This tutorial shows how to use the available tools to extract data from an existing dat file and use it to create an hmd file.

Modelling water flow rate variation with depth and formation of calcareous deposits in offshore structures

These tutorials describe the additional files needed to set up simulations for offshore structures using profiles for flow rate variation with depth and long term curves to represent the formation of calcareous deposits.

Methodology

To include the effects of flow rate variation with depth allowing the formation of calcareous deposits a set of additional input files need to be created. This tutorial introduces to the modelling procedure and additional files needed to set up these runs.

How to prepare a long-term file .

This tutorial shows how to create the sigmoidal curve to use in the long-term file.

How to prepare a dynamic polarisation curve which take into account flow rate

4

This tutorial shows how to produce the family of dynamic polarisation curves which must be used when simulating the variation of water flow rate profile with depth and formation of calcareous deposits.

Note that if the file containing the flow-rate profile file is not used, then "depth" will be used to interpolate into the family, with undesired consequences.

Files format

Example files can be saved to your local working space by right clicking into the following links:

  • Longterm files, mat files and flow profile files to use in a flow environment. Right click here to save files.zip

NOTE: You may need to adjust the files provided so that the long-term curves are "between" the pairs of potentio-dynamic curves at all potentials. If this is not the case the CP solver will stop with a FATAL ERROR Message

This document summarises the formats of the files needed to simulate calcareous deposits and flow rate

Calcareous deposits on tidal waters

This tutorial illustrates how to perform a time-stepping run for an offshore monopile that contemplates the formation of calcareous deposits and water flow rate variation with depth.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


How to use an old datfile with the CP Builder

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\useolddatfile\useolddatfile.htm

How to use an old R15 dat file with the CP Builder

This tutorial shows how to use the available tools to extract data from an existing dat file and use it to create an hmd file.

CONTENTS

1 Introduction

2 The R15 model

3 The tool "ListGroups"

3.1 How to run the tool

3.2 How to process the file "oldModel.dat"

4 Complete the model using the CP Builder

4.1 Copy the partial template data into the full template file

4.2 Edit section MESH

4.3 Edit Section ZONE_DEFINITION

5 Running CP Builder

6 Solve

7 Other possible required actions

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    It may be that an old model needs to be modified (re-meshed, or other changes), and using CP Builder offers many advantages. For this reason it may be desirable to extract data from an existing model, and use it with CP Builder.

    This tutorial gives an example of how to use the available tools to perform these operations for a specific model which was created using the CP Wizard. The model was part of previous releases of BEASY software.

    The files used in this example are provided in multiple folders:

    • R15_BEASYGid

    • R15_CPWizard

    • R15_Solve

    • R19_ListGroups/before

    • R19_ListGroups/after

    • R19_Build

    • R19_CPBuilder

    • R19_Solve

  2. The R15 model

    The R15 model (created using the GiD problem type "BEASY_10Jul2012") is included in folder "R15_BEASYGiD".

    The model has:

    • a steel structure in zone 1 which has properties of seawater

    • an anode in zone 1

    • a second zone which has properties of seabed

    The model was processed using the R15 CP_Wizard in folder "R15_CPWizard".

    Note the model has elements which are not in any group as follows:

    • on the sides of the water zone

    • on the seabed (interface between zones 1 and 2)

    • on the sides and bottom of zone 2

    Folder "R15_Solve" contains results files obtained using the old model, and Figure 1 shows contours of electrolyte potential on the surfaces away from the structure.

    Figure 1 Contours of electrolyte potential on surfaces away from the structure

  3. The tool "ListGroups"

    The tool used in this example is "ListGroups.exe"

    1. How to run the tool

      The tool used in this example is "ListGroups.exe", typically located in folder "C:\Program Files\beasy\beasy10.0r19\bin" or "C:\Program Files\beasy\beasy21\bin\cp" on your machine.

      It will be necessary to create a text file with file extension ".bat" file, which for example might be called "runListGroups.bat" (make sure you can see file extensions, as otherwise you may in fact have created a file called "runListGroups.bat.txt" – and in this case it will not behave correctly).

      Into the .bat file insert text as follows:

      "C:\Program Files\beasy\beasy10.0r19\bin\ListGroups.exe" >temp.log

      And then double click on the .bat file to run it. This will create instructions as shown in Figure 2.

      Figure 2

    2. How to process the file "oldModel.dat"

    To process the file "oldModel.dat", insert into the .bat file the following text:

    "C:\Program Files\beasy\beasy10.0r19\bin\ListGroups.exe" oldModel.dat -g >temp.log 2>&1

    A batch file containing the above text is included in folder "R19ListGroups\before".

    Note:

    • that this .bat file will only process the file if both the .bat and the .dat are in the same folder

    • that the characters "2>&1" at the end of the line cause all text to be sent to the file "temp.log".

    Now double click on the .bat file to run it.

    Because the file "oldModel.dat" does not have any elements which are NOT in groups, the only action performed by the ListGroups tool is to create file "oldModel_ListGroups.txt".

    File "oldModel_ListGroups.txt" is a partial template hmd file for use with the CP Builder.

    Files present after using the ListGroups tool are included in folder "R19ListGroups\after".

  4. Complete the model using the CP Builder

    File "oldModel_ListGroups.txt" was copied to folder "R19_Build", and the contents were then pasted into spreadsheet "oldModel_ListGroups.xlsx" for checking. A view of this data is shown in Figure 3.

    Figure 3

    From this data it can be seen that:

    • The model includes two zones

    • None of the groups contains tube elements

    • Polarisation curves "ZINC" and "STEL" are used

    • Some fields have "UNDEFINED"

    The fields which contain "UNDEFINED" need to be modified before the data can be used in the hmd file. For this model:

    • We can guess from the group names "mud" and "water" that these groups defined the bounding boxes of the seawater and the seabed. If it is not obvious, it might be necessary to use "Check dat" (see other example) to identify function of these groups. Since we think that "mud" and "water" groups define bounding boxes, it is appropriate to replace these fields in the "SURFACE_TYPE" column with "BOUNDING_BOX" (See the full template file for options which can be used)

    • We know that group "seabed" is an interface (since column "SLAVE_ZONE" is not zero), and the most likely "BOUNDARY_TYPE" is that it is an interface which allows current to flow from one zone to another. For this type of interface, the "BOUNDARY_TYPE" must be "NO_BC"

    Having made these corrections, the data appears as shown in Figure 4.

    Figure 4

    File "oldModel_ListGroups_corrected.txt" in folder "R19_Build" contains the corrected data.

    Because the template hmd is partial (in that it includes limited data – for example groups), it is necessary to create a full (but empty) template.

    This can be achieved using the CP Builder as shown in Figure 5 to Figure 7.

    Figure 5

    Figure 6

    Figure 7

    Next it is necessary:

    • to copy the partial template data in file "oldModel_ListGroups.txt" into the full template file "newModel.hmd" (see next section)

    • to complete other sections of data (see later sections)

    • the mesh name "MESH_FILENAME"

    • the mesh format "MESH_FILE_FORMAT"

    • the zone definition (ID, conductivity, symmetry) for each zone

    In this model no other fields need to be completed, but for other model further fields in the full template file might need to be completed.

    1. Copy the partial template data into the full template file

      First locate the data shown in Figure 8, then delete the lines shown boxed in red (note this includes the line which starts with "MESH_NAME"), and in their place insert all the data from file "oldModel_ListGroups_corrected.txt".

      Figure 8

      Data in the file after this step is shown in Figure 9.

      Figure 9

    2. Edit section MESH

      Data shown in Figure 10 is replaced with data shown in Figure 11.

      Figure 10

      Regarding the numbered sections in Figure 11:

      1. This text must correspond to the text in the first column in Figure 9

      2. This must be the name of the .dat file used, in this case "oldModel.dat"

      3. This must be "BEASY_DAT"

      Figure 11

    3. Edit Section ZONE_DEFINITION

    By inspection of the .dat file (data shown in Figure 12 to Figure 14) it can be identified that for this model:

    • Zone 1 is a normal zone, with conductivity 3 and symmetry about z=0

    • Zone 2 is a normal zone, with conductivity 0.5 and no symmetry

    Figure 12. Old dat file

    Figure 13 Old dat file

    Figure 14 Old dat file

    In the hmd file "newModel.hmd", locate data shown Figure 15, and because neither zone 1 nor zone 2 is "multi-zone", delete the section shown boxed in red in Figure 15.

    Figure 15. ZONES_DEFINITIONS section in the hmd file

    Next insert correct data for zone 1 in the section shown boxed in blue in Figure 15.

    Finally, create a similar section for zone 2, and insert correct data for this zone.

    The data section should now appear as shown in Figure 16.

    Figure 16. Edited section ZONES_DEFINTION

    Now the edition of the hmd is finished.

  5. Running CP Builder

    The following files were copied from folder "R19_Build" to folder "R19_CPBuilder":

    • newModel.hmd

    • oldModel.dat

    Then the CP Builder was used as shown in Figure 17 to Figure 18.

    Figure 17

    Figure 18

    After successful processing the files in folder "R19_CPBuilder" are as shown in Figure 19.

    Figure 19

  6. Solve

    File "newModel.dat" was copied to folder "R19_Solve", and file "oldModel.mat_cp" was first copied to folder "R19_Solve" then renamed to "newModel.mat_cp".

    Then solution was performed, and results displayed as shown in Figure 20.

    Figure 20

    Comparison of results for the new model (Figure 20) and for the old model (Figure 1) confirms that behaviour has not changed, and therefore confirms that the change to use of CP Builder has been correctly carried out.

  7. Other possible required actions

Although models created using the CP_Wizard (available in earlier release of BEASY) will have defined groups for all elements, it is possible that other meshes might have elements that are not in a group. Such elements might be:

  • On a bounding box around a zone

  • On an interface between two zones

In such a case it is necessary to modify the .dat file so that it includes additional groups, as well as creating a partial template hmd file which includes all groups in the modified .dat file.

This additional operation (modifying the .dat file so that it includes additional groups) is automatically carried out by ListGroups which creates a new .dat file.

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Create mat_cp using Pol2MatCP

BEASY version 21 - CP

Filename: installdir\docs\cp\tutorials\usepol2matcp\usepol2matcp.htm

How to create a mat_cp file using Pol2MatCP tool

Follow the steps described in this document to create a material file from a file containing a list of pairs potential, current density.

This tutorial shows how to create a material file from a series of sets of polarisation data (i.e. pairs potential and, current density).

This methodology can be applied to any linear, non-linear polarisation curve, in particular to a sigmoidal curve used to represent the formation of calcareous deposits in offshore structures

1 Introduction

2 Example 1. Polarisation curves and breakdown factors

3 Example 2. Sigmoidal curve

Files needed for this tutorial are zipped and you can save them into your working area by right clicking in the following link: Right click here to save files.zip

  1. Introduction

    Pol2MatCP translates an ASCII file (*.pol) containing pairs of potential and current density for different polarisation curves into a mat file (*.mat_cp)

  2. Example 1. Polarisation curves and breakdown factors

    This example assumes we have polarisation data for bare steel and zinc. The pairs of potential and current density are shown in Table 1 and Table 2.

    Potential (mV Ag/AgCl seawater)

    Current Density (mA/m2)

    -650.0000

    0.0000e+000

    -1000.0000

    2.1000e+003

    Table 1. Steel polarisation data

    Potential (mV Ag/AgCl seawater)

    Current Density (mA/m2)

    -950.0000

    -4.2780e+004

    -1060.0000

    0.0000e+000

    Table 2. Zinc polarisation data

    We want to create a material file that includes both curves (using labels STBA and ZINC) plus the polarisation curves for steel with the following breakdown factors:

    • 2 % breakdown factor

    • 7 % breakdown factor

    • 12 % breakdown factor

    • 22 % breakdown factor

    • 27 % breakdown factor

    Files provided:

    • example_01_start.pol: Template to start adding data

    • example_01.pol: File with data added

    Proceed as follows:

    STEP 1: Open the template file (example_01_start.pol).

    STEP 2: Copy the sets of data for bare steel and zinc in example_01_start.pol and save it with a different name for example: myexample_01.pol.

    STEP 3: To include polarisation curves with different breakdown factors in the material file add the following commands at the end of the file:

    REPLICATE STBA ST00 0.02

    REPLICATE STBA ST05 0.07

    REPLICATE STBA ST10 0.12

    REPLICATE STBA ST15 0.17

    REPLICATE STBA ST20 022

    REPLICATE STBA ST25 0.27

    Save and close the file.

    STEP 4: Open a command line tool in the folder where you created the *.pol file and type the following command:

    "%BEASY_CP_21%\bin\Pol2MatCP" myexample_01.pol myexample_01.mat_cp

  3. Example 2. Sigmoidal curve

This example assumes we have polarisation data for steel in seawater represented by a sigmoidal curve. The pairs of potential and current density are shown in Table 3

Potential (mV Ag/AgCl seawater) | Current Density (mA/m2)
-612.81 | 1.06
-621.7 | 8.39
-631.75 | 18.09
-639.46 | 23.33
-651.02 | 31.19
-662.67 | 38
-679.7 | 45.34
-702.22 | 52.15
-726.29 | 56.62
-758.78 | 57.94
-784.75 | 56.12
-809.46 | 52.99
-841.24 | 46.73
-868.91 | 40.72
-899.41 | 33.4
-928.47 | 27.14
-950.51 | 23.48
-964.28 | 21.4
-982.09 | 19.57
-995.72 | 19.06
-1012.02 | 19.06
-1030.88 | 20.91
-1052.32 | 24.32
-1065.57 | 28.25
-1074.77 | 31.92
-1087.91 | 37.16
-1103.53 | 45.29

Table 3. Wetted Bare Steel polarisation data. Sigmoidal Curve

Files provided:

  • example_02_start.pol: Template to start adding data

  • example_02.pol: File with data added

Proceed as follows:

STEP 1: Open the template file (example_01_start.pol).

STEP 2: Copy the set of data for the wetted bare steel in example_01_start.pol and save it with a different name for example: myexample_02.pol.

STEP 3: To include polarisation curves with different breakdown factors in the material file add the following commands at the end of the file:

REPLICATE SIGM SI00 0.02

REPLICATE SIGM SI05 0.07

REPLICATE SIGM SI10 0.12

REPLICATE SIGM SI15 0.17

REPLICATE SIGM SI20 022

REPLICATE SIGM SI25 0.27

Save and close the file.

STEP 4: Open a command line tool in the folder where you created the *.pol file and type the following command:

"%BEASY_CP_21%\bin\Pol2MatCP" myexample_02.pol myexample_02.mat_cp

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Search Words List

! 1 2 3 4 5 6 7

# 1 2 3 4 5 6 7 8 9

$

% 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173

& 1 2 3 4 5 6

' 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22

( 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133

>>


Search Words List

<<

) 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133

* 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69

+ 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23

, 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160

>>


Search Words List

<<

at 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
ata
ate
ati
atic
ation
atlas 1 2 3 4 5 6
attached 1 2 3 4 5 6
attack
attempted 1 2 3
atype1
au
author
auto 1 2
automatic 1 2 3 4 5 6 7 8 9 10 11 12
automatically 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
auxiliary
av 1 2
availability 1 2
available 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
aval
avera
average 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
average_voltage
averflow
avoid 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
aware 1 2
away 1 2 3 4 5 6 7 8 9 10 11 12
awminum
ax1
ax2
ax3
axes 1 2
axial 1 2 3 4 5 6 7
axis 1 2 3 4 5 6 7
axisymmetric 1 2
axis’
ay
aylor
ays

b 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
b01
b443c
ba
back 1 2 3 4 5 6 7 8 9 10
background 1 2 3 4 5 6 7
backslash
bal
balance 1 2 3 4 5 6 7 8 9 10 11
band 1 2
bar 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
bar3
bards
bare_flow
bare_flow_env
barge
based 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
basic 1 2 3 4 5 6 7 8 9 10 11 12 13 14
basically 1 2
basis
bat 1 2
batch 1 2 3 4 5 6 7 8 9 10 11 12 13

>>


Search Words List

<<

bc 1 2 3 4 5
bch 1 2
bcids
be 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123
beak
beams
beasy 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
beasy10 1 2
beasy21 1 2 3 4 5 6
beasy_
beasy_10jul2012
beasy_12may2020 1 2
beasy_13mar2020
beasy_18jun2020 1 2
beasy_21
beasy_21may2020
beasy_21may_2020
beasy_cp_21 1 2 3 4 5 6 7 8 9 10
beasy_cp_homepage
beasy_cp_v21 1 2
beasy_dat 1 2
beasy_ddmmmyyyy 1 2 3
beasy_ddmmyyyy
beasy_gid 1 2 3 4 5
beasy_labels
beasy_off
beasyand 1 2 3
beasybanner 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
beasycp 1 2 3
beasycp_21
beasyd
because 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
becomes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
been 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
before 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
before_solve 1 2
beforehand
beforesolve
begin 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
begin_polarisation_curve
behalf
behaving 1 2 3 4 5
behavior 1 2
behaviorof
behaviour 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
behav
behind
being 1 2 3 4 5 6 7 8 9 10
bellow
belong 1 2 3 4 5 6 7 8 9 10 11
below 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
bem 1 2
beneath
beneficial
berger
best 1 2 3 4 5 6 7
bethesd
bethesda
better 1 2 3 4 5
between 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
betweenspecimens
beyond

>>


Search Words List

<<

bf 1 2 3
bf_wizard2
bi 1 2 3 4
big 1 2 3 4
bigger 1 2 3 4
billerica 1 2
bimetalliccell 1 2
bin 1 2 3 4 5 6 7 8 9 10 11 12 13 14
binary
bit 1 2
bj
black
blade 1 2
blade_damage
blank 1 2 3 4
block 1 2 3 4 5
blue 1 2 3 4 5 6 7
bmenu
bo
body
book
boolean 1 2
border
both 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
bottom 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
boundaries 1 2 3 4 5 6 7 8
boundary 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
boundary_cond_bottom
boundary_cond_top
boundary_type
boundary_value_side2
bounding 1 2 3 4 5 6 7 8 9 10 11
bounding_box 1 2 3
boundingbox 1 2
box 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
br 1 2 3 4
bracelet 1 2 3 4 5 6 7 8
brackets
branch 1 2 3
breakdown 1 2 3 4 5 6 7 8 9
brick 1 2 3 4 5 6 7
brick_flush_mounted 1 2 3 4 5 6
brickanode
brickanode_bottom
brickanode_top
bridge 1 2
brief 1 2 3 4 5
bright
bro
broken 1 2 3 4 5 6 7
bronze 1 2
brought
browse 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
browser 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173

>>


Search Words List

<<

btu
bubble
bug
builder 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
building 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
buildup
builiding
built 1 2 3 4 5
bulk 1 2 3
burden 1 2
buried 1 2 3 4 5 6 7 8 9 10 11
but 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
bution
button 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
button’
bw
by 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115
bytes
bzmsh 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20

c 1 2 3 4 5 6 7 8 9 10 11 12 13
c01
c1
c10
c11
c13
c2
c3
c4
c5
c6
c7
c706
c70600
c71500
c8
c9 1 2
c92200
c95800
ca
ca7150
cabling
cad 1 2 3
caissons_type1 1 2 3
caissons_type2 1 2 3
calcareous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
calcarous
calculate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
calculation 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
calculator 1 2
called 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
calomel
can 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137
canada
cannot 1 2 3 4 5 6 7
canvas 1 2 3 4
capabilities 1 2
capability 1 2 3
capable 1 2
capacity 1 2 3 4 5 6 7 8 9
caplan
capture 1 2 3
card 1 2
carderock 1 2 3
carderockdi
carderockdiv
cardiv
cardivnsw
cardivnswc 1 2 3
care 1 2 3 4
careful 1 2 3
carried 1 2 3
carry 1 2 3 4
cartesian
cartisan
case 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
castin
categories 1 2 3
category
cates
cath
catho
cathod 1 2 3 4 5 6 7
cathodic 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
cathodically 1 2
catio
caus
causes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
cava
cavity 1 2 3

>>


Search Words List

<<

cb
cd
ce
cell 1 2 3 4 5 6
celsius 1 2
cent
center 1 2 3 4 5
centre 1 2 3 4 5 6 7 8 9 10 11 12 13
centrifugal
centroid 1 2
certain 1 2 3 4 5 6 7 8 9
cf
ch
changes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
channel
chapter 1 2
characterised 1 2
characteristic 1 2 3
characters 1 2 3 4 5 6 7 8 9 10
charge
chart 1 2 3 4
checkdat 1 2 3
checks 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
chemical
chen 1 2
chest
chevron 1 2
choice 1 2 3 4 5
choose 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
chosen 1 2 3 4 5 6 7
chrom 1 2 3
ci
circ
circled 1 2 3
circuit 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
circumference 1 2 3 4 5 6
circumferential 1 2
circumferentional
circumscribed 1 2
circumstances
city
civi
cj
ck
ckel
cl
clas
classes
classically
classif
clause
clay
cleaning
clearly 1 2 3 4 5 6 7
clicking 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
client
clipping 1 2 3 4 5 6 7 8 9
closeness 1 2 3
closer 1 2
closest
closing 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
cloud 1 2 3

>>


Search Words List

<<

cm 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
cm2
cmn
co 1 2
coarser 1 2
coating 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
code 1 2 3 4 5
coeff
coefficient 1 2 3 4 5
coincide 1 2
coincident 1 2 3 4 5 6 7
coll
collapsed 1 2 3 4 5 6
collected 1 2
collection 1 2
collinear
colored
coloured 1 2 3 4 5 6 7 8 9 10 11
cols 1 2 3 4 5 6
column 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
com 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
combination 1 2 3 4
combined 1 2
command 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
commas 1 2
commences
comment 1 2 3 4 5 6 7 8 9 10 11
commmts
commonly 1 2 3 4 5 6 7 8 9 10 11 12 13 14
communications
comparative
compared 1 2 3 4 5 6
comparedwith
comparison 1 2 3 4 5
complete 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
completely 1 2 3 4 5 6
completeness 1 2 3 4
completion 1 2 3 4
complex 1 2 3
componenets
component_name
components 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
components_definitions
composed 1 2 3 4
composite
composition 1 2
comprehensive 1 2
comprising 1 2
compromise 1 2
compulsory
computational 1 2 3
computed 1 2 3
computer 1 2 3 4 5
computerized
comput
com
con
concentrate 1 2 3 4
concentration 1 2 3 4
concepts 1 2 3 4 5 6 7 8 9 10
conclusions
concurrent
cond
condenser
conditi
condition 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
conditionsas
conducting 1 2 3
conductivities 1 2 3 4
conductivity 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
conductor 1 2 3
conference 1 2
confidence 1 2
confidently
config 1 2
configuration 1 2 3 4 5 6 7
configured 1 2 3 4 5
confined 1 2 3 4
confirm 1 2 3 4 5 6 7 8
conform 1 2 3 4 5 6
connect 1 2 3 4 5 6 7 8 9 10 11 12 13 14
connectedto
connection 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
connectivity 1 2
consea
consequence 1 2 3 4
consequential
consequently 1 2 3 4 5
conservative 1 2
considerable
considerably 1 2 3
consideration 1 2 3 4 5
considered 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
consistency
consistent 1 2 3 4 5 6 7 8 9 10
consists 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
console 1 2 3
constant 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
constraining
constraints 1 2
constructed 1 2 3 4 5 6 7 8 9 10 11 12 13
consult
consumed 1 2
consumption 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
contact 1 2 3 4 5 6 7 8 9 10 11
contain 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
container
containg
contemplates 1 2 3
contents 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
contextual 1 2 3
contflag
contiguous 1 2 3
continental 1 2
continuation
continue 1 2 3 4 5 6 7 8 9 10 11 12
continuity 1 2 3 4 5 6
continuous 1 2 3
continuously 1 2 3
contour 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
contract
contrary
contributes
contributions 1 2 3
control 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
controllable
convenient 1 2 3 4 5 6 7
convention 1 2 3 4 5 6 7 8 9 10
conver
converge 1 2 3
convergence 1 2 3 4 5 6 7 8 9
converted 1 2 3 4 5 6 7 8 9 10
converterand
coord
coordinate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
coordinates_translations
copies 1 2 3 4 5
copm_1
copper
copy 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
cor
cordinate
corner 1 2
corr
correct 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
correction 1 2
correlates
correlation
correspondence
correspondig
corresponding 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
corro
corroborate 1 2
corroding 1 2
corrosi
corrosio
corrosion 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
corrosionand
corro
corrupted
costly 1 2
couect
could 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
couldn
count 1 2
counter
countour
countour_ranges
countries
coupling 1 2
coupons
course 1 2 3
covering 1 2 3 4 5 6 7

>>


Search Words List

<<

cp 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
cp_anode
cp_anode_decay 1 2
cp_create
cp_createreport 1 2 3 4
cp_createreport_options
cp_modelling
cp_polarisation 1 2
cp_respolcurve
cp_wizard
cp_wizard_data 1 2
cpbuilder 1 2 3 4 5 6 7
cpbuilder_sac_anodes_report 1 2 3 4 5
cpmodel
cpopt
cpreportcurrent 1 2 3 4
cprespolcurve 1 2 3 4 5
cr
crack
create 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109
create_interface_groups
create_internal_point_groups
create_points
creation 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
criteria 1 2 3 4 5 6 7
criterion 1 2
criterion’
critical 1 2 3 4 5 6 7
cross 1 2 3 4 5
crystal
ct
ctrl
cu
cubic
cuboid 1 2 3 4 5 6 7 8
cumulative
cur 1 2
curate
curr 1 2
curren
current 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
current_density
current_name 1 2 3
currentfactor
curvature 1 2 3
curve 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
curvesfrom
custom 1 2 3 4 5 6
customers 1 2
customisable 1 2
customise 1 2 3
customizable 1 2
cutting 1 2 3 4 5 6

>>


Search Words List

<<

cyan 1 2
cyclc
cycles 1 2 3 4
cyclic
cylinder 1 2 3 4 5 6 7
cylindrical 1 2 3 4 5 6 7 8 9 10 11 12 13 14
czyryca

d 1 2 3 4 5 6 7
d01
d1
d2
d3
da
daemon
daf
daily 1 2 3
damage 1 2 3 4 5 6 7
dara
dark
dashed
dat 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
data 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93
data_points 1 2 3 4
database 1 2 3 4 5 6 7 8 9 10 11
databasepolar 1 2
data’ 1 2
datfile 1 2
david 1 2 3
davis
davs
day 1 2 3 4 5 6 7
daysavera
daysaveraged
daysexposure
dayspreexposure
dd 1 2
ddd
dddd
ddmmmyyyy 1 2
ddmmyy
de 1 2
dealing 1 2 3
debug 1 2
debug_cp_mlayer
dec
decay 1 2 3 4 5 6 7 8 9 10
decide 1 2 3 4
decimal 1 2
declaration
declare 1 2 3 4 5 6 7 8 9
decrease 1 2 3 4
dedicated 1 2 3 4 5 6
deduced
deep 1 2
default 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
default_element_order 1 2
defence 1 2
define 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102
definition 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
definition’
deftracx1
deftracx2
deftracx3
degeorgi
degiorgi
degradation 1 2 3 4
degrees 1 2 3 4 5 6 7 8 9 10
delay
deleted 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
deletion
delimiters
delimiting 1 2
delta_history
demand
demonstrated 1 2
dena
denoting 1 2
dens 1 2
densi
densit
densities 1 2 3 4 5 6 7
densitiesused
densitiy
density 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
department
depcon
depe
dependant 1 2 3
dependent 1 2 3
depending 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
deposition
deposits 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
deprive
depth 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
depth1
depth2
der
derivative
derived
derquiescent
describes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
description 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
desig
designdata
designed 1 2 3 4 5 6 7 8 9 10
desirable 1 2 3
desired 1 2 3 4 5 6 7
desktop 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
despite 1 2 3 4
destination 1 2
detailed 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
detected 1 2
determinations
determines 1 2 3 4 5 6 7 8 9 10 11 12 13
developed 1 2 3 4 5 6 7 8 9
development
deviated

>>


Search Words List

<<

dg
di
dia
diagnose
diagnostic 1 2
diagrams 1 2 3 4
dialog 1 2
diameter 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
dianamic
dictions
did 1 2 3 4 5 6
dielectric 1 2
differ 1 2
difference 1 2 3 4 5 6 7 8 9 10 11 12 13 14
different 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82
differentiate 1 2
difficult 1 2 3
digital 1 2
dimension 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
dimensional 1 2 3 4
diminished 1 2
dir
direc
direct_access_solution_file_2
direction 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
directly 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
directorate
directories
directory 1 2 3 4 5 6 7
dirlayer
disabled 1 2
discard 1 2
discharge
disclosure
disconnected 1 2 3 4 5
discontinous
discontinuous 1 2 3 4
discrete
discretisation 1 2
discretised 1 2
discretized
discussing 1 2 3 4
discussion 1 2
disk 1 2 3 4
disp
displacement 1 2
displacment
display 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
displx1
displx2
displx3
disregarded
dissimilar 1 2 3 4
dissolves
distance 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
distance_name 1 2 3
distancetomove
distant 1 2 3
distinctively
distinguish
distorted 1 2 3 4 5 6 7 8
distr
distribution 1 2 3 4 5 6 7
ditional
divided 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
divider 1 2
dividual
division 1 2 3 4 5 6
dixes

>>


Search Words List

<<

dnv 1 2
do 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
do_not_change_history
do_not_use_angle_change_limit
do_not_use_flux_density_limit_for_moves
docs 1 2
documen
document 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156
documentation 1 2 3 4 5 6 7 8 9 10 11 12
does 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
doing 1 2 3 4 5 6 7 8 9 10
domain 1 2 3 4
don 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
dongle
don’t
dot
double 1 2 3 4 5 6 7 8 9 10 11 12
doubt 1 2
down 1 2 3 4 5 6 7 8 9 10 11 12 13 14
download
downstream
dr
drag
drain
drawings 1 2 3
drawn 1 2 3
drift 1 2
drilled
drip
drive 1 2 3
driver
drop 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
drying
dt
dtrc 1 2 3
dual 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
due 1 2 3 4 5 6 7 8 9
dummy
dump
duplicate 1 2 3
duplication
duration
during 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26

>>


Search Words List

<<

- 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173

/ 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64

0000000e 1 2 3
0000e 1 2 3 4 5 6
001_cp 1 2
001j
002_cp
002e 1 2 3
0163e
0198e
0281e
0292e
03ml
03u3
03x72
0500e 1 2
0602e
08s
0902e
0998496e
0r15 1 2
0r19 1 2
0v
0°

1000000e
1000mv 1 2
1088890e
10m 1 2
10r15
10°
1100mv
11c
1240e
1283m
12_anode_monopile
12_anodes 1 2
12a
1300e
1350863e
1391758e
14q
15m 1 2
1634832e
16zinc
1729e
1753407e
1880e
18jun2020 1 2
1919802e
1day
1e25
1esponse
1ff
1hr
1m 1 2
1or
1st
1using

2000000e 1 2
2000e 1 2
200a
200kg
2010e 1 2 3
2018e
2030e
203e
20q
2150e
2158e
2168e
2170e
2180e
230ae
24_anode_monopile
24_anodes
24_anodes_monopile
2505e
2661e
2673e
2712e
2780e
2800e
2961e
2d 1 2 3 4 5 6 7 8
2m 1 2 3
2nd

>>


Search Words List

<<

dx
dy
dynami
dynamic 1 2 3 4 5 6 7 8
dz

e 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
e01
e03
e11
each 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
ead
eader
ear
earch
earlier 1 2 3 4 5
earliest
ease
easier 1 2 3 4
easily 1 2 3 4 5 6 7
easy 1 2 3
eate
eawater
eb 1 2
ec
echn
echnical
echniques
echnology
ectrical
ectrode
ecur
ed
edge 1 2 3 4
edit 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
edition 1 2
editor 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68
ee
eet
effec
effectively 1 2
effectiveness
effecton
effects 1 2 3 4 5 6 7 8 9 10 11 12 13 14
efficiency 1 2
efficiently
efieldx1
efieldx2
efieldx3
eflon
eg 1 2 3 4 5
eic
eight
either 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
el
el_id
elastic
elasticity
electric 1 2 3 4 5
electrically 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
electro
electrochemical 1 2 3 4
electrodeport
electrodeposition
electrodes 1 2 3 4 5 6 7 8 9
electrolyte 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
electrostatic
elem
elem1
elem2
element_1
element_2
element_3
element_zone
elementmodel
elements 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70
elements_in_group
elementstudy
elevations
eleven 1 2
eligible
eliminate 1 2 3 4 5
elmtlist
elnum
elsewhere

>>


Search Words List

<<

email
embedded
eme
ement
emod
emod_i
emory
employed 1 2 3 4 5
empty 1 2 3 4 5 6 7
en
enable_multi_layer
enabling 1 2 3 4 5 6
enclosing 1 2 3 4 5 6 7 8 9 10 11 12
encounters
end 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155
end_polarisation_curve
endpoint 1 2 3 4
end’
energy
enforce 1 2 3 4
engin
engineering 1 2 3
england
ength
enhanced
enlarge 1 2 3
enough 1 2 3 4
ens
ensit
ensure 1 2 3 4 5 6 7 8 9
ent
entered 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
entiost
entire 1 2 3 4 5
entirely 1 2
entities 1 2 3 4 5 6 7 8 9 10 11 12 13 14
entity 1 2 3 4 5 6 7
entries 1 2 3 4
entry 1 2 3 4 5 6 7
enumerates
environment 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
environmental
eopper
eport
epoxy 1 2
epth
eq
equal 1 2 3 4
equations 1 2 3 4 5 6 7
equilibrium 1 2 3 4
equipment
equipped 1 2 3 4 5 6 7 8 9 10 11 12 13 14
equivalent 1 2 3
er
erence
erification
erm
ermpotentiostatic
ern
errors 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35

>>


Search Words List

<<

es
escape 1 2 3 4
esce
escent
ese
esh
especially 1 2
essential 1 2 3 4
establishing 1 2
estimate 1 2 3 4 5 6 7
estimation
ests
et 1 2
eta
etc 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
ethernet
etroleum
evaluate 1 2 3 4 5 6 7
even 1 2 3 4 5 6
event 1 2 3 4
eventually 1 2 3
every 1 2 3 4 5 6 7 8 9 10 11 12 13
everything 1 2 3
everywhere
evolution
ex
exactly 1 2 3 4 5 6
example 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
example_01
example_01_start
example_02
example_02_start
exceeded 1 2 3 4
excel 1 2 3 4 5 6 7 8 9
except 1 2 3 4 5 6 7 8 9 10 11
excess 1 2
exchange 1 2
excluded 1 2 3 4 5
exclusively
exe 1 2 3 4 5 6 7
executable 1 2
executed
execution
exhaustive
existent 1 2
existing 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
exit
exp
expanded 1 2
expansion
expected 1 2 3 4 5 6 7 8 9 10 11 12
experience 1 2 3
experimental 1 2 3 4 5 6
experiments
expired
explains 1 2 3 4
explanatory
explicitly 1 2 3 4 5 6 7 8
exploded
explore
explorer 1 2
exponential 1 2
export_layers_names
exporting 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
expos
exposed 1 2 3 4 5 6 7 8 9
exposu
exposures
exposuretime
expo
expressed 1 2 3 4 5
expression
extends 1 2 3 4 5 6 7
extension 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
extent
exterior 1 2
external 1 2 3 4 5 6 7 8 9 10 11 12 13 14
extra 1 2
extracting 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
extraction
extrapolated 1 2 3
extrapolation 1 2
extreme 1 2 3 4 5 6 7 8 9 10
extremely 1 2
extremities 1 2

>>


Search Words List

<<

ey

f 1 2 3 4 5
f01
f1 1 2
faces 1 2 3 4 5 6 7 8 9
facilitate 1 2 3 4 5 6 7 8
facilities
facility 1 2
fact 1 2 3
factor 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
fahrenheit
fail
false 1 2 3 4
familiar 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
familiarise
family 1 2
far 1 2 3 4
faster 1 2
fastest 1 2
fatal 1 2 3 4 5 6 7
fax 1 2
fe
features 1 2 3 4 5 6 7 8 9 10 11
feb
fed
federal
ferrara
few 1 2 3 4 5
fewer 1 2
ff
ffl
fi
ficat
ficati
field 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
fifteen
figure 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
figure1
fig
file 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125
fileds
filename 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
file’ 1 2
file�?
fill 1 2 3 4 5 6 7 8 9 10 11 12 13 14
film
filter_internal_points 1 2 3 4
filtered 1 2 3 4 5 6 7 8 9 10 11 12
fil
finalising
finally 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
find 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
fine
finishes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
finishon
finite
firewall
first 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
fischer 1 2 3
fit 1 2 3 4 5
five
fixed 1 2 3 4 5 6 7 8 9 10 11 12 13 14

>>


Search Words List

<<

fj
fl
fl2d1
fl2d2
fl3d3
fla
flagged 1 2
flat 1 2 3 4 5 6 7 8
flattened
fle
flex
flexibility
flexible
flexlm
flexnet
flo
float 1 2 3
flow1
flow2
flow3
flow_environment
flowing 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
flowlines 1 2 3 4 5 6 7 8
flowprofile 1 2 3 4 5
flowrate 1 2 3
flowrate_depth_profile 1 2 3
fluctuations
flush 1 2 3 4
flux 1 2 3 4 5 6 7 8
flux_density_limit_for_moves
fluxdensitylimit
fluxlines
fo
focus 1 2 3 4 5 6
folders 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
followin
following 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106
follows… 1 2
fonts
foot
for 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
forbidden
force 1 2 3 4 5 6
forget 1 2
forgotten
form 1 2 3 4 5 6 7 8 9 10 11 12 13
form1 1 2
form2 1 2
form3
form4
format 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
format1
formation 1 2 3 4 5 6 7 8 9 10 11 12
former 1 2
forth
forward 1 2 3 4 5 6 7 8 9 10
forward_datfile
forward_stepping_controller
fos
foster
found 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
four 1 2 3 4 5 6 7 8
fourier
fourth

>>


Search Words List

<<

fpso 1 2 3
fracture
frames
framestructure
free 1 2 3
freedom 1 2 3 4 5 6 7 8
freely
frequencies
frequency
frequently
fric
friction
frictionless
from 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96
front 1 2 3 4
frozen
ft 1 2
ftp
full 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
fully 1 2 3 4 5 6 7 8
fully_bounded
function 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
functionalities 1 2 3
functionality 1 2 3 4 5 6
fundamentals 1 2
funded
fundi
furnished
further 1 2 3 4 5 6 7 8 9 10 11
furthermore
futher
future 1 2 3 4

g 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
g001 1 2
g002 1 2
g01
g5
g_approx
g_exact
ga
gagorik
gal
galvanic 1 2 3 4 5 6 7 8 9 10
galvanicor
gamma
gamma_max
gamma_max_approx
gamma_min
gamma_min_approx
gap1
gapn
gaps 1 2 3 4
gas
gasket
gdf 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
gdf_file
gdffile 1 2 3
gener
general 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
generalised
generality
generate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
generatedcurves
generatedin
generation 1 2 3 4
generic
geographical 1 2 3
geometric 1 2 3 4 5 6 7 8 9 10 11 12 13 14
geometrically 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
geometries 1 2 3 4
geometry 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73
geometry’
geomtry
getting 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

>>


Search Words List

<<

gh
gi
gid 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102
gid14 1 2
gid9
gid_offset_distance 1 2
gidproblemtype 1 2
gigabytes
giovanni
gis
given 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
gives 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
glass 1 2
global 1 2
gmax_auto
gmin_auto
gname
go 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
goes 1 2 3
going 1 2 3 4 5 6 7 8 9 10
good 1 2 3 4 5 6 7 8 9 10 11
google
government
gradients
grading 1 2 3 4 5 6
gradually 1 2 3 4 5
graph 1 2 3 4 5
graphic 1 2 3
graphical 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
gravitation
gravitational
great 1 2 3 4 5 6 7
greater 1 2 3 4 5 6 7 8 9
greatest
green 1 2 3 4 5 6 7
green’s
grey
grid_of_points
grids 1 2 3 4 5 6
grill
grillage 1 2
grinding
grit
ground 1 2 3 4 5
group_name 1 2
groupa
groupid
groupname1
groupname2
groupnamen
groups 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
grow
growth 1 2

>>


Search Words List

<<

gspring1
gspring2
gspring3
gu
guanti 1 2 3
guanti’s
guarantee 1 2
guess
gui 1 2 3
guidance 1 2 3 4
guide 1 2 3 4 5
guidelines 1 2 3 4 5 6 7 8 9
gure
gutters

h 1 2 3 4 5 6 7 8 9 10 11
h001 1 2 3
h002 1 2 3
h01
h02
h1
ha
hac
hack 1 2 3 4
had 1 2 3
half 1 2
hampshire
hand 1 2 3 4 5 6 7 8 9 10 11 12
handled 1 2
handy 1 2
happens 1 2 3 4
happy 1 2
hard 1 2 3
harder
hardware
hardy
harrogate 1 2
hartt 1 2 3
harvey
has 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64
hash 1 2
have 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91
haven 1 2 3 4 5
hays
hbadquatters
he
header 1 2
heat 1 2
hed
height 1 2 3 4
held 1 2
help 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
helpful
hence 1 2 3 4 5 6 7 8
here 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
herein 1 2
hev
hh
hidden 1 2
hide 1 2 3 4 5
hierarchical
higher 1 2 3 4 5 6 7 8 9 10
highest 1 2 3
highlighted 1 2 3 4 5 6 7 8
highly 1 2 3 4 5 6 7 8 9 10
highwa
hin
history 1 2 3 4 5

>>


Search Words List

<<

hmd 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
ho
hodically
holding 1 2
hole 1 2 3
home
homogeneous 1 2 3 4 5 6 7 8
hore
horizontal 1 2 3 4 5 6 7
hostid
hours 1 2 3 4 5
housto
houston
how 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109
however 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
hown
hr 1 2
htm 1 2
html 1 2 3 4 5
hull 1 2 3 4 5 6 7 8 9
hull_01
hull_02
hull_03
hundred
hy
hydrogen
hydrostatic

i 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
i1
i2
i3
i_
ia
ib
ic
icat
iccp 1 2 3 4 5 6 7 8 9 10
icon 1 2 3 4 5 6 7 8 9 10 11 12 13 14
id 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
idea 1 2 3 4
ideally 1 2 3
ideftracx1
ideftracx2
ideftracx3
ideftrcnorm
ideftrctang1
ideftrctang2
identical 1 2
identidfies
identification 1 2
identifies 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
identify 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
identity
ids 1 2 3 4 5 6 7 8 9 10 11 12

>>


Search Words List

<<

ie 1 2 3 4
iebe
ies
if 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101
iflcl
iges 1 2
ignored 1 2 3 4 5 6 7 8 9
ii
iii
iinidisnorm
iinidispx1
iinidispx2
iinidispx3
iinidistang1
iinidistang2
ij
il
illustrating 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
illustrative
im
imag 1 2 3 4 5 6
image001 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
image002 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114
image003 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
image004 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76
image005 1 2 3 4 5 6 7 8
image006 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
image007 1 2 3 4 5 6 7
image008 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
image009 1 2 3 4 5
image010 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
image011 1 2 3 4 5 6
image012 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
image013 1 2 3 4 5
image014 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
image015 1 2 3 4 5
image016 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
image017 1 2 3 4
image018 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
image019 1 2 3 4
image020 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
image021 1 2 3 4
image022 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
image023 1 2
image024 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
image025 1 2 3
image026 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
image027 1 2 3
image028 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
image029 1 2
image030 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
image031 1 2
image032 1 2 3 4 5 6 7 8 9 10 11 12 13 14
image033 1 2
image034 1 2 3 4 5 6 7 8 9 10 11 12 13
image035 1 2
image036 1 2 3 4 5 6 7 8 9 10 11 12 13 14
image037
image038 1 2 3 4 5 6 7 8 9 10 11 12 13
image040 1 2 3 4 5 6 7 8 9 10 11 12 13
image041
image042 1 2 3 4 5 6 7 8 9 10
image043
image044 1 2 3 4 5 6 7 8 9 10
image045 1 2
image046 1 2 3 4 5 6 7
image047
image048 1 2 3 4 5 6 7
image049
image050 1 2 3 4 5 6
image051
image052 1 2 3 4 5 6
image053
image054 1 2 3 4 5
image055
image056 1 2 3 4
image057
image058 1 2 3
image059
image060 1 2 3
image062 1 2 3
image064 1 2 3
image066 1 2 3 4
image067
image068 1 2 3 4
image069
image070 1 2 3 4
image071
image072 1 2 3 4
image073
image074 1 2 3 4
image075
image076 1 2 3
image077
image078 1 2 3
image079
image080
image081 1 2
image082
image084
image086
image087
image088
image089
image090
image092
image093
image094
image095
image097
image098
image099
image100
image101 1 2
image103 1 2
image105
image106
image107
image108
image109
image110
image112
image113
image114
image116
image118
image119
image120
image122
image123
image124
image126
image127
image128
image130
image131
image132
image133
image135
image137
image139
image140
image141
image142
image143
image144
image145
image147
image148
image149
image150
image151
image152
image154
image155
image156
image158
image159
image161
image162
image163
image164
image166
image167
image168
image170
image172
image173
image174
image176
image177
image178
image179
image181
image182
image183
image185
image186
image187
image190
image192
image193
image194
image196
image197
image198
image200
image201
image203
image204
image205
image206
image207
image209
image210
image211
image212
image214
image216
image217
image218
image219
image220
image221
image223
image225
image226
image227
image228
image230
image231
image232
image233
image235
image236
image238
image239
image240
image241
image242
image243
image244
image246
image247
image248
image249
image250
image251
image253
image254
image256
image257
image258
image259
image262
image263
image264
image265
image267
image268
image269
image270
image272
image273
image276
image277
image278
image279
image281
image282
image283
image284
image287
image288
image289
image290
image291
image292
image294
image295
image297
image298
image299
image300
image301
image302
image303
image304
image309
image310
image312
image314
image316
image318
image320
image321
image322
image324
image326
image327
image328
image329
image331
image332
image334
image336
image338
image339
image341
image342
image343
image344
image346
image348
image350
image352
image353
image355
image356
image357
image359
image360
image361
image363
image365
image367
image368
image370
image372
image374
image375
image377
image378
image379
image380
image381
image382
image383
image384
image385
image386
image387
image389
image390
image391
image392
image393
image394
image395
image396
image398
image399
image400
image401
image402
image404
image405
image406
image407
image408
image410
image411
image412
image413
image414
image416
image417
image419
image420
image421
image422
image423
image424
image425
image427
image429
image431
image432
image433
image434
image435
imaginary
immediately 1 2 3
immerse 1 2 3 4 5 6 7 8 9 10
impact 1 2 3 4 5 6
impedance
implemented 1 2 3 4
implications 1 2
implies 1 2 3
importance 1 2 3
important 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
imported 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
imposed 1 2 3 4 5 6
impressed 1 2
improvements
improves 1 2 3 4 5
ims 1 2 3

>>


Search Words List

<<

309c
3230e
3263m
3292e
3308e
350t
36_anodes
36_anodes_monopile
36anodes_tidalwaters_calcdep
377632097864959e
3811123e
390t
3d 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
3m
3rd

400mv
4105e
4139549e
4200e
4300e
4348e
4520e
4530e
4728e
4735e
4804e
4825e
4935e
494e
4to
4’

5263e
5444700e
5594447e
5614681e
570e
5922e
5e0
5m 1 2
5th

6000e
6119699e
6216h
6241e
62761n
6317880e
6319287e
64bit
6534938e
6563545e
6564993e
6600602e
6639e
676mv
6992e
6_andoes
6_anodes_monopile
6anodes_monopile_sac
6e
6h
6ls
6’

7000e
700mv
7068e
7150e
7172e
726mv
738e
7444e
750mv 1 2
7960e
7972088e
7999977e
7aa 1 2
7e11
7q

80a1
8110e
8135e
814e 1 2 3 4
8300e
8958e
8v

9200e
9235e
92r
9332e
9470e
9580e
9774e
9800e
9850e
9919493e
9925e
9nab
9stel
9°c

: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173

>>


Search Words List

<<

in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
inaccuracies 1 2 3 4 5
inaccuracy
inaccurate 1 2 3
inac
inappropriate
inc 1 2
inches
incidences
included 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
incluede
inclusion
inclusive
inconsistencies
inconsistent 1 2
incorporated 1 2
incorrect 1 2 3
increase 1 2 3 4 5 6 7 8 9 10 11 12 13
increment
incremental
indefinitely 1 2 3
independent 1 2 3 4 5 6 7 8 9 10 11 12 13
index 1 2 3 4
indicates 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
indication 1 2
indica
indices
individual 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
induced 1 2
industrial
industry 1 2
inefficient 1 2
inert
inf 1 2 3
infigure
infinite 1 2 3 4 5
infinity 1 2 3 4 5 6 7 8
influence 1 2 3 4 5 6 7 8 9 10 11
info 1 2
inform
information 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
inform•tion
ing
ingle
ington
inherent
inherited 1 2
ini
inidisnorm
inidispx1
inidispx2
inidispx3
inidistang1
inidistang2
initial 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
inlet
input 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
input_files
ins
inscribe
inserted 1 2 3 4 5 6 7 8 9 10 11 12 13 14
insertion 1 2
inside 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
inspect 1 2 3
inspection 1 2
instability
install
installation 1 2 3 4 5 6 7 8 9 10 11 12
installation_path 1 2
installed 1 2 3 4
instances 1 2 3 4 5 6 7 8 9 10
instead 1 2 3
instructions 1 2 3 4 5 6 7 8 9 10 11 12 13 14
instructive
instrumentation
insufficient
insulating 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
insulating_walls
insulation
int 1 2 3
inteface 1 2
integer 1 2 3 4 5 6 7 8 9 10 11
integral
integrate 1 2 3
integration 1 2 3
intend 1 2 3 4 5 6 7 8
intensity
intention
inter 1 2 3 4
interaction 1 2
interconnecting 1 2 3 4 5
interconnection 1 2
interconnection_method 1 2
interconnection_resistance
interconnection_resitance
interest 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
interfaces 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
interference 1 2
interior 1 2 3
intermediate 1 2 3 4 5 6 7 8 9 10 11
internal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
internal_point 1 2 3 4 5
internal_points_in_zone_1 1 2
international
interna
internet 1 2
interpolated 1 2 3 4
interpolation 1 2 3 4 5
interpretation
interprets 1 2 3 4 5 6 7 8
interrupted 1 2
intersecting 1 2 3 4 5
intersections 1 2 3 4 5
interval 1 2
into 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79
intpts
intranet
introduce 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
introduction 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60
introductory
invariably
inverts
investigation
investigators
inves
invoking 1 2 3
involved 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
involvement
inward
in

>>


Search Words List

<<

io
iodyna
ion
ionsand
ior
ios
iostatic
ip 1 2 3 4 5 6 7
ipconfig
ir 1 2 3 4
iradexchfac
iron
irrelevant
is 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157
is_dual
is_pipe
isolated 1 2
isolated2
isotropic 1 2
ispring1
ispring2
ispring3
ispringnorm
ispringtang1
ispringtang2
issuing 1 2
isted
isurfsource
it 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110
item 1 2 3 4
iterates
iterations 1 2 3 4 5 6
iterative 1 2 3 4 5
iteratively 1 2
ither
itioned
its 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
itself 1 2
iu
ivan
ization

j 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
j1
j2
j3
jacket 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
jacket1
jacket1_t
jacket1_t_t
jacket_structures 1 2 3
jackov
jan
janeczko
java

>>


Search Words List

<<

jbox 1 2
je
jefferson
ji
jj
jl
jli
job
john
joinca
joining 1 2
joint 1 2 3 4
judged
judgement
jun 1 2 3
junction 1 2 3 4 5 6 7
just 1 2 3 4 5 6 7 8

k 1 2 3 4 5 6 7 8
kapprox
kaznoft
ke
keep 1 2 3 4 5 6 7 8 9 10
kel
kept 1 2 3 4 5 6
kernel
keys 1 2 3 4 5 6 7 8 9 10 11
keywest
keywords 1 2 3 4 5 6 7 8 9 10 11 12 13 14
kg 1 2 3
kiiiiiic
kingdom
kink
kins
know 1 2 3 4 5 6 7 8 9 10
known 1 2 3 4 5 6 7 8 9 10
kp250
krylov

l 1 2 3 4
l1
l101
l103
l2
l3
label 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
laboratory 1 2
lambda
laplace 1 2
laque
large 1 2 3 4 5 6 7 8 9 10 11 12
larger 1 2 3 4 5 6
larization
larized
larke
last 1 2 3
later 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
lateral 1 2 3
latest 1 2 3
latter
launch 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
launcher 1 2
layered 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
layout
lb
lbf
ldin
le
lead 1 2 3 4 5 6 7 8 9
learn 1 2 3 4 5 6 7 8
least 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
leave 1 2 3 4 5 6 7 8 9 10 11 12
lectrod
led
left 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
legal
legend 1 2 3 4
legs 1 2
length 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
lengthy
less 1 2 3
lets 1 2 3
letter 1 2 3 4 5 6 7
let’s
level 1 2 3 4 5 6 7 8 9 10 11 12

>>


Search Words List

<<

li
lic
licence
license 1 2
licensees
licenseservercomputer
licenseserverhostid
lies 1 2 3 4 5 6 7
life 1 2 3 4 5 6 7 8 9 10 11 12 13
like 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
likely 1 2 3 4 5 6 7 8 9 10
limit 1 2 3 4 5 6 7 8
limitations
linear 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
lines 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76
lines’
ling
link 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
list 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
listbox
listfile
listgroups 1 2 3 4 5
litan
lj
lko
ll
llaro
lljl1
lmgrd
lmtools
lo
lo2 1 2 3 4 5
load_labels_from_datfile
loadcase
loading 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
loadkey
loaoading
local 1 2 3 4 5 6 7 8 9 10
localised 1 2
localization
located 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
location 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
locked
lodge 1 2
log 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
logarithm
logarithmic
logical 1 2
lon
long 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
longer 1 2 3 4 5 6
longest
longeterm
longter
longterm 1 2 3 4 5
longterm_curve 1 2 3
look 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
loop 1 2
lor
loss 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
lossand
losses 1 2 3 4
lost 1 2 3 4 5 6
lot
low 1 2 3 4
lower 1 2 3 4 5 6 7 8

>>


Search Words List

<<

ls
lsid
lsp
luggin
lye 1 2
lying

m 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
m01
m2
ma 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
machine 1 2 3
macros
macroscopic
made 1 2 3 4 5 6 7 8 9 10 11 12 13 14
magenta
magnetic
magnifying
magnitude 1 2 3
magni
main 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
maintains 1 2 3 4 5
maintenance 1 2 3 4
major 1 2 3 4
majority
make 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
makeup
man
manageable
managed 1 2 3 4 5 6 7 8 9 10 11 12 13 14
management 1 2 3 4 5 6 7
manager 1 2 3 4
mance
mandatory
manipulate
manipulation 1 2
manner
manually 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
many 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
map
march 1 2
marine 1 2 3 4
marker
marks 1 2
mass 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
master 1 2 3 4 5 6 7 8 9 10 11 12 13
mat 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
mat_cp 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
mat_cp’
matam
match 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
matcp 1 2 3
matcp2pol 1 2 3
mately
mater 1 2
materia
material 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58
material_affected 1 2 3 4
material_name
materialson
material’
mate
matfile 1 2 3 4 5 6 7 8
mathematical
matnam
matrices 1 2 3 4 5
matricies
matrix 1 2 3 4
matter
matviewer
max
maxflow
maximum 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
may 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36

>>


Search Words List

<<

mbytes
md 1 2
me 1 2
meaningful
means 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
meant 1 2
measurable
measured 1 2 3 4 5 6 7 8 9
measurement 1 2 3 4 5
mechanics 1 2
mechanism 1 2
media
mediterranean
medium 1 2 3 4
meet 1 2 3
megabytes
members 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
members_diam_0
members_diam_1
members_diam_2
members’ 1 2
member’
membrane
memory 1 2
memts
men
ment
mentioned 1 2 3 4 5 6
menu 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
menu’
merged 1 2
mes
mesh 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
mesh1 1 2
mesh_file_format 1 2 3
mesh_filename 1 2 3
mesh_import_parameters 1 2
mesh_name 1 2
mesh_rotate
mesh_translate
mesh_with_layers 1 2 3 4 5 6 7 8
meshpoint 1 2
messages 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
metal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
metal_voltage
metallic 1 2 3 4 5 6 7 8 9 10
meter
method 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
method1 1 2
method2
methodologies
methodology 1 2 3 4 5 6 7
metres
metric
mfttc
mg 1 2
mgp
mgs
mh
mi
mic
micro 1 2 3 4 5 6
microelectrodes
microns
microreference
microsas 1 2
microsoft 1 2 3 4 5
mid 1 2
middle 1 2 3 4 5
might 1 2 3 4 5
mil
mild
mimics 1 2
min
mind 1 2 3 4 5
minimal
minimising 1 2 3 4 5 6 7
minimum 1 2 3 4 5 6 7
minu
minuslo
minutes 1 2
mis 1 2 3 4 5
miscellaneous
misspelling 1 2 3
mistakes
mixed

>>


Search Words List

<<

ml
mlayer_debug_mm_nn
mllna
mm 1 2 3
mmm 1 2
mn
mode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
model0
model_has_been_meshed
model_listgroups
model_new
model_plab
model_rot
modela
modela_0
modela_5
modelfiles 1 2 3 4 5 6
modelfiles_noips
modelin
modellend
modelling 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139
modification 1 2
modified 1 2 3 4 5 6 7 8 9 10
modify 1 2 3 4 5 6 7 8 9 10 11 12 13
modular
modules 1 2
modulus
moment 1 2
mone
monel
monitor 1 2 3 4
mono
monopile 1 2 3 4 5
monopile_01
monopole 1 2 3
month 1 2 3 4 5
moonpool
moores
more 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
morton
most 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
moun
mounted 1 2 3 4 5 6 7 8
mouse 1 2
move 1 2 3 4 5 6
move_internal_points
movie
mp1
mp1mp2
mp2
mp3
mp4
mp5
mp6
mp7
mp8
mp9
mpi
mpids 1 2 3
mps
mr
msh 1 2 3 4 5 6 7 8 9 10 11 12 13
mt
mtype
mu
much 1 2 3 4 5
mud 1 2 3 4 5
multi 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
multilayer 1 2
multiple 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
multiplied 1 2
multiplier 1 2
must 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34

>>


Search Words List

<<

mv 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
mvresults 1 2 3
my
my_backup
my_labels
mycomputer
myexample_01
myexample_02
myfile 1 2 3
myhostid
mymatfile 1 2
mymodel 1 2 3 4
myolddat
myreport 1 2
myresults
mysummary
myzone

n 1 2 3 4 5 6 7 8 9
n01
n04400
n06625
n_exp
n_exp_approx
n_sample_points
na
na00
na03
nace
naceintemational
naceintern
name 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
name1 1 2 3 4
name2 1 2 3
namely
nasa
nated
national
natural
nature 1 2
nava
naval 1 2 3 4 5 6
navigate 1 2 3
navy
nb
nc 1 2
ncell43
nconel
nd 1 2
ndrvefldx1
ndrvefldx2
ndrvefldx3
ndrvnorme
ndrvtange1
ndrvtange2
near 1 2 3 4 5 6 7
nearby 1 2
nearest 1 2 3 4
necessarily
necessary 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
need 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95
negative 1 2 3 4 5 6 7 8 9 10 11 12 13
negligible 1 2 3 4 5 6 7 8 9 10 11 12 13
neither 1 2 3 4 5
network 1 2 3 4
neutrality
never 1 2 3 4 5
nevertheless 1 2 3
new 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
newmodel
next 1 2 3 4 5 6 7 8 9 10 11 12 13

>>


Search Words List

<<

ng
nganese
ngs
nh
nhdtsd
ni 1 2
nickel 1 2
nine
niter
nium50
nn
nnedy
nnt
no 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
no_bc 1 2 3 4
no_sac 1 2 3 4
nobc
noble
nodal
node 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
node1
node2
nodelockedcomputer
nodelockedhostid
nodnum
nominal
non 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
non_overlapping_data_block
non_overlapping_groups
non_overlapping_groups_data 1 2 3 4 5
nor 1 2
norm
normal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
normal_current
normal_current_density 1 2
normalacc
normaldisp
normalflux 1 2 3
normalising
normalizing
normalspring
normaltrac
normalvelo
normdeftrac
normefldn
normpresfit
north 1 2 3
northern 1 2
norwegian 1 2 3
notation
notepad 1 2 3 4 5
notes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101
notice 1 2 3
notifies
november 1 2 3
now 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
np
npoints
nr
ns
nsi
nsit
nsity
nsn
nstep
nswc
nt 1 2
ntemara
ntiodyn
ntiostatic
ntriglio
ntroduction
nu 1 2
null
number 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
number_of_layers
number_of_multilayer_materials
numberofmoves
numeration
numeric 1 2 3 4 5 6 7 8 9 10 11 12
numerical 1 2 3 4 5 6 7 8 9
numericallyintegrated
numerous
numver 1 2 3
nurbs

>>


Search Words List

<<

nz

o 1 2 3 4
oarhering
oas
obey
objectives 1 2 3 4 5 6 7
objects 1 2 3 4 5 6 7 8
oblique
observation 1 2 3 4 5 6
observed 1 2 3 4
obtain 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
obvious
obviously 1 2
oc
occupies 1 2 3 4 5
occupy
occur 1 2 3 4 5 6 7
occurrence
ochre
od
ode
odically
ody
odyna
odynamic
of 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172
off 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
offered 1 2 3 4 5 6
office
offpotentials 1 2
offset 1 2 3 4 5 6 7 8 9 10
offset_0
offshore 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
offshore_trans
offshorejacket_gidplugin
off
often 1 2
og
ohms 1 2
oio
ok 1 2 3 4 5
ol
ola
olarization
olarized
old 1 2 3 4 5 6 7
older 1 2
oldmodel
oldmodel_listgroups
oldmodel_listgroups_corrected
oll5
omb
omitted 1 2
ompulsory

>>


Search Words List

<<

; 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

<

= 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146

> 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59

? 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25

@ 1 2

[ 1 2 3 4 5 6 7 8

] 1 2 3 4 5 6 7 8 9

^

_
_cpbuilder
_id
_intpoints
_j
_off_potential 1 2
_points 1 2
_report
_report_custom
_report_intpoints
_t
_trans
_type
_x
_year
_zero

>>


Search Words List

<<

on 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115
once 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
one 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
only 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
onr
onr332
onshore 1 2
onto 1 2 3
oo
oop
open 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
opengl
opent
operating
operational
operations 1 2 3 4 5 6 7 8 9 10 11 12 13
opp
opper
opposite 1 2 3 4 5 6 7
optimal 1 2
optimisation
optimised 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
option 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
optional 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19

>>


Search Words List

<<

or 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102
orafice
order 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
ordinates
orga
organi
organisation
organised 1 2 3 4 5 6 7 8 9 10 11
orientated 1 2 3 4 5 6
orientation 1 2 3 4 5 6 7 8 9 10 11 12 13 14
oriented 1 2 3 4 5 6 7 8 9
origin 1 2 3 4 5 6 7
original 1 2 3 4 5 6 7 8 9 10 11 12 13 14
ork
orphan
orrosion
ors
orthogonal
os
oscillating
osen
osion
ostatic
oste
osu
osure
ot
ote
oten
otent1odynamic
otent1ostat1c
otentlo
other 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
otherwise 1 2 3 4 5 6 7
ould
our 1 2 3 4 5 6 7 8 9 10
out 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
outcome 1 2
outer 1 2
outfile
outline 1 2
outputs 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
outside 1 2 3 4
outwards 1 2 3 4 5 6 7 8 9
oved
over 1 2 3 4 5 6 7 8 9 10 11 12 13
overall 1 2
overcome 1 2 3
overflow
overlapping 1 2 3 4 5 6 7 8 9 10 11
overlay
overridden
overrides 1 2 3
overview 1 2 3 4 5 6 7 8 9
overwritten

>>


Search Words List

<<

ow
owingcell
own 1 2 3
ows
oxidation
oxyge
oxygen
oy
oys

p 1 2 3 4 5 6 7 8
p1
p2
p3
pa
pacific
packaged
page 1 2 3 4 5
paint 1 2
pairid
pairs 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
pale
panel 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
paper 1 2 3 4
paperworlr
parallel 1 2 3 4 5 6 7 8 9
parallelto
parameterised
parameters 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
parametrically
parametrised
paramount 1 2 3
parent
parentheses
parentid
park
part 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
partially 1 2 3 4 5 6 7
particular 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
particularities
partitions 1 2
party 1 2
passed 1 2 3
passes 1 2 3
past 1 2 3 4 5 6
patch
path 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
patibility
patran
pattern 1 2 3
pb
pc
pcsmooth
pdb
pdb’
peak 1 2
pecimens
per 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
percent 1 2 3 4
percentage 1 2 3
perfectly 1 2
perform 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
performance 1 2 3 4 5 6 7 8 9 10 11 12
perfor
periments
period 1 2 3 4
periodically 1 2
permeability
permeabilty
permissible
permission
permitted 1 2
perpendicular 1 2
pertinent 1 2 3 4
per
peterson
pf 1 2
philadelphia
physcont1
physcont2
physcont3
physically 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17

>>


Search Words List

<<

pic1
picked 1 2 3 4
picture 1 2
picture_b
pid1
pid2
piece 1 2 3
piecewise 1 2 3
piecewise_bconds_function
pile 1 2 3 4
pink
pipe 1 2 3 4 5 6 7 8 9 10 11 12
pipeline1
pipeline2
pipeline__report_intpoints
pipeline_off_potential
pipeline_off_potential_report_intpoints
pipelines 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
pipingsystem
pipleline
pla
plab
placed 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
placement
plain 1 2 3 4 5 6 7 8
plane 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
planes123
plates 1 2 3 4 5 6 7 8 9 10 11 12
platforms 1 2 3
platinum
please 1 2 3 4
ples
plot 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
plotswere
plug 1 2 3 4
plugin 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
plus 1 2 3 4 5 6
pms
pnts 1 2 3
po
poimt
point_near_tube
point_on_surface
pointer
pointids
points 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67
points’
point’
poissons
pol 1 2 3 4 5
pol2mat
pol2matcp 1 2 3 4 5 6
polar
polarasing
polari
polarisation 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60
polarisation_curves_con2
polarising 1 2 3 4 5 6 7 8 9 10 11 12 13 14
polarization
polarized
polcurve_comment
polcurve_depths
polcurve_formations
polcurve_name
polcurve_ref_electrode
polcurve_units
polcurvex
polyurethane
ponsored
poor 1 2
pops 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
populated 1 2 3 4 5 6
portions
ports
pos
position 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
positive 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
possibility 1 2
possible 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
post 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
post_processing_group_sets
post_processing_groups_sets
postlayer1
postlayer3
postprocessing 1 2 3 4 5 6
postprocessoptions
postprocessor 1 2
posur
pot_zero
pote 1 2 3 4 5 6
poten
potent
potent1ostat1c
potenti
potentia
potential 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
potential_name 1 2 3
potentialafter
potentio 1 2 3 4 5 6
potentiodyna
potentiodynam
potentiodynam1c
potentiodynamic 1 2 3
potentiodynamically
potentiodynarnically
potentiost
potentiosta
potentiostat
potentiostatic
potentiostatically
potentjump
poten
power 1 2 3 4 5 6 7
powerful 1 2
po

>>


Search Words List

<<

pp 1 2
pr
practical 1 2 3 4
practice 1 2 3 4
practise
pre 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
preceded
precise
precision
predefined 1 2
predict 1 2 3 4 5 6 7
prediction 1 2 3 4 5 6
preex
preexp
preexpos
preexposu
preexposure
preferences 1 2 3 4 5 6
preferred 1 2 3 4 5
preheated
preparation 1 2 3 4
prepared 1 2 3 4 5 6 7 8 9 10 11 12 13
preparin
prescribed 1 2 3 4 5
preselected 1 2 3 4
presence
present 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
presentsall
preserve 1 2 3 4 5 6
presfitx1
presfitx2
presfitx3
pressing 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
pressure 1 2
presumably 1 2
prevent 1 2 3
prevention 1 2
previous 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
previously 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
previouslypublished
pri 1 2
price
priglian
primarily 1 2 3
primary 1 2
princeton
principal
principle 1 2
printed 1 2 3 4 5 6 7 8 9
printer
printout
prior 1 2
priority
private 1 2 3 4 5 6
privileges
probe
problems 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80
problemtypes
procced
procedure 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
proceed 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
proceeding 1 2 3 4 5 6
processes 1 2 3
processing 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
processors
produces 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
product 1 2 3 4 5 6 7
production
profile 1 2 3 4 5 6 7 8 9 10 11
program 1 2 3 4 5 6 7 8 9
programdata
programmer
progress 1 2 3 4 5 6
progressive
progressively 1 2 3 4
project 1 2 3 4 5 6 7
projectwas
prompted 1 2 3 4 5
propagation
propel
propellers 1 2 3 4 5
proper
properties 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
property 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
property_name
prophub
proportional 1 2 3 4
proposed 1 2 3
propulsion
protect 1 2 3 4
protection 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
protectionof
protective
provided 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
proximity 1 2 3
pro

>>


Search Words List

<<

psid
pts
pub
publi
public
published 1 2
pumped
purchase
pure
purposes 1 2 3 4 5 6 7 8 9 10
put 1 2 3 4 5 6 7 8 9 10 11 12 13
puter

q 1 2 3 4 5
q1 1 2
q2 1 2
q3
q38 1 2 3
q3_8
qi
qu
quad9
quadrangular
quadratic 1 2 3 4 5 6 7 8
quadratic9 1 2
quadratically
quadrilateral 1 2 3 4 5 6 7 8 9 10
quads
qualitative
quality
quantification
quantitative
quantities 1 2
quantity 1 2 3
quare
quatric
question 1 2
quick 1 2 3 4 5 6 7 8 9 10
quie
quiesce
quiescent 1 2
quincy
quisition
quote

r 1 2 3 4 5 6 7 8
r15 1 2
r15_beasygid
r15_cpwizard
r15_solve
r19 1 2 3
r19_build
r19_cpbuilder
r19_listgroups
r19_solve
r19listgroups
r50400
ra
radambpoten
radexchfac
radial 1 2
radians
radiative
radio 1 2 3 4 5 6 7 8
radius 1 2 3 4
raduction
railways
range 1 2 3 4 5 6 7 8 9
rangement
rangesfor
rapidly 1 2 3 4 5
rates 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
rather 1 2 3 4
ratios 1 2 3 4 5 6 7
ra
rd
re 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
reached 1 2 3 4 5 6 7 8
react
reactions
read_initial_history_from_file
reading 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
ready 1 2 3 4 5 6 7 8 9 10 11
real 1 2 3 4 5 6 7 8 9 10 11 12 13 14
rearranged
reason 1 2 3
reasonable 1 2 3
recede
receive
recent
recirculation
recognised 1 2
recommended 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
reconnected 1 2
records 1 2 3 4 5 6 7 8 9 10 11 12
recover
recreated
rectangular 1 2
rectifier 1 2 3 4 5 6 7
rectorate
red 1 2 3 4 5 6 7 8 9 10 11 12 13 14
redefine
redirect 1 2 3 4
redraw
reduces 1 2 3 4 5 6 7 8 9 10
reduction 1 2 3 4 5 6
reexposure
ref 1 2
refer 1 2 3 4 5 6 7 8 9 10 11 12 13
reference 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
refined 1 2 3
refinement 1 2 3
reflect 1 2 3 4 5 6 7 8
reflection
reflective
refresh 1 2
refreshment
refuse
ref
rega
regained
regarded 1 2 3 4 5 6 7 8 9 10
regardless
regenerate 1 2 3
regions 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
register 1 2
relating 1 2 3 4 5 6 7 8 9 10
relation
relationship 1 2 3 4 5 6
relative 1 2
rela
release 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
relevant 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
reliance
relieves
remainder 1 2 3 4
remainin
remains 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
remarks
remember 1 2 3
reminder
removal
removes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
ren
renamed 1 2
render 1 2 3
rent
renumbering
reoprt
repair
repeated 1 2 3 4 5
repelled 1 2
replaced 1 2 3 4 5 6
replicate 1 2 3
replotted
repolarise 1 2
report 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
report_internal_points 1 2 3 4
report_of_overlapping_between_groups 1 2 3
report_on_unused_groups 1 2 3
repot
represent 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
representation 1 2 3 4 5 6 7 8
representative 1 2 3 4 5
reproduce 1 2
request
required 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
requirement 1 2 3 4
reread
res 1 2 3 4 5 6 7 8 9 10 11 12 13 14
researc
research 1 2 3 4 5
researchestablishment
resels 1 2 3
resemble
resend_surfaces
reserves
reset
resistance_length
resistance_value
resistances 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
resistant
resistivity 1 2 3 4 5 6 7 8 9 10 11 12 13
resistors 1 2
resolution
resolving 1 2
resources
respect
respectively 1 2 3 4 5 6 7
responsible
rest 1 2 3 4
restart 1 2
restraint
restrict 1 2 3 4
restrictions 1 2 3 4
result_elements_report_intpoints
result_surface
resultelements 1 2
resultelements_report_custom
resultelemnts
results 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
results_at_internal_point_in_zone
resultsof
retains 1 2 3
retrieval
retrieve 1 2
retrofit 1 2
return 1 2 3 4 5 6 7 8 9 10 11 12
reuse 1 2 3
reversed 1 2
reversible
revert
review 1 2 3 4 5
reviflwing
revise 1 2 3 4 5
reynolds

>>


Search Words List

<<

rf1po
rface
rflporting
rg
ri
rials
rice
rides
right 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
rigid
rigorous
ring
ring_002
ring_003
ring_004
ring_of_6_anodes
riser036_type1 1 2 3
riser_1 1 2 3
riser_2 1 2 3
riser_3 1 2 3
riser_4 1 2 3
rj
rm
rms
rn
rnu
rnu_i
ro
robert
robust
rod 1 2 3
roe 1 2
roestrommen_1985 1 2
role 1 2 3 4 5
room
root 1 2 3 4 5 6 7 8 9 10
rootame
rootname 1 2 3 4 5 6 7 8 9
rootname_cpbuilder
rootname_inihis
rootname_inihisfixed
rootname_report
rosion
rotate 1 2 3 4
rotation 1 2 3 4
rotational
rough
rows 1 2 3 4 5 6 7 8 9
rpoi
rr
rrara
rre
rren
rrent
rrodin
rs
rtttttt
rule 1 2 3 4 5 6 7 8 9
run 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
run_metal_voltage
run_timestep
run_timestep_batch
runlistgroups
runlog 1 2
runlog1
runtime 1 2 3 4 5 6 7
rve
rwduc
rx1
rx2
rx3
ry

s 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
s1
s2
s9
sa
sac 1 2 3 4 5 6 7 8 9 10 11 12 13
sacrificial 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
sacrificial_anode_data
sacrificial_anode_geometry
sacrificial_anodes_data
sacrifiicial
sae
safe
said 1 2 3
same 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
same_as_side1 1 2
sample 1 2 3 4 5 6
sam
sanity 1 2 3 4
sas 1 2 3 4 5
sat
satisfactory 1 2 3 4 5
satisfied
satisfy 1 2
saturated
saturation
save 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
say 1 2 3 4

>>


Search Words List

<<

sbe
sc
scalar 1 2 3
scale 1 2 3 4 5 6 7 8 9 10 11
scan
scatter 1 2 3
scenarios 1 2 3 4 5
scent
schematic 1 2 3 4
schematically
scheme 1 2 3 4
scratch 1 2
screen 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
screwed
script
scroll 1 2 3 4 5 6 7
scrolling 1 2 3 4
scull
scully
se
sea 1 2 3 4 5 6 7 8 9 10 11 12 13
sea03m
seabed 1 2 3 4 5 6 7 8 9 10
search 1 2 3 4 5 6 7 8 9 10 11 12
season 1 2 3
seasonal
seaw
seawater 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
sec 1 2
second 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
secondary
section 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
sectional 1 2
secur
sedriks
see 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
seems 1 2 3
seen 1 2 3 4 5
segments
select 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79
selection 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
self 1 2
semc
semi
send 1 2 3 4 5 6
sense 1 2 3 4
sensitive 1 2
sent 1 2 3 4
separate_mesh_each_track
separated 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
separately 1 2 3
separation 1 2
separator
sequence 1 2 3
sequential 1 2 3
sequential_access_solution_file_2
ser
series 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
server
service 1 2 3
session 1 2 3 4
set 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
setid
setup 1 2 3 4 5 6
setup64
seven
seventeen
several 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
severely

>>


Search Words List

<<

sf1 1 2 3
sf2 1 2 3 4 5
sf3
sf61541
sh
shaft 1 2
shaftrod
shall
shape 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
shapeless 1 2 3
sharing 1 2 3 4 5 6 7
sharp 1 2
shbs
shee
sheet 1 2 3 4
shelf 1 2
shell 1 2 3
shields 1 2
ship 1 2 3 4 5 6 7 8 9 10 11
ship_001
shipboard
shiphull 1 2 3 4
shiphull_01
shiphull_02_report_custom
shiphull_02_report_intpoints
short_members
shortly 1 2 3 4
should 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
show 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88
shown 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80
shrinks
si
si00
si05
si10
si15
si20
si25
side2
sides 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
sigm
sigmoidal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
sign 1 2 3 4
signal
significance
significant 1 2 3 4 5 6 7 8 9 10 11 12 13 14
silently
similar 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
simlab
simple 1 2 3 4 5 6 7 8 9 10 11
simpler 1 2
simplicity
simplified 1 2 3 4
simplify 1 2 3 4 5 6
simply 1 2 3 4 5 6 7
simulate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
simulation 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
simultaneous 1 2
simultaneously 1 2 3
since 1 2 3 4 5 6 7 8 9 10 11 12 13
single 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
singlenode
singlesource
singular
sink
sion
situ 1 2
situated 1 2
situations 1 2 3 4 5 6 7
sity
six 1 2
sixty
size 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

>>


Search Words List

<<

sketch_multi_layer 1 2 3 4
sl2d1
sl2d2
sl3d3
slack 1 2 3
slash
slave 1 2 3 4 5 6 7 8 9 10 11 12
slave_zone
slide1
slide2
slide3
slider
sliding
slightly
slip
slippage
slope 1 2
slot
sloter
slow 1 2 3
slowest 1 2
small 1 2 3 4 5 6 7 8 9 10 11 12
smaller 1 2 3 4 5 6 7
sme 1 2 3
smoothly 1 2 3 4 5 6
sn
snap
so 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
so40 1 2
society
soft
software 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
soil 1 2 3
solid 1 2 3 4 5 6 7 8 9
solidmembers
solidworks 1 2
solution 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
solution_control_settings 1 2 3
solutionfiles_ips
solutiontime 1 2
solve 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
solve_1_withlabel_zinc_noips
solve_1_withpotential_400_noips
solve_2_withlabel_stel_noips
solve_2_withpotential_500_noips
solve_3_withlabel_stel_andanipadded
solve_3_withpotential_500_andipadded
solver 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
some 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
something
sometimes 1 2 3 4
song
sons
soo
soon
sorted 1 2 3 4
sound
source 1 2 3 4 5 6 7 8 9
southampton 1 2

>>


Search Words List

<<

a 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159
a01
a4
a8
a80
a9
ab
abank
abbreviations
ability
able 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
about 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
above 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
abruptly 1 2 3 4 5
absolutely
absorbing
abstrac
abstract
acceleration
accept 1 2 3 4 5 6 7 8 9 10 11 12 13 14
acceptable 1 2 3
acceptance
accesible
access 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
accessible 1 2 3 4 5 6
accordingly 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
account 1 2 3 4 5 6 7 8 9 10 11 12 13
accumulation 1 2 3 4 5
accuracy 1 2 3 4 5 6
accurate 1 2 3 4 5 6 7 8 9
accurately
achieve 1 2 3 4 5 6 7 8 9 10 11
acknowledge
acknowledgments
acouadmit
acouambprs
acouimpdnc
acouspress
acoustic
acoustrvlo
acronym 1 2
across 1 2 3 4 5
acting 1 2 3 4 5 6
actions 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
activate 1 2 3 4 5 6 7
active 1 2 3 4 5 6
actual 1 2 3
ac

>>


Search Words List

<<

sp
space 1 2 3 4 5 6 7 8 9 10 11 12 13
spec
speci
special 1 2 3 4 5 6 7 8 9 10 11 12 13
specialises 1 2
specific 1 2 3 4 5 6 7
specifically
specifications
specified 1 2 3 4 5 6 7 8 9 10 11 12 13
specify 1 2 3 4 5 6
specime
specimen
specimenmount
speci
speckled
spectrum
speed 1 2 3
speeds
sphere
spherical
spid
spid1
spid2
spid3
spin 1 2 3 4
split 1 2 3 4
sponsori
sponsoring
spread 1 2 3
spreadsheet 1 2 3 4 5 6
spring 1 2 3
sq
square 1 2
ss
ssi
ssnd
st
st00 1 2 3 4 5 6
st03
st05 1 2
st10 1 2
st15 1 2
st20 1 2
st25 1 2
sta 1 2
staff
stage 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
stand 1 2 3 4 5
stand_off 1 2 3 4 5 6 7 8 9
standard 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
standardised
started 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61
startfilestimestepping
state 1 2 3 4 5 6 7 8 9
statement 1 2
static 1 2 3
station
status 1 2 3 4 5 6 7 8
stay
stba
std 1 2 3 4 5 6 7 8
stead 1 2
steel 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
steep
stel 1 2 3 4 5 6 7 8
step2
steps 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
ster
stess
stick
stiffness
still 1 2 3
stm
stmn 1 2 3
stops 1 2 3 4 5 6 7 8 9 10 11 12
storage
stored 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
storm 1 2
str 1 2 3 4 5 6 7 8 9
str1
str2
str3
straight 1 2 3 4 5
strain
strategies
strategy 1 2 3
stratified 1 2 3 4
stratpolcurve
stray 1 2 3 4
street 1 2
strength 1 2
stress 1 2 3 4
stri
stringent
strip
strommen 1 2 3
strongly 1 2 3 4
structural 1 2 3 4 5 6 7 8 9 10 11 12
structures 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
sts
studied
study 1 2 3
studyfor
styles 1 2

>>


Search Words List

<<

su
sub 1 2 3 4 5 6 7 8 9 10 11 12
subdivided
subfolder
subject 1 2 3 4
submenus
submerged 1 2 3 4
submitted 1 2
subsection
subsequent 1 2 3 4
subset
substantially 1 2 3
successfully 1 2 3 4 5 6 7 8 9 10
successive
such 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
suction
sudden
suffer
sufficient 1 2
suggested 1 2 3 4 5 6 7 8 9
suit
suitable 1 2 3 4 5 6 7 8 9 10 11 12 13 14
sum 1 2
summarise 1 2 3
summary 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
summation 1 2 3 4 5
summer
sup
superimposed
supplementary
supplied 1 2 3 4 5 6 7 8
supply 1 2 3 4 5
supplying
support 1 2 3 4 5 6 7 8 9 10 11 12 13 14
suppress
sure 1 2 3 4 5 6 7 8 9 10 11
surf
surface_type
surfacearea
surfaces 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
surfsource
surrounding 1 2 3 4 5 6
survey 1 2 3 4 5 6 7 8 9
survey_points
survivability
suspended
suwestions
sw
swap 1 2 3 4 5
swc
switcher
switches 1 2 3 4 5 6 7 8 9 10
sydberger 1 2
symbol
symmetric 1 2
symmetry 1 2 3 4 5 6 7 8 9 10
sys 1 2 3
system 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
systematic 1 2 3 4 5 6
systemscommand
systemson

t 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26

>>


Search Words List

<<

t1 1 2
t2 1 2
t3
t88
tab 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
tabel
table 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
tabulated 1 2 3 4 5 6
tafel
tag
taken 1 2 3 4 5 6 7
takes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
tanaa
tang
tangdeftrac1
tangdeftrac2
tangdisp1
tangdisp2
tangefldn1
tangefldn2
tangential 1 2
tangpresfit1
tangpresfit2
tangspring1
tangspring2
tangtrac1
tangtrac2
tanium
tank 1 2 3 4 5 6 7
tansformation
tapped
target 1 2 3 4 5
task 1 2 3 4 5 6
tatic
taylor 1 2 3
te 1 2
teaching
technical 1 2
technique 1 2 3 4 5 6 7 8 9
tected
ted
teel
tel 1 2
tells
temp 1 2 3
temperature 1 2 3
template 1 2 3 4 5 6 7 8 9 10 11 12
temporary
ten
tendency
tenth 1 2
tentiosta
tentiostatic
teps
ter
terminals 1 2
terminated 1 2
termpotentiostatic
terms 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
ternational
tests 1 2 3 4 5 6 7 8
text 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
tf
th 1 2 3 4 5
than 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
that 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115
the 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
their 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
them 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
themselves
then 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
theoretical 1 2 3
there 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
thereafter
therefore 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
thermal 1 2
thermocouple
thermodynamically
these 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
theta_i
they 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
thi5
thick
thickest
thickness 1 2 3 4 5 6 7 8 9 10 11 12
thin 1 2 3 4 5 6 7 8 9 10 11 12
think
third 1 2 3 4 5 6 7
this 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128
thisburden
thisstudy
thod
thoma
those 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
though 1 2 3
threads 1 2
three 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
threezones_001
threezones_with_internalpoints 1 2
threezones_with_internalpoints_zone1
threshold
throu
through 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
throughout 1 2 3 4 5 6 7 8
thru
thus 1 2 3 4 5 6

>>


Search Words List

<<

ti
tial
tic
tick 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
tidal 1 2 3 4 5
tidal_waters_files
tidy 1 2
tigation
till
time 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
time_name 1 2 3
timedia
timestepping
timestepping_startingfiles
ting
tio
tiodynam1c
tiodynamic
tion
tional
tiostatic
tip 1 2 3 4 5 6
tipton
tit
titanium
titanium50
title 1 2 3 4 5 6 7 8 9 10
tively
ti
tj
tle
tm
tn
to 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168
to30
to_fwd_time
together 1 2 3 4 5 6 7 8 9 10 11 12
toggles 1 2
tolerance 1 2 3 4 5 6 7 8
tolerance1
tolerance2
tolerance_for_j 1 2 3
ton
too 1 2 3 4 5 6 7 8 9 10 11
tool 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85
toolbar 1 2 3 4 5 6
toolbox 1 2
toolsets
top 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
top_layer_location
topics 1 2 3
torage
torsion
totally 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
towards 1 2 3 4 5 6

>>


Search Words List

<<

tp 1 2 3
tp00 1 2
tp05
tp10
tp15
tp20
tr 1 2 3
trac
track 1 2
track_nodal_results
traction
tractx1
tractx2
tractx3
traditional 1 2
transcoeff
transfer 1 2 3 4 5 6
transformations 1 2 3 4 5 6 7 8 9 10
transformation’
transformed 1 2 3
transformer 1 2 3 4
transition 1 2 3 4 5 6 7
translated 1 2 3 4 5 6 7 8 9 10 11 12
translation 1 2 3 4 5 6 7
translator
transmission
transparent
transported
trapolated
treated 1 2 3
tree 1 2
treseder
trhough
tria3
triangular 1 2 3 4 5 6
trigger
trim_report
trimmed 1 2 3 4 5 6 7 8 9 10
trimmed’
trimming’
trimtab
tripod
trivial
trod
troubleshooting
tru 1 2 3 4 5 6 7 8 9 10 11 12 13
trvct
try 1 2 3 4
ts
ttt
tube 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
tubecontaining
tubeelements_638b
tubular 1 2 3 4 5 6
tude
tuning
turbulent
ture
turns 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
turret
tutorials 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
tv
twenty
twice
two 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
tx
txt 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
txt’ 1 2
txt�?
ty
type 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
type1 1 2
type2 1 2
typem
typical 1 2 3 4 5 6
typographical

>>


Search Words List

<<

u 1 2 3 4 5
u1 1 2
u2
u3
ubje
udget
uf
ui
uimette
uj
uk 1 2 3
ultimately
um
umin
un 1 2 3 4 5 6 7 8 9
unable
unalloyed
uncheck
unclassified
uncollapse 1 2 3
uncommented 1 2 3
undefined 1 2
under 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
underpinning
understanding 1 2 3
undesired 1 2
undisplaced
unformatted
unfortunatel
uni
uniform 1 2 3
uninstall
unique
unit 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
unitary
unknown 1 2 3 4 5 6
unless 1 2
unlikely 1 2 3 4
unlimited 1 2
unloaded 1 2 3 4 5 6 7
unnecessary 1 2 3
unreal 1 2
unrealistic
uns
unstructured 1 2 3
unsure
untick 1 2
until 1 2 3 4
untrimmed
unwanted 1 2 3
un
up 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
update 1 2 3 4 5 6 7
upon 1 2 3
upper 1 2 3
upplied
upstream
ur
ural
urc
ure
urr
urray
urren
usa 1 2 3
usb
use 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112
use_all_groups_in_gdf_file
use_server
used 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127
useful 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
user 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
user_connections
user_options
username
userprofile
usually 1 2 3 4 5 6 7 8 9 10 11 12 13 14

>>


Search Words List

<<

util
utilisation 1 2 3 4 5 6 7 8 9 10 11 12 13
utilised
utilities 1 2 3 4 5 6 7 8
utility 1 2 3

v 1 2 3 4 5 6 7 8 9 10 11 12
va
valid 1 2 3
value 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
value1
valuei
valve
valx
valx1
valx2
valx3
valy
valy1
valy2
valy3
valz
valz1
valz2
valz3
variability
variables 1 2 3 4 5 6 7 8 9 10 11 12 13
variations 1 2 3 4 5 6 7 8 9 10 11 12 13
varies 1 2 3 4 5 6
variety
various 1 2 3 4 5 6
vary 1 2 3 4 5 6 7 8
vast
vd
ve 1 2
vectors 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
velocity 1 2
velopoten
vendor
verified
verify 1 2 3 4 5
versa
version 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
versus 1 2 3 4 5
vertical 1 2 3 4 5 6 7 8 9 10
very 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
vessels 1 2
vesselswere
vgp
vgs
vi
via 1 2 3
vice
view 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
viewer 1 2 3 4 5
viny
violet
virtual
visi
visibility
visible 1 2 3 4 5 6 7 8 9 10 11 12
visit 1 2 3 4 5
visual 1 2
visualisation 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
visualise 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37

>>


Search Words List

<<

vj
vm 1 2
vnsw
vnswc
voids
vol
voltage 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
volume 1 2 3 4 5 6 7 8 9 10
volumetric
vs
vx
vy 1 2
vz

w 1 2 3 4
wa
wacke
waiting
wall 1 2
want 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
warf
warfare 1 2 3
warfarece
warm 1 2
warmer 1 2 3
warning 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
was 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
wash
washington
washklgton
watch
water 1 2 3 4 5 6 7 8 9 10 11 12
wave
ways 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
wbst
wc00
we 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
week
weight 1 2 3
welcome
weld
well 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
went
were 1 2 3 4 5 6 7 8 9 10 11 12 13
wetted 1 2 3 4 5 6 7 8 9 10 11 12 13
wgp
wgs
what 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
whatever
whehn 1 2
when 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
whenever 1 2
where 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
whereas 1 2 3 4
whether 1 2 3 4 5 6 7 8 9
which 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72
while 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
who
whole 1 2 3 4 5 6 7 8 9
whom
whose 1 2 3 4
why 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18

>>


Search Words List

<<

wide 1 2
width 1 2 3
wiley
will 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
window 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
winsock
winter
wire
wireframe
wish 1 2 3 4 5 6 7 8 9
with 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131
within 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
without 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
wizard 1 2 3 4 5 6 7 8 9
won 1 2 3
won’t 1 2
wooden
words 1 2 3 4 5 6
worker
working 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
worksheet 1 2
workspace
world 1 2
worth 1 2 3 4 5
would 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33

>>


Search Words List

<<

wrage
write 1 2 3 4 5 6 7 8 9 10 11
written 1 2 3 4 5 6 7 8 9 10 11 12 13
wrong 1 2 3 4 5
www 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
wyatt

x 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173
x1 1 2
x1jusu
x1x1
x2 1 2
x2x2
x3
x3x3
x86
xcentre
xcoord
xgp
xgs
xi 1 2
xj
xls 1 2
xlsx
xpos 1 2
xposu
xposur
xros
xx
xx_xx
xx_xx_eta
xx_xy
xx_yy
xx_zz
xy 1 2
xyz
xyzr

>>


Search Words List

<<

adamson
adapt 1 2 3
adaptive
add 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
added 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
adder
addfluxd
adding 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
addition 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
additional 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
address
addtangtrac1
addtangtrac2
addtracnorm
addtracx1
addtracx2
addtracx3
ade
adequate 1 2 3 4 5
adjacent 1 2 3 4 5 6 7 8 9 10 11
adja
adjusted 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
adjustments 1 2
administration
administrative 1 2
administrator
admissible
admittance
adopted 1 2
advanced 1 2 3 4
advantage 1 2 3 4 5
adversely
advisable 1 2 3 4 5
advised 1 2 3
aeronautics
affect 1 2 3 4 5 6 7 8
after 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
after_solve 1 2
aftersolve
ag 1 2 3 4 5 6 7 8 9
agai
again 1 2 3 4 5 6 7 8 9 10 11 12 13
agci
agcl 1 2 3 4 5 6 7 8 9
age 1 2
agency 1 2
aggregate 1 2 3
agp
agrams
agreements
agree
ags
aho
aided 1 2
aimed 1 2 3 4 5 6 7 8 9 10 11 12
air 1 2 3 4
al 1 2 3 4
algorithm
alig
align 1 2 3
all 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76
all_internalpoints
allo
allocate 1 2
allowable
allowedto
allows 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
alloys 1 2
almost 1 2
along 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
alpha
alphabetic
already 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
also 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
alterantive
alteration
alternate
alternatevely
alternative 1 2 3 4 5 6 7 8 9
alternatively 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
although 1 2 3 4 5
althoughonly
altogether 1 2
alum 1 2 3
aluminium 1 2 3 4 5
aluminum 1 2
always 1 2 3 4 5 6 7 8 9 10 11 12 13

>>


Search Words List

<<

y 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
y1
y2
yb
ycentre
ycoord
year 1 2 3 4 5 6 7 8 9 10 11
yellow 1 2 3 4 5 6
yes 1 2
yet 1 2 3 4 5
yie
yield 1 2
yna
ynam
ynamic
york
you 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133
youngs
your 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
yourgroup
yourself
ypos
yr
ys
ysis
yy
yy_xy
yy_yy
yy_yy_eta
yy_zz
yyyy

z 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
z1 1 2
z12 1 2
z1b 1 2 3
z1z2
z2
z2b 1 2 3
z3
zat
zati
zation
zcentre
zcoord
ze
zero 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
zeroflow
zi
zinc 1 2 3 4 5 6 7 8 9 10
zincsteel
zip 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
zn
znli
zonal
zond 1 2
zone1 1 2 3
zone2 1 2
zone3
zone_1_to_2_interface 1 2
zone_1_to_2_steel_interface 1 2 3
zone_2_cathode 1 2
zone_3_cathode2 1 2
zone_definition
zone_id
zone_type
zone_x_interface_y
zone_x_nobc
zoneid 1 2
zonelist
zones 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
zones_definitions 1 2
zones_defintion
zooming

>>


Search Words List

<<

zpos
zt
zz
zz_zz
zz_zz_eta

{ 1 2 3 4

} 1 2 3 4 5

¢

°
°c

µa
µm
µ•

à 1 2

α

δ

π

σ

‎

– 1 2 3 4 5 6 7 8
–1100mv
–700mv
–g
–gid
–html
–out
–txt

‘
‘69
‘7e11
‘80a1’
‘add
‘advanced
‘apply
‘bare
‘cathodic
‘convert’ 1 2
‘d
‘default
‘delete’
‘description
‘distance
‘do
‘end
‘experimental
‘extend
‘final
‘folders
‘free
‘i3’
‘indication’ 1 2
‘initial
‘load
‘main
‘material
‘members
‘model
‘name’
‘next’
‘off’ 1 2
‘ok’
‘perform
‘remove
‘rotate
‘save
‘short’
‘specific
‘start’
‘title
‘translate
‘trim 1 2
‘trim’
‘write
‘write’

’ 1 2

“ 1 2
“between�?
“process
“rootname

�?

„field 1 2

• 1 2
•osure
••
••u•••
•••
••••
•••••
••••••

… 1 2 3 4 5 6 7
…… 1 2
……… 1 2
……………
…………………

≤


Search Words List

<<

ambient
ambientpot
american
among 1 2 3 4
amount 1 2 3 4 5 6
amp 1 2 3
an 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94
anal
analog
analy
analyse 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
analysis 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
analyzed 1 2
anchorch_added 1 2 3
anchorchain01 1 2 3
and 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158
andh
andw
angle 1 2 3 4
angle_change_limit_for_moves
anglechangelimit
angular 1 2 3 4
animate
animation 1 2
anium
anium50
ano
anode_back 1 2 3
anode_topsides 1 2 3 4
anode_type
anode_type1
anodes 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64
anodes_active_surfaces
anodes_back
anodes_insulated_surfaces
anodic 1 2 3 4 5 6 7 8 9
anodic_current
anodically 1 2
another 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
answer 1 2
anti 1 2
anticipated
antisymmetric
antisymmetry
any 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
anything 1 2
anyway 1 2
anywhere 1 2

>>


Search Words List

<<

ap
apart 1 2 3 4
apparatus
appear 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
appearance 1 2
appendix 1 2 3
appendix_trimmingb
appendix_trimmingc
appen
apple
applicable
applications 1 2 3 4 5 6 7 8 9 10 11
applied 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
apply 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
apply_maximum_history_change
applying 1 2 3 4 5 6 7 8 9 10 11 12
appr
approach 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
appropriate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
approval
approved
approximate 1 2 3
approximatedimensions
approximately 1 2 3
approximation 1 2
approxi
apr
april 1 2 3 4 5
ar
arbitrary 1 2
archive 1 2 3
ard
ardiv
ardivnswc
are 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133
area 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54
area_factor 1 2
aren
argument
ario
arithmetic
arlington
around 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
arrange 1 2 3 4 5 6 7 8 9 10
arrows 1 2 3 4 5 6 7 8 9
ary

>>


Search Words List

<<

as 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113
asci
ascii 1 2 3 4 5 6 7 8 9 10 11 12
ashurst 1 2
aside
ask 1 2 3 4 5
aspects 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
assembled 1 2 3 4 5 6
asses
assessed 1 2 3 4 5 6 7 8 9 10
assessment
assign 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
assignment 1 2 3 4
assistant
assists 1 2 3
associate 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
assumed 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
assumption 1 2 3 4 5
asterisk 1 2 3
astm

>>


Search Words letter

^ A A0 A4 A8 A9 AB AC AD AE AF AG AH AI AL AM AN AP AR AS AT AU AV AW AX AY ^


Search Words letter

^ B B0 B4 BA BC BE BF BI BJ BL BM BO BR BT BU BW BY BZ ^


Search Words letter

^ K KA KE KG KI KN KP KR ^


Search Words letter

^ L L1 L2 L3 LA LB LD LE LI LJ LK LL LM LO LS LU LY ^


Search Words letter

^ M M0 M2 MA MB MD ME MF MG MH MI ML MM MN MO MP MR MS MT MU MV MY ^


Search Words letter

^ N N0 N_ NA NB NC ND NE NG NH NI NN NO NP NR NS NT NU NZ ^


Search Words letter

^ O OA OB OC OD OF OG OH OI OK OL OM ON OO OP OR OS OT OU OV OW OX OY ^


Search Words letter

^ P P1 P2 P3 PA PB PC PD PE PF PH PI PL PM PN PO PP PR PS PT PU ^


Search Words letter

^ Q Q1 Q2 Q3 QI QU ^


Search Words letter

^ R R1 R5 RA RD RE RF RG RI RJ RM RN RO RP RR RS RT RU RV RW RX RY ^


Search Words letter

^ S S1 S2 S9 SA SB SC SE SF SH SI SK SL SM SN SO SP SQ SS ST SU SW SY ^


Search Words letter

^ T T1 T2 T3 T8 TA TE TF TH TI TJ TL TM TN TO TP TR TS TT TU TV TW TX TY ^


Search Words letter

^ C C0 C1 C2 C3 C4 C5 C6 C7 C8 C9 CA CB CD CE CF CH CI CJ CK CL CM CO CP CR CT CU CY CZ ^


Search Words letter

^ U U1 U2 U3 UB UD UF UI UJ UK UL UM UN UP UR US UT ^


Search Words letter

^ V VA VD VE VG VI VJ VM VN VO VS VX VY VZ ^


Search Words letter

^ W WA WB WC WE WG WH WI WO WR WW WY ^


Search Words letter

^ X X1 X2 X3 X8 XC XG XI XJ XL XP XR XX XY ^


Search Words letter

^ Y Y1 Y2 YB YC YE YI YN YO YP YR YS YY ^


Search Words letter

^ Z Z1 Z2 Z3 ZA ZC ZE ZI ZN ZO ZP ZT ZZ ^


Search Words letter

^ D D0 D1 D2 D3 DA DD DE DG DI DN DO DR DT DU DX DY DZ ^


Search Words letter

^ E E0 E1 EA EB EC ED EE EF EG EI EL EM EN EO EP EQ ER ES ET EV EX EY ^


Search Words letter

^ F F0 F1 FA FE FF FI FJ FL FO FP FR FT FU ^


Search Words letter

^ G G0 G5 G_ GA GD GE GH GI GL GM GN GO GR GS GU ^


Search Words letter

^ H H0 H1 HA HB HE HH HI HM HO HR HT HU HY ^


Search Words letter

^ I I1 I2 I3 I_ IA IB IC ID IE IF IG II IJ IL IM IN IO IP IR IS IT IU IV IZ ^


Search Words letter

^ J J1 J2 J3 JA JB JE JI JJ JL JO JU ^


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Installation and SetUp
Help and Support
Release Notes
Working Environment
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
What_does_it_do
How_to_use_it
Why_would_you_use_it
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Introduction
Load_HMD_File
Internal_Points
Points_along_lines
Points_on_flat_grids
Solve_and_Results
Post_process
Contour_plots_on
Numeric_results_on
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Introduction
Internal_Point_Editor
Loading_the_Model
Points_along_Lines
Grid_of_Points
Solve_Model
Results
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
Introduction
Example_1_Polarisation
Example_2_Sigmoidal_curve
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Introduction
Model_description
Model_checking_tool
Viewing_the_zone
Using_GiD9_to_view_zone
Using_GiD14_to_view_zone
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Introduction
Model_description
Procedure
Off_Potential_Wizard
Process_Results
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Introduction
Overview
Keywords_in_the_dat_file
Resulting_flux_lines
Keywords_which_may_be
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Introduction
The_process_to_change_a
The_process_to_add_an
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Introduction
The_process_to_change_a
The_process_to_add_an
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
Introduction
Geometry_and_Mesh
Model_definition
Open_the_CP_Model_Editor
Group_definitions_tab
Zone_tab
Solve_tab
Results_tab
Post_process
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
Introduction
CP_Builder
Template_for_the_CP
Section_MESH_IMPORT
Section_NON_OVERLAPPING
Proceed_editing_sections
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
What_does_it_do
How_to_use_it
Why_would_you_use_it
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Introduction
Procedure
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
Open_polarisation
Create_a_mat_file_with
Select_materials_to_go
Define_label
Press_Write_to_keep
Press_Write_and_go_the
Mat_file
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
How to prepare a dynamic polarisation curve
How to prepare a long-term file
Files Format
Flow Profile and Calcareous deposits tutorial
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
Introduction
Flow_profile_files
Long_term_curve_file
mat_cp_file
How to prepare a dynamic polarisation curve
How to prepare a long-term file
Files Format
Flow Profile and Calcareous deposits tutorial
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
How to prepare a dynamic polarisation curve
Introduction
The_flow_profile_file
Dynamic_polarisation
Long_term_curves
References
How to prepare a long-term file
Files Format
Flow Profile and Calcareous deposits tutorial
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
How to prepare a dynamic polarisation curve
How to prepare a long-term file
Introduction
The_long_term_curve
Files Format
Flow Profile and Calcareous deposits tutorial
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
How to prepare a dynamic polarisation curve
How to prepare a long-term file
Files Format
1_Calcareous_deposits
2_Starting_from
3_Do_not_allow
4_Flow_rate_profile_file
5_Simulating_different
Flow Profile and Calcareous deposits tutorial
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
Water flow rate and calcarous deposits
How to prepare a dynamic polarisation curve
How to prepare a long-term file
Files Format
Flow Profile and Calcareous deposits tutorial
Introduction
Model_description
Coating_degradation
Flow_profile_files
Long_term_curve_file
Material_file_mat_cp
Anode_data
Procedure
Launch_run_timestep_bat
Results
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder
Introduction
The_R15_model
The_tool_ListGroups
How_to_run_the_tool
How_to_process_the_file
Complete_the_model_using
Copy_the_partial
Edit_section_MESH
Edit_Section_ZONE
Running_CP_Builder
Solve
Other_possible_required


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
What_does_it_do
How_to_use_it
Input_Files
Why_would_you_use_it
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
How_to_use_it
Why_would_you_use_it
Results_passed_to_post
Polarisation_labels
Optional_Features
Command_line_Options
Example
User_Input_File
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
What_does_it_do
How_to_use_it
Why_would_you_use_it
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
What_does_it_do
How_to_use_it
Why_would_you_use_it
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
What_does_it_do
How_to_use_it
Why_would_you_use_it
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
What_does_it_do
How_to_use_it
Why_would_you_use_it
Example
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
What_does_it_do
How_to_use_it
Why_would_you_use_it
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
What_does_it_do
How_to_use_it
Why_would_you_use_it
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Installation and SetUp
Introduction
Resources_required_to
Hardware
Operating_System
Other_software
Installation_instructions
Starting_installation
Installing_the_License
Installing_JAVA
Installing_the_BEASY
License_set_up
How_to_provide_us_with
Node_locked_license_for
Floating_license_for_a
Dongle_locked_license
How_to_Use_your_licenses
Node_locked_licence_for
Prepare_the_licence_file
Set_up_the_licence
Floating_licence_for_a
How_to_set_up_the
Prepare_the_licence_file1
Set_up_the_licence1
On_the_client_machine
Dongle_locked_licence
Installing_the_dongle
Insert_the_dongle_and
Set_up_a_licence_service
Licence_service
How_to_interpret_error
What_to_do_if_you_cannot
What_processes_should
Test_the_installation
BEASY_CP_Help
Appendix_Background
How_the_FLEXlm_based
Help and Support
Release Notes
Working Environment
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Results on Polarisation Curves
Pol To Mat File
MatCP to Pol
CP Report Current
Report Internal Points
Filter Internal Points
List Groups
CP Builder
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Results on Polarisation Curves
Pol To Mat File
MatCP to Pol
CP Report Current
Report Internal Points
Filter Internal Points
List Groups
CP Builder
CP_Builder_Features
How_to_use_the_CP_Builder
Data_sections
How_to_create_an_hmd_file
Report_files_created_by
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Introduction
ProblemTypeLoad
ProblemTypeFunctions
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Introduction
ProblemTypeLoad
Getting started with BEASY GiD
Location of the problem type
Load BEASY GiD problem type
How to know if the problem type is loaded
What happens if the problem type is not loaded
Unload BEASY GiD problem type
ProblemTypeFunctions
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Introduction
ProblemTypeLoad
ProblemTypeFunctions
Problem type functions
Export BEASY mesh
Export hmd template
Import.off file
Import Multiple GiD Meshes
Geometric Tools
Add BEASY labels
Layer Tools
Report Entities IDs
Line Operations
Surface Area Calculation
CP Modelling
Help and problem type version number
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Introduction
ProblemTypeLoad
ProblemTypeFunctions
Problem type functions
Export BEASY mesh
Export hmd template
Import.off file
Import Multiple GiD Meshes
Geometric Tools
Add BEASY labels
Layer Tools
Report Entities IDs
Line Operations
Surface Area Calculation
CP Modelling
CP Modelling Menu
Ship Building
Jacket Structures
Pipelines
Anodes
Survey Points
Help and problem type version number
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Introduction
ProblemTypeLoad
ProblemTypeFunctions
Problem type functions
Export BEASY mesh
Export hmd template
Import.off file
Import Multiple GiD Meshes
Geometric Tools
Add BEASY labels
Layer Tools
Report Entities IDs
Line Operations
Surface Area Calculation
CP Modelling
CP Modelling Menu
Ship Building
Introduction
Overlay_shape_on_hull
Position_anode_near_Hull
Jacket Structures
Pipelines
Anodes
Survey Points
Help and problem type version number
Pre-Process
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Pre-processing mode
Move Entities To Layer
Un-Collapse
Collapse lines
Check For Coincident Lines
View Surface Normals
Swap Surface Normals
How to define a mesh for CP modelling
Post-Process
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
Result Visualisation
Post-processing mode
Open Result File
Displaying Results BEASY CP
CP - Layers in post-process mode
Location of the colour bar
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
Result Visualisation
Post-processing mode
Open Result File
Displaying Results BEASY CP
View_Results
Contour_fill
View_Results_Window
Tube_elements
Dual_elements
CP - Layers in post-process mode
Location of the colour bar
GiDPlugin Tutorials
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Aspects_of_modelling_and
Examples
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
Load_BEASY_GiD_problem
Create_or_import
Define_the_mesh
Export_mesh_file
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Load_problem_type
How_would_you_know_the
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Procedure
Mesh_definition
Element_order
Mesh_generation
Discontinuous_and_Meshes
Appendix
Structured_mesh
Element_concentration
Unstructured_Mesh
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define_Anodes
Brick
Tubular
Custom
Position_Anodes
Insert_Anodes_on_Tube
Insert_Anodes_on_Surf
Align_custom_Anode_to
Insert_bracelet_anode_on
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Define_member_properties
Use_the_trimming_tool
Jackets_Conventions_for
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
What_does_it_do
How_to_use_it
Why_would_you_use_it
CPModelEditor
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Introduction
Geometry_building
Mesh_generation
Export_mesh
Comments
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Introduction
Geometry_using_BEASY_GiD
Anode_geometry
Monopile_geometry
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Introduction
Geometry_using_BEASY_GiD
Open_the_GiD_project
GiD_layers
Export_mesh
Jacket Structure - GiD plugin
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
Introduction
Geometry_using_BEASY_GiD
STEP_0_Load_BEASY
STEP_1_Import_OFF_file
STEP_2_Define_anode
STEP_3_Insert_SAC_anodes
STEP_4_Trim_the
STEP_5_Organising_layers
STEP_6_Define_a_suitable
STEP_8_Export_the_mesh
ShipHull - Gid plugin
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
Graphical Intefaces Index
GiD Plugin
GiD Plugin Introduction
Main Window
GiD Use and Help
BEASYGiD problem type
Pre-Process
Post-Process
GiDPlugin Tutorials
CP
Contents
Modelling Steps
How to load BEASY tools
Meshing
Create the anodes geometry
Define Member Properties
Organise members into layers
Visualise tube elements in 3D
Modelling intersecting pipes
Bi-Metallic Cell - Gid plugin
Monopile - Gid plugin
Flowline - Gid plugin
Jacket Structure - GiD plugin
ShipHull - Gid plugin
Introduction
Open_GiD_open_the_model
GiD_layers_and_BEASY
Export_mesh
Comments
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Cathodic_Protection
Mathematical_Background
Designing_a_CP_system
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Preparation
Data_Requirement
Building_the_Model
Results
Resolving_Problems
Optimisation_and
Input Data and Outputs
Input Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Types_of_input_data
Types_of_outputs
CP_Solver_input_and
Input Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Introduction
Meshes
Polarisation Curves
Units
Groups Definitions
Zones
Internal Points
Sacrificial anodes
Return path circuit
Solve tab
Report files
Results tab
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Introduction
The_bzmsh_mesh_file
Meshing
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Grading
How_many_elements_should
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Aspect_ratio
Distorted_elements
Elements_too_close
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Introduction
Normal_directions_in
Normal_directions_on
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Mesh_elements_on_surfaces
Order_of_the_elements_in
Order_of_the_elements_in1
Result_Elements
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Dual_Elements
Use_of_dual_elements
How_to_create_the
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Introduction
Use_of_tube_elements
How_to_create_the
Internal Points
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
How_to_define_internal
How_to_define_result
Display_results
Geometry of Sacrifiicial Anodes
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
Mesh
Mesh guidelines
Accuracy. Aspects to consider
Normal Vectors to Surfaces
Common Element Types
Dual Elements
Tube Elements
Internal Points
Geometry of Sacrifiicial Anodes
Sacrificial_anodes
Cuboid_shape_anodes
Cylinder
How_to_create_the
GeneralData
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Introduction
CP_Model_Editor_Features
CP_Model_Editor_tools
Information_bar
Tabs_used_to_define
CPBuilder_log
CPBuilder_SAC_Anodes
Results_tab
Meshes
Polarisation Curves
Units
Groups Definitions
Zones
Internal Points
Sacrificial anodes
Return path circuit
Solve tab
Report files
Results tab
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Single_zone_model
Symmetry_planes
Multi_layer_approach
Multi_zone
How_to_define_zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Boundary_Conditions_on
Polarisation_Curves
Insulated_surfaces
Boundary_condition_at
Boundary_condition_on
How_to_define_boundary
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Introduction
How_to_model_tube
Manually_editing_the_hmd
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Introduction
Anode_Types
BRICK
CYLINDER
BRACELET_or_SHAPELESS
STAND_OFF
BRICK_FLUSH_MOUNTED
How_to_model_sacrificial
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Introduction
How_to_model_dual
Manually_editing_the_hmd
Boundary_Condition_on
Offset_parameter_for
Restrictions
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Introduction
Resistance_per_unit
Electrical_components
TRUs
JBOX
Electrical_connections
How_to_define_a_non
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
Introduction
Control_element_order
hmd File
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
Data_sections
hmd_file_template
Editing_the_hmd_file
CP Data file
CP Data file
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Introduction
Zones
Boundary Conditions
Define Tube Properties
Sacrificial Anode Data
Dual Elements
Return Path Circuit
Control Element Order in Solution
hmd File
CP Data file
CP Data file
Document_Overview
Introduction
Overview_of_BEASY_files
Model_files
Work_files
Structure_of_the_BEASY
Private_Data_Sections
Keyword_details
Header_Information
Solution_Control_Section
General_Data_Section
General_Data_Zone
Private_data_sections1
Group_Tool_Data
Polarisation Data
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Introduction
Meshes
Polarisation Curves
Units
Groups Definitions
Group_definitions_tab
Visualisations
Row_and_Column_operations
_Basic_visualisation
_Intermediate
_Advanced_visualisation
Zones
Internal Points
Sacrificial anodes
Return path circuit
Solve tab
Report files
Results tab
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Adding a new material into the database
Material File
Sigmoidal Curve Method
PolDat atlasCP
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Introduction
Where_to_find_it
Main_Page
Add_new_material_data
Grouping_the_data_in_the
Considerations_to_add
How_to_add_new_material
How_to_add_a_New_Season
How_to_add_a_new
Plot_curves
Experimental_Curve
Export_Import_Files
Create_Mat_File
Export_the_Data
Import_Data_to_the
Add_or_Remove_Data
Remove_Data
Add_new_data
Modify_Data
Modify_material
Modify_polarisation
Delete_Season_Depth
Delete_Formation
Delete_Depth_and_Season
Delete_Material
Data_structure_within
Material_Data
Polarisation Data and CP
Adding a new material into the database
Material File
Sigmoidal Curve Method
PolDat atlasCP
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Polarisation_curve
Factors_modifying
Sign_convention_for_the
Rules_when_defining
Optimising_the_run
Results_off_the_end_of
Polarisation_data_and
Solution_Tolerance
Number_of_iterations
Convergence_Problems
Polarisation_curves_and
References
Adding a new material into the database
Material File
Sigmoidal Curve Method
PolDat atlasCP
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Adding a new material into the database
Material File
Introduction
The_Material_Data_File
Title_Records
Season_definition
Conductivity_definition
Cathode_polarisation_data
Anode_polarisation_data
Sigmoidal Curve Method
PolDat atlasCP
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Adding a new material into the database
Material File
Sigmoidal Curve Method
Introduction
Various_published
Hartt_1
Strommen_5
Application_of_the
Bare_steel_surfaces
Coated_steel
Application_of_the1
Method_to_determine_the
Method_to_determine
Method_to_determine_most
Selecting_data
References
PolDat atlasCP
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Adding a new material into the database
Material File
Sigmoidal Curve Method
PolDat atlasCP
Atlas of Polarisation Diagrams
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Geometry
GeneralData
Polarisation Data
Introduction
Database and Mat Management
Polarisation Data and CP
Adding a new material into the database
Material File
Sigmoidal Curve Method
PolDat atlasCP
Atlas of Polarisation Diagrams
_TOC_250009
_TOC_250008
_TOC_250007
_TOC_250006
_TOC_250005
_TOC_250004
_TOC_250003
_TOC_250002
_TOC_250001
_TOC_250000
Results
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
Introduction
Available Results
Visualisation in 3D interface
GDF File
Tools to process numeric results
Model Checking
Adjust settings while running
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
Introduction
Available Results
Visualisation in 3D interface
GDF File
Tools to process numeric results
Model Checking
Check_that_a_solution
Check_convergence
If_your_model_has_not
Warning_messages_in_the
Identify_locations_that
Checks_on_the_report_file
Current_Balance
Results_lie_on_the
Checks_on_the_input_data
Adjust settings while running
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
Introduction
Available Results
Visualisation in 3D interface
GDF File
Tools to process numeric results
Model Checking
Adjust settings while running
Overview
Keywords_which_can_be
STOP
APPLY_MAXIMUM_HISTORY
ARCHIVE_SOLUTION_FILES
STOP_ARCHIVE_SOLUTION
CP_CURRENT_DENSITY
TRACK_NODAL_RESULTS
ModellingAspects
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Introduction
Meshes
Polarisation Curves
Units
Groups Definitions
Zones
Internal Points
Sacrificial anodes
Return path circuit
Return_path_circuit_tab
How_to_create_a_non
Resistance_per_unit
Electrical_Components
Options_toolbox
Electrical_Components1
Power_Supply_toolbox
Electrical_connections
Summary
Solve tab
Report files
Results tab
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Elements
Element_Shape_for_a_3D
Elements_order_on_the
Elements_order_on_the1
Guidelines_for_mesh
Aspect_ratio
Element_size
Shape_of_elements
Element_Order_in_the
Element_Order_in_the1
Elements_close_together
Grading
How_many_elements_should
Special_Elements
Tube_elements
Dual_Elements
Internal_Points_Result
Multi-layered zone
JacketStructures
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
Introduction
Setting_up_a_multi
Advanced_user_information
The_multi_layer_algorithm
gfeq
Fine_tuning
Limitations
JacketStructures
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Introduction
Files Format
Starting with OFF file
Starting with IGES file
MICRO-SAS
Geometrical Tansformation
Additional tools for trimming
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Introduction
Introduction
Assess_input_data
Importing_the_geometry
Anode_creation
Trimming
Files Format
Starting with OFF file
Starting with IGES file
MICRO-SAS
Geometrical Tansformation
Additional tools for trimming
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Introduction
Files Format
Starting with OFF file
Starting with IGES file
MICRO-SAS
Geometrical Tansformation
Additional tools for trimming
Introduction
Default_trimming
Criteria_used_in_the
Checking_the_model_after
Modifications_to_the
Short_members
Check_the_geometry
Trim_isolated_members
Forward Time Stepping
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Forward Time Stepping
Introduction
Create_the_initial_data
Launch_the_time_stepping
Results_folders
Post_process_folder
Modelling_anode_decay
Breakdown_factor
What_happens_if
Sigmoidal Curve Method
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Introduction
Theoretical Aspects
Approach To Modelling
Input Data and Outputs
Input Data
Results
ModellingAspects
Modelling Steps
Contents
Multi-layered zone
JacketStructures
Forward Time Stepping
Sigmoidal Curve Method
Introduction
Various_published
Application_of_the
Application_of_the1
Selecting_data
References
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Model_Build_Tutorials
Polarisation_Data
Internal_Points
Checking_tool
Modelling_calcareous
OFF_Potential
Miscellaneous
Using_old_model_data
Modelling_water_flow
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Introduction
CP Desktop
Create Mesh - View Results
CPModelEditor
Introduction
Meshes
Polarisation Curves
Units
Groups Definitions
Zones
Internal Points
Sacrificial anodes
Return path circuit
Solve tab
Report files
CPBuilder_log
CPBuilder_SAC_Anodes
Results tab
Model Checking Tool
Launch Solver
IP Editor
Process Results from a BEASY GDF file
Offshore Tools
Polarisation Database
MatFile Viewer
OffPotential Wizard
Settings
Results Filter
AdditionalTools
Graphical Interfaces
CP Solver
Tutorials


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
Introduction
Geometry_and_mesh
Polarisation_data
Model_Definition
Open_the_CP_Model_Editor
Import_mesh
Import_polarisation
Group_Definitions
Zones
Save_the_hmd_file
Solve
Results
Post_process
Protection_Potential
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
Introduction
Procedure
Solve_Create_Model
Results
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
Introduction
Procedure
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Introduction
Procedure
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Creating_a_model_from_an
What_happens_if_the_mesh
What_happens_if_the
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Introduction
Geometry_and_mesh
Polarisation_data
Model_definition_The_12
Open_the_CP_Model_Editor
Import_meshes
Import_polarisation
Group_Definitions
Zones
Save_the_hmd_file
Solve
Results
Modifying_the_anode
The_24_anodes_model
Imported_meshes_tool
Group_Definitions_tab
Save_the_hmd_file1
Solve_tab
Results1
Tips_for_creating_the_36
36_anodes_model
Transformations_needed
Define_and_Solve_the_36
Post_process
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Introduction
Geometry_and_mesh
Polarisation_data
Model_definition
Open_the_CP_Model_Editor
Import_mesh
Import_polarisation
Group_Definitions
Zones
Sacrificial_anodes
Return_Path_Circuit
Save_the_hmd_file
Solve
Results
Post_process
Protection_Potential
IR_drop
Numeric_results
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Introduction
Geometry1
Model_Definition
Open_the_CP_Model_Editor
Import_mesh
Import_polarisation
Group_Definitions
Zones
Sacrificial_anodes
Save_the_hmd_file
Solve
Results
Post_process
Ship Hull - Damaged blade
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Introduction
Mesh
Model_definition
Start_the_CP_Model_Editor
Importing_a_Mesh_File
Adding_Material_File
Group_Definitions
Zone_Definitions
Save_the_hmd_file
Solve_tab_Create_model
Solve_tab_Run_the
Results_tab
Post_process
Protection_Potential
Internal Points. Results Elements
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Content

BEASY_CP_HomePage
GettingStarted
Working Environment
Graphical Interfaces
CP Solver
Tutorials
Contents
Bi-Metallic Cell
How Add Sacrificial Anode Data
How to create a model from mesh
How to remove a mesh
Create Model from existing HMD
Monopile
Flowline with internal resistance
Offshore Jacket Structure
Ship Hull - Damaged blade
Internal Points. Results Elements
Introduction
Geometry_and_mesh
Model_definition
Post_process
Contour_plots_of
Import_internal_point
Internal Points - CP Model Editor
Internal Points. IP Editor
Create mat_cp using Pol2MatCP
How to check zones are correctly defined
Off Potentials
Flux Lines
Minimise SolutionTime whehn changing POT BC
Minimise SolutionTime whehn changing material LABEL
Polarasing Condition on Interface
How to use the geometry from an old dat file
How to use old geometry
Polarisation DataBase Create Mat
FlowProfile
How to use an old datfile with the CP Builder


Search Letters

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


CP Builder

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\cp_builder\cp_builder.htm

CP Builder

The CP Builder is a pre-processing tool used to create the CP model file ".dat" needed to launch a run. The CP Builder is launched and managed by the CP Model Editor. In general, the CP Builder can be ignored by users, since the CP Model Editor acts as a front end for the CP Builder.

CP Builder Features

How to use the CP Builder

Data sections

How to create an "hmd" file

Report files created by the CP Builder

CP Builder Features

The main advantage of the CP Builder is the use of a modular approach in the data management. Data is divided into data sections which can be edited independently. In this way,

  • model geometry can be changed/updated independently from the physical parameters applied to it

  • the model geometry can be created in different sub-models, and integrate or take away part of it without having to regenerate the full set of pre-processing data or revise an existent sub-model again.

  • New model parts can be integrated to an existent model without having to regenerate the complete modelling information such as polarisation properties previously defined or networks of electrical connections previously defined.

  • CP-Builder produces a .dat file which includes functionality which requires use of BEASYCP solver versions which are being developed in parallel with CP-Builder

  • The CP-Builder input file (*.hmd file) is created while defining model parameters with the CP Model Editor.

  • The CP-Builder input file (hmd file) can also be constructed either using a text editor or using a spreadsheet, but it is recommended to use the CP Model Editor instead.

When you are creating/editing your model with the "CP Model Editor", the input model parameters and other model data is stored when you save the hmd file.

The CP Builder is launched at the time of pressing "Create Model" in the "Solve" tab.

How to use the CP Builder

When you press "Create Model" button in the "CP Model Editor" the CP Builder is launched and used to create a dat file.

If you want to manually launch the CP Builder open a console and type the following command:

"%BEASY_CP_21%\bin\cp\CPBuilder" MyFile.hmd

Data sections

The hmd file is structured into data sections as follows:

These data is stored in the "hmd" file.

How to create an "hmd" file

There are two ways of start creating an "hmd" file.

  1. The "hmd" file is created by the CP Model Editor. After importing a mesh of your model, you can save the hmd file. This file has the empty canvas for each of the sections except from the section "NON-OVERLAPPING GROUP DATA". This section is populated with the layers that exist in the GiD model. You can then add properties with the CP Model Editor and save the hmd with the defined properties

  2. You can also create an empty template: To create an empty template:

  1. Run "CPBuilder" from a console: console and type the following command:

    "%BEASY_CP_21%\bin\cp\CPBuilder"

  2. A file named "MyModel.hmd" is created.

Report files created by the CP Builder

CPBuilder.log

The CPBuilder.log file has a record of warnings and errors. Check those to eliminate possible errors in your model.

The CPBuilder.log file has a section reporting the number of anodes with sacrificial anode properties anode properties defined on each mesh:

START REPORTS ON SACRIFICIAL ANODES

START SUMMARY REPORT 1

Mesh A has 11 SAC anodes of type CAISSONS_Type1

Mesh A has 4 SAC anodes of type CAISSONS_Type2

Mesh B has 36 SAC anodes of type RISER036_Type1

END SUMMARY REPORT 1

END REPORTS ON SACRIFICIAL ANODES

The CPBuilder.log file has a section reporting electrical connection with componenets:

START REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS {{{

Component FPSO generated 71 internal connections involving 72 groups.

Component AnchorChain01 generated 0 internal connections involving 1 groups arranged as a pipeline

…

…

Sub-group: "Riser_1" has 10 elements and 2 endpoints with IDs 143257 143260

Sub-group: "Riser_2" has 10 elements and 2 endpoints with IDs 143303 143307

Sub-group: "Riser_3" has 10 elements and 2 endpoints with IDs 143350 143352

Sub-group: "Riser_4" has 10 elements and 2 endpoints with IDs 143395 143399

END REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS }}}

START REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

Connection between: COMPONENT "FPSO" and COMPONENT "AnchorChain01" : MPIDs = 20819 and 196

….

….

END REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

There is a section reporting the groups that have been removed:

START REPORT_ON_UNUSED_GROUPS {{{

Mesh: "A" Group: "anchorch_added" has been explicitly REMOVED.

END REPORT_ON_UNUSED_GROUPS }}}

There is a section reporting the total numver of pairs of overlapping groups (if any):

START REPORT_OF_OVERLAPPING_BETWEEN_GROUPS {{{

Total number of pairs of overlapping groups = 0

END REPORT_OF_OVERLAPPING_BETWEEN_GROUPS }}}

CPBuilder_SAC_Anodes_Report.txt

This file is created if sacrificial anode sacrificial anode properties have been declared in the hmd file.

It has a record of the total number of anodes.

For each individual anode it shows:

  • Assigned ID

  • Name of the associated group

  • Name assigned to the sacrificial anode type

  • Anode Type (STAND_OFF, BRACELET, etc)

  • Utilisation factor

  • Consumption factor

  • Original mass

  • Mounting bar diameter

  • Density

  • Mass loss per Amp per year

  • Processing order

  • Number of elements

  • Anode Centre ( x , y, z coordinates)

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP Report Current

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\cpreportcurrent\cpreportcurrent.htm

CP Report Current

What does it do?

This tool reads selected elements from a GDF file and writes them to a plain text file. Elements can be selected by group name and/or by explicitly giving a list of element IDs to extract. In addition a summary of the results on the selected elements is printed to STD OUT (standard output)

How to use it?

Open a command prompt in the folder where you have solved the model with BEASY-CP (or a folder containing at least the model .gdf file with results) and type the following command

"%BEASY_CP_21%\bin\cp\CPReportCurrent" ListFile GDFFile outfile

where:

  • ListFile is the name of a text file containing a list of element ids and/or group names to be selected for processing

  • GDF_File is the name of the GDF file with element results (must contain at list the keyword ELEMENT_ZONE

  • outfile : (Optional) Name of a text file where to dump results corresponding to the selected elements

TIPS

Tip 1: To select elements contained in group "My Group" and "YourGroup" to elements 3 4 5 and 6 (but not 7 and 8), add the following lines to the ListFile:

       3 4 5 6 # 7 8

       GROUP_NAME My Group

       GROUP_NAME YourGroup

Tip 2: If you want to have the summary in a text file named "MySummary.txt" you can redirect STD OUT to said file as shown in the example below:

CPReportCurrent ListFile GDFFile outfile > MySummary.txt

Why would you use it?

This tool is useful for filtering results from a GDF file and creating custom reports. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Results on Polarisation Curves

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\cprespolcurve\cprespolcurve.htm

CPResPolCurve

What does it do?

This tool reads results at mesh elements from a .gdf file and creates one separate report file (in plain text) per each polarisation curve label used in the model. The report for a polarisation label consists of a table, where each row corresponds to a mesh element that has been assigned the selected polarisation label and each column contains properties and results on the element, such as element Id, coordinates, electrolyte potential, etc.

In addition a summary of results for each polarisation label is printed to the standard output (STD OUT).

How to use it?

Open a command line tool in the folder where you have solved a BEASY CP model (or a folder containing at least the input .dat and its corresponding .gdf file with results).

Then, assuming that the root-name of your model is "MyModel", type the following command:

"%BEASY_CP_21%\bin\cp\CPResPolCurve" MyModel.gdf MyModel.dat > Summary.txt

Where

MyModel.gdf: Name of a .gdf file (result file produced by the BEASY-CP solver)

MyModel.dat: Name of a .dat file (consistent with the input .gdf file given as first input)

%BEASY_CP_21% is the environment variable which contains the path to the BEASY CP version 21 installation folder. This variable is setup during installation of the software.

OUTPUTS

For each polarisation label, this tool produces a report file in plain text format with extension ".txt" named MODEL_PLAB.txt, where MODEL is the rootname of the input .gdf file, and PLAB is the polarisation label. Then, the file contains a table with the following results at elements with label PLAB:

  • Element (EL_ID);

  • Polarisation label (LABEL);

  • Zone Id (ZONEID)

  • X,Y,Z coordinates of element centroid (XCENTRE YCENTRE ZCENTRE);

  • Element surface are (AREA); Current flowing through element (NORMAL_CURRENT);

  • Average electrolyte potential at element centroid (AVERAGE_VOLTAGE)

  • Metal voltage in the element (METAL_VOLTAGE);

  • Normal current density (CURRENT_DENSITY);

  • Protection potential (POTENTIAL); and

  • surface area factor (AREA_FACTOR)

Why would you use it?

To filter results based on polarisation curve labels.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Filter Internal Points

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\filter_internalpoints\filter_internalpoints.htm

Filter Internal Points

What does it do?

This tool extracts results at individually selected internal points from a GDF file and prints them to STD OUT (standard output)

How to use it?

Open a console in the folder where you have solved the model with BEASY-CP (or a folder containing at the model .gdf file with results) and type the following command

"%BEASY_CP_21%\bin\cp\Filter_Internal_Points" GDFFile PointIds.txt

Where GDFFile and PointIds.txt are the names of the files used as input by this tool

Inputs

  • GDFFile: is the name of the GDF file (considered as input by this tool) with results at internal points. Note that the keyword "RESULTS_AT_INTERNAL_POINT_IN_ZONE"

  • PointIds.txt : Name of an input text file containing the list of internal point (id numbers) to use. This file must contain a list of integers separated by one or more spaces or tabs or end-of-line characters (i.e. a column of numbers). Then, each internal point from the input .gdf file whose id matches any of the id numbers in this file will get selected.

Outputs

The table of results at selected internal points is printed to STD OUT of your console. You can redirect it to a text file as shown below:

Filter_Internal_Points Input.gdf PointIds.txt > MyResults.txt

Why would you use it?

This tool is useful for having a quick analysis of preselected internal points in your model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


List Groups

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\listgroups\listgroups.htm

ListGroups

What does it do?

This tool reads a BEASY-CP .dat file and reports the list of groups appearing in the "PRIVATE DATA FOR GROUPS TOOL" section and the properties associated to it to a text file.

How to use it?

Open a command prompt in the folder where you have the BEASY-CP .dat file and type the following command

"%BEASY_CP_21%\bin\CP\ListGroups" MODEL.dat [-g] > Warnings.log 2&1

where MODEL.dat is the name of a BEASY-CP input .dat file and [-g] is an optional parameter.

If the –g option is present, any orphan element (i.e. an element which does not belong to a group) will be assigned one automatically with the name: ZONE_X_NOBC for non-interface elements and the name ZONE_X_INTERFACE_Y for interface elements, where X is the master zone number, and Y is the slave zone number. In addition a new .dat file called MODEL_new.dat will be created provided that there are orphan elements in the input .dat file

The result of this tool is a table, exported to a text file named automatically "MODEL_ListGroups.txt", where MODEL is the rootname of the original input .dat file. The table enumerates the list of groups in the .dat file and the properties assigned to it.

TIPS

  • Groups defined between keywords "START PRIVATE DATA FOR GROUPS TOOL" and "END PRIVATE DATA FOR GROUPS TOOL" as well as groups defined between the keywords "START PRIVATE DATA FOR CPOPT" and "END PRIVATE DATA FOR CPOPT" in the input .dat file are included in the report.

  • The input .dat file is opened as read-only.

  • Boundary conditions are read from the section beginning with "DEFINE BOUNDARY AND INTERFACE CONDITIONS".

  • Polarisation labels are read from the section of the .dat file starting with: "DEFINE ELEMENTS POLARISATION PROPERTIES"

  • The type and value of the boundary condition and a numerical flag, 1 or 0 indicating dual or not dual respectively, will be reported for each group if all elements in it have the same type and value of boundary condition and are all either dual or not dual at the same time.

  • Any error/warning detected will be sent to the standard error unit, hence it is good idea to redirect the output to a file for example by using: ListGroups Model.dat > Warnings.log 2>&1.

  • If all elements in a group are involved as master in the same zone, then the master and slave zone number will be reported, otherwise zero zone values will be reported

Why would you use it?

This tool is useful for interpreting the data stored in a .dat file. The table that this tool produces helps to complete the NON_OVERLAPPING_DATA_BLOCK section of a CPBuilder template file (.hmd file).

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


MatCP to Pol

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\matcp2pol\matcp2pol.htm

MatCP2Pol

What does it do?

This tools translates a *.mat_cp file into an ASCII file that lists pairs of current density and potential for the the polarisation curves defined in the matfile.

How to use it?

Open a command line tool in the folder where you have a mat file. Then, assuming that the mat file "MyMatFile.mat_cp", type the following command:

"%BEASY_CP_21%\bin\cp\MatCP2Pol" MyMatFile.mat_cp MyFile.pol

where

Myfile.pol: Name of a pol file (file containing pairs current density-potential)

MyMatFile.mat_cp: Name to assign to the material file created

%BEASY_CP_V21% is the environment variable which contains the path to the BEASY-CP version 21 installation folder. This variable is setup during installation of the software.

If the tool is launch without parameters it sends a user help through the standard output.

NOTE: Each formation in a polarisation curve in the .mat_cp file will appear as a new polarisation curve in the .dat.pol file.

Why would you use it?

To retrieve the polarisation curves in a matfile

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Pol To Mat File

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\pol2matcp\pol2matcp.htm

Pol to MatCP

What does it do?

This tool translates an ASCII file (*.pol) containing pairs of potential and current density for different polarisation curves into a matfile (*.mat_cp)

How to use it?

Open a command line tool in the folder where you have a file with the polarisation curves.

Then, assuming that the ASCII file containing the polarisation curves is "MyFile.pol", type the following command:

"%BEASY_CP_21%\bin\cp\Pol2MatCP" Myfile.pol MymatFile.mat_cp

Where

Myfile.pol: Name of a pol file (file containing pairs current density-potential)

MyMatFile.mat_cp: Name to assign to the material file created

%BEASY_CP_21% is the environment variable which contains the path to the BEASY CP version 21 installation folder. This variable is setup during installation of the software.

If the tool is launch without parameters it sends a user help through the standard output.

Why would you use it?

This tools is useful if you want to create a matfile (*.mat_cp) from a potential and current density pairs.

Pol2MatCP reads a *.pol ASCII file and outputs a matfile

Format of the input file (*.pol)

The input file is a text file which can have any extension, ('.pol' is commonly used).

The file consists of a sequence of blocks like the one below:

BEGIN_POLARISATION_CURVE

POLCURVE_NAME Aluminium #Will be exported as ALUM

POLCURVE_UNITS mV mA m # Default: V A m

ANODIC_CURRENT NEGATIVE # Default: "POSITIVE"

POLCURVE_COMMENT Material used for sacrificial anodes.

POLCURVE_FORMATIONS 0.0 1.0 # Formation factors (NH real numbers).

# Default: 0.0

POLCURVE_DEPTHS 0.0 70.0 # Depth factors (ND real numbers). Default: 0.0

POLCURVE_REF_ELECTRODE Unknown # (Optional, Ignored)

# First column is potential, the following NH columns represent current densities

# for formation factors 1 to NH at depth 1. Then again for depth 2 and so on.

# Potential Current Current Current Current

# Density Density Density Density

# [form1, depth1] [form2, depth1] [form1, depth2] [form2, depth2]

-100.00 0.0000e+000 0.0000e+000 0.0000e+000 0.0000e+000

-246.22 4.2170e+000 4.2170e-002 1.2018e+001 1.0163e-001

-340.02 2.2712e+001 2.2712e-001 6.4728e+001 5.4735e-001

-453.76 1.0292e+002 1.0292e+000 2.9332e+002 2.4804e+000

-592.35 4.6639e+002 4.6639e+000 1.3292e+003 1.1240e+001

-1100.00 4.2661e+003 4.2661e+001 1.2158e+004 1.0281e+002

END_POLARISATION_CURVE

NOTES:

1) Any text after the hash symbol "#" is a comment

2) Only the first 4 characters from the string following POLCURVE_NAME will

become the label in the mat_cp file.

3) The string after ANODIC_CURRENT defines the current sign convention.

This could be either NEGATIVE or POSITIVE (default = POSITIVE)

4) The points {U(k) J(k)} where k = 1 to N, must be in sequence.

5) If J(0) > J(N) the list U(k)J(k) will be automatically reversed

6) If POLCURVE_FORMATIONS and/or POLCURVE_DEPTHS parameters are given:

a) The number of current density columns must be at least NH by ND, where

NH = number of formation factors, and ND = number of depth factors.

b) Any data beyond column NH x ND will be ignored.

c) The ordering of current density columns is as follows:

Column 1 = Current density at Formation 1, Depth 1

Column 2 = Current density at Formation 2, Depth 1

Column NH = Current density at Formation NH, Depth 1

Column NH + 1 = Current density at Formation 1, Depth 2

Column NH + 2 = Current density at Formation 2, Depth 2

Column 2 * NH = Current density at Formation NH, Depth 2

Column NH * ND = Current density at Formation NH, Depth ND

7) It is possible to create a new polarisation curve based on a scale

factor applied to an already defined curve. To achieve this

include lines at the end of the file with the following format:

REPLICATE Name1 Name2 CurrentFactor

where:

Name1 = Name of pol curve already defined in the input file

Name2 = Name to assign to the new polarisation curve

CurrentFactor = (Real number) Proportional factor to scale current

density in the existing polarisation curve

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Report Internal Points

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\additionaltools\report_internalpoints\report_internalpoints.htm

Report Internal Points

What does it do?

This tool reads all results at internal points from a GDF file and for each zone with internal points, it reports average and extremes of electrolyte potential. The report is printed to STD OUT (standard output)

How to use it?

Open a command prompt in the folder where you have solved the model with BEASY CP (or a folder containing at least the model .gdf file with results) and type the following command

"%BEASY_CP_V21%\bin\cp\Report_Internal_Points" GDFFile

where:

  • GDFFile is the name of the input GDF file with results at internal points

TIPS

If you want to have the summary in a text file you can redirect STD OUT to said file as shown in the example below:

"%BEASY_CP_V21%\bin\Report_Internal_Points" GDFFile > MyReport.txt

Why would you use it?

This tool is useful for having a quick analysis of the internal points in different zones of the model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


CP Desktop

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cp_desktop\cp_desktop.htm

BEASY CP Desktop

The CP Desktop is the main window which gives access to different software components of the software.

Tools accessible from the CP Desktop

Tool

Description

Create Mesh and View Results

This launches the GiD interface. In pre-processing mode, when the BEASY GiD problem type is loaded, you can create/import/export the geometry of a model, generate a mesh and visualise results.

The BEASY GiD problem type allows you to export a BEASY mesh format and has dedicated tools for BEASY CP modelling

CP Model Editor

The CP Model Editor is an interface that provides a canvas for model management, model properties can be defined, edited or deleted. It allows aggregating different meshes. It is also used to launch a simulation.

Model Checking tools

The Model Checking tools is an interface that facilitates model checking. In particular, it allows you to inspect completeness of zones and normal orientations defined in a dat file.

IP Editor

The IP Editor is used to find solutions at additional internal points for a BEASY model that has already been solved.

Launch Solver

Use this tool to run a CP model.

Inputs are : "*.dat" file and "*.mat_cp" file

Process Results from a BEASY GDF file

This is a results reporting tool for BEASY-CP which reads model results (primarily from the .gdf file generated by the BEASY-CP solver "beasyand.exe") and generates a summary of the results in different formats (html, tabulated text and GiD post-processing results).

Offshore Tools

These tools are used to launch or create batch files for launching time dependant simulations and to assist in the modelling of jacket structures.

Polarisation database

The polarisation database is used to store polarisation data and create mat_cp-files.

MAT File Viewer

The MAT File Viewer is used to plot graphs from polarisation curves stored in material files (*.mat_cp file)

OFF Potential Wizard

This tool calculates off potentials at given observation points, based on the polarisation that the structure had when the CP system was turned off. This is useful for pipelines modelling

Results Filter

The tool filters results from a solution file (*.gdf file) so you can then display specific results by group name.

CP Help

The CP Help button gives you access to reference documentation and tutorials for CP modelling

You need to have a browser installed in your PC (such as Internet Explorer, Chrome, etc.) to be able to access the documentation, but you do not need an Internet connection as the material is already stored in your PC.

Settings

The "Settings" utility allows you to define and visualise configuration variables

Additional Tools

The following set of tools can be found in the beasy bin\cp folder (installation_path/beasy21/bin/cp)

Tool

Description

CP Create report (Process results from a BEASY GDF file)

This tool is useful for creating automatic and customizable reports on the results obtained by the BEASY-CP solver

CP_CreateReport reads model results and generates a summary of the results in different formats (html, tabulated text and GiD postprocessing results)

Report Current

This tool is useful for filtering results from a GDF file and creating custom reports. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

CPReportCurrent reads solution for selected elements from a GDF file and writes them to a plain text file.

Results on Polarisation Curves

This tool is used to filter results based on polarisation curve labels.

CPResPolCurve reads results at mesh elements from a .gdf file and creates one separate report file (in plain text) per each polarisation curve label used in the model

Report Internal Points

This tool is useful for having a quick analysis of the internal points in different zones of the model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

Report_Internal_Points reads all results at internal points from a GDF file and for each zone with internal points, it reports average and extremes of electrolyte potential

Filter Internal Points

This tool is useful for having a quick analysis of preselected internal points in your model. You can also run analysis on several models in a systematic way if you put the instruction in a Windows batch file

Filter_Internal_Points extracts results at individually selected internal points from a GDF file and prints them to STD OUT (standard output)

MatCP to Pol

This tools is useful if you want to extract the polarisation data in a matfile (*.mat_cp)

MatCP2Pol reads a *.mat_cp file and outputs an ASCII file listing current density and potential for the list of the polarisation curves in the matfile.

Pol2MatCP

This tools is useful if you want to create a matfile (*.mat_cp) from a potential and current density pairs.

Pol2MatCP reads a *.pol ASCII file and outputs a matfile.

ListGroups

This tool reads a BEASY-CP .dat file and reports the list of groups appearing in the "PRIVATE DATA FOR GROUPS TOOL" section and the properties associated to it to a text file. ListGroups is useful for interpreting the data stored in a .dat file..

==============================End of document===============================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Process Results from a BEASY GDF file

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpcreatereport\cpcreatereport.htm

Process Results and CP Create Report

What does it do?

How to use it?

Why would you use it?

Results passed to post-processing files

Polarisation labels

Optional Features

Command line Options

Example

User Input File

What does it do?

This is a results reporting tool for BEASY CP which reads model results (primarily from the .gdf file generated by the BEASY CP solver) and generates a summary of the results in different formats (html, tabulated text and GiD post-processing results).

How to use it?

You can access the main functions of the tool through the BEASY CP Desktop using "Process Results from a BEASY GDF file".

This brings up the launcher for the CP_Create report executable:

You can alternatively, open a console in the folder where you have solved the model (or a folder containing the model .gdf file with results) and type the following command:

"%BEASY_CP_21%\bin\CP\CP_CreateReport" model.gdf [options]

Where model.gdf is a .gdf file generated by the BEASY CP solver, and [OPTIONS] are a number of optional parameters to control the output format.

This is useful if want to take advantage of additional options of the tool that are not available in the interface "Process Results from a BEASY GDF file"

IMPORTANT: This tool requires the .dat and .log files matching with the .gdf file to be present in the same folder as the .gdf file. All these files are used as input for this tool and are NOT modified by it.

Why would you use it?

This tool is useful for creating automatic and customisable reports on the results obtained by the BEASY CP solver.

Results passed to post-processing files

The results passed to the post-processing files are:

  • Current Density (averaged on mesh-points and on elements)

  • Electrolyte Average Potential (averaged on mesh-points)

  • Protection Potential (averaged on mesh-points)

  • Materials Polarisation labels (averaged on nodes or per elements)

  • Electric field at internal points

Polarisation labels

If a .dat file matching the input .gdf file (i.e. with the same rootname and in the same path) can be found then polarisation labels can be interpreted and exported to the GiD post-procesing file.

You can then load the ".post.res" file produced by this tool and visualise polarisation labels either as "Contour Fill" or as "Colour Ranges".

In the case of Countour Fill, each material is assigned an integer number (material Id number) greater than zero in order of occurrence in the section "DEFINE ELEMENTS POLARISATION PROPERTIES" in the .dat file, and zero is always assigned to "INSULATED" parts of the model.

The table showing the correspondence between the material id number and the polarisation label appears in the .log file produced by this tool (invariably named "CP_CreateReport.log").

In the case of "Countour_Ranges" the polarisation labels assigned to each part of the model appear as a legend as shown in Figure 1.

Figure 2: Visualisation of polarisation labels applied in GiD post-processing mode

Note that the property "Polarisation label" is assigned to an element in the .dat file, but transferred to a mesh-point in the model. The polarisation label that this tool associates to a mesh point is actually an average over all the polarisation labels of the elements connected to this mesh-point.

In this way, a mesh-point with non-integer polarisation label indicates that the elements connected to it have dissimilar material properties.

Optional Features

Command line Options

This section describes the special (optional) command line keywords which the tool supports to customise the type of report produced. If present, they should be placed after the name of the input .gdf file.

Options to control the type of report:

-html to produce a full report document in .html format

-txt to produce tabulated results on groups in a text file

-gid to produce GiD result files on selected groups

-intpts to produce tabulated internal point results in a text file with extension _IntPoints.txt

-all it has the same effect as having -html -txt -gid -intpts altogether

If no report type options are specified, only -html is assumed by default

Options above are covered by the interface "Process Results from a BEASY GDF file "

Other options

-config PostProcessOptions.txt

This option allows reading additional parameters from configuration file PostProcessOptions.txt. You may want to use a PostProcessOptions.txt file if you want to customise what goes into the different reports produced by this tool. For example you can rename, merge or filter out groups. The format of the configuration file is explained in section 6.

-out ROOTNAME

The keyword –out must be the full path to output file excluding the file extension, which will be deduced automatically from the selected REPORT option. If this parameter is not given, the default rootname for the output file report will be assembled as ROOTNAME_report.TXT (i.e. the ROOTNAME of the input gdf file, followed by the string "_report" followed by the standard extension of the selected output, for example .html for HTML reports, .post.res and .post.msh for GiD report, etc.

-mt : Creates a template file named CP_CreateReport_OPTIONS.txt

If -mt is introduced all other options are ignored and the only output is a template file to create

Example

For example, if you want to produce GiD post-processing files and an html report file, of a model called "CPModel" with reports named "MyReport" use the following instruction:

"%BEASY_CP_21%\bin\CP\CP_CreateReport" CPModel.gdf –html –gid –out MyReport

User Input File

The user input file is a text file containing the information shown in Figure 1. It allows you to:

  • select which groups you actually want to include in the report;

  • rename the groups for reporting purposes only

  • create "sets" of groups (groups of groups), in which case the summary will be applied to a set of groups rather than to an individual group

In addition, and exclusively for processing results with –gid option you can apply a physical translation to certain groups.

BEGIN SETTINGS

LOAD_LABELS_FROM_DATFILE # Optional

GID OFFSET DISTANCE dx # Optional, dx = real number indicating gap for dual elements

# USE_ALL_GROUPS_IN_GDF_FILE # Automatic generation of post-processing layers

END SETTINGS

BEGIN COORDINATES_TRANSLATIONS

GroupName1 dx dy dz # Where dx,dy,dz are real numbers denoting a translation vector

GroupName2 dx dy dz # Where dx,dy,dz are real numbers denoting a translation vector

END COORDINATES_TRANSLATIONS

BEGIN POST_PROCESSING_GROUP_SETS

GroupName1 PostLayer1

GroupName2 PostLayer1

...

GroupNameN PostLayer3

END POST_PROCESSING_GROUP_SETS

Figure 1: Configuration file

Any character on the right of a hash "#" character is considered as a comment and ignored by this tool.

The keywords BEGIN SETTINGS and END SETTINGS are mandatory delimiters for the settings data block. The keywords allowed in this data block are explained as follows:

LOAD_LABELS_FROM_DATFILE: If present or uncommented, the tool will attempt to find polarisation labels from a .dat file with the same rootname as the .gdf file and located in the same folder in order to be able to visualise distribution of polarisation curve labels in the model. We recommend to always leave this keyword present (which is the default action if no configuration file is provided)

GID_OFFSET_DISTANCE must be followed by a real number (dx) indicating the gap for visualisation of dual elements in the GiD .post files.

USE_ALL_GROUPS_IN_GDF_FILE: If this keyword is present or uncommented, then every single group in the GDF file will be processed by this group and the list of groups presented in the POST_PROCESSING_GROUPS_SETS region will be ignored.

The keywords BEGIN POST_PROCESSING_GROUP_SETS and END POST_PROCESSING_GROUP_SETS are mandatory delimiters for the data block containing a list of BEASY groups to export and the corresponding name of the layer in which the group appears. GroupName1 is a string representing the name of the group as it appears in the section "ELEMENTS_IN_GROUP" of the gdf file. PostLayer1 is a string representing the name of the post-processing set in which this group will be included (this is user defined, i.e.you can use whatever name you want, excluding the followin characters:

# (hash)

" (double quote)

’ (single quote)

SPACE (space character)

TABS (tab)

\ (backslash)

/ (forward slash)

The reports created by this tool will always be based on post-processing sets rather than groups. By default if no configuration file is provided or if the keyword USE_ALL_GROUPS_IN_GDF_FILE is enabled, the tool automatically considers having one group per each post-processing set and each set named the same as the group it contains.

A post-processing set is turns out to be a post-processing GiD layer for –gid results, or a record in the reoprt file created with the –txt option, or a record in the .html report.

If the configuration file is given, and the keyword USE_ALL_GROUPS_IN_GDF_FILE is not enabled, only the results from the groups which appear explicitly written in the POST_PROCESSING_GROUP_SETS data block will be considered for creating the report.

The keywords BEGIN COORDINATES_TRANSLATIONS and END COORDINATES_TRANSLATIONS are optional and can be included to create "exploded" views of the results where individual groups of elements can be physically translated to different positions. In this list

GroupName1 is the name of a group to translate

dx dy dz are three real numbers denoting the translation vector

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Return path circuit

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_circ\cpme_circ.htm

CP Model Editor. Return path circuit tab

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Return path circuit tab

How to create a non-default circuit

Resistance per unit length

Components

Options toolbox

Electrical Components toolbox

Power Supply toolbox

Electrical connections

Summary

Return path circuit tab

By default, all the groups are electrically connected. There are options in the "Return path circuit" tab that allow defining a non-default circuit.

NOTE: The information related to the non-default circuit will only be processed if the "Options" toolbox in the "Return path circuit" tab has "Activate no-default return path circuit" ticked on. If not, the information will not be processed and a default circuit will be created (i.e. all groups electrically connected)

Figure 1 Return path circuit tab

The "Return Path Circuit" tab is divided into two panels. In the left hand side there are three toolboxes: Options, Electrical Components and Power Supplies. In the right hand side there is the "Electrical Connections" toolbox.

How to create a non-default circuit

To create a non-default circuit you will need to input information about electrical connections, resistances, etc. However, even if you entered this information, the circuit will not be created if the option "Activate no-default return path circuit" is not selected. This option is found in the "Options" toolbox in the "Return path circuit" tab. Figure 2.

So you can start for activating the creation of the no-default return path circuit.

Figure 2 "Return Path Circuit" tab. Options toolbox

If after the circuit data is created, you want to re-run a simulation with no power loss through metals/anodes you can do so by de-activating the no default return path circuit, without losing any circuit data.

There are aspects of the non-default circuit that need to be defined in the "Group Definitions" tab. Those aspects are:

  • Resistance per unit length

  • Components names

Other information is input in the "Return Path Circuit" tab

Resistance per unit length

For flowlines, pipelines or other structures represented by tube elements, if the voltage drop along the length of the structure is non-negligible, then the internal resistance can be modelled by defining the resistance per unit-length.

The resistance per unit length needs to be input in the "Groups Definitions" tab. Select "Intermediate" Visualisation on the top left of the tab to make the field "Resistance per unit length" visible.

You can use the "Geometry Type" column to filter by "Line" and define the value for "Resistance per unit length" for the pertinent groups.

Electrical Components

A component is a set of interconnected groups sharing the same inter-connecting resistance. To define components names, use the "Group Definitions" tab as shown in Figure 2.

Figure 3 "Group definitions" tab. Components names for the existing groups

Options toolbox

The "Options" toolbox is on the left hand side in the "Return Path Circuit" tab. (Figure 4)

Tick on "Activate no-default return path circuit" to simulate a non-default return path circuit. If this option is not ticked the simulation will model the default return path circuit, i.e. everything electrically connected.

Figure 4. "Options" toolbox. Activate non-default circuit

If "Automatic Location of Reference Metal Voltage (Vm=0)" is un-ticked, then options become available to assigned metal voltage 0 to a group of surfaces. Give the name of the mesh and group in the model to reference metal voltage.

Figure 5 "Return Path Circuit" tab. Define reference group for Metal Voltage

Electrical Components toolbox

The "Electrical Components" toolbox is located on the left hand side in the Return Path Circuit panel (Figure 6 ).

After components names are defined in the "Group Definitions" tab, go to the "Return Path Circuit" tab. The components names previously defined will be automatically displayed.

Figure 6 "Return Path Circuit" tab. "Electrical components" toolbox

Inter-connection Method

In the "Electrical Components" toolbox, choose the "Interconnection Method" and the inter-connecting resistances for each of the components names.

Start by selecting the inter-connection method using the drop down menu (Figure 7)

Figure 7 "Return Path Circuit" tab. Select the "Interconnection Method"

To define interconnection methods use the drop down menu and select:

  • Interconnected: To connect all the groups in the component to one of the groups (all to one)

  • Internally disconnected: To disconnect all the groups in the component

For groups with tube elements:

  • Pipeline (Shared MPS): To connect different groups of tube elements that share a mesh point. Groups are connected through shared mesh points.

  • Pipeline (proximity): To connect different groups of tube elements that do not share a mesh point. Groups are connected by proximity

  • Flowline (tube element): To connect discontinuous groups of tube elements with non-zero internal resistance. The relevant groups are automatically broken into two-ended pipes and then reconnected by physical proximity

  • Exclude: To exclude the whole component from the return path circuit. Components containing groups of type INTERFACE, BOUNDINGBOX or INTERNAL_POINTS must be assigned this connection method.

Note that this connection method cannot be assigned to any component that contains groups of type METAL or ANODE.

For groups with tube elements, once the interconnection method is defined you can assign a value for the interconnecting resistance.

Resistance

The resistance represents the connection resistance for the automatic interconnection of the component. This field is only relevant for components assigned inter-connection methods PIPELINE, FLOWLINE.

Tolerance

This parameter defines the maximum distance allowed for establishing an automatic electrical connection between connection points of different groups involved in a component with inter-connection method PIPELINE or FLOWLINE.

NOTE: This field is only relevant when using INTERCONNECTION_METHOD PIPELINE and FLOWLINE.

Power Supply toolbox

The "Power supply" toolbox is used to define transformer rectifier units (TRU). Press "insert" key to add a new TRU entry.

Figure 8 "Return Path Circuit" tab. Power Supplies toolbox

Use the down arrow to select the TRU type. You can choose between V-TRU and I-TRU. V-TRU is controlled by potential and I-TRU by current.

You can then input the output value.

Figure 9 "Return Path Circuit" tab. Power Supplies toolbox. TRU type

Electrical connections

Once the electrical components have been defined, you can proceed to define the electrical connections in the "Electrical Connections" toolbox at the right hand side of the window (Figure 10).

Figure 10 Electrical connections tab

This toolbox is used to create electrical connections between components, groups, power supplies and junction boxes.

Each row represents one electrical connection established between two objects: 1 and 2.

Thus, an electrical connection is defined by

  • the type and name of the objects at each end of the connection

  • a method for selecting the connection point in each object

  • the electrical resistance

Type

Type1 and Type2 indicate the type of objects to be connected at end 1 and 2 of the connection. Using the down arrow you can select between: COMPONENT, GROUP, TRU or JBOX. (Figure 11)

Figure 11 Electrical connections. Select "Type" for object connection 1

Mesh, Name and method

Mesh and Name identify the object to be connected.

Method indicates the method used to detect the connection point within each object.

Values assigned to "Mesh, Name and Method" depend on the value selected for Type1 or Type2:

  • if Type 1 is COMPONENT:

  • Name1 is the component name as given in the "Group Definition" tab

  • Mesh1 is not needed

  • Method1 can be one of the following:

  • P

  • XYZ

  • XYZR

  • if Type 1 is GROUP

  • Name1 is the group name as given in the "Group Definition" tab

  • Mesh1 is the name of the corresponding mesh.

  • Method1 can be one of the following:

  • P

  • XYZ

  • XYZR

  • If Type1 is TRU

  • Name1 is an integer (id number) that identifies the TRU

  • Mesh1 is not needed

  • Method1 is Supply or Return

  • If Type1 is JBOX

  • Name1 is an integer (id number) that identifies the junction box

  • Mesh1 is not needed

  • Method1 is not needed

Methods for COMPONENT and GROUP

Method P: Selects the connection point in a mesh point in the object which is nearest to the opposite object across the connection, i.e. the connection point in object 1 is as close as possible to object 2.

Method XYZ: Selects the connection point in a mesh point in the object which is nearest to a point with coordinates x y z. This option must be followed by three real numbers indicating 3D coordinates in the model input to the "Parameters" column.

Method XYZR: Same as XYZ option except that the point needs to be detected within a certain radius R. This option must be followed by 4 real numbers indicating X, Y and Z coordinates and the radius R input to the "Parameters" column.

Methods for TRU

Method Supply: Selects the connection point in the supply terminal of a TRU

Method Return: Selects the connection point in the return terminal of a TRU

Resistance Value

Assign the value of the interconnecting resistance.

The example shown in Figure 12 shows a connection between component "MOONPOOL" and component "TURRET". The interconnecting resistance is 0.02 the connection point in the component "MOONPOOL" is as close as possible to (x, y, z) = (0,1,0) and the connection point in component "TURRET" is as close as possible to component "MOONPOOL".

Figure 12 Electrical connections example

Summary

To create a non-default circuit you have to follow the actions listed below:

In the "Group Definitions" tab:

  1. Define components names for each group

  2. If there are structures which expected considerable voltage drop along them due to internal resistance, define resistance per unit length on tubular elements

In the "Return path circuit" tab define :

  1. Activate the non-default circuit in the Options toolbox

  2. Define "Interconnection Method" for each component in the "Electrical Components" toolbox

  3. If needed, define TRU in the "Power Supplies" toolbox

  4. Create electrical connections in the "Electrical connections" toolbox.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Groups Definitions

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_groups\cpme_groups.htm

CP Model Editor. Group definitions tab

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Group definitions tab

Visualisations

Row and Column operations

"Basic" visualisation

"Intermediate" visualisation

"Advanced" visualisation

Group definitions tab

The "Group definitions" tab allows managing properties (define, edit, delete) to apply to the groups of surfaces defined in the imported meshes.

Figure 1 Group definitions tab

The Group definitions tab is used to define the role of each group in the assembled model. Groups must be non-overlapping, in the sense that any element in the model can belong to only one group.

List of groups with default properties

After a mesh is imported the groups present in the mesh are displayed in the "Group Definitions" tab with default parameters as shown in Figure 2. You can then proceed to define data for the existing groups.

Figure 2 "Group definition" tab after importing a mesh (the different properties have default values)

Open an existing ".hmd" file

Once an existing ".hmd" file is opened, the defined data is available in the different tabs. In particular, the "Group Definitions" tab will show the defined group data as shown in Figure 3.

Figure 3 "Group definitions" tab with defined data

Visualisations

The "Group Definitions" tab has three visualisation options: "Basic", "Intermediate" and "Advanced".

Figure 4 "Group definitions" tab. Visualisation options

The "Basic" visualisation shows a number of group properties that are commonly used for many modelling situations. Depending on your model objectives, you may need to access properties in the "Intermediate" or "Advance" visualisations.

Row and Column operations

By clicking on the column property, you can sort the column by alphabetic order.

Row and column operations are also accessed by right-clicking on any of the column titles. Operations are shown in Figure 5.

Figure 5 Column and row operations

Use "Filter rows" to visualise rows that have a common pattern or value. Type the characters you want to filter, for instance "hull" (Figure 6)

Figure 6 Filter rows

"Basic" visualisation

The different group properties in the Basic visualisation are:

Mesh: Indicates the name of the mesh to which the group belongs.

Group: Indicates the name of the group in the mesh file (*.bzmsh file).

Master Zone ID: The Master Zone ID of the zones that is master to this group. The zone ID is a positive integer ( Zone ) that correlates with the IDs used in the "Zones" tab. If there is more than one zone, the Master Zone IDs are defined progressively with increasing number starting from 1.

You can edit this value by clicking on it and entering a value, or using the spin box control.

Figure 4 Zone ID property

It is possible to highlight a number of values in a column, for example, and copy them as shown in Figure 5 and Figure 6.

Figure 5 Highlight and copy

Figure 6 Paste values

Note: the "Mater Zone ID" values appear in red because the zone properties have not been defined in the "Zones" tab.

Slave Zone ID: When the group represents an INTERFACE or a DIVIDER between two adjacent zones, this property contains the zone ID number (as used in the Zones tab ) of the slave zone. For non-interface groups Slave Zone must be zero

Slave elements are elements on the interface between two zones

Group Type: Group type defines the role of the group in the simulation. Options are ANODE, METAL, BOUNDING_BOX, INTERFACE, INTERNAL_POINTS, DIVIDER or REMOVE. You can select one of them using the drop down menu. Select:

  • ANODE for groups that need to be specially considered as anode or need to be assigned sacrificial anode properties.

Note: The CP Solver will calculate the performance despite of this assignment. For example, depending on the particular conditions of the problem results could show that a group defined as "ANODE" has cathodic behaviour.

  • METAL for groups of the structure with polarising, insulated, fixed current density or potential boundary conditions (or for boundary surfaces which confine the shape electrolyte).

  • BOUNDING_BOX for insulated surfaces which confine the electrolyte and do not form part of the return path circuit.

  • INTERFACE for groups containing non-material surfaces representing an interface between two zones which are connected by the electrolyte. An interface allows continuity of electrolyte potential and continuity of current normal current density between its two adjacent zones, and it cannot be assigned any type of boundary condition apart from NO_BC. Interfaces cannot form part of the return path circuit, and require a Master Zone ID number greater than 1.

  • DIVIDER for a group of surfaces representing a solid boundary between two zones (i.e. like a dividing wall). Similarly to INTERFACE, this type of group must be assigned a Slave Zone ID number greater than 1. But contrary to interfaces, this group must be assigned a polarising boundary condition.

  • INTERNAL_POINTS to represent groups containing non-material elements used for visualising results in the electrolyte (e.g. field observation points, reference cells, surfaces or lines for observation). INTERNAL_POINT groups cannot be assigned material boundary conditions (they only accept NO_BC type).

  • REMOVE to ignore the presence of this group. The keyword REMOVE has the same final effect as deleting the line defining the group.

  • BOUNDING_BOX for groups of surfaces that represent the zone boundary at infinity. These surfaces have insulating conditions applied.

  • INTERFACE for groups of surfaces that represent the interface between two zones.

  • INTERNAL_POINTS for groups of internal points. Internal points are defined to calculate the solution on areas within the electrolyte.

  • DIVIDER for a surface that divides two zones but have material properties such as polarising condition.

  • REMOVE for groups that you want to exclude from the calculation.

Boundary Type: Options are: INSULATED, NORMAL_CURRENT_DENSITY, POTENTIAL, POLARISATION, STRATPOLCURVE, PIECEWISE or NO_BC. Select:

  • INSULATED: to define insulating conditions on "METAL" or "ANODE" groups

  • NORMAL_CURRENT_DENSITY: to define a fixed value for the normal flux density on surfaces

  • POTENTIAL: to define a fixed value for the potential on surfaces

  • POLARISATION: to define a non-linear relationship between potential and normal flux density (or polarisation data)

  • STRATPOLCURVE: to define a non-linear relationship between potential and normal flux density (i.e. polarisation data) that varies with depth

  • PIECEWISE:

  • NO_BC: applied to surface types such as "INTERFACES"

Boundary Value: This is the value corresponding to the "Boundary Type" defined in the previous property. For example, you will need to input:

  • A numeric value if Boundary Type is "NORMALFLUX" or "POTENTIAL". Note the entered value needs to be expressed in the chosen model units .

  • A material label if Boundary Type is "POLARISATION" or "STRATPOLCURVE".

If a material file is already imported using the "Material file panel", you can select the label using the drop down menu.

Component: Name of the electrical component this group belongs to. Note that many different groups may be part of the same electrical component. Groups belonging to the same component are electrically connected. The connection mechanism is set up later in the "Return Path Circuit" tab .

All the groups are by default, electrically connected. A non-default circuit can be created by defining electrical components and electrical connections. You will need to define components if either:

1. There are internal resistances in tubular members of the structure with significant influence on the results of the model.

2. There are connection resistances between components with significant influence on the results of the model.

3. You want to include a TRU

4. You need to disconnect a group (or set of groups)

NOTE: Return-path metal voltage losses will be calculated in those cases if you specifically select "Activate non-default return path circuit" in the "Options" window in the "Return Path Circuit" Panel as shown in Figure 10. If the option is not selected, the definition of electrical components becomes irrelevant.

Figure 10 Activate non-default return path circuit

"Intermediate" visualisation

The properties that are added in the Intermediate visualisation are:

Swap Normal: The default value is "false". In this case, the normal direction to the mesh elements in the selected group will remain as it is defined in the mesh file (*.bzmsh). If "true" the normal direction to the mesh elements in the selected group will be swapped in the model simulation files (BEASY dat file).

Is dual: The default value is "false". Change this property to "true" if you want to define the mesh elements in the corresponding group as " dual elements ".

Is Tube Element: By default this parameter is set to "false". Change to "true" if this group is intended to represent tube elements . In this case you will need to fill in the property column "Diameter" to identify the diameter to apply to the line. You may also need to fill in the property "Resistance per unit length" if the resistance per unit-length is not negligible.

SAC geometry: You need to define an entry if you want to introduce sacrificial anode data . The default value is "NO_SAC". You can press the drop down menu to access the possible values: "TOP", "BOTTOM" or "NO_SAC". Select

  • NO_SAC: Use if you don't intend to model sacrificial anode data

  • TOP: Use for any anode type except for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

  • BOTTOM: Use for the groups containing the bottom surfaces on BRICK anodes and BRICK FLUSH MOUNTED anodes

SAC name: If you want to model sacrificial anode data and you defined the previous property with values TOP or BOTTOM then define the anode type name in this group. You will use this name in the "Sacrificial Anodes" tab to assign properties such as mass, anode capacity, consumption factor and utilisation factor.

Area factor: If you need to apply an area factor to a group you could do it entering the corresponding value in this column property. This is a real number.

Diameter: If "Is tube Element" is true, then the property is used to enter the diameter for the tube element. Note the entered value needs to be expressed in the chosen model units .

Resistance Length: If "Is tube Element" is true, then you can use this property to define the resistance per unit length of the tube element. This must be a real number of value zero or greater used to define the resistance per unit length of all tube elements in this group. This property is ignored (set internally to zero) if "Activate non-default return path circuit" in the "Options" window in the "Return Path Circuit" Panel is not selected.

If a non-zero value is defined a return path metal voltage calculation will be performed provided you set to "Activate non-default return path circuit". In addition all groups must be given a "Component" name. All electrical components must be defined in the "Electrical components" tab, and electrical connections may be defined in the "Electrical connections" tab.

Note the entered values need to be expressed in the chosen model units .

"Advanced" visualisation

Properties in this section are optional parameters.

SAC Processing order: (Optional) This is a positive integer number that indicates priority for assigning anode ids. If all groups in this region are assigned SAC processing order zero, the processing order will be following the order in which groups appear listed in this region.

SAC Sub-processing method: (Optional) This is a string indicating further sorting criteria for sacrificial anodes with the same SAC Processing order.

SAC start anode id: (Optional)This is a positive integer number suggesting an initial id number for anodes in this group. Note that this is likely to cause gaps in the numeration. If the suggested start anode id is already used, the next available higher id number will be used

Boundary value side 2: This entry is use only for dual elements, in case side 2 needs a boundary value different from the one assigned in "Boundary Value". The default value "SAME_AS_SIDE1" means both sides pf the dia; e;e,memts

Metal Voltage: This is a real number indicating a fixed metal voltage to assign to a group. The default value is zero. If a non-default value is used, you should have "Activate non-default return path circuit" un-selected.

Element order: (Optional) This is an integer which overrides DEFAULT_ELEMENT_ORDER for a given group. Possible values are as follows:

  • 0 = use Default,

  • 1 = constant,

  • 2 = linear,

  • 3 = quadratic,

  • 38 = Q38 for quads.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Internal Points

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_intpts\cpme_intpts.htm

CP Model Editor. Internal Points tab

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Internal Points tab

The "Internal Points" tab is used to create internal points.

Figure 1 Internal points tab

Internal points can be created in three ways:

  • Scattered points

  • Points in lines

  • Points on flat grids

Figure 2 Internal points tab

After selecting one type of internal points (eg..Scattered points) press the "+" button at to add one internal point. Define the zone ID, the x, y, z coordinates.

The point ID is automatically selected as the maximum mesh point ID plus one. You can choose a bigger number if you want to.

Possible inputs for "Scattered points" are shown in Figure 3.

Figure 3 Scattered points

Possible inputs for "Points along lines" are shown inFigure 4. Input the start and end point of a line and the total number of internal points to create.

Figure 4 Points along lines

Note that when creating internal points in this way, results at internal points will be shown as a cloud of points (i.e. contour plots will not be available)

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_intro\cpme_intro.htm

CP Model Editor

The CP Model Editor is an interface that provides a canvas for model management, where model properties can be defined, edited or deleted. It allows aggregating different meshes. It is also used to launch a simulation.

CP Model Editor Features

CP Model Editor tools

Information bar

Tabs used to define model properties, launch an analysis and retrieve results

Model creation report files

CPBuilder.log

CPBuilder_SAC_Anodes_Report.txt

Results tab

CP Model Editor Features

The CP Model Editor is an interface that provides a canvas for model creation, introducing the possibility to aggregate different meshes and defining/editing model data and model parameters independently. In this way,

  • model geometry can be changed/updated independently from the physical parameters applied to it

  • the model geometry can be created in different sub-models, and integrate or take away part of it without having to regenerate the full set of pre-processing data or revise an existent sub-model again.

  • New model parts can be integrated to an existent model without having to regenerate modelling information such as polarisation properties previously defined or networks of electrical connections previously defined.

  • One instance of model geometry can be created and the associated mesh can be used applying geometrical transformations to generate several instances of the initial geometry at different locations/orientations without the need of creating the geometry.

The CP Model Editor also allows creating a CP model for later use. It performs a series of checks and produces report files that are useful when assessing possible model errors. It allows launching a simulation and creating a report on the solution.

CP Model Editor tools

The different tools of the CP model editor are illustrated in Figure 1.

Figure 1 CP Model editor tools

You can change the location and/or visibility of the tools by closing windows or changing the windows location (an example with an alternative visualisation is shown in Figure 2.

Figure 2 CP Model editor

The available tools are accessible through the "Tools" menu at the top of the window.

  • Imported meshes: This tool is used to import and/or apply geometric transformation to meshes.

  • Imported polarisation curves : This tool is used to import polarisation curves from a mat_cp fle.

  • Defined zones information: This is an information window, showing IDs of the defined zones and zones names as defined in the Zones tab.

  • Model Title: This is an optional entry

  • Units to use during simulation: Use this to define the model units. The CP Solver will use these units and results will be consistent with these units. Note that any entry of numeric values need to be provided in the selected units. There are a number of parameters, like the electrolyte conductivity (resistivity), or layer thickness, in which different units can be chosen independently. The units for these parameters are explicitly shown in the CP Model Editor and will be automatically converted at the time of creating the model files to be consistent with the selected model units. This also applies for the material file; units declared in the imported material file will be converted at the time of creating the model files.

  • Modelling Notes: This is canvas to add modelling notes and comments.

Information bar

Note messages on the information bar reporting actions or possible errors (Figure 3)

Figure 3 CP Model editor. Information bar

Tabs used to define model properties, launch an analysis and retrieve results

  • Group definitions

  • Zones

  • Internal points

  • Sacrificial anodes

  • Return path circuit

  • Solve

  • Results

Model creation

When pressing "Create Model" on the "Solve" tab two report files are generated to allow to read comments, warnings and error messages that could appear while creating the model.

CPBuilder.log

The CPBuilder.log file has a record of warnings and errors. Check those to eliminate possible errors in your model.

The CPBuilder.log file has a section reporting the number of anodes with sacrificial anode properties defined on each mesh:

START REPORTS ON SACRIFICIAL ANODES

START SUMMARY REPORT 1

Mesh A has 11 SAC anodes of type CAISSONS_Type1

Mesh A has 4 SAC anodes of type CAISSONS_Type2

Mesh B has 36 SAC anodes of type RISER036_Type1

END SUMMARY REPORT 1

END REPORTS ON SACRIFICIAL ANODES

The CPBuilder.log file has a section reporting electrical connection with components:

START REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS {{{

Component FPSO generated 71 internal connections involving 72 groups.

Component AnchorChain01 generated 0 internal connections involving 1 groups arranged as a pipeline

…

…

Sub-group: "Riser_1" has 10 elements and 2 endpoints with IDs 143257 143260

Sub-group: "Riser_2" has 10 elements and 2 endpoints with IDs 143303 143307

Sub-group: "Riser_3" has 10 elements and 2 endpoints with IDs 143350 143352

Sub-group: "Riser_4" has 10 elements and 2 endpoints with IDs 143395 143399

END REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS }}}

START REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

Connection between: COMPONENT "FPSO" and COMPONENT "AnchorChain01" : MPIDs = 20819 and 196

….

….

END REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

There is a section reporting the groups that have been removed:

START REPORT_ON_UNUSED_GROUPS {{{

Mesh: "A" Group: "anchorch_added" has been explicitly REMOVED.

END REPORT_ON_UNUSED_GROUPS }}}

There is a section reporting the total numver of pairs of overlapping groups (if any):

START REPORT_OF_OVERLAPPING_BETWEEN_GROUPS {{{

Total number of pairs of overlapping groups = 0

END REPORT_OF_OVERLAPPING_BETWEEN_GROUPS }}}

CPBuilder_SAC_Anodes_Report.txt

This file is created if sacrificial anode sacrificial anode properties have been declared in the hmd file.

It has a record of the total number of anodes.

For each individual anode it shows:

  • Assigned ID

  • Name of the associated group

  • Name assigned to the sacrificial anode type

  • Anode Type (STAND_OFF, BRACELET, etc)

  • Utilisation factor

  • Consumption factor

  • Original mass

  • Mounting bar diameter

  • Density

  • Mass loss per Amp per year

  • Processing order

  • Number of elements

  • Anode Centre ( x , y, z coordinates)

Results tab

The Results tab allows creating a repot with a summary of results.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Meshes

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_meshes\cpme_meshes.htm

CP Model Editor. Imported meshes tool

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Imported meshes

The "Imported meshes" tool is at the top on the right hand side.

Figure 1 Import meshes

Press the "+" button at the bottom of the panel, or click inside the panel area to add a mesh. The "Import mesh file" window pops up. Browse to a BEASY mesh *.bzmsh file.

Figure 2 Import Mesh file

You can apply geometrical transformations to the mesh, adding a transformation in the "Ordered transformations" panel. For example a translation is shown in Figure 3.

Figure 3 Translate mesh

After pressing "Accept" the mesh is added to the panel and the groups (or layers) defined in the mesh file are listed in the "Group Definitions" tab as shown in Figure 4. Note that when a mesh is imported the list of groups present in the mesh appears in the in the "Group Definitions" tab.

Figure 4 Added mesh "Ship_001"

Continue pressing on the "+" button to add another mesh.

Note that when after a mesh is added, you can change the mesh name by right clicking on the corresponding mesh on the "Imported meshes" tool and selecting "Edit Mesh".

You can also use "Edit Mesh" to add a geometrical transformation to a mesh that is already imported.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Polarisation Curves

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_polccurves\cpme_polccurves.htm

CP Model Editor. Imported polarisation curves tool

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Imported polarisation curves

The "Imported polarisation curves" tool is shown highlighted in yellow in Figure 1.

Figure 1 Import polarisation curves

Press the "+" button at the bottom of the panel, or click inside the panel area to add a polarisation curve. The "Import polarisation file" window pops up. Browse to a BEASY CP material file *.mat_cp file.

Figure 2 Material file with 4 polarisation curves imported

Assign material labels to groups

When meshes are already added and properties for groups have already been defined, labels can be assigned to groups in different ways:

  • Type the first letter of the label

  • Double click on the field and select the label using the drop down menu

  • Drag the labels using the double chevron as shown in Figure 3 and Figure 4.

NOTE: You can add labels to groups only if the "Boundary type" is already defined as "POLARISATION"

Figure 3 First select the rows to apply label in the column "Boundary value"

Figure 4 Click on the label and then on the double chevron

After pressing the double chevron the label is applied to the selected groups.

Figure 5 Showing added labels

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Report files

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_reports\cpme_reports.htm

CP Model Editor. Report files on vertical tabs

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

CPBuilder.log

CPBuilder_SAC_Anodes_Report.txt

When pressing "Create Model" in the "Solve" tab, the files needed to perform a simulation with the CP Solver are created. In addition, report files created at this stage help identifying possible model errors.

CPBuilder.log

The CPBuilder.log file has a record of warnings and errors. Check those to eliminate possible errors in your model.

The CPBuilder.log file has a section reporting the number of anodes with sacrificial anode properties anode properties defined on each mesh:

START REPORTS ON SACRIFICIAL ANODES

START SUMMARY REPORT 1

Mesh A has 11 SAC anodes of type CAISSONS_Type1

Mesh A has 4 SAC anodes of type CAISSONS_Type2

Mesh B has 36 SAC anodes of type RISER036_Type1

END SUMMARY REPORT 1

END REPORTS ON SACRIFICIAL ANODES

The CPBuilder.log file has a section reporting electrical connection with components:

START REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS {{{

Component FPSO generated 71 internal connections involving 72 groups.

Component AnchorChain01 generated 0 internal connections involving 1 groups arranged as a pipeline

…

…

Sub-group: "Riser_1" has 10 elements and 2 endpoints with IDs 143257 143260

Sub-group: "Riser_2" has 10 elements and 2 endpoints with IDs 143303 143307

Sub-group: "Riser_3" has 10 elements and 2 endpoints with IDs 143350 143352

Sub-group: "Riser_4" has 10 elements and 2 endpoints with IDs 143395 143399

END REPORT ON AUTOMATIC CONNECTIONS WITHIN COMPONENTS }}}

START REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

Connection between: COMPONENT "FPSO" and COMPONENT "AnchorChain01" : MPIDs = 20819 and 196

….

….

END REPORT ON EXTERNAL ELECTRICAL CONNECTIONS

There is a section reporting the groups that have been removed:

START REPORT_ON_UNUSED_GROUPS {{{

Mesh: "A" Group: "anchorch_added" has been explicitly REMOVED.

END REPORT_ON_UNUSED_GROUPS }}}

There is a section reporting the total numver of pairs of overlapping groups (if any):

START REPORT_OF_OVERLAPPING_BETWEEN_GROUPS {{{

Total number of pairs of overlapping groups = 0

END REPORT_OF_OVERLAPPING_BETWEEN_GROUPS }}}

CPBuilder_SAC_Anodes_Report.txt

This file is created if sacrificial anode sacrificial anode properties have been specified. It has a record of the total number of anodes with sacrificial anode properties defined.

For each individual anode it shows:

  • Assigned ID

  • Name of the associated group

  • Name assigned to the sacrificial anode type

  • Anode Type (STAND_OFF, BRACELET, etc)

  • Utilisation factor

  • Consumption factor

  • Original mass

  • Mounting bar diameter

  • Density

  • Mass loss per Amp per year

  • Processing order

  • Number of elements

  • Anode Centre ( x , y, z coordinates)

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Results tab

The "Results" tab is used to create a results summary report. Press "Create Report" to create a summary report

Figure 1 Summary report

Summary report

The "Summary report" includes the following general information (shown in Figure 2)

  • Model units

  • Mesh information: It reports the number of mesh points, elements, groups and zones in the model

  • Polarisation curves: includes the list of labels used in the model

  • Zones data: contains the id and conductivity values for each zone

Figure 2 General information

The Results section includes

  • Model Current Balance: Check that the error in current balance is negligible.

  • Zone Results: This gives the current balance per each zone

  • Group Results: Summarises information for each group

  • Interface group results: has a summary of results on interfaces

Figure 3 Model Current Balance and Zone Results

Figure 4 Group Results

Figure 5 Interface group results

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Sacrificial anodes

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_sacs\cpme_sacs.htm

CP Model Editor. Sacrificial anodes tab

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Sacrificial Anodes tab

The "Sacrificial Anodes" tab is used to add sacrificial anode data.

It is recommended to first define "SAC geometry" and "SAC name" in the "Group Definitions" tab as shown in Figure 1.

Figure 1 Sacrificial anodes name and geometry in "Group Definitions" tab

Then, when you open the "Sacrificial Anodes" tab the "SAC Names" are already available with default data. (Figure 2)

Define data for each SAC name:

  • Type. Use the drop down menu to select the anode type

  • Utilisation Factor

  • Consumption Factor

  • Mass

  • Capacity

Figure 2 Sacrificial anodes tab. Default parameters

Optional parameters are:

  • Mounting bar diameter

  • Mass density

  • Observations

When defining the anode "Type", double click on the field and choose from the list. (Figure 3) Follow the link to see a full description of the different anode types.

Figure 3 Select Type

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Solve tab

The "Solve" tab is used to create the input files to the CP Solver and launch the simulation.

Figure 1 Solve tab

Settings

The "Settings" button gives access to the "Model Settings" Window. The "Solution Control" panel is shown in Figure 2.

Figure 2 Model Settings window

If in doubt, leave the defaults. Options are as follows:

Create interface groups: It controls whether to write interface groups to the

"PRIVATE DATA FOR GROUPS TOOL" section in the dat file. We suggest to keep it always selected, and untick it if you wish to minimise file size.

Create groups of internal points: This parameter controls whether to write groups of internal points to the "PRIVATE DATA FOR GROUPS TOOL" section in the dat file. We would suggest leaving it always selected, and only untick it if you need to minimise file size.

Fix mesh points near symmetry planes: If this is enabled the mesh points which are very close to a zone symmetry plane (up to a certain tolerance) will be adjusted. If the distance between the mesh points and the symmetry plain is less than the tolerance, then the selected coordinates of the mesh points will be assigned a value 0.

Symmetry planes fix tolerance: This is the tolerance to fix mesh points near symmetry planes

Default element order: It defines the default interpolation order for mesh elements.

The preferred order for BEASY CP is "Constant"

Export pre-processing GiD Mesh: This parameter lets you export a pre-processing mesh of the whole model for visualisation in GiD

Current density tolerance non-sigmoidal: This value is the amount by which a result can be away from the associated curve (measured along the current density axis) without causing a further iteration of the solution.

Current density tolerance sigmoidal: This value is the amount by which a result can be away from the associated curve (measured along the current density axis) without causing a further iteration of the solution

Note there are separate controls for non-sigmoidal and sigmoidal curves, mainly because it is harder to get convergence onto the sigmoidal curve, so a bigger error might in practise be needed.

Post-processing step number: This parameter defines the step number used for post-processing results in GiD.

Post processing distance for dual elements: This parameter defines the offset distance for post-processing dual elements

Maximum number of iterations: Maximum number of iterations for non-linear polarisation curves (default = 40)

The "Post-solver operations" panel is shown in Figure 3. These operations affect the management of files after finalising an analysis.

Figure 3 Post-solver operations

If in doubt, leave the defaults. After a run is finished these options help you to keep the disk space for your model minimal. Options are listed below:

Remove H and G influence matrix files: If ticked files "*.h001", "*.g001", "*.h002", "*.g002", etc. will be removed.

Remove .pri files: If selected, pri file will be removed

Remove lo2 and sf2 files: If selected lo2 and sf2 files will be removed. If you need to calculate solution at internal points after a simulation has been done without having to re-run the simulation again, you need to keep the lo2 and sf2 files.

Create model

The "Create Model" button performs the following actions:

  1. Creates a mat_cp file using the materials defined in the imported mat_cp file. The file is created with the same root name as the hmd file. If necessary, units are converted to match the model units defined in the top of CP Model Editor window ("Units used in simulation")

  2. Saves the hmd file with the current name. If the hmd has never been saved before, then you will be asked to provide a name.

  3. Performs sanity checks in the model

  4. Runs the CP Builder to create a dat file.

  5. It also creates a batch file to launch the CP Solver from command line

Note that if you make changes in the data to simulate a different scenario in the same session as one previously defined, you need to save the hmd file with a different name to avoid losing the previous scenario.

Reports window

The Reports window shows reports in the different tabs located at the right on :

  • Model Creation : Shows the output messages while the CP Builder is running

  • Model Creation Reports: Shows the CP Builder log file (*_CPBuilder.log)

  • Solver runtime report: Shows the output messages while the CP Solver is running

  • Solver log file:

Figure 3 Reports

Checks

You should check for warnings or errors

  • in the Model Creation Report before launching "Solve Model", this will help you identify errors in the model definition.

  • in the Solver Log File after running an analysis.

You can search for warnings or errors using the "search" button at the bottom of the window.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Units

The units to use during the simulation are defined in the "Units to use during simulation" tool..

Figure 1 Units to use during simulation

The CP Solver will use these units and results will be consistent with these units.

Note that any entry of numeric values need to be provided in the selected units.

There are a number of parameters, like the electrolyte conductivity (resistivity), or layer thickness, in which different units can be chosen independently. The units for these parameters are explicitly shown in the CP Model Editor and will be automatically converted at the time of creating the model files to be consistent with the selected model units.

This also applies for the material file; units declared in the imported material file will be converted at the time of creating the model files.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Zones

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\cpmodeleditor\cpme_zones\cpme_zones.htm

CP Model Editor. Zones tab

The CP Model Editor is used to manage model data, to create a CP model and to launch simulations.

Zones tab

The "Zones" tab is used to define the zone properties such us conductivity/resistivity of the electrolyte.

Figure 1 Zones tab

If there aren't zones defined, press the "+" button at the bottom of the panel to add a zone. Zones are added in progressive order

You can select the type of zone on the "Zone type" field:

  • Homogeneous: For a zone with homogeneous conductivity value

  • Layered: For a stratified zone with layered conductivity values

Homogeneous zone

Possible inputs for a homogeneous zone are shown in Figure 2.

Figure 2 Homogeneous zone parameters

NOTE: you can change the units for visualisation in this window. Values used in the simulation will be converted using the model units.

Layered zone

Possible inputs for a layered zone are shown in Figure 3.

Layered zones use the "multi-layer" approach.

Figure 3 Multi-layered zone parameters

Parameters used in the multi-layer zone are described in Figure 15.

Figure 4: Parameters involved in the definition of a multi-layer zone

Zone Name: This input is optional. It can be used as a reference.

Layering direction: Is the direction perpendicular to the planes that divide layers.

Top layer location: Refers to the position of the top surface of the zone.

Press the "+" button to add a new layer and define values for:

  • Conductivity or Resistivity. You can define either of those

  • Thickness: Define the thickness of the layer

  • Top location: Define the coordinate at the top of this layer (in the layering direction)

  • Bottom location: This is displayed for information and automatically filled once the thickness is defined

Zone boundaries: Options are "INFINITE" or "BOUNDED". The default is "INFINITE". Select "BOUNDED" if lateral surfaces are present in the model.

Leave the default if the model has no lateral boundaries.

Top layer boundary condition, Bottom layer boundary condition: These fields allow defining the type of boundary condition associated to the top and bottom surfaces as referred in Figure 4 (TOP and BOTTOM). Options are:

  • "INSULATED": It imposes zero normal current density

  • "INFINITE": The first layer extends indefinitely in the direction Options are "INFINITE" or "INSULATED".

Select "INSULATED" for the top and "INFINITE" for the bottom.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Create Mesh - View Results

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\createmeshviewresults\createmeshviewresults.htm

Create mesh and view results

What does it do?

How to use it?

Why would you use it?

What does it do?

This tool launches the GiD interface. The GiD interface equipped with the BEASY GiD problem type is used to create/import the geometry of a model, create a mesh and visualise results

How to use it?

This tool to launch GiD can be accessed through the CP Desktop.

Why would you use it?

  • You need to access GiD to start creating a model. When the BEASY GiD problem type is loaded, you can export the mesh of a model and use additional tools provided by the BEASY problem type to facilitate the geometry building.

  • You need to access GiD to visualise results. The BEASY CP Solver produces output files for visualisation of results in GiD.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Introduction

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\introduction\introduction.htm

BEASY CP

BEASY CP is designed to simulate the behaviour of galvanic corrosion problems and cathodic protection designs. It can be used:

  • to analyse corrosion and monitor the protection systems employed

  • to predict corrosion rates

  • to optimise cathodic protection designs

  • to predict stray current problems, for example the interaction between separate cathodic protection systems, and also the impact of an external power system on a CP system performance and corrosion rates.

  • to predict long term performance. The user can generate a static prediction of the structural condition or predict how the structure condition will vary with time.

Modelling inputs

The main modelling inputs are:

  • a three dimensional (3D) mesh of the surfaces subject to corrosion

  • macroscopic polarisation curves for the materials exposed to the electrolyte

  • physical properties of the electrolyte in contact with the materials

Optional inputs are:

  • internal resistance of cylindrical metallic structures

  • interconnecting resistances between components

Simulation procedure

The basic steps in a simulation are as follows:

Pre-processing, which involves the user defining the geometry and mesh through a graphical interface equipped with a BEASY Plugin

Definition of model parameters, which involves the user defining modelling parameters through the CP Model Editor.

Solution, which involves the CP solver interpreting the input data, generating the corresponding system of equations, solving them and producing the corresponding outputs

Post-processing stage, which involves the user interpreting the results obtained by the solver

Using the software

The CP Desktop is the main window which gives access to the different software components of the CP software.

Follow the link for an introduction to the CP Solver.

Follow the link for a quick start working on an example.

Follow the link to start working on guided Tutorials.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


IP Editor

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\ipeditor\ipeditor.htm

IP Editor

What does it do?

How to use it?

Input Files

Why would you use it?

What does it do?

The IP Editor is used to add internal points to a BEASY model that has already been solved and to launch a run for internal point calculation only.

How to use it?

This tool can be access through the CP Desktop.

The IP editor is shown in Figure 1.

Figure 1 CP IP editor

Press "Load model" and browse to the folder containing the dat file and corresponding solution files.

If the model had internal points already defined, they will appear listed in the upper window.

Use the tools at the bottom of the window to add points, lines or grids of points.

Figure 2 Tools to add internal points

For each tool you will be prompt to add parameters accordingly.

Note that when adding points you need to specify the zone ID, and a name for the group of internal points

Input Files

Input files to the tool are the solution files with extensions as follows :

  • *.dat

  • *.mat_cp

  • *.lo2

  • *.sf2

Why would you use it?

You will use the IP Editor is to avoid re-running a model if you need to find solutions at internal points and you have already solved the model.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Launch Solver

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\launchsolver\launchsolver.htm

Launch Solver

What does it do?

How to use it?

Why would you use it?

What does it do?

The "Launch Solver" utility allows you to select an existing input data (.dat) and (*.mat_cp) files and launch a run.

How to use it?

The Quick Launcher can be accessed through the CP Desktop.

Load a *.dat and *.mat_cp file and press the "Solve" button.

Why would you use it?

Use the Quick Launcher if you have already created the input files to the CP Solver and need to launch a run.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


MatFile Viewer

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\matfile_viewer\matfile_viewer.htm

MAT File Viewer

What does it do?

How to use it?

Why would you use it?

What does it do?

The MAT File Viewer is used to plot graphs from polarisation curves stored in material files (*.mat_cp file)

How to use it?

Start by selecting the BEASY Mat File Viewer icon in the CP Desktop.

An Excel worksheet is opened:

Press "Plot polarisation Curve".

Browse to the material file (*.mat_cp) and select the materials you want to plot.

An example material file is zipped and you can save it by right clicking in the following links: Right click here to save zincsteel.zip

The plot for STEL, corresponding to the example file provided (zincsteel.mat_cp) is as follows:

Why would you use it?

To quickly plot polarisation curves defined in a mat_cp file

==========End of document===================================================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Model Checking Tool

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\modelchecking\modelchecking.htm

Model checking tool

What does it do?

How to use it?

Why would you use it?

What does it do?

This tool facilitates model checking. In particular, it allows you to inspect completeness of zones and normal orientations defined in a dat file

How to use it?

The "Model Checking tool" can be accessed through the CP Desktop.

The input file to the checking tool is an existing "*.dat" file.

You can follow a tutorial showing the use of the tool.

Why would you use it?

Use it to create GiD files. You can then visualise zones separately and check closeness of zones in the model and normal orientation.

The tool creates a series of mesh files for each zone that can be imported into GiD. In this way you can check each zone and zone normals independently.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


OffPotential Wizard

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\offpotential_wizard\offpotential_wizard.htm

Off Potential Wizard

What does it do?

How to use it

Why would you use it?

Example

What does it do?

This tools is used to create a *dat file suitable for the calculation of the "OFF" potential field. Once the input files are created ( *_off_potentials.dat and *_off_potentials.mat_cp) the tool launches the CP Solver.

How to use it

First perform a normal run using polarising conditions (ON simulation). Then the calculation of the OFF potential results can proceed. To do so, select the BEASY Off Potential Wizard icon in the CP Desktop.

This launches OFF potential calculator:

Why would you use it?

For the pipeline industry accurate survey measurement of the ‘OFF’ potential is of paramount importance, because this value can be used to estimate the protection potential on a nearby pipeline.

BEASY CP software can be used to simulate the usual ICCP system in its "ON" state. This simulation produces the "ON" potential field throughout the electrolyte, and comparison with survey measurements of ground level "ON" potentials can be used to verify the simulation assumptions regarding coating damage, so increasing confidence in the simulation results for protection potentials at the pipe surface.

In cases where it is nevertheless required to calculate the "OFF" potential field, the BEASY "OFF Potential" tool can be used to produce the necessary data file.

The tool takes as input the dat and mat_cp files which were used to calculate the "ON" potentials, plus the ".gdf" results file from that simulation. For any selected polarising surface the tool determines the protection potential (which is the difference between the potential in the electrolyte and the potential in the nearby metal) and applies it to the surface, at the same time removing the "polarising" boundary condition. In addition, any rectifier is removed from the model.

The resulting data file can be solved to determine the "OFF" potential field.

Example

Follow a tutorial showing how to calculate OFF potentials.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Offshore Tools

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\offshore_tools\offshore_tools.htm

Offshore Tools

What does it do?

How to use it?

Why would you use it?

What does it do?

This tool offers two different functions:

  • assists in the modelling of geometries with cylindrical members, like the elements in jacket structures. (by selecting "Translate geometry" and "Trim members"

  • Also there is a capability to launch time stepping runs to take into account anode mass loss and/or the breakdown factor increase during the time stepping. (Select: "Perform forward time stepping solutions")

Note, except for the time stepping solutions, most of the other functionalities offered by the toolsets for jacket structures can be also performed inside the GiD User interface environment equipped with the BEASY GiD problem type.

How to use it?

Starting from the CP Desktop, click twice on the BEASY Offshore Tools icon

The BEASY Offshore tools window pops up:

Why would you use it?

The different processes provided assist you in the following.

  • Translate geometry: Allowing the translation of the structural file (MICRO-SAS format) into BEASY file formats (*.off file). In addition, geometric transformations such as rotations, translations, scale, etc are also provided but these operations can be done inside the user interface environment.

  • Trim members: By trimming the members of the structure, we avoid intersections between members and preserve the total surface area. These operations can be performed inside the GiD User Interface environment.

  • Forward time stepping: This tool is used to launch time stepping runs when modelling the degradation of the coating, the decrease on anode mass, the accumulation of calcareous deposits and/or the effect of flow profiles.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Polarisation Database

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\poldatabase\poldatabase.htm

Polarisation Database

What does it do?

How to use it?

Why would you use it?

What does it do?

This tool launches the Polarisation Database application. The polarisation database is a tool developed in order to store polarisation data and export them to a material file (mat_cp).

How to use it?

The Polarisation Database tool can be accessed through the CP Desktop.

The polarisation database software has been developed in Microsoft Excel.

Detailed information on how to use the Polarisation Database can be found in this link.

Why would you use it?

You can use it to create a material file (*.mat_cp) with a set of polarisation curves.

Note that you can also create a mat_cp file using the alterantive tool: Pol2MatCP

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Results Filter

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\results_filter\results_filter.htm

Results Filter

What does it do?

How to use it?

Why would you use it?

What does it do?

This tool can be used to extract results from a result file ( gdf file). The output is a file containing a selection of the data that can be easily imported and plotted using Microsoft Excel.

How to use it?

Start by selecting the BEASY Result Filter icon in the CP Desktop

The window will pop up:

Files for this example are provided – right click on the link below to save the referenced files to your working folder: Right-click here to save example.zip

You can choose results at elements, mesh points or internal points:

Then, select if you want all or only a particular group:

Select the data you want to include in the output file:

Then press ‘Save selected data’. For example save the file as ‘bare.txt’.

Why would you use it?

This tool may be useful for different purposes. In pipeline applications, it allows having all the results along a pipeline section identified by a group to plot results versus distance along the pipeline, for example. This can be used as well in any tube defined by one group. Another used may be to plot results together with the polarisation curve, which could be of particular interest when using sigmoidal curves. Finally, another use may be to identify results at internal points in a separate file.

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com


Settings

BEASY version 21 - CP

Filename: installdir\docs\cp\working_environment\settings\settings.htm

System Settings

What does it do?

How to use it?

Why would you use it?

What does it do?

The "Settings" utility allows you to define and visualise configuration variables.

How to use it?

It can be accessed through the CP Desktop.

The information is stored in a file named "beasyCP_21.ini" and is used to locate the different software components. Note that normally this file is created automatically during the installation and located in the system user folder. After pressing the "Apply" button, all changes are accepted and saved in the "beasyCP_21.ini" file.

Why would you use it?

You need to use it to set up the GiD Home Directory. For example, the default location for GiD 14 is shown below.

NOTE: You may have changed the default location of the GiD Home Directory during installation.

================================End of document===========================

For optimised display view in the browser at 100%

© 2020 CM BEASY www.beasy.com